384d2e88cc
Upstream commit: ff450cdbdee0b8cb6b9d653d6d2fa892de29be31 - Fix deadlock when pthread_atfork handler calls pthread_atfork or dlclose - x86: Fallback {str|wcs}cmp RTM in the ncmp overflow case [BZ #29127] - string.h: fix __fortified_attr_access macro call [BZ #29162] - linux: Add a getauxval test [BZ #23293] - rtld: Use generic argv adjustment in ld.so [BZ #23293] - S390: Enable static PIE
106 lines
3.2 KiB
Diff
106 lines
3.2 KiB
Diff
commit b2585cae2854d7d2868fb2e51e2796042c5e0679
|
|
Author: Szabolcs Nagy <szabolcs.nagy@arm.com>
|
|
Date: Tue May 3 13:18:04 2022 +0100
|
|
|
|
linux: Add a getauxval test [BZ #23293]
|
|
|
|
This is for bug 23293 and it relies on the glibc test system running
|
|
tests via explicit ld.so invokation by default.
|
|
|
|
Reviewed-by: Florian Weimer <fweimer@redhat.com>
|
|
Reviewed-by: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
(cherry picked from commit 9faf5262c77487c96da8a3e961b88c0b1879e186)
|
|
|
|
diff --git a/sysdeps/unix/sysv/linux/Makefile b/sysdeps/unix/sysv/linux/Makefile
|
|
index 0657f4003e7116c6..5c772f69d1b1f1f1 100644
|
|
--- a/sysdeps/unix/sysv/linux/Makefile
|
|
+++ b/sysdeps/unix/sysv/linux/Makefile
|
|
@@ -123,6 +123,7 @@ tests += tst-clone tst-clone2 tst-clone3 tst-fanotify tst-personality \
|
|
tst-close_range \
|
|
tst-prctl \
|
|
tst-scm_rights \
|
|
+ tst-getauxval \
|
|
# tests
|
|
|
|
# Test for the symbol version of fcntl that was replaced in glibc 2.28.
|
|
diff --git a/sysdeps/unix/sysv/linux/tst-getauxval.c b/sysdeps/unix/sysv/linux/tst-getauxval.c
|
|
new file mode 100644
|
|
index 0000000000000000..c4b619574369f4c5
|
|
--- /dev/null
|
|
+++ b/sysdeps/unix/sysv/linux/tst-getauxval.c
|
|
@@ -0,0 +1,74 @@
|
|
+/* Basic test for getauxval.
|
|
+ Copyright (C) 2022 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <unistd.h>
|
|
+#include <stdio.h>
|
|
+#include <support/check.h>
|
|
+#include <sys/auxv.h>
|
|
+
|
|
+static int missing;
|
|
+static int mismatch;
|
|
+
|
|
+static void
|
|
+check_nonzero (unsigned long t, const char *s)
|
|
+{
|
|
+ unsigned long v = getauxval (t);
|
|
+ printf ("%s: %lu (0x%lx)\n", s, v, v);
|
|
+ if (v == 0)
|
|
+ missing++;
|
|
+}
|
|
+
|
|
+static void
|
|
+check_eq (unsigned long t, const char *s, unsigned long want)
|
|
+{
|
|
+ unsigned long v = getauxval (t);
|
|
+ printf ("%s: %lu want: %lu\n", s, v, want);
|
|
+ if (v != want)
|
|
+ mismatch++;
|
|
+}
|
|
+
|
|
+#define NZ(x) check_nonzero (x, #x)
|
|
+#define EQ(x, want) check_eq (x, #x, want)
|
|
+
|
|
+static int
|
|
+do_test (void)
|
|
+{
|
|
+ /* These auxv entries should be non-zero on Linux. */
|
|
+ NZ (AT_PHDR);
|
|
+ NZ (AT_PHENT);
|
|
+ NZ (AT_PHNUM);
|
|
+ NZ (AT_PAGESZ);
|
|
+ NZ (AT_ENTRY);
|
|
+ NZ (AT_CLKTCK);
|
|
+ NZ (AT_RANDOM);
|
|
+ NZ (AT_EXECFN);
|
|
+ if (missing)
|
|
+ FAIL_EXIT1 ("Found %d missing auxv entries.\n", missing);
|
|
+
|
|
+ /* Check against syscalls. */
|
|
+ EQ (AT_UID, getuid ());
|
|
+ EQ (AT_EUID, geteuid ());
|
|
+ EQ (AT_GID, getgid ());
|
|
+ EQ (AT_EGID, getegid ());
|
|
+ if (mismatch)
|
|
+ FAIL_EXIT1 ("Found %d mismatching auxv entries.\n", mismatch);
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+#include <support/test-driver.c>
|