94eca17094
Upstream commit: ede8d94d154157d269b18f3601440ac576c1f96a - csu: Implement and use _dl_early_allocate during static startup - Linux: Introduce __brk_call for invoking the brk system call - Linux: Implement a useful version of _startup_fatal - ia64: Always define IA64_USE_NEW_STUB as a flag macro - Linux: Define MMAP_CALL_INTERNAL - i386: Honor I386_USE_SYSENTER for 6-argument Linux system calls - i386: Remove OPTIMIZE_FOR_GCC_5 from Linux libc-do-syscall.S - elf: Remove __libc_init_secure - Linux: Consolidate auxiliary vector parsing (redo) - Linux: Include <dl-auxv.h> in dl-sysdep.c only for SHARED - Revert "Linux: Consolidate auxiliary vector parsing" - Linux: Consolidate auxiliary vector parsing - Linux: Assume that NEED_DL_SYSINFO_DSO is always defined - Linux: Remove DL_FIND_ARG_COMPONENTS - Linux: Remove HAVE_AUX_SECURE, HAVE_AUX_XID, HAVE_AUX_PAGESIZE - elf: Merge dl-sysdep.c into the Linux version - elf: Remove unused NEED_DL_BASE_ADDR and _dl_base_addr - x86: Optimize {str|wcs}rchr-evex - x86: Optimize {str|wcs}rchr-avx2 - x86: Optimize {str|wcs}rchr-sse2 - x86: Cleanup page cross code in memcmp-avx2-movbe.S - x86: Remove memcmp-sse4.S - x86: Small improvements for wcslen - x86: Remove AVX str{n}casecmp - x86: Add EVEX optimized str{n}casecmp - x86: Add AVX2 optimized str{n}casecmp - x86: Optimize str{n}casecmp TOLOWER logic in strcmp-sse42.S - x86: Optimize str{n}casecmp TOLOWER logic in strcmp.S - x86: Remove strspn-sse2.S and use the generic implementation - x86: Remove strpbrk-sse2.S and use the generic implementation - x86: Remove strcspn-sse2.S and use the generic implementation - x86: Optimize strspn in strspn-c.c - x86: Optimize strcspn and strpbrk in strcspn-c.c - x86: Code cleanup in strchr-evex and comment justifying branch - x86: Code cleanup in strchr-avx2 and comment justifying branch - x86_64: Remove bcopy optimizations - x86-64: Remove bzero weak alias in SS2 memset - x86_64/multiarch: Sort sysdep_routines and put one entry per line - x86: Improve L to support L(XXX_SYMBOL (YYY, ZZZ)) - fortify: Ensure that __glibc_fortify condition is a constant [BZ #29141]
95 lines
3.5 KiB
Diff
95 lines
3.5 KiB
Diff
commit 1a5b9d1a231ae788aac3520dab07dc856e404c69
|
|
Author: Florian Weimer <fweimer@redhat.com>
|
|
Date: Wed May 4 15:37:21 2022 +0200
|
|
|
|
i386: Honor I386_USE_SYSENTER for 6-argument Linux system calls
|
|
|
|
Introduce an int-80h-based version of __libc_do_syscall and use
|
|
it if I386_USE_SYSENTER is defined as 0.
|
|
|
|
Reviewed-by: H.J. Lu <hjl.tools@gmail.com>
|
|
(cherry picked from commit 60f0f2130d30cfd008ca39743027f1e200592dff)
|
|
|
|
diff --git a/sysdeps/unix/sysv/linux/i386/Makefile b/sysdeps/unix/sysv/linux/i386/Makefile
|
|
index abd0009d58f06303..e379a2e767d96322 100644
|
|
--- a/sysdeps/unix/sysv/linux/i386/Makefile
|
|
+++ b/sysdeps/unix/sysv/linux/i386/Makefile
|
|
@@ -14,7 +14,7 @@ install-bin += lddlibc4
|
|
endif
|
|
|
|
ifeq ($(subdir),io)
|
|
-sysdep_routines += libc-do-syscall
|
|
+sysdep_routines += libc-do-syscall libc-do-syscall-int80
|
|
endif
|
|
|
|
ifeq ($(subdir),stdlib)
|
|
diff --git a/sysdeps/unix/sysv/linux/i386/libc-do-syscall-int80.S b/sysdeps/unix/sysv/linux/i386/libc-do-syscall-int80.S
|
|
new file mode 100644
|
|
index 0000000000000000..2c472f255734b357
|
|
--- /dev/null
|
|
+++ b/sysdeps/unix/sysv/linux/i386/libc-do-syscall-int80.S
|
|
@@ -0,0 +1,25 @@
|
|
+/* Out-of-line syscall stub for six-argument syscalls from C. For static PIE.
|
|
+ Copyright (C) 2022 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#ifndef SHARED
|
|
+# define I386_USE_SYSENTER 0
|
|
+# include <sysdep.h>
|
|
+
|
|
+# define __libc_do_syscall __libc_do_syscall_int80
|
|
+# include "libc-do-syscall.S"
|
|
+#endif
|
|
diff --git a/sysdeps/unix/sysv/linux/i386/sysdep.h b/sysdeps/unix/sysv/linux/i386/sysdep.h
|
|
index 39d6a3c13427abb5..4c6358c7fe43fe0b 100644
|
|
--- a/sysdeps/unix/sysv/linux/i386/sysdep.h
|
|
+++ b/sysdeps/unix/sysv/linux/i386/sysdep.h
|
|
@@ -43,6 +43,15 @@
|
|
# endif
|
|
#endif
|
|
|
|
+#if !I386_USE_SYSENTER && IS_IN (libc) && !defined SHARED
|
|
+/* Inside static libc, we have two versions. For compilation units
|
|
+ with !I386_USE_SYSENTER, the vDSO entry mechanism cannot be
|
|
+ used. */
|
|
+# define I386_DO_SYSCALL_STRING "__libc_do_syscall_int80"
|
|
+#else
|
|
+# define I386_DO_SYSCALL_STRING "__libc_do_syscall"
|
|
+#endif
|
|
+
|
|
#ifdef __ASSEMBLER__
|
|
|
|
/* Linux uses a negative return value to indicate syscall errors,
|
|
@@ -302,7 +311,7 @@ struct libc_do_syscall_args
|
|
}; \
|
|
asm volatile ( \
|
|
"movl %1, %%eax\n\t" \
|
|
- "call __libc_do_syscall" \
|
|
+ "call " I386_DO_SYSCALL_STRING \
|
|
: "=a" (resultvar) \
|
|
: "i" (__NR_##name), "c" (arg2), "d" (arg3), "S" (arg4), "D" (&_xv) \
|
|
: "memory", "cc")
|
|
@@ -316,7 +325,7 @@ struct libc_do_syscall_args
|
|
}; \
|
|
asm volatile ( \
|
|
"movl %1, %%eax\n\t" \
|
|
- "call __libc_do_syscall" \
|
|
+ "call " I386_DO_SYSCALL_STRING \
|
|
: "=a" (resultvar) \
|
|
: "a" (name), "c" (arg2), "d" (arg3), "S" (arg4), "D" (&_xv) \
|
|
: "memory", "cc")
|