a8db42ba53
Upstream commit: 71326f1f2fd09dafb9c34404765fb88129e94237 - nptl: Fix pthread_cancel cancelhandling atomic operations - mips: Fix mips64n32 64 bit time_t stat support (BZ#29069) - hurd: Fix arbitrary error code - nptl: Handle spurious EINTR when thread cancellation is disabled (BZ#29029) - S390: Add new s390 platform z16. - NEWS: Update fixed bug list for LD_AUDIT backports. - hppa: Fix bind-now audit (BZ #28857) - elf: Replace tst-audit24bmod2.so with tst-audit24bmod2 - Fix elf/tst-audit25a with default bind now toolchains - elf: Fix runtime linker auditing on aarch64 (BZ #26643) - elf: Issue la_symbind for bind-now (BZ #23734) - elf: Fix initial-exec TLS access on audit modules (BZ #28096) - elf: Add la_activity during application exit - elf: Do not fail for failed dlmopen on audit modules (BZ #28061) - elf: Issue audit la_objopen for vDSO - elf: Add audit tests for modules with TLSDESC - elf: Avoid unnecessary slowdown from profiling with audit (BZ#15533) - elf: Add _dl_audit_pltexit - elf: Add _dl_audit_pltenter - elf: Add _dl_audit_preinit - elf: Add _dl_audit_symbind_alt and _dl_audit_symbind - elf: Add _dl_audit_objclose - elf: Add _dl_audit_objsearch - elf: Add _dl_audit_activity_map and _dl_audit_activity_nsid - elf: Add _dl_audit_objopen - elf: Move la_activity (LA_ACT_ADD) after _dl_add_to_namespace_list() (BZ #28062) - elf: Move LAV_CURRENT to link_lavcurrent.h - elf: Fix elf_get_dynamic_info() for bootstrap - elf: Fix dynamic-link.h usage on rtld.c - elf: Fix elf_get_dynamic_info definition - elf: Avoid nested functions in the loader [BZ #27220] - powerpc: Delete unneeded ELF_MACHINE_BEFORE_RTLD_RELOC - hppa: Use END instead of PSEUDO_END in swapcontext.S - hppa: Implement swapcontext in assembler (bug 28960) Reviewed-by: Florian Weimer <fweimer at redhat.com>
160 lines
5.0 KiB
Diff
160 lines
5.0 KiB
Diff
commit ce0cb6d1d2daac2d58006a41c3d19c551b86f255
|
|
Author: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
Date: Mon Jul 19 15:47:51 2021 -0300
|
|
|
|
elf: Add _dl_audit_objopen
|
|
|
|
It consolidates the code required to call la_objopen audit callback.
|
|
|
|
Checked on x86_64-linux-gnu, i686-linux-gnu, and aarch64-linux-gnu.
|
|
|
|
Reviewed-by: Florian Weimer <fweimer@redhat.com>
|
|
(cherry picked from commit aee6e90f93e285016b6cd9c8bd00402c19ba271b)
|
|
|
|
Resolved conflicts:
|
|
elf/Makefile
|
|
|
|
diff --git a/elf/Makefile b/elf/Makefile
|
|
index bf6da98bdd15a18d..85165c0591412a45 100644
|
|
--- a/elf/Makefile
|
|
+++ b/elf/Makefile
|
|
@@ -118,6 +118,7 @@ elide-routines.os = \
|
|
# interpreter and operating independent of libc.
|
|
rtld-routines = \
|
|
$(all-dl-routines) \
|
|
+ dl-audit \
|
|
dl-compat \
|
|
dl-conflict \
|
|
dl-diagnostics \
|
|
diff --git a/elf/dl-audit.c b/elf/dl-audit.c
|
|
new file mode 100644
|
|
index 0000000000000000..4066dfe85146b9d4
|
|
--- /dev/null
|
|
+++ b/elf/dl-audit.c
|
|
@@ -0,0 +1,39 @@
|
|
+/* Audit common functions.
|
|
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <ldsodefs.h>
|
|
+
|
|
+void
|
|
+_dl_audit_objopen (struct link_map *l, Lmid_t nsid)
|
|
+{
|
|
+ if (__glibc_likely (GLRO(dl_naudit) == 0))
|
|
+ return;
|
|
+
|
|
+ struct audit_ifaces *afct = GLRO(dl_audit);
|
|
+ for (unsigned int cnt = 0; cnt < GLRO(dl_naudit); ++cnt)
|
|
+ {
|
|
+ if (afct->objopen != NULL)
|
|
+ {
|
|
+ struct auditstate *state = link_map_audit_state (l, cnt);
|
|
+ state->bindflags = afct->objopen (l, nsid, &state->cookie);
|
|
+ l->l_audit_any_plt |= state->bindflags != 0;
|
|
+ }
|
|
+
|
|
+ afct = afct->next;
|
|
+ }
|
|
+}
|
|
diff --git a/elf/dl-load.c b/elf/dl-load.c
|
|
index a8c6df3959f2b331..a2d73d025c65cd79 100644
|
|
--- a/elf/dl-load.c
|
|
+++ b/elf/dl-load.c
|
|
@@ -1515,22 +1515,8 @@ cannot enable executable stack as shared object requires");
|
|
|
|
#ifdef SHARED
|
|
/* Auditing checkpoint: we have a new object. */
|
|
- if (__glibc_unlikely (GLRO(dl_naudit) > 0)
|
|
- && !GL(dl_ns)[l->l_ns]._ns_loaded->l_auditing)
|
|
- {
|
|
- struct audit_ifaces *afct = GLRO(dl_audit);
|
|
- for (unsigned int cnt = 0; cnt < GLRO(dl_naudit); ++cnt)
|
|
- {
|
|
- if (afct->objopen != NULL)
|
|
- {
|
|
- struct auditstate *state = link_map_audit_state (l, cnt);
|
|
- state->bindflags = afct->objopen (l, nsid, &state->cookie);
|
|
- l->l_audit_any_plt |= state->bindflags != 0;
|
|
- }
|
|
-
|
|
- afct = afct->next;
|
|
- }
|
|
- }
|
|
+ if (!GL(dl_ns)[l->l_ns]._ns_loaded->l_auditing)
|
|
+ _dl_audit_objopen (l, nsid);
|
|
#endif
|
|
|
|
return l;
|
|
diff --git a/elf/rtld.c b/elf/rtld.c
|
|
index ad5ddb2a0ab94e7f..45fec0df3043b90a 100644
|
|
--- a/elf/rtld.c
|
|
+++ b/elf/rtld.c
|
|
@@ -1064,25 +1064,6 @@ ERROR: audit interface '%s' requires version %d (maximum supported version %d);
|
|
dlmargs.map->l_auditing = 1;
|
|
}
|
|
|
|
-/* Notify the the audit modules that the object MAP has already been
|
|
- loaded. */
|
|
-static void
|
|
-notify_audit_modules_of_loaded_object (struct link_map *map)
|
|
-{
|
|
- struct audit_ifaces *afct = GLRO(dl_audit);
|
|
- for (unsigned int cnt = 0; cnt < GLRO(dl_naudit); ++cnt)
|
|
- {
|
|
- if (afct->objopen != NULL)
|
|
- {
|
|
- struct auditstate *state = link_map_audit_state (map, cnt);
|
|
- state->bindflags = afct->objopen (map, LM_ID_BASE, &state->cookie);
|
|
- map->l_audit_any_plt |= state->bindflags != 0;
|
|
- }
|
|
-
|
|
- afct = afct->next;
|
|
- }
|
|
-}
|
|
-
|
|
/* Load all audit modules. */
|
|
static void
|
|
load_audit_modules (struct link_map *main_map, struct audit_list *audit_list)
|
|
@@ -1101,8 +1082,8 @@ load_audit_modules (struct link_map *main_map, struct audit_list *audit_list)
|
|
program and the dynamic linker itself). */
|
|
if (GLRO(dl_naudit) > 0)
|
|
{
|
|
- notify_audit_modules_of_loaded_object (main_map);
|
|
- notify_audit_modules_of_loaded_object (&GL(dl_rtld_map));
|
|
+ _dl_audit_objopen (main_map, LM_ID_BASE);
|
|
+ _dl_audit_objopen (&GL(dl_rtld_map), LM_ID_BASE);
|
|
}
|
|
}
|
|
|
|
diff --git a/sysdeps/generic/ldsodefs.h b/sysdeps/generic/ldsodefs.h
|
|
index bcf1f199c5985c65..5709e4e48dff4355 100644
|
|
--- a/sysdeps/generic/ldsodefs.h
|
|
+++ b/sysdeps/generic/ldsodefs.h
|
|
@@ -1372,6 +1372,11 @@ link_map_audit_state (struct link_map *l, size_t index)
|
|
return &base[index];
|
|
}
|
|
}
|
|
+
|
|
+/* Call the la_objopen from the audit modules for the link_map L on the
|
|
+ namespace identification NSID. */
|
|
+void _dl_audit_objopen (struct link_map *l, Lmid_t nsid)
|
|
+ attribute_hidden;
|
|
#endif /* SHARED */
|
|
|
|
#if PTHREAD_IN_LIBC && defined SHARED
|