a8db42ba53
Upstream commit: 71326f1f2fd09dafb9c34404765fb88129e94237 - nptl: Fix pthread_cancel cancelhandling atomic operations - mips: Fix mips64n32 64 bit time_t stat support (BZ#29069) - hurd: Fix arbitrary error code - nptl: Handle spurious EINTR when thread cancellation is disabled (BZ#29029) - S390: Add new s390 platform z16. - NEWS: Update fixed bug list for LD_AUDIT backports. - hppa: Fix bind-now audit (BZ #28857) - elf: Replace tst-audit24bmod2.so with tst-audit24bmod2 - Fix elf/tst-audit25a with default bind now toolchains - elf: Fix runtime linker auditing on aarch64 (BZ #26643) - elf: Issue la_symbind for bind-now (BZ #23734) - elf: Fix initial-exec TLS access on audit modules (BZ #28096) - elf: Add la_activity during application exit - elf: Do not fail for failed dlmopen on audit modules (BZ #28061) - elf: Issue audit la_objopen for vDSO - elf: Add audit tests for modules with TLSDESC - elf: Avoid unnecessary slowdown from profiling with audit (BZ#15533) - elf: Add _dl_audit_pltexit - elf: Add _dl_audit_pltenter - elf: Add _dl_audit_preinit - elf: Add _dl_audit_symbind_alt and _dl_audit_symbind - elf: Add _dl_audit_objclose - elf: Add _dl_audit_objsearch - elf: Add _dl_audit_activity_map and _dl_audit_activity_nsid - elf: Add _dl_audit_objopen - elf: Move la_activity (LA_ACT_ADD) after _dl_add_to_namespace_list() (BZ #28062) - elf: Move LAV_CURRENT to link_lavcurrent.h - elf: Fix elf_get_dynamic_info() for bootstrap - elf: Fix dynamic-link.h usage on rtld.c - elf: Fix elf_get_dynamic_info definition - elf: Avoid nested functions in the loader [BZ #27220] - powerpc: Delete unneeded ELF_MACHINE_BEFORE_RTLD_RELOC - hppa: Use END instead of PSEUDO_END in swapcontext.S - hppa: Implement swapcontext in assembler (bug 28960) Reviewed-by: Florian Weimer <fweimer at redhat.com>
391 lines
12 KiB
Diff
391 lines
12 KiB
Diff
commit e25fe992132c460fecc1ab9fade185d5dd3f91ff
|
|
Author: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
Date: Thu Nov 11 09:28:21 2021 -0300
|
|
|
|
elf: Move la_activity (LA_ACT_ADD) after _dl_add_to_namespace_list() (BZ #28062)
|
|
|
|
It ensures that the the namespace is guaranteed to not be empty.
|
|
|
|
Checked on x86_64-linux-gnu.
|
|
|
|
Reviewed-by: Florian Weimer <fweimer@redhat.com>
|
|
(cherry picked from commit ed3ce71f5c64c5f07cbde0ef03554ea8950d8f2c)
|
|
|
|
Resolved conflicts:
|
|
elf/Makefile
|
|
|
|
diff --git a/elf/Makefile b/elf/Makefile
|
|
index 7fa80946ff3aae42..bf6da98bdd15a18d 100644
|
|
--- a/elf/Makefile
|
|
+++ b/elf/Makefile
|
|
@@ -363,6 +363,7 @@ tests += \
|
|
tst-audit15 \
|
|
tst-audit16 \
|
|
tst-audit17 \
|
|
+ tst-audit18 \
|
|
tst-auditmany \
|
|
tst-auxobj \
|
|
tst-auxobj-dlopen \
|
|
@@ -623,6 +624,7 @@ modules-names = \
|
|
tst-audit12mod2 \
|
|
tst-audit12mod3 \
|
|
tst-audit13mod1 \
|
|
+ tst-audit18mod \
|
|
tst-auditlogmod-1 \
|
|
tst-auditlogmod-2 \
|
|
tst-auditlogmod-3 \
|
|
@@ -640,6 +642,7 @@ modules-names = \
|
|
tst-auditmod9b \
|
|
tst-auditmod11 \
|
|
tst-auditmod12 \
|
|
+ tst-auditmod18 \
|
|
tst-auxvalmod \
|
|
tst-big-note-lib \
|
|
tst-deep1mod1 \
|
|
@@ -1999,6 +2002,10 @@ $(objpfx)tst-auditmod17.so: $(objpfx)tst-auditmod17.os
|
|
CFLAGS-.os += $(call elide-stack-protector,.os,tst-auditmod17)
|
|
tst-audit17-ENV = LD_AUDIT=$(objpfx)tst-auditmod17.so
|
|
|
|
+$(objpfx)tst-audit18.out: $(objpfx)tst-auditmod18.so \
|
|
+ $(objpfx)tst-audit18mod.so
|
|
+tst-audit18-ARGS = -- $(host-test-program-cmd)
|
|
+
|
|
# tst-sonamemove links against an older implementation of the library.
|
|
LDFLAGS-tst-sonamemove-linkmod1.so = \
|
|
-Wl,--version-script=tst-sonamemove-linkmod1.map \
|
|
diff --git a/elf/dl-load.c b/elf/dl-load.c
|
|
index a920b12a906a9dec..a8c6df3959f2b331 100644
|
|
--- a/elf/dl-load.c
|
|
+++ b/elf/dl-load.c
|
|
@@ -1054,42 +1054,6 @@ _dl_map_object_from_fd (const char *name, const char *origname, int fd,
|
|
/* This is the ELF header. We read it in `open_verify'. */
|
|
header = (void *) fbp->buf;
|
|
|
|
- /* Signal that we are going to add new objects. */
|
|
- if (r->r_state == RT_CONSISTENT)
|
|
- {
|
|
-#ifdef SHARED
|
|
- /* Auditing checkpoint: we are going to add new objects. */
|
|
- if ((mode & __RTLD_AUDIT) == 0
|
|
- && __glibc_unlikely (GLRO(dl_naudit) > 0))
|
|
- {
|
|
- struct link_map *head = GL(dl_ns)[nsid]._ns_loaded;
|
|
- /* Do not call the functions for any auditing object. */
|
|
- if (head->l_auditing == 0)
|
|
- {
|
|
- struct audit_ifaces *afct = GLRO(dl_audit);
|
|
- for (unsigned int cnt = 0; cnt < GLRO(dl_naudit); ++cnt)
|
|
- {
|
|
- if (afct->activity != NULL)
|
|
- afct->activity (&link_map_audit_state (head, cnt)->cookie,
|
|
- LA_ACT_ADD);
|
|
-
|
|
- afct = afct->next;
|
|
- }
|
|
- }
|
|
- }
|
|
-#endif
|
|
-
|
|
- /* Notify the debugger we have added some objects. We need to
|
|
- call _dl_debug_initialize in a static program in case dynamic
|
|
- linking has not been used before. */
|
|
- r->r_state = RT_ADD;
|
|
- _dl_debug_state ();
|
|
- LIBC_PROBE (map_start, 2, nsid, r);
|
|
- make_consistent = true;
|
|
- }
|
|
- else
|
|
- assert (r->r_state == RT_ADD);
|
|
-
|
|
/* Enter the new object in the list of loaded objects. */
|
|
l = _dl_new_object (realname, name, l_type, loader, mode, nsid);
|
|
if (__glibc_unlikely (l == NULL))
|
|
@@ -1511,6 +1475,44 @@ cannot enable executable stack as shared object requires");
|
|
/* Now that the object is fully initialized add it to the object list. */
|
|
_dl_add_to_namespace_list (l, nsid);
|
|
|
|
+ /* Signal that we are going to add new objects. */
|
|
+ if (r->r_state == RT_CONSISTENT)
|
|
+ {
|
|
+#ifdef SHARED
|
|
+ /* Auditing checkpoint: we are going to add new objects. Since this
|
|
+ is called after _dl_add_to_namespace_list the namespace is guaranteed
|
|
+ to not be empty. */
|
|
+ if ((mode & __RTLD_AUDIT) == 0
|
|
+ && __glibc_unlikely (GLRO(dl_naudit) > 0))
|
|
+ {
|
|
+ struct link_map *head = GL(dl_ns)[nsid]._ns_loaded;
|
|
+ /* Do not call the functions for any auditing object. */
|
|
+ if (head->l_auditing == 0)
|
|
+ {
|
|
+ struct audit_ifaces *afct = GLRO(dl_audit);
|
|
+ for (unsigned int cnt = 0; cnt < GLRO(dl_naudit); ++cnt)
|
|
+ {
|
|
+ if (afct->activity != NULL)
|
|
+ afct->activity (&link_map_audit_state (head, cnt)->cookie,
|
|
+ LA_ACT_ADD);
|
|
+
|
|
+ afct = afct->next;
|
|
+ }
|
|
+ }
|
|
+ }
|
|
+#endif
|
|
+
|
|
+ /* Notify the debugger we have added some objects. We need to
|
|
+ call _dl_debug_initialize in a static program in case dynamic
|
|
+ linking has not been used before. */
|
|
+ r->r_state = RT_ADD;
|
|
+ _dl_debug_state ();
|
|
+ LIBC_PROBE (map_start, 2, nsid, r);
|
|
+ make_consistent = true;
|
|
+ }
|
|
+ else
|
|
+ assert (r->r_state == RT_ADD);
|
|
+
|
|
#ifdef SHARED
|
|
/* Auditing checkpoint: we have a new object. */
|
|
if (__glibc_unlikely (GLRO(dl_naudit) > 0)
|
|
diff --git a/elf/tst-audit18.c b/elf/tst-audit18.c
|
|
new file mode 100644
|
|
index 0000000000000000..ef784908f60d50aa
|
|
--- /dev/null
|
|
+++ b/elf/tst-audit18.c
|
|
@@ -0,0 +1,129 @@
|
|
+/* Check DT_AUDIT with dlmopen.
|
|
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <array_length.h>
|
|
+#include <getopt.h>
|
|
+#include <string.h>
|
|
+#include <stdlib.h>
|
|
+#include <unistd.h>
|
|
+#include <gnu/lib-names.h>
|
|
+#include <support/capture_subprocess.h>
|
|
+#include <support/check.h>
|
|
+#include <support/xdlfcn.h>
|
|
+#include <support/xstdio.h>
|
|
+#include <support/support.h>
|
|
+
|
|
+static int restart;
|
|
+#define CMDLINE_OPTIONS \
|
|
+ { "restart", no_argument, &restart, 1 },
|
|
+
|
|
+static int
|
|
+handle_restart (void)
|
|
+{
|
|
+ {
|
|
+ void *h = xdlmopen (LM_ID_NEWLM, LIBC_SO, RTLD_NOW);
|
|
+
|
|
+ pid_t (*s) (void) = xdlsym (h, "getpid");
|
|
+ TEST_COMPARE (s (), getpid ());
|
|
+
|
|
+ xdlclose (h);
|
|
+ }
|
|
+
|
|
+ {
|
|
+ void *h = xdlmopen (LM_ID_NEWLM, "tst-audit18mod.so", RTLD_NOW);
|
|
+
|
|
+ int (*foo) (void) = xdlsym (h, "foo");
|
|
+ TEST_COMPARE (foo (), 10);
|
|
+
|
|
+ xdlclose (h);
|
|
+ }
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int
|
|
+do_test (int argc, char *argv[])
|
|
+{
|
|
+ /* We must have either:
|
|
+ - One our fource parameters left if called initially:
|
|
+ + path to ld.so optional
|
|
+ + "--library-path" optional
|
|
+ + the library path optional
|
|
+ + the application name */
|
|
+
|
|
+ if (restart)
|
|
+ return handle_restart ();
|
|
+
|
|
+ char *spargv[9];
|
|
+ int i = 0;
|
|
+ for (; i < argc - 1; i++)
|
|
+ spargv[i] = argv[i + 1];
|
|
+ spargv[i++] = (char *) "--direct";
|
|
+ spargv[i++] = (char *) "--restart";
|
|
+ spargv[i] = NULL;
|
|
+
|
|
+ setenv ("LD_AUDIT", "tst-auditmod18.so", 0);
|
|
+ struct support_capture_subprocess result
|
|
+ = support_capture_subprogram (spargv[0], spargv);
|
|
+ support_capture_subprocess_check (&result, "tst-audit18", 0, sc_allow_stderr);
|
|
+
|
|
+ struct
|
|
+ {
|
|
+ const char *name;
|
|
+ bool found;
|
|
+ } audit_iface[] =
|
|
+ {
|
|
+ { "la_version", false },
|
|
+ { "la_objsearch", false },
|
|
+ { "la_activity", false },
|
|
+ { "la_objopen", false },
|
|
+ { "la_objclose", false },
|
|
+ { "la_preinit", false },
|
|
+#if __WORDSIZE == 32
|
|
+ { "la_symbind32", false },
|
|
+#elif __WORDSIZE == 64
|
|
+ { "la_symbind64", false },
|
|
+#endif
|
|
+ };
|
|
+
|
|
+ /* Some hooks are called more than once but the test only check if any
|
|
+ is called at least once. */
|
|
+ FILE *out = fmemopen (result.err.buffer, result.err.length, "r");
|
|
+ TEST_VERIFY (out != NULL);
|
|
+ char *buffer = NULL;
|
|
+ size_t buffer_length = 0;
|
|
+ while (xgetline (&buffer, &buffer_length, out))
|
|
+ {
|
|
+ for (int i = 0; i < array_length (audit_iface); i++)
|
|
+ if (strncmp (buffer, audit_iface[i].name,
|
|
+ strlen (audit_iface[i].name)) == 0)
|
|
+ audit_iface[i].found = true;
|
|
+ }
|
|
+ free (buffer);
|
|
+ xfclose (out);
|
|
+
|
|
+ for (int i = 0; i < array_length (audit_iface); i++)
|
|
+ TEST_COMPARE (audit_iface[i].found, true);
|
|
+
|
|
+ support_capture_subprocess_free (&result);
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+#define TEST_FUNCTION_ARGV do_test
|
|
+#include <support/test-driver.c>
|
|
diff --git a/elf/tst-audit18mod.c b/elf/tst-audit18mod.c
|
|
new file mode 100644
|
|
index 0000000000000000..096a9167c9f8353f
|
|
--- /dev/null
|
|
+++ b/elf/tst-audit18mod.c
|
|
@@ -0,0 +1,23 @@
|
|
+/* Check DT_AUDIT with dlmopen.
|
|
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+int
|
|
+foo (void)
|
|
+{
|
|
+ return 10;
|
|
+}
|
|
diff --git a/elf/tst-auditmod18.c b/elf/tst-auditmod18.c
|
|
new file mode 100644
|
|
index 0000000000000000..182992e9fdb1620c
|
|
--- /dev/null
|
|
+++ b/elf/tst-auditmod18.c
|
|
@@ -0,0 +1,73 @@
|
|
+/* Check DT_AUDIT with dlmopen.
|
|
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <stdio.h>
|
|
+#include <link.h>
|
|
+
|
|
+unsigned int
|
|
+la_version (unsigned int version)
|
|
+{
|
|
+ fprintf (stderr, "%s\n", __func__);
|
|
+ return LAV_CURRENT;
|
|
+}
|
|
+
|
|
+char *
|
|
+la_objsearch (const char *name, uintptr_t *cookie, unsigned int flag)
|
|
+{
|
|
+ fprintf (stderr, "%s\n", __func__);
|
|
+ return (char *) name;
|
|
+}
|
|
+
|
|
+void
|
|
+la_activity (uintptr_t *cookie, unsigned int flag)
|
|
+{
|
|
+ fprintf (stderr, "%s\n", __func__);
|
|
+}
|
|
+
|
|
+unsigned int
|
|
+la_objopen (struct link_map *map, Lmid_t lmid, uintptr_t *cookie)
|
|
+{
|
|
+ fprintf (stderr, "%s\n", __func__);
|
|
+ return LA_FLG_BINDTO | LA_FLG_BINDFROM;
|
|
+}
|
|
+
|
|
+unsigned int
|
|
+la_objclose (uintptr_t *cookie)
|
|
+{
|
|
+ fprintf (stderr, "%s\n", __func__);
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+void
|
|
+la_preinit (uintptr_t *cookie)
|
|
+{
|
|
+ fprintf (stderr, "%s\n", __func__);
|
|
+}
|
|
+
|
|
+uintptr_t
|
|
+#if __ELF_NATIVE_CLASS == 32
|
|
+la_symbind32 (Elf32_Sym *sym, unsigned int ndx, uintptr_t *refcook,
|
|
+ uintptr_t *defcook, unsigned int *flags, const char *symname)
|
|
+#else
|
|
+la_symbind64 (Elf64_Sym *sym, unsigned int ndx, uintptr_t *refcook,
|
|
+ uintptr_t *defcook, unsigned int *flags, const char *symname)
|
|
+#endif
|
|
+{
|
|
+ fprintf (stderr, "%s\n", __func__);
|
|
+ return sym->st_value;
|
|
+}
|