94eca17094
Upstream commit: ede8d94d154157d269b18f3601440ac576c1f96a - csu: Implement and use _dl_early_allocate during static startup - Linux: Introduce __brk_call for invoking the brk system call - Linux: Implement a useful version of _startup_fatal - ia64: Always define IA64_USE_NEW_STUB as a flag macro - Linux: Define MMAP_CALL_INTERNAL - i386: Honor I386_USE_SYSENTER for 6-argument Linux system calls - i386: Remove OPTIMIZE_FOR_GCC_5 from Linux libc-do-syscall.S - elf: Remove __libc_init_secure - Linux: Consolidate auxiliary vector parsing (redo) - Linux: Include <dl-auxv.h> in dl-sysdep.c only for SHARED - Revert "Linux: Consolidate auxiliary vector parsing" - Linux: Consolidate auxiliary vector parsing - Linux: Assume that NEED_DL_SYSINFO_DSO is always defined - Linux: Remove DL_FIND_ARG_COMPONENTS - Linux: Remove HAVE_AUX_SECURE, HAVE_AUX_XID, HAVE_AUX_PAGESIZE - elf: Merge dl-sysdep.c into the Linux version - elf: Remove unused NEED_DL_BASE_ADDR and _dl_base_addr - x86: Optimize {str|wcs}rchr-evex - x86: Optimize {str|wcs}rchr-avx2 - x86: Optimize {str|wcs}rchr-sse2 - x86: Cleanup page cross code in memcmp-avx2-movbe.S - x86: Remove memcmp-sse4.S - x86: Small improvements for wcslen - x86: Remove AVX str{n}casecmp - x86: Add EVEX optimized str{n}casecmp - x86: Add AVX2 optimized str{n}casecmp - x86: Optimize str{n}casecmp TOLOWER logic in strcmp-sse42.S - x86: Optimize str{n}casecmp TOLOWER logic in strcmp.S - x86: Remove strspn-sse2.S and use the generic implementation - x86: Remove strpbrk-sse2.S and use the generic implementation - x86: Remove strcspn-sse2.S and use the generic implementation - x86: Optimize strspn in strspn-c.c - x86: Optimize strcspn and strpbrk in strcspn-c.c - x86: Code cleanup in strchr-evex and comment justifying branch - x86: Code cleanup in strchr-avx2 and comment justifying branch - x86_64: Remove bcopy optimizations - x86-64: Remove bzero weak alias in SS2 memset - x86_64/multiarch: Sort sysdep_routines and put one entry per line - x86: Improve L to support L(XXX_SYMBOL (YYY, ZZZ)) - fortify: Ensure that __glibc_fortify condition is a constant [BZ #29141]
99 lines
2.4 KiB
Diff
99 lines
2.4 KiB
Diff
commit 6cba46c85804988f4fd41ef03e8a170a4c987a86
|
|
Author: H.J. Lu <hjl.tools@gmail.com>
|
|
Date: Sat Feb 5 11:52:33 2022 -0800
|
|
|
|
x86_64/multiarch: Sort sysdep_routines and put one entry per line
|
|
|
|
(cherry picked from commit c328d0152d4b14cca58407ec68143894c8863004)
|
|
|
|
diff --git a/sysdeps/x86_64/multiarch/Makefile b/sysdeps/x86_64/multiarch/Makefile
|
|
index 37d8d6f0bd2d10cc..8c9e7812c6af10b8 100644
|
|
--- a/sysdeps/x86_64/multiarch/Makefile
|
|
+++ b/sysdeps/x86_64/multiarch/Makefile
|
|
@@ -132,37 +132,55 @@ CFLAGS-strspn-c.c += -msse4
|
|
endif
|
|
|
|
ifeq ($(subdir),wcsmbs)
|
|
-sysdep_routines += wmemcmp-sse4 wmemcmp-ssse3 wmemcmp-c \
|
|
- wmemcmp-avx2-movbe \
|
|
- wmemchr-sse2 wmemchr-avx2 \
|
|
- wcscmp-sse2 wcscmp-avx2 \
|
|
- wcsncmp-sse2 wcsncmp-avx2 \
|
|
- wcscpy-ssse3 wcscpy-c \
|
|
- wcschr-sse2 wcschr-avx2 \
|
|
- wcsrchr-sse2 wcsrchr-avx2 \
|
|
- wcslen-sse2 wcslen-sse4_1 wcslen-avx2 \
|
|
- wcsnlen-c wcsnlen-sse4_1 wcsnlen-avx2 \
|
|
- wcschr-avx2-rtm \
|
|
- wcscmp-avx2-rtm \
|
|
- wcslen-avx2-rtm \
|
|
- wcsncmp-avx2-rtm \
|
|
- wcsnlen-avx2-rtm \
|
|
- wcsrchr-avx2-rtm \
|
|
- wmemchr-avx2-rtm \
|
|
- wmemcmp-avx2-movbe-rtm \
|
|
- wcschr-evex \
|
|
- wcscmp-evex \
|
|
- wcslen-evex \
|
|
- wcsncmp-evex \
|
|
- wcsnlen-evex \
|
|
- wcsrchr-evex \
|
|
- wmemchr-evex \
|
|
- wmemcmp-evex-movbe \
|
|
- wmemchr-evex-rtm
|
|
+sysdep_routines += \
|
|
+ wcschr-avx2 \
|
|
+ wcschr-avx2-rtm \
|
|
+ wcschr-evex \
|
|
+ wcschr-sse2 \
|
|
+ wcscmp-avx2 \
|
|
+ wcscmp-avx2-rtm \
|
|
+ wcscmp-evex \
|
|
+ wcscmp-sse2 \
|
|
+ wcscpy-c \
|
|
+ wcscpy-ssse3 \
|
|
+ wcslen-avx2 \
|
|
+ wcslen-avx2-rtm \
|
|
+ wcslen-evex \
|
|
+ wcslen-sse2 \
|
|
+ wcslen-sse4_1 \
|
|
+ wcsncmp-avx2 \
|
|
+ wcsncmp-avx2-rtm \
|
|
+ wcsncmp-evex \
|
|
+ wcsncmp-sse2 \
|
|
+ wcsnlen-avx2 \
|
|
+ wcsnlen-avx2-rtm \
|
|
+ wcsnlen-c \
|
|
+ wcsnlen-evex \
|
|
+ wcsnlen-sse4_1 \
|
|
+ wcsrchr-avx2 \
|
|
+ wcsrchr-avx2-rtm \
|
|
+ wcsrchr-evex \
|
|
+ wcsrchr-sse2 \
|
|
+ wmemchr-avx2 \
|
|
+ wmemchr-avx2-rtm \
|
|
+ wmemchr-evex \
|
|
+ wmemchr-evex-rtm \
|
|
+ wmemchr-sse2 \
|
|
+ wmemcmp-avx2-movbe \
|
|
+ wmemcmp-avx2-movbe-rtm \
|
|
+ wmemcmp-c \
|
|
+ wmemcmp-evex-movbe \
|
|
+ wmemcmp-sse4 \
|
|
+ wmemcmp-ssse3 \
|
|
+# sysdep_routines
|
|
endif
|
|
|
|
ifeq ($(subdir),debug)
|
|
-sysdep_routines += memcpy_chk-nonshared mempcpy_chk-nonshared \
|
|
- memmove_chk-nonshared memset_chk-nonshared \
|
|
- wmemset_chk-nonshared
|
|
+sysdep_routines += \
|
|
+ memcpy_chk-nonshared \
|
|
+ memmove_chk-nonshared \
|
|
+ mempcpy_chk-nonshared \
|
|
+ memset_chk-nonshared \
|
|
+ wmemset_chk-nonshared \
|
|
+# sysdep_routines
|
|
endif
|