abcc04a5bf
Upstream commit: 224d8c1890b6c57c7e4e8ddbb792dd9552086704 - debug: Synchronize feature guards in fortified functions [BZ #28746] - debug: Autogenerate _FORTIFY_SOURCE tests - Enable _FORTIFY_SOURCE=3 for gcc 12 and above - fortify: Fix spurious warning with realpath - __glibc_unsafe_len: Fix comment - debug: Add tests for _FORTIFY_SOURCE=3 - Make sure that the fortified function conditionals are constant - Don't add access size hints to fortifiable functions - nss: Protect against errno changes in function lookup (bug 28953) - nss: Do not mention NSS test modules in <gnu/lib-names.h> - io: Add fsync call in tst-stat - hppa: Fix warnings from _dl_lookup_address - nptl: Fix cleanups for stack grows up [BZ# 28899] - hppa: Revise gettext trampoline design - hppa: Fix swapcontext - Fix elf/tst-audit2 on hppa - localedef: Handle symbolic links when generating locale-archive - NEWS: Add a bug fix entry for BZ #28896 - x86: Fix TEST_NAME to make it a string in tst-strncmp-rtm.c - x86: Test wcscmp RTM in the wcsncmp overflow case [BZ #28896] - x86: Fallback {str|wcs}cmp RTM in the ncmp overflow case [BZ #28896] - string: Add a testcase for wcsncmp with SIZE_MAX [BZ #28755] - linux: fix accuracy of get_nprocs and get_nprocs_conf [BZ #28865] - Add reference to BZ#28860 on NEWS - linux: Fix missing __convert_scm_timestamps (BZ #28860)
294 lines
9.6 KiB
Diff
294 lines
9.6 KiB
Diff
commit f8c2f620f1929ad78cb0a247601bec972f140c51
|
|
Author: Siddhesh Poyarekar <siddhesh@sourceware.org>
|
|
Date: Wed Jan 12 23:34:23 2022 +0530
|
|
|
|
debug: Autogenerate _FORTIFY_SOURCE tests
|
|
|
|
Rename debug/tst-chk1.c to debug/tst-fortify.c and add make hackery to
|
|
autogenerate tests with different macros enabled to build and run the
|
|
same test with different configurations as well as different
|
|
fortification levels.
|
|
|
|
The change also ends up expanding the -lfs tests to include
|
|
_FORTIFY_SOURCE=3.
|
|
|
|
Signed-off-by: Siddhesh Poyarekar <siddhesh@sourceware.org>
|
|
Reviewed-by: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
(cherry picked from commit db27f1251b008280a29d540b4f8ab2a38a0d80af)
|
|
|
|
diff --git a/Makerules b/Makerules
|
|
index 596fa68376f45298..7fbe85719aacc230 100644
|
|
--- a/Makerules
|
|
+++ b/Makerules
|
|
@@ -424,6 +424,12 @@ $(objpfx)%$o: $(objpfx)%.c $(before-compile); $$(compile-command.c)
|
|
endef
|
|
object-suffixes-left := $(all-object-suffixes)
|
|
include $(o-iterator)
|
|
+
|
|
+define o-iterator-doit
|
|
+$(objpfx)%$o: $(objpfx)%.cc $(before-compile); $$(compile-command.cc)
|
|
+endef
|
|
+object-suffixes-left := $(all-object-suffixes)
|
|
+include $(o-iterator)
|
|
endif
|
|
|
|
# Generate .dT files as we compile.
|
|
diff --git a/debug/Makefile b/debug/Makefile
|
|
index bc37e466eed490fa..acc1b8f6ad029c62 100644
|
|
--- a/debug/Makefile
|
|
+++ b/debug/Makefile
|
|
@@ -1,4 +1,5 @@
|
|
-# Copyright (C) 1998-2021 Free Software Foundation, Inc.
|
|
+# Copyright (C) 1998-2022 Free Software Foundation, Inc.
|
|
+# Copyright The GNU Toolchain Authors.
|
|
# This file is part of the GNU C Library.
|
|
|
|
# The GNU C Library is free software; you can redistribute it and/or
|
|
@@ -110,32 +111,60 @@ CFLAGS-tst-longjmp_chk3.c += -fexceptions -fasynchronous-unwind-tables
|
|
CPPFLAGS-tst-longjmp_chk3.c += -D_FORTIFY_SOURCE=1
|
|
CPPFLAGS-tst-realpath-chk.c += -D_FORTIFY_SOURCE=2
|
|
|
|
+# _FORTIFY_SOURCE tests.
|
|
+# Auto-generate tests for _FORTIFY_SOURCE for different levels, compilers and
|
|
+# preprocessor conditions based on tst-fortify.c.
|
|
+#
|
|
+# To add a new test condition, define a cflags-$(cond) make variable to set
|
|
+# CFLAGS for the file.
|
|
+
|
|
+tests-all-chk = tst-fortify
|
|
+tests-c-chk =
|
|
+tests-cc-chk =
|
|
+
|
|
+CFLAGS-tst-fortify.c += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
+
|
|
+# No additional flags for the default tests.
|
|
+define cflags-default
|
|
+endef
|
|
+
|
|
+define cflags-lfs
|
|
+CFLAGS-tst-fortify-$(1)-lfs-$(2).$(1) += -D_FILE_OFFSET_BITS=64
|
|
+endef
|
|
+
|
|
# We know these tests have problems with format strings, this is what
|
|
# we are testing. Disable that warning. They are also testing
|
|
# deprecated functions (notably gets) so disable that warning as well.
|
|
# And they also generate warnings from warning attributes, which
|
|
# cannot be disabled via pragmas, so require -Wno-error to be used.
|
|
-CFLAGS-tst-chk1.c += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-CFLAGS-tst-chk2.c += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-CFLAGS-tst-chk3.c += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-CFLAGS-tst-chk4.cc += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-CFLAGS-tst-chk5.cc += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-CFLAGS-tst-chk6.cc += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-CFLAGS-tst-chk7.c += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-CFLAGS-tst-chk8.cc += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-CFLAGS-tst-lfschk1.c += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-CFLAGS-tst-lfschk2.c += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-CFLAGS-tst-lfschk3.c += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-CFLAGS-tst-lfschk4.cc += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-CFLAGS-tst-lfschk5.cc += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-CFLAGS-tst-lfschk6.cc += -Wno-format -Wno-deprecated-declarations -Wno-error
|
|
-LDLIBS-tst-chk4 = -lstdc++
|
|
-LDLIBS-tst-chk5 = -lstdc++
|
|
-LDLIBS-tst-chk6 = -lstdc++
|
|
-LDLIBS-tst-chk8 = -lstdc++
|
|
-LDLIBS-tst-lfschk4 = -lstdc++
|
|
-LDLIBS-tst-lfschk5 = -lstdc++
|
|
-LDLIBS-tst-lfschk6 = -lstdc++
|
|
+define gen-chk-test
|
|
+tests-$(1)-chk += tst-fortify-$(1)-$(2)-$(3)
|
|
+CFLAGS-tst-fortify-$(1)-$(2)-$(3).$(1) += -D_FORTIFY_SOURCE=$(3) -Wno-format \
|
|
+ -Wno-deprecated-declarations \
|
|
+ -Wno-error
|
|
+$(eval $(call cflags-$(2),$(1),$(3)))
|
|
+$(objpfx)tst-fortify-$(1)-$(2)-$(3).$(1): tst-fortify.c Makefile
|
|
+ ( echo "/* Autogenerated from Makefile. */"; \
|
|
+ echo ""; \
|
|
+ echo "#include \"tst-fortify.c\"" ) > $$@.tmp
|
|
+ mv $$@.tmp $$@
|
|
+endef
|
|
+
|
|
+chk-extensions = c cc
|
|
+chk-types = default lfs
|
|
+chk-levels = 1 2 3
|
|
+
|
|
+$(foreach e,$(chk-extensions), \
|
|
+ $(foreach t,$(chk-types), \
|
|
+ $(foreach l,$(chk-levels), \
|
|
+ $(eval $(call gen-chk-test,$(e),$(t),$(l))))))
|
|
+
|
|
+tests-all-chk += $(tests-c-chk) $(tests-cc-chk)
|
|
+
|
|
+define link-cc
|
|
+LDLIBS-$(1) = -lstdc++
|
|
+endef
|
|
+$(foreach t,$(tests-cc-chk), $(eval $(call link-cc,$(t))))
|
|
|
|
# backtrace_symbols only works if we link with -rdynamic. backtrace
|
|
# requires unwind tables on most architectures.
|
|
@@ -152,19 +181,25 @@ LDFLAGS-tst-backtrace6 = -rdynamic
|
|
|
|
CFLAGS-tst-ssp-1.c += -fstack-protector-all
|
|
|
|
-tests = backtrace-tst tst-longjmp_chk tst-chk1 tst-chk2 tst-chk3 \
|
|
- tst-lfschk1 tst-lfschk2 tst-lfschk3 test-strcpy_chk test-stpcpy_chk \
|
|
- tst-chk4 tst-chk5 tst-chk6 tst-chk7 tst-chk8 tst-lfschk4 tst-lfschk5 \
|
|
- tst-lfschk6 tst-longjmp_chk2 tst-backtrace2 tst-backtrace3 \
|
|
- tst-backtrace4 tst-backtrace5 tst-backtrace6 tst-realpath-chk
|
|
+tests = backtrace-tst \
|
|
+ tst-longjmp_chk \
|
|
+ test-strcpy_chk \
|
|
+ test-stpcpy_chk \
|
|
+ tst-longjmp_chk2 \
|
|
+ tst-backtrace2 \
|
|
+ tst-backtrace3 \
|
|
+ tst-backtrace4 \
|
|
+ tst-backtrace5 \
|
|
+ tst-backtrace6 \
|
|
+ tst-realpath-chk \
|
|
+ $(tests-all-chk)
|
|
|
|
ifeq ($(have-ssp),yes)
|
|
tests += tst-ssp-1
|
|
endif
|
|
|
|
ifeq (,$(CXX))
|
|
-tests-unsupported = tst-chk4 tst-chk5 tst-chk6 tst-chk8 \
|
|
- tst-lfschk4 tst-lfschk5 tst-lfschk6
|
|
+tests-unsupported = $(tests-cc-chk)
|
|
endif
|
|
|
|
extra-libs = libSegFault libpcprofile
|
|
@@ -191,20 +226,10 @@ ifeq ($(run-built-tests),yes)
|
|
LOCALES := de_DE.UTF-8
|
|
include ../gen-locales.mk
|
|
|
|
-$(objpfx)tst-chk1.out: $(gen-locales)
|
|
-$(objpfx)tst-chk2.out: $(gen-locales)
|
|
-$(objpfx)tst-chk3.out: $(gen-locales)
|
|
-$(objpfx)tst-chk4.out: $(gen-locales)
|
|
-$(objpfx)tst-chk5.out: $(gen-locales)
|
|
-$(objpfx)tst-chk6.out: $(gen-locales)
|
|
-$(objpfx)tst-chk7.out: $(gen-locales)
|
|
-$(objpfx)tst-chk8.out: $(gen-locales)
|
|
-$(objpfx)tst-lfschk1.out: $(gen-locales)
|
|
-$(objpfx)tst-lfschk2.out: $(gen-locales)
|
|
-$(objpfx)tst-lfschk3.out: $(gen-locales)
|
|
-$(objpfx)tst-lfschk4.out: $(gen-locales)
|
|
-$(objpfx)tst-lfschk5.out: $(gen-locales)
|
|
-$(objpfx)tst-lfschk6.out: $(gen-locales)
|
|
+define chk-gen-locales
|
|
+$(objpfx)$(1).out: $(gen-locales)
|
|
+endef
|
|
+$(foreach t, $(tests-all-chk), $(eval $(call chk-gen-locales,$(t))))
|
|
endif
|
|
|
|
sLIBdir := $(shell echo $(slibdir) | sed 's,lib\(\|64\)$$,\\\\$$LIB,')
|
|
diff --git a/debug/tst-chk2.c b/debug/tst-chk2.c
|
|
deleted file mode 100644
|
|
index be37ce2d22f0760a..0000000000000000
|
|
--- a/debug/tst-chk2.c
|
|
+++ /dev/null
|
|
@@ -1,2 +0,0 @@
|
|
-#define _FORTIFY_SOURCE 1
|
|
-#include "tst-chk1.c"
|
|
diff --git a/debug/tst-chk3.c b/debug/tst-chk3.c
|
|
deleted file mode 100644
|
|
index 38b8e4fb360ba722..0000000000000000
|
|
--- a/debug/tst-chk3.c
|
|
+++ /dev/null
|
|
@@ -1,2 +0,0 @@
|
|
-#define _FORTIFY_SOURCE 2
|
|
-#include "tst-chk1.c"
|
|
diff --git a/debug/tst-chk4.cc b/debug/tst-chk4.cc
|
|
deleted file mode 100644
|
|
index c82e6aac86038791..0000000000000000
|
|
--- a/debug/tst-chk4.cc
|
|
+++ /dev/null
|
|
@@ -1 +0,0 @@
|
|
-#include "tst-chk1.c"
|
|
diff --git a/debug/tst-chk5.cc b/debug/tst-chk5.cc
|
|
deleted file mode 100644
|
|
index be37ce2d22f0760a..0000000000000000
|
|
--- a/debug/tst-chk5.cc
|
|
+++ /dev/null
|
|
@@ -1,2 +0,0 @@
|
|
-#define _FORTIFY_SOURCE 1
|
|
-#include "tst-chk1.c"
|
|
diff --git a/debug/tst-chk6.cc b/debug/tst-chk6.cc
|
|
deleted file mode 100644
|
|
index 38b8e4fb360ba722..0000000000000000
|
|
--- a/debug/tst-chk6.cc
|
|
+++ /dev/null
|
|
@@ -1,2 +0,0 @@
|
|
-#define _FORTIFY_SOURCE 2
|
|
-#include "tst-chk1.c"
|
|
diff --git a/debug/tst-chk7.c b/debug/tst-chk7.c
|
|
deleted file mode 100644
|
|
index 2a7b32381268135c..0000000000000000
|
|
--- a/debug/tst-chk7.c
|
|
+++ /dev/null
|
|
@@ -1,2 +0,0 @@
|
|
-#define _FORTIFY_SOURCE 3
|
|
-#include "tst-chk1.c"
|
|
diff --git a/debug/tst-chk8.cc b/debug/tst-chk8.cc
|
|
deleted file mode 100644
|
|
index 2a7b32381268135c..0000000000000000
|
|
--- a/debug/tst-chk8.cc
|
|
+++ /dev/null
|
|
@@ -1,2 +0,0 @@
|
|
-#define _FORTIFY_SOURCE 3
|
|
-#include "tst-chk1.c"
|
|
diff --git a/debug/tst-chk1.c b/debug/tst-fortify.c
|
|
similarity index 100%
|
|
rename from debug/tst-chk1.c
|
|
rename to debug/tst-fortify.c
|
|
diff --git a/debug/tst-lfschk1.c b/debug/tst-lfschk1.c
|
|
deleted file mode 100644
|
|
index f3e6d47d5e4484c3..0000000000000000
|
|
--- a/debug/tst-lfschk1.c
|
|
+++ /dev/null
|
|
@@ -1,2 +0,0 @@
|
|
-#define _FILE_OFFSET_BITS 64
|
|
-#include "tst-chk1.c"
|
|
diff --git a/debug/tst-lfschk2.c b/debug/tst-lfschk2.c
|
|
deleted file mode 100644
|
|
index 95d4db1d32d2eeb3..0000000000000000
|
|
--- a/debug/tst-lfschk2.c
|
|
+++ /dev/null
|
|
@@ -1,2 +0,0 @@
|
|
-#define _FILE_OFFSET_BITS 64
|
|
-#include "tst-chk2.c"
|
|
diff --git a/debug/tst-lfschk3.c b/debug/tst-lfschk3.c
|
|
deleted file mode 100644
|
|
index 50a1ae1258f1553d..0000000000000000
|
|
--- a/debug/tst-lfschk3.c
|
|
+++ /dev/null
|
|
@@ -1,2 +0,0 @@
|
|
-#define _FILE_OFFSET_BITS 64
|
|
-#include "tst-chk3.c"
|
|
diff --git a/debug/tst-lfschk4.cc b/debug/tst-lfschk4.cc
|
|
deleted file mode 100644
|
|
index f3e6d47d5e4484c3..0000000000000000
|
|
--- a/debug/tst-lfschk4.cc
|
|
+++ /dev/null
|
|
@@ -1,2 +0,0 @@
|
|
-#define _FILE_OFFSET_BITS 64
|
|
-#include "tst-chk1.c"
|
|
diff --git a/debug/tst-lfschk5.cc b/debug/tst-lfschk5.cc
|
|
deleted file mode 100644
|
|
index 95d4db1d32d2eeb3..0000000000000000
|
|
--- a/debug/tst-lfschk5.cc
|
|
+++ /dev/null
|
|
@@ -1,2 +0,0 @@
|
|
-#define _FILE_OFFSET_BITS 64
|
|
-#include "tst-chk2.c"
|
|
diff --git a/debug/tst-lfschk6.cc b/debug/tst-lfschk6.cc
|
|
deleted file mode 100644
|
|
index 50a1ae1258f1553d..0000000000000000
|
|
--- a/debug/tst-lfschk6.cc
|
|
+++ /dev/null
|
|
@@ -1,2 +0,0 @@
|
|
-#define _FILE_OFFSET_BITS 64
|
|
-#include "tst-chk3.c"
|