0129572436
Upstream commit: 387bff63dc2dccd62b09aa26dccf8cdc5f3c985c - powerpc64[le]: Fix CFI and LR save address for asm syscalls [BZ #28532] - linux: Use /proc/stat fallback for __get_nprocs_conf (BZ #28624) - nptl: Do not set signal mask on second setjmp return [BZ #28607] - s390: Use long branches across object boundaries (jgh instead of jh) - elf: Earlier missing dynamic segment check in _dl_map_object_from_fd - gconv: Do not emit spurious NUL character in ISO-2022-JP-3 (bug 28524)
103 lines
3.7 KiB
Diff
103 lines
3.7 KiB
Diff
commit bfe68fe3c475fe34bed4e017d6e63196c305c934
|
|
Author: Florian Weimer <fweimer@redhat.com>
|
|
Date: Wed Nov 24 08:59:54 2021 +0100
|
|
|
|
nptl: Do not set signal mask on second setjmp return [BZ #28607]
|
|
|
|
__libc_signal_restore_set was in the wrong place: It also ran
|
|
when setjmp returned the second time (after pthread_exit or
|
|
pthread_cancel). This is observable with blocked pending
|
|
signals during thread exit.
|
|
|
|
Fixes commit b3cae39dcbfa2432b3f3aa28854d8ac57f0de1b8
|
|
("nptl: Start new threads with all signals blocked [BZ #25098]").
|
|
|
|
Reviewed-by: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
(cherry picked from commit e186fc5a31e46f2cbf5ea1a75223b4412907f3d8)
|
|
|
|
diff --git a/nptl/pthread_create.c b/nptl/pthread_create.c
|
|
index bc213f0bc4e948bd..3db0c9fdf40ae2bf 100644
|
|
--- a/nptl/pthread_create.c
|
|
+++ b/nptl/pthread_create.c
|
|
@@ -407,8 +407,6 @@ start_thread (void *arg)
|
|
unwind_buf.priv.data.prev = NULL;
|
|
unwind_buf.priv.data.cleanup = NULL;
|
|
|
|
- __libc_signal_restore_set (&pd->sigmask);
|
|
-
|
|
/* Allow setxid from now onwards. */
|
|
if (__glibc_unlikely (atomic_exchange_acq (&pd->setxid_futex, 0) == -2))
|
|
futex_wake (&pd->setxid_futex, 1, FUTEX_PRIVATE);
|
|
@@ -418,6 +416,8 @@ start_thread (void *arg)
|
|
/* Store the new cleanup handler info. */
|
|
THREAD_SETMEM (pd, cleanup_jmp_buf, &unwind_buf);
|
|
|
|
+ __libc_signal_restore_set (&pd->sigmask);
|
|
+
|
|
LIBC_PROBE (pthread_start, 3, (pthread_t) pd, pd->start_routine, pd->arg);
|
|
|
|
/* Run the code the user provided. */
|
|
diff --git a/sysdeps/pthread/Makefile b/sysdeps/pthread/Makefile
|
|
index df8943f4860a39d8..c65710169697ad95 100644
|
|
--- a/sysdeps/pthread/Makefile
|
|
+++ b/sysdeps/pthread/Makefile
|
|
@@ -118,6 +118,7 @@ tests += tst-cnd-basic tst-mtx-trylock tst-cnd-broadcast \
|
|
tst-unload \
|
|
tst-unwind-thread \
|
|
tst-pt-vfork1 tst-pt-vfork2 tst-vfork1x tst-vfork2x \
|
|
+ tst-pthread-exit-signal \
|
|
tst-pthread-setuid-loop \
|
|
tst-pthread_cancel-exited \
|
|
tst-pthread_cancel-select-loop \
|
|
diff --git a/sysdeps/pthread/tst-pthread-exit-signal.c b/sysdeps/pthread/tst-pthread-exit-signal.c
|
|
new file mode 100644
|
|
index 0000000000000000..b4526fe663671068
|
|
--- /dev/null
|
|
+++ b/sysdeps/pthread/tst-pthread-exit-signal.c
|
|
@@ -0,0 +1,45 @@
|
|
+/* Test that pending signals are not delivered on thread exit (bug 28607).
|
|
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+/* Due to bug 28607, pthread_kill (or pthread_cancel) restored the
|
|
+ signal mask during during thread exit, triggering the delivery of a
|
|
+ blocked pending signal (SIGUSR1 in this test). */
|
|
+
|
|
+#include <support/xthread.h>
|
|
+#include <support/xsignal.h>
|
|
+
|
|
+static void *
|
|
+threadfunc (void *closure)
|
|
+{
|
|
+ sigset_t sigmask;
|
|
+ sigfillset (&sigmask);
|
|
+ xpthread_sigmask (SIG_SETMASK, &sigmask, NULL);
|
|
+ xpthread_kill (pthread_self (), SIGUSR1);
|
|
+ pthread_exit (NULL);
|
|
+ return NULL;
|
|
+}
|
|
+
|
|
+static int
|
|
+do_test (void)
|
|
+{
|
|
+ pthread_t thr = xpthread_create (NULL, threadfunc, NULL);
|
|
+ xpthread_join (thr);
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+#include <support/test-driver.c>
|