330b961e66
Upstream commit: 4ed990e5b97a61f29f929bdeb36c5b2abb547a64 - Add MADV_POPULATE_READ and MADV_POPULATE_WRITE from Linux 5.14 to bits/mman-linux.h - Update kernel version to 5.14 in tst-mman-consts.py - Update syscall lists for Linux 5.14 - Use Linux 5.14 in build-many-glibcs.py - Fix failing nss/tst-nss-files-hosts-long with local resolver - iconvconfig: Fix behaviour with --prefix [BZ #28199] - nptl: Fix race between pthread_kill and thread exit (swbz#12889, #1994068) - nptl: pthread_kill, pthread_cancel should not fail after exit (swbz#19193, #1994068) - support: Add support_wait_for_thread_exit - MIPS: Setup errno for {f,l,}xstat - x86-64: Use testl to check __x86_string_control - elf: Fix missing colon in LD_SHOW_AUXV output (swbz#28253, #1995648) - librt: add test (swbz#28213, #1994264) - CVE-2021-38604: fix NULL pointer dereference in mq_notify (swbz#28213, #1994264) - Linux: Fix fcntl, ioctl, prctl redirects for _TIME_BITS=64 (bug 28182) - iconv_charmap: Close output file when done - copy_and_spawn_sgid: Avoid double calls to close() - gaiconf_init: Avoid double-free in label and precedence lists - gconv_parseconfdir: Fix memory leak - ldconfig: avoid leak on empty paths in config file
118 lines
3.7 KiB
Diff
118 lines
3.7 KiB
Diff
commit addc9d62d61eea790a35328cbfce53333a07bd3e
|
|
Author: Florian Weimer <fweimer@redhat.com>
|
|
Date: Mon Aug 30 13:43:56 2021 +0200
|
|
|
|
support: Add support_wait_for_thread_exit
|
|
|
|
(cherry picked from commit 032d74eaf6179100048a5bf0ce942e97dc8b9a60)
|
|
|
|
diff --git a/support/Makefile b/support/Makefile
|
|
index a462781718426d35..ef2b1a980a407f8f 100644
|
|
--- a/support/Makefile
|
|
+++ b/support/Makefile
|
|
@@ -82,9 +82,10 @@ libsupport-routines = \
|
|
support_test_compare_blob \
|
|
support_test_compare_failure \
|
|
support_test_compare_string \
|
|
- support_write_file_string \
|
|
support_test_main \
|
|
support_test_verify_impl \
|
|
+ support_wait_for_thread_exit \
|
|
+ support_write_file_string \
|
|
temp_file \
|
|
timespec \
|
|
timespec-time64 \
|
|
diff --git a/support/support.h b/support/support.h
|
|
index 834dba909770a992..a5978b939af2fb41 100644
|
|
--- a/support/support.h
|
|
+++ b/support/support.h
|
|
@@ -174,6 +174,10 @@ timer_t support_create_timer (uint64_t sec, long int nsec, bool repeat,
|
|
/* Disable the timer TIMER. */
|
|
void support_delete_timer (timer_t timer);
|
|
|
|
+/* Wait until all threads except the current thread have exited (as
|
|
+ far as the kernel is concerned). */
|
|
+void support_wait_for_thread_exit (void);
|
|
+
|
|
struct support_stack
|
|
{
|
|
void *stack;
|
|
diff --git a/support/support_wait_for_thread_exit.c b/support/support_wait_for_thread_exit.c
|
|
new file mode 100644
|
|
index 0000000000000000..658a81381006ea62
|
|
--- /dev/null
|
|
+++ b/support/support_wait_for_thread_exit.c
|
|
@@ -0,0 +1,72 @@
|
|
+/* Wait until all threads except the current thread has exited.
|
|
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <dirent.h>
|
|
+#include <errno.h>
|
|
+#include <string.h>
|
|
+#include <support/check.h>
|
|
+#include <support/support.h>
|
|
+#include <unistd.h>
|
|
+
|
|
+void
|
|
+support_wait_for_thread_exit (void)
|
|
+{
|
|
+#ifdef __linux__
|
|
+ DIR *proc_self_task = opendir ("/proc/self/task");
|
|
+ TEST_VERIFY_EXIT (proc_self_task != NULL);
|
|
+
|
|
+ while (true)
|
|
+ {
|
|
+ errno = 0;
|
|
+ struct dirent *e = readdir (proc_self_task);
|
|
+ if (e == NULL && errno != 0)
|
|
+ FAIL_EXIT1 ("readdir: %m");
|
|
+ if (e == NULL)
|
|
+ {
|
|
+ /* Only the main thread remains. Testing may continue. */
|
|
+ closedir (proc_self_task);
|
|
+ return;
|
|
+ }
|
|
+
|
|
+ if (strcmp (e->d_name, ".") == 0 || strcmp (e->d_name, "..") == 0)
|
|
+ continue;
|
|
+
|
|
+ int task_tid = atoi (e->d_name);
|
|
+ if (task_tid <= 0)
|
|
+ FAIL_EXIT1 ("Invalid /proc/self/task entry: %s", e->d_name);
|
|
+
|
|
+ if (task_tid == gettid ())
|
|
+ /* The current thread. Keep scanning for other
|
|
+ threads. */
|
|
+ continue;
|
|
+
|
|
+ /* task_tid does not refer to this thread here, i.e., there is
|
|
+ another running thread. */
|
|
+
|
|
+ /* Small timeout to give the thread a chance to exit. */
|
|
+ usleep (50 * 1000);
|
|
+
|
|
+ /* Start scanning the directory from the start. */
|
|
+ rewinddir (proc_self_task);
|
|
+ }
|
|
+#else
|
|
+ /* Use a large timeout because we cannot verify that the thread has
|
|
+ exited. */
|
|
+ usleep (5 * 1000 * 1000);
|
|
+#endif
|
|
+}
|