Use vpath in crypt-glibc/Makefile to obtain the test input file

Reported by Stefan Liebler.
This commit is contained in:
Florian Weimer 2017-01-25 16:46:01 +01:00
parent be6211a715
commit fbc423659c
2 changed files with 7 additions and 3 deletions

View File

@ -10,7 +10,7 @@ Index: b/crypt-glibc/Makefile
===================================================================
--- /dev/null
+++ b/crypt-glibc/Makefile
@@ -0,0 +1,60 @@
@@ -0,0 +1,61 @@
+# Build libcrypt against internal cryptographic algorithms.
+# Copyright (C) 1996-2016 Free Software Foundation, Inc.
+# This file is part of the GNU C Library.
@ -41,6 +41,7 @@ Index: b/crypt-glibc/Makefile
+
+# Use the sources in the crypt subdirectory.
+vpath %.c ../crypt
+vpath %.input ../crypt
+
+libcrypt-routines := \
+ crypt-entry md5-crypt sha256-crypt sha512-crypt crypt crypt_util
@ -85,7 +86,7 @@ Index: b/crypt/sha256.c
===================================================================
--- a/crypt/sha256.c
+++ b/crypt/sha256.c
@@ -212,4 +212,4 @@ __sha256_process_bytes (const void *buff
@@ -211,4 +211,4 @@ __sha256_process_bytes (const void *buff
}
}

View File

@ -1,6 +1,6 @@
%define glibcsrcdir glibc-2.24-33-ge9e69e4
%define glibcversion 2.24
%define glibcrelease 4%{?dist}
%define glibcrelease 5%{?dist}
# Pre-release tarballs are pulled in from git using a command that is
# effectively:
#
@ -2266,6 +2266,9 @@ rm -f *.filelist*
%endif
%changelog
* Fri Jan 27 2017 Florian Weimer <fweimer@redhat.com> - 2.24-5
- Use vpath in crypt-glibc/Makefile to obtain the test input file.
* Fri Dec 23 2016 Carlos O'Donell <carlos@systemhalted.org> - 2.24-4
- Auto-sync with upstream release/2.24/master,
commit e9e69e468039fcd57276f783a16aa771a8e4214e, fixing: