auto-import glibc-2.3.4-10 on branch devel from glibc-2.3.4-10.src.rpm

This commit is contained in:
Jakub Jelinek 2005-02-12 11:01:55 +00:00
parent 54d12e3eef
commit efa0c2f767
3 changed files with 41 additions and 16 deletions

View File

@ -1,6 +1,11 @@
--- glibc-20050211T1037/ChangeLog 11 Feb 2005 10:17:19 -0000 1.9192
+++ glibc-20050211T1037-fedora/ChangeLog 11 Feb 2005 15:06:16 -0000 1.8782.2.78
@@ -1,3 +1,14 @@
+++ glibc-20050211T1037-fedora/ChangeLog 12 Feb 2005 10:01:49 -0000 1.8782.2.79
@@ -1,3 +1,19 @@
+2005-02-12 Jakub Jelinek <jakub@redhat.com>
+
+ * elf/rtld.c (dlmain): If LD_TRACE_PRELINKING, clear l_relocated flag
+ before relocating ld.so again.
+
+2005-02-11 Jakub Jelinek <jakub@redhat.com>
+
+ * debug/chk_fail.c (__chk_fail): Add a while (1) loop around
@ -15,7 +20,7 @@
2005-02-11 Roland McGrath <roland@redhat.com>
[BZ #715]
@@ -19,6 +30,18 @@
@@ -19,6 +35,18 @@
* scripts/soversions.awk: Fix default version set handling.
@ -34,7 +39,7 @@
2005-02-10 Roland McGrath <roland@redhat.com>
[BZ #157]
@@ -1752,6 +1775,14 @@
@@ -1752,6 +1780,14 @@
2004-11-26 Jakub Jelinek <jakub@redhat.com>
@ -49,7 +54,7 @@
* posix/Makefile (install-others): Add $(inst_libexecdir)/getconf.
(CFLAGS-sysconf.c): Add -D_GETCONF_DIR.
(CFLAGS-getconf.c): New.
@@ -2343,6 +2374,16 @@
@@ -2343,6 +2379,16 @@
* sysdeps/generic/tempname.c (__path_search): Add missing argument
TRY_TMPDIR.
@ -66,7 +71,7 @@
2004-10-31 Mariusz Mazur <mmazur@kernel.pl>
* sysdeps/unix/sysv/linux/alpha/setregid.c: New file.
@@ -2638,6 +2679,11 @@
@@ -2638,6 +2684,11 @@
* posix/execvp.c (execvp): Also ignore ENODEV and ETIMEDOUT errno
values.
@ -78,7 +83,7 @@
2004-10-20 Roland McGrath <roland@redhat.com>
* Makeconfig ($(common-objpfx)shlib-versions.v.i): Check also
@@ -2710,6 +2756,11 @@
@@ -2710,6 +2761,11 @@
* debug/catchsegv.sh: Update copyright year.
Use mktemp to create segv_output file.
@ -90,7 +95,7 @@
2004-10-18 Jakub Jelinek <jakub@redhat.com>
* elf/dl-libc.c (__libc_dlsym_private, __libc_register_dl_open_hook):
@@ -3693,6 +3744,22 @@
@@ -3693,6 +3749,22 @@
* string/string.h: Add __nonnull annotations.
* stdlib/stdlib.h: Likewise.
@ -113,7 +118,7 @@
2004-09-20 H.J. Lu <hongjiu.lu@intel.com>
* sysdeps/unix/sysv/linux/ia64/sysdep.h (DO_INLINE_SYSCALL):
@@ -4422,6 +4489,23 @@
@@ -4422,6 +4494,23 @@
before return type.
* locale/localename.c (__current_locale_name): Likewise.
@ -137,7 +142,7 @@
2004-08-30 Roland McGrath <roland@frob.com>
* scripts/extract-abilist.awk: If `lastversion' variable defined, omit
@@ -4578,6 +4662,22 @@
@@ -4578,6 +4667,22 @@
* resolv/nss_dns/dns-canon.c (_nss_dns_getcanonname_r): Initialize
status to NSS_STATUS_UNAVAIL.
@ -160,7 +165,7 @@
2004-08-19 Ulrich Drepper <drepper@redhat.com>
* sysdeps/posix/getaddrinfo.c (gaih_inet): Use h->h_name in the
@@ -4882,6 +4982,12 @@
@@ -4882,6 +4987,12 @@
* iconvdata/testdata/ISO-2022-JP-3: Regenerated.
@ -419,7 +424,7 @@
search_dirs ();
--- glibc-20050211T1037/elf/rtld.c 25 Jan 2005 11:11:43 -0000 1.346
+++ glibc-20050211T1037-fedora/elf/rtld.c 11 Feb 2005 15:02:46 -0000 1.330.2.13
+++ glibc-20050211T1037-fedora/elf/rtld.c 12 Feb 2005 10:01:55 -0000 1.330.2.14
@@ -509,8 +509,8 @@ _dl_start (void *arg)
data access using the global offset table. */
@ -552,6 +557,24 @@
if (__builtin_expect (npreloads, 0) != 0)
{
/* Set up PRELOADS with a vector of the preloaded libraries. */
@@ -1919,10 +2027,13 @@ ERROR: ld.so: object '%s' from %s cannot
if ((GLRO(dl_debug_mask) & DL_DEBUG_PRELINK)
&& GL(dl_rtld_map).l_opencount > 1)
- _dl_relocate_object (&GL(dl_rtld_map), main_map->l_scope,
- 0, 0);
- }
-
+ {
+ /* Mark the link map as not yet relocated again. */
+ GL(dl_rtld_map).l_relocated = 0;
+ _dl_relocate_object (&GL(dl_rtld_map), main_map->l_scope,
+ 0, 0);
+ }
+ }
#define VERNEEDTAG (DT_NUM + DT_THISPROCNUM + DT_VERSIONTAGIDX (DT_VERNEED))
if (version_info)
{
--- glibc-20050211T1037/elf/tst-tls10.h 17 Apr 2003 19:19:01 -0000 1.1
+++ glibc-20050211T1037-fedora/elf/tst-tls10.h 22 Sep 2004 21:20:48 -0000 1.1.2.1
@@ -1,8 +1,8 @@

View File

@ -1,7 +1,7 @@
%define glibcdate 20050211T1037
%define glibcname glibc
%define glibcversion 2.3.4
%define glibcrelease 9
%define glibcrelease 10
%define auxarches i586 i686 athlon sparcv9 alphaev6
%define prelinkarches noarch
%define nptlarches i386 i686 athlon x86_64 ia64 s390 s390x sparcv9 ppc ppc64
@ -844,7 +844,7 @@ done
grep '%{_prefix}/%{_lib}/lib.*_p\.a' < rpm.filelist > profile.filelist || :
grep '%{_infodir}' < rpm.filelist | grep -v '%{_infodir}/dir' > devel.filelist
grep '%{_prefix}/include/gnu/stubs-[32164]\+\.h' < rpm.filelist >> devel.filelist || :
grep '%{_prefix}/include/gnu/stubs-[32164]\+\.h' < rpm.filelist >> devel.filelist
grep '%{_prefix}/include' < rpm.filelist |
egrep -v '%{_prefix}/include/(nptl|gnu/stubs-[32164]+\.h)' \
@ -1272,10 +1272,12 @@ rm -f *.filelist*
%endif
%changelog
* Sat Feb 12 2005 Jakub Jelinek <jakub@redhat.com> 2.3.4-10
- hopefully fix interaction with prelink (#147655)
* Fri Feb 11 2005 Jakub Jelinek <jakub@redhat.com> 2.3.4-9
- update from CVS
- bi-arch <gnu/stubs.h> (BZ#715)
- hopefully fix interaction with prelink (#147655)
* Fri Feb 11 2005 Jakub Jelinek <jakub@redhat.com> 2.3.4-8
- update from CVS

View File

@ -1,2 +1,2 @@
b49c03c4cbbd0dd68a6bbe9bf9d1db1e glibc-20050211T1037.tar.bz2
887df147527cf5d418a13645b2de8b3d glibc-fedora-20050211T1037.tar.bz2
fd20f1a288463012bcf91c2117b1ba89 glibc-fedora-20050211T1037.tar.bz2