Auto-sync with upstream release/2.26/master
Upstream commit: fdf58ebc60ce0eb459fd616241b52872b3571ac1 - Drop glibc-gcc-strict-overflow.patch, different workaround applied upstream. - Fix nearbyint arithmetic moved before feholdexcept (swbz#22225) - Avoid __MATH_TG in C++ mode with -Os for fpclassify (swbz#22146) - Place $(elf-objpfx)sofini.os last (swbz#22051) - __libc_dynarray_emplace_enlarge: Add missing else - dynarray: Set errno on overflow-induced allocation failure - resolv: __resolv_conf_attach must not free passed conf object (swbz#22096) - resolv: Fix memory leak with OOM during resolv.conf parsing (swbz#22095) - nss_dns: Remove dead PTR IPv4-to-IPv6 mapping code
This commit is contained in:
parent
58b49c298b
commit
eb8447b64e
@ -1,37 +0,0 @@
|
||||
Builds with gcc 7.0 fail with:
|
||||
|
||||
../test-skeleton.c: In function ‘legacy_test_function’:
|
||||
cc1: error: assuming signed overflow does not occur when \
|
||||
assuming that (X - c) <= X is always true [-Werror=strict-overflow]
|
||||
|
||||
Ignoring this warning until the test or compiler is adjusted.
|
||||
Disabled with -Wno-strict-overflow. Attempted -Wstrict-overflow=1,
|
||||
but it still results in the same warning.
|
||||
|
||||
Index: glibc-2.24-661-g5653ab1/string/Makefile
|
||||
===================================================================
|
||||
--- glibc-2.24-661-g5653ab1.orig/string/Makefile
|
||||
+++ glibc-2.24-661-g5653ab1/string/Makefile
|
||||
@@ -71,7 +71,9 @@ include ../Rules
|
||||
CFLAGS-inl-tester.c = -fno-builtin
|
||||
CFLAGS-noinl-tester.c = -fno-builtin
|
||||
CFLAGS-tst-strlen.c = -fno-builtin
|
||||
-CFLAGS-stratcliff.c = -fno-builtin
|
||||
+# Added '-Wno-strict-overflow' for gcc 7.0 until the test or compiler
|
||||
+# is adjusted.
|
||||
+CFLAGS-stratcliff.c = -fno-builtin -Wno-strict-overflow
|
||||
CFLAGS-test-ffs.c = -fno-builtin
|
||||
CFLAGS-tst-inlcall.c = -fno-builtin
|
||||
CFLAGS-tst-xbzero-opt.c = -O3
|
||||
Index: glibc-2.24-661-g5653ab1/wcsmbs/Makefile
|
||||
===================================================================
|
||||
--- glibc-2.24-661-g5653ab1.orig/wcsmbs/Makefile
|
||||
+++ glibc-2.24-661-g5653ab1/wcsmbs/Makefile
|
||||
@@ -102,3 +102,7 @@ CPPFLAGS += $(libio-mtsafe)
|
||||
CPPFLAGS-wcstold_l.c = -I../stdlib
|
||||
|
||||
$(objpfx)tst-wcstod-nan-locale: $(libm)
|
||||
+
|
||||
+# Added '-Wno-strict-overflow' for gcc 7.0 until the test or compiler
|
||||
+# is adjusted.
|
||||
+CFLAGS-wcsatcliff.c = -Wno-strict-overflow
|
@ -34,24 +34,6 @@ Date: Thu Sep 7 15:28:28 2017 +0200
|
||||
* iconvdata/tst-tables.sh: Add IBM858
|
||||
* localedata/charmaps/IBM858: New file.
|
||||
|
||||
diff --git a/ChangeLog b/ChangeLog
|
||||
index 3e32d14dbf302da2..7ff11c3a65ed9aa5 100644
|
||||
--- a/ChangeLog
|
||||
+++ b/ChangeLog
|
||||
@@ -1,3 +1,13 @@
|
||||
+2017-09-14 Mike FABIAN <mfabian@redhat.com>
|
||||
+
|
||||
+ [BZ #21084]
|
||||
+ * benchtests/strcoll-inputs/filelist#en_US.UTF-8: Add IBM858 and ibm858.c.
|
||||
+ * iconvdata/Makefile: Add IBM858.
|
||||
+ * iconvdata/gconv-modules: Likewise.
|
||||
+ * iconvdata/tst-tables.sh: Likewise.
|
||||
+ * iconvdata/ibm858.c: New file.
|
||||
+ * localedata/charmaps/IBM858: Likewise.
|
||||
+
|
||||
2017-09-01 Florian Weimer <fweimer@redhat.com>
|
||||
|
||||
[BZ #21915]
|
||||
diff --git a/benchtests/strcoll-inputs/filelist#en_US.UTF-8 b/benchtests/strcoll-inputs/filelist#en_US.UTF-8
|
||||
index 6cee2374f42b6bbe..aa44107ad6a3663f 100644
|
||||
--- a/benchtests/strcoll-inputs/filelist#en_US.UTF-8
|
||||
|
19
glibc.spec
19
glibc.spec
@ -1,6 +1,6 @@
|
||||
%define glibcsrcdir glibc-2.26-27-ga71a3374cd
|
||||
%define glibcsrcdir glibc-2.26-43-gfdf58ebc60
|
||||
%define glibcversion 2.26
|
||||
%define glibcrelease 9%{?dist}
|
||||
%define glibcrelease 10%{?dist}
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
#
|
||||
@ -230,7 +230,6 @@ Patch0059: glibc-c-utf8-locale.patch
|
||||
Patch0060: glibc-rh1324623.patch
|
||||
|
||||
# Fix -Wstrict-overflow issues with gcc 7.0.
|
||||
Patch0061: glibc-gcc-strict-overflow.patch
|
||||
Patch62: glibc-rh1416405.patch
|
||||
|
||||
##############################################################################
|
||||
@ -803,7 +802,6 @@ microbenchmark tests on the system.
|
||||
%patch2112 -p1
|
||||
%patch2115 -p1
|
||||
%patch2116 -p1
|
||||
%patch0061 -p1
|
||||
%patch62 -p1
|
||||
|
||||
##############################################################################
|
||||
@ -2219,6 +2217,19 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Oct 01 2017 Florian Weimer <fweimer@redhat.com> - 2.26-10
|
||||
- Drop glibc-gcc-strict-overflow.patch, different workaround applied upstream.
|
||||
- Auto-sync with upstream release/2.26/master,
|
||||
commit fdf58ebc60ce0eb459fd616241b52872b3571ac1:
|
||||
- Fix nearbyint arithmetic moved before feholdexcept (swbz#22225)
|
||||
- Avoid __MATH_TG in C++ mode with -Os for fpclassify (swbz#22146)
|
||||
- Place $(elf-objpfx)sofini.os last (swbz#22051)
|
||||
- __libc_dynarray_emplace_enlarge: Add missing else
|
||||
- dynarray: Set errno on overflow-induced allocation failure
|
||||
- resolv: __resolv_conf_attach must not free passed conf object (swbz#22096)
|
||||
- resolv: Fix memory leak with OOM during resolv.conf parsing (swbz#22095)
|
||||
- nss_dns: Remove dead PTR IPv4-to-IPv6 mapping code
|
||||
|
||||
* Sat Sep 30 2017 Florian Weimer <fweimer@redhat.com> - 2.26-9
|
||||
- Add IBM858 charset (#1416405)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (glibc-2.26-27-ga71a3374cd.tar.gz) = dd2bdc8b885309ed8f6c488aaa65b03cb556c3b8fca7fc1af53948a04a0c9b4b63803d4416e734b1d3120221be36fcbb699c611aa511021c17a99940ca1aeed8
|
||||
SHA512 (glibc-2.26-43-gfdf58ebc60.tar.gz) = f9ddfd31fae7dda066c4c9b09060af6efc21751d157d34a09058420796e75fe9f35859dd58e8ac84b88f570be2c6d31cff89171bdb93d95684ae14e6fcb29e1a
|
||||
|
Loading…
Reference in New Issue
Block a user