Remove non-ELF support in rtkaio

This commit is contained in:
Siddhesh Poyarekar 2013-08-20 10:14:34 +05:30
parent 35b51a8d80
commit e9a081ef75
2 changed files with 37 additions and 1 deletions

View File

@ -0,0 +1,31 @@
diff -pruN glibc-2.17-c758a686/rtkaio/Makefile glibc-2.17-c758a686.new/rtkaio/Makefile
--- glibc-2.17-c758a686/rtkaio/Makefile 2011-10-19 16:34:41.000000000 +0530
+++ glibc-2.17-c758a686.new/rtkaio/Makefile 2013-08-13 18:23:21.064888432 +0530
@@ -55,7 +55,7 @@ extra-libs-others := $(extra-libs)
include $(..)Makeconfig
-ifeq (yesyes,$(build-shared)$(elf))
+ifeq (yes,$(build-shared))
generated += librt.so$(librt.so-version)
$(objpfx)librt.so$(librt.so-version): $(objpfx)librtkaio.so; $(make-link)
@@ -73,7 +73,7 @@ CPPFLAGS-librtkaio += -DIS_IN_librt=1 -I
rpath-dirs := $(patsubst rt,rtkaio,$(rpath-dirs))
-ifeq (yesyes,$(build-shared)$(elf))
+ifeq (yes,$(build-shared))
others: $(objpfx)librt.so$(librt.so-version)
endif
@@ -81,8 +81,7 @@ endif
# This ensures they will load libc.so for needed symbols if loaded by
# a statically-linked program that hasn't already loaded it.
$(objpfx)librtkaio.so: $(common-objpfx)libc.so $(common-objpfx)libc_nonshared.a \
- $(shared-thread-library) \
- $(if $(filter yes,$(elf)), $(elfobjdir)/ld.so)
+ $(shared-thread-library) $(elfobjdir)/ld.so
ifeq (yes,$(build-shared))
$(addprefix $(objpfx),$(tests)): $(objpfx)librtkaio.so $(shared-thread-library)

View File

@ -110,6 +110,9 @@ Patch0036: %{name}-rh892777.patch
Patch0037: %{name}-rh952799.patch
Patch0038: %{name}-rh959034.patch
# Remove non-ELF support in rtkaio
Patch0040: %{name}-rh731833-rtkaio.patch
#
# Patches from upstream
#
@ -437,6 +440,7 @@ package or when debugging this package.
%patch2040 -p1
%patch1009 -p1
%patch1010 -p1
%patch0040 -p1
# On powerpc32, hp timing is only available in power4/power6
# libs, not in base, so pre-power4 dynamic linker is incompatible
@ -1227,9 +1231,10 @@ rm -f *.filelist*
%endif
%changelog
* Thu Aug 22 2013 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.17-14
* Mon Aug 26 2013 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.17-14
- Add systemd to BuildRequires (#999924).
- Expand sizes of some types in strcoll (#855399, CVE-2012-4424).
- Remove non-ELF support in rtkaio.
* Mon Aug 19 2013 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.17-13
- Fix stack overflow in getaddrinfo with many results (#947892, CVE-2013-1914).