This commit is contained in:
Jakub Jelinek 2005-02-11 15:23:09 +00:00
parent 271728ab7e
commit e023db3a75
3 changed files with 63 additions and 12 deletions

View File

@ -1,6 +1,21 @@
--- glibc-20050211T1037/ChangeLog 11 Feb 2005 10:17:19 -0000 1.9192
+++ glibc-20050211T1037-fedora/ChangeLog 11 Feb 2005 11:02:06 -0000 1.8782.2.75
@@ -19,6 +19,18 @@
+++ glibc-20050211T1037-fedora/ChangeLog 11 Feb 2005 15:06:16 -0000 1.8782.2.78
@@ -1,3 +1,14 @@
+2005-02-11 Jakub Jelinek <jakub@redhat.com>
+
+ * debug/chk_fail.c (__chk_fail): Add a while (1) loop around
+ __libc_message to kill GCC warning about noreturn function returning.
+
+ * elf/rtld.c (_dl_start): Set bootstrap_map.l_relocated even
+ for already prelinked ld.so.
+
+ * scripts/soversions.awk: Only record first WORDSIZE{32,64}
+ matching line.
+
2005-02-11 Roland McGrath <roland@redhat.com>
[BZ #715]
@@ -19,6 +30,18 @@
* scripts/soversions.awk: Fix default version set handling.
@ -19,7 +34,7 @@
2005-02-10 Roland McGrath <roland@redhat.com>
[BZ #157]
@@ -1752,6 +1764,14 @@
@@ -1752,6 +1775,14 @@
2004-11-26 Jakub Jelinek <jakub@redhat.com>
@ -34,7 +49,7 @@
* posix/Makefile (install-others): Add $(inst_libexecdir)/getconf.
(CFLAGS-sysconf.c): Add -D_GETCONF_DIR.
(CFLAGS-getconf.c): New.
@@ -2343,6 +2363,16 @@
@@ -2343,6 +2374,16 @@
* sysdeps/generic/tempname.c (__path_search): Add missing argument
TRY_TMPDIR.
@ -51,7 +66,7 @@
2004-10-31 Mariusz Mazur <mmazur@kernel.pl>
* sysdeps/unix/sysv/linux/alpha/setregid.c: New file.
@@ -2638,6 +2668,11 @@
@@ -2638,6 +2679,11 @@
* posix/execvp.c (execvp): Also ignore ENODEV and ETIMEDOUT errno
values.
@ -63,7 +78,7 @@
2004-10-20 Roland McGrath <roland@redhat.com>
* Makeconfig ($(common-objpfx)shlib-versions.v.i): Check also
@@ -2710,6 +2745,11 @@
@@ -2710,6 +2756,11 @@
* debug/catchsegv.sh: Update copyright year.
Use mktemp to create segv_output file.
@ -75,7 +90,7 @@
2004-10-18 Jakub Jelinek <jakub@redhat.com>
* elf/dl-libc.c (__libc_dlsym_private, __libc_register_dl_open_hook):
@@ -3693,6 +3733,22 @@
@@ -3693,6 +3744,22 @@
* string/string.h: Add __nonnull annotations.
* stdlib/stdlib.h: Likewise.
@ -98,7 +113,7 @@
2004-09-20 H.J. Lu <hongjiu.lu@intel.com>
* sysdeps/unix/sysv/linux/ia64/sysdep.h (DO_INLINE_SYSCALL):
@@ -4422,6 +4478,23 @@
@@ -4422,6 +4489,23 @@
before return type.
* locale/localename.c (__current_locale_name): Likewise.
@ -122,7 +137,7 @@
2004-08-30 Roland McGrath <roland@frob.com>
* scripts/extract-abilist.awk: If `lastversion' variable defined, omit
@@ -4578,6 +4651,22 @@
@@ -4578,6 +4662,22 @@
* resolv/nss_dns/dns-canon.c (_nss_dns_getcanonname_r): Initialize
status to NSS_STATUS_UNAVAIL.
@ -145,7 +160,7 @@
2004-08-19 Ulrich Drepper <drepper@redhat.com>
* sysdeps/posix/getaddrinfo.c (gaih_inet): Use h->h_name in the
@@ -4882,6 +4971,12 @@
@@ -4882,6 +4982,12 @@
* iconvdata/testdata/ISO-2022-JP-3: Regenerated.
@ -272,6 +287,20 @@
#endif
/* These function symbols are provided for the .init/.fini section entry
--- glibc-20050211T1037/debug/chk_fail.c 26 Jan 2005 20:57:19 -0000 1.3
+++ glibc-20050211T1037-fedora/debug/chk_fail.c 11 Feb 2005 15:06:18 -0000 1.1.2.5
@@ -26,7 +26,9 @@ void
__attribute__ ((noreturn))
__chk_fail (void)
{
- __libc_message (1, "*** buffer overflow detected ***: %s terminated\n",
- __libc_argv[0] ?: "<unknown>");
+ /* The loop is added only to keep gcc happy. */
+ while (1)
+ __libc_message (1, "*** buffer overflow detected ***: %s terminated\n",
+ __libc_argv[0] ?: "<unknown>");
}
libc_hidden_def (__chk_fail)
--- glibc-20050211T1037/debug/tst-chk1.c 18 Nov 2004 23:23:17 -0000 1.5
+++ glibc-20050211T1037-fedora/debug/tst-chk1.c 19 Nov 2004 00:18:08 -0000 1.1.2.7
@@ -213,7 +213,7 @@ do_test (void)
@ -390,7 +419,17 @@
search_dirs ();
--- glibc-20050211T1037/elf/rtld.c 25 Jan 2005 11:11:43 -0000 1.346
+++ glibc-20050211T1037-fedora/elf/rtld.c 8 Feb 2005 10:04:03 -0000 1.330.2.12
+++ glibc-20050211T1037-fedora/elf/rtld.c 11 Feb 2005 15:02:46 -0000 1.330.2.13
@@ -509,8 +509,8 @@ _dl_start (void *arg)
data access using the global offset table. */
ELF_DYNAMIC_RELOCATE (&bootstrap_map, 0, 0);
- bootstrap_map.l_relocated = 1;
}
+ bootstrap_map.l_relocated = 1;
/* Please note that we don't allow profiling of this object and
therefore need not test whether we have to allocate the array
@@ -1223,6 +1223,53 @@ ld.so does not support TLS, but program
++GL(dl_ns)[LM_ID_BASE]._ns_nloaded;
++GL(dl_load_adds);
@ -1957,6 +1996,17 @@
#endif /* LIBC_SCCS and not lint */
#include <sys/types.h>
--- glibc-20050211T1037/scripts/soversions.awk 11 Feb 2005 09:54:30 -0000 1.3
+++ glibc-20050211T1037-fedora/scripts/soversions.awk 11 Feb 2005 15:02:19 -0000 1.1.2.4
@@ -8,7 +8,7 @@ BEGIN {
{ thiscf = $1 }
$2 ~ /WORDSIZE[3264]/ {
- if (config ~ thiscf) {
+ if ((config ~ thiscf) && !othercf) {
othercf = $3;
sub(/@CPU@/, cpu, othercf);
sub(/@VENDOR@/, vendor, othercf);
--- glibc-20050211T1037/sunrpc/rpc_clntout.c 17 Oct 2004 14:59:39 -0000 1.7
+++ glibc-20050211T1037-fedora/sunrpc/rpc_clntout.c 18 Oct 2004 09:58:53 -0000 1.6.4.1
@@ -33,7 +33,7 @@

View File

@ -1275,6 +1275,7 @@ rm -f *.filelist*
* Fri Feb 11 2005 Jakub Jelinek <jakub@redhat.com> 2.3.4-9
- update from CVS
- bi-arch <gnu/stubs.h> (BZ#715)
- hopefully fix interaction with prelink (#147655)
* Fri Feb 11 2005 Jakub Jelinek <jakub@redhat.com> 2.3.4-8
- update from CVS

View File

@ -1,2 +1,2 @@
b49c03c4cbbd0dd68a6bbe9bf9d1db1e glibc-20050211T1037.tar.bz2
a9e4ad2410a2c728bf9e110f2fc31ab2 glibc-fedora-20050211T1037.tar.bz2
887df147527cf5d418a13645b2de8b3d glibc-fedora-20050211T1037.tar.bz2