Avoid tst-audit2 failure due to GCC 5 optimization.
This commit is contained in:
Florian Weimer 2016-02-08 12:17:18 +01:00
parent b3a96fb7e3
commit d8e28bee29
2 changed files with 24 additions and 1 deletions

19
glibc-rh970866.patch Normal file
View File

@ -0,0 +1,19 @@
commit 51225803259c69a792a272d067443f3fbc9b79d7
Author: Andreas Schwab <schwab@suse.de>
Date: Thu Jan 22 17:54:21 2015 +0100
Fix failure of elf/tst-audit2 when compiled with GCC-5
Index: b/elf/Makefile
===================================================================
--- a/elf/Makefile
+++ b/elf/Makefile
@@ -1016,6 +1016,8 @@ $(objpfx)tst-audit1.out: $(objpfx)tst-au
tst-audit1-ENV = LD_AUDIT=$(objpfx)tst-auditmod1.so
$(objpfx)tst-audit2.out: $(objpfx)tst-auditmod1.so
+# Prevent GCC-5 from translating a malloc/memset pair into calloc
+CFLAGS-tst-audit2.c += -fno-builtin
tst-audit2-ENV = LD_AUDIT=$(objpfx)tst-auditmod1.so
$(objpfx)tst-audit9: $(libdl)

View File

@ -231,6 +231,8 @@ Patch1006: glibc-rh1276761-3.patch
Patch1007: glibc-rh1214152.patch
Patch1008: glibc-rh970866.patch
##############################################################################
#
# Patches submitted, but not yet approved upstream.
@ -607,6 +609,7 @@ package or when debugging this package.
%patch1005 -p1
%patch1006 -p1
%patch1007 -p1
%patch1008 -p1
##############################################################################
# %%prep - Additional prep required...
@ -1779,11 +1782,12 @@ rm -f *.filelist*
%endif
%changelog
* Fri Feb 5 2016 Florian Weimer <fweimer@redhat.com> - 2.21-10
* Mon Feb 8 2016 Florian Weimer <fweimer@redhat.com> - 2.21-10
- Make locale -a output ASCII-only (#1184168).
- CVE-2015-8777: Apply additional pointer guard hardening. (#1276761)
- CVE-2015-1781: glibc: buffer overflow in gethostbyname_r and
related functions with misaligned buffer. (#1214152)
- Avoid tst-audit2 failure due to GCC 5 optimization. (#970866)
* Wed Oct 28 2015 Florian Weimer <fweimer@redhat.com> - 2.21-9
- Prevent malloc arena free list from becoming cyclic. (#1276112)