Auto-sync with upstream master

Upstream commit: 73dfd088936b9237599e4ab737c7ae2ea7d710e1
This commit is contained in:
Florian Weimer 2017-01-02 13:32:25 +01:00
parent e9dcd51d77
commit c659285752
6 changed files with 43 additions and 7024 deletions

View File

@ -1,19 +0,0 @@
Disable pretty printers so that they do not fail the build until
rhbz#1403329 is fixed.
Index: b/nptl/nptl_lock_constants.pysym
===================================================================
--- a/nptl/nptl_lock_constants.pysym
+++ b/nptl/nptl_lock_constants.pysym
@@ -51,11 +51,6 @@ PTHREAD_COND_SHARED (void *)
-- Value of __total_seq for destroyed condvars.
PTHREAD_COND_DESTROYED -1ull
--- __nwaiters encodes the number of threads waiting on a condvar
--- and the clock ID.
--- __nwaiters >> COND_NWAITERS_SHIFT gives us the number of waiters.
-COND_NWAITERS_SHIFT
-
-- Condvar clock IDs
CLOCK_REALTIME
CLOCK_MONOTONIC

View File

@ -550,17 +550,17 @@ Index: b/nscd/aicache.c
===================================================================
--- a/nscd/aicache.c
+++ b/nscd/aicache.c
@@ -26,6 +26,7 @@
#include <unistd.h>
@@ -27,6 +27,7 @@
#include <sys/mman.h>
#include <resolv/resolv-internal.h>
#include <resolv/res_hconf.h>
+#include <scratch_buffer.h>
#include "dbg_log.h"
#include "nscd.h"
@@ -112,10 +113,13 @@ addhstaiX (struct database_dyn *db, int
@@ -113,10 +114,13 @@ addhstaiX (struct database_dyn *db, int
int old_res_options = _res.options;
_res.options &= ~RES_USE_INET6;
_res.options &= ~DEPRECATED_RES_USE_INET6;
- size_t tmpbuf6len = 1024;
- char *tmpbuf6 = alloca (tmpbuf6len);
@ -576,7 +576,7 @@ Index: b/nscd/aicache.c
int32_t ttl = INT32_MAX;
ssize_t total = 0;
char *key_copy = NULL;
@@ -128,6 +132,7 @@ addhstaiX (struct database_dyn *db, int
@@ -129,6 +133,7 @@ addhstaiX (struct database_dyn *db, int
int status[2] = { NSS_STATUS_UNAVAIL, NSS_STATUS_UNAVAIL };
int naddrs = 0;
size_t addrslen = 0;
@ -584,7 +584,7 @@ Index: b/nscd/aicache.c
char *canon = NULL;
size_t canonlen;
@@ -142,12 +147,17 @@ addhstaiX (struct database_dyn *db, int
@@ -143,12 +148,17 @@ addhstaiX (struct database_dyn *db, int
at = &atmem;
rc6 = 0;
herrno = 0;
@ -604,7 +604,7 @@ Index: b/nscd/aicache.c
}
if (rc6 != 0 && herrno == NETDB_INTERNAL)
@@ -225,41 +235,38 @@ addhstaiX (struct database_dyn *db, int
@@ -226,41 +236,38 @@ addhstaiX (struct database_dyn *db, int
while (1)
{
rc6 = 0;
@ -662,7 +662,7 @@ Index: b/nscd/aicache.c
}
if (rc4 != 0 && herrno == NETDB_INTERNAL)
@@ -285,13 +292,11 @@ addhstaiX (struct database_dyn *db, int
@@ -286,13 +293,11 @@ addhstaiX (struct database_dyn *db, int
cfct = __nss_lookup_function (nip, "getcanonname_r");
if (cfct != NULL)
{
@ -678,7 +678,7 @@ Index: b/nscd/aicache.c
== NSS_STATUS_SUCCESS)
canon = s;
else
@@ -320,18 +325,20 @@ addhstaiX (struct database_dyn *db, int
@@ -321,18 +326,20 @@ addhstaiX (struct database_dyn *db, int
addrfamily = AF_INET6;
}
@ -704,7 +704,7 @@ Index: b/nscd/aicache.c
}
if (rc == 0)
@@ -559,6 +566,10 @@ next_nip:
@@ -560,6 +567,10 @@ next_nip:
dh->usable = false;
}
@ -1319,7 +1319,7 @@ Index: b/nss/nss_files/files-hosts.c
@@ -22,7 +22,7 @@
#include <arpa/nameser.h>
#include <netdb.h>
#include <resolv.h>
#include <resolv/resolv-internal.h>
-
+#include <scratch_buffer.h>
@ -1511,7 +1511,7 @@ Index: b/posix/glob.c
#endif
if (pattern == NULL || pglob == NULL || (flags & ~__GLOB_FLAGS) != 0)
@@ -650,33 +651,13 @@ glob (const char *pattern, int flags, in
@@ -637,33 +638,13 @@ glob (const char *pattern, int flags, in
{
struct passwd *p;
# if defined HAVE_GETPWNAM_R || defined _LIBC
@ -1549,7 +1549,7 @@ Index: b/posix/glob.c
{
if (errno != ERANGE)
{
@@ -684,67 +665,37 @@ glob (const char *pattern, int flags, in
@@ -671,67 +652,37 @@ glob (const char *pattern, int flags, in
break;
}
@ -1631,7 +1631,7 @@ Index: b/posix/glob.c
retval = GLOB_NOMATCH;
goto out;
}
@@ -865,57 +816,24 @@ glob (const char *pattern, int flags, in
@@ -852,57 +803,24 @@ glob (const char *pattern, int flags, in
{
struct passwd *p;
# if defined HAVE_GETPWNAM_R || defined _LIBC
@ -1697,7 +1697,7 @@ Index: b/posix/glob.c
}
__set_errno (save);
}
@@ -944,8 +862,7 @@ glob (const char *pattern, int flags, in
@@ -931,8 +849,7 @@ glob (const char *pattern, int flags, in
dirname = malloc (home_len + rest_len + 1);
if (dirname == NULL)
{
@ -1707,7 +1707,7 @@ Index: b/posix/glob.c
retval = GLOB_NOSPACE;
goto out;
}
@@ -957,13 +874,11 @@ glob (const char *pattern, int flags, in
@@ -944,13 +861,11 @@ glob (const char *pattern, int flags, in
dirlen = home_len + rest_len;
dirname_modified = 1;

View File

@ -10,11 +10,11 @@ Date: Wed Jul 13 14:06:00 2016 +0200
The sln program is implicitly tested during the build, so no test
case is needed.
diff --git a/elf/Makefile b/elf/Makefile
index 593403c..d90f21a 100644
Index: b/elf/Makefile
===================================================================
--- a/elf/Makefile
+++ b/elf/Makefile
@@ -70,12 +70,8 @@ install-others = $(inst_rtlddir)/$(rtld-installed-name)
@@ -96,12 +96,8 @@ install-others = $(inst_rtlddir)/$(rtld-
install-bin-script = ldd
endif
@ -28,7 +28,7 @@ index 593403c..d90f21a 100644
ifeq (yes,$(use-ldconfig))
ifeq (yes,$(build-shared))
@@ -83,8 +79,16 @@ others-static += ldconfig
@@ -109,8 +105,16 @@ others-static += ldconfig
others += ldconfig
install-rootsbin += ldconfig
@ -46,7 +46,7 @@ index 593403c..d90f21a 100644
endif
endif
@@ -466,8 +470,6 @@ $(objpfx)ldd: ldd.bash.in $(common-objpfx)soversions.mk \
@@ -533,8 +537,6 @@ $(objpfx)ldd: ldd.bash.in $(common-objpf
$(objpfx)sprof: $(libdl)
@ -55,8 +55,8 @@ index 593403c..d90f21a 100644
$(objpfx)ldconfig: $(ldconfig-modules:%=$(objpfx)%.o)
SYSCONF-FLAGS := -D'SYSCONFDIR="$(sysconfdir)"'
diff --git a/elf/ldconfig.c b/elf/ldconfig.c
index 467ca82..972737c 100644
Index: b/elf/ldconfig.c
===================================================================
--- a/elf/ldconfig.c
+++ b/elf/ldconfig.c
@@ -44,6 +44,8 @@
@ -68,7 +68,7 @@ index 467ca82..972737c 100644
#ifdef _DL_FIRST_PLATFORM
# define _DL_FIRST_EXTRA (_DL_FIRST_PLATFORM + _DL_PLATFORMS_COUNT)
#else
@@ -1275,6 +1277,9 @@ main (int argc, char **argv)
@@ -1285,6 +1287,9 @@ main (int argc, char **argv)
/* Set the text message domain. */
textdomain (_libc_intl_domainname);
@ -78,14 +78,14 @@ index 467ca82..972737c 100644
/* Parse and process arguments. */
int remaining;
argp_parse (&argp, argc, argv, 0, &remaining, NULL);
diff --git a/elf/sln.c b/elf/sln.c
index fa4ccec..c6889d7 100644
Index: b/elf/sln.c
===================================================================
--- a/elf/sln.c
+++ b/elf/sln.c
@@ -1,4 +1,4 @@
-/* `sln' program to create symbolic links between files.
+/* sln helper to create symbolic links between files, invoked from ldconfig.
Copyright (C) 1998-2016 Free Software Foundation, Inc.
Copyright (C) 1998-2017 Free Software Foundation, Inc.
This file is part of the GNU C Library.
@@ -31,21 +31,29 @@
@ -126,9 +126,8 @@ index fa4ccec..c6889d7 100644
switch (argc)
{
case 2:
diff --git a/elf/sln.h b/elf/sln.h
new file mode 100644
index 0000000..a3a16ab
Index: b/elf/sln.h
===================================================================
--- /dev/null
+++ b/elf/sln.h
@@ -0,0 +1,30 @@

File diff suppressed because it is too large Load Diff

View File

@ -1,6 +1,6 @@
%define glibcsrcdir glibc-2.24-531-gcecbc79
%define glibcsrcdir glibc-2.24-592-g73dfd08
%define glibcversion 2.24.90
%define glibcrelease 26%{?dist}
%define glibcrelease 27%{?dist}
# Pre-release tarballs are pulled in from git using a command that is
# effectively:
#
@ -254,12 +254,6 @@ Patch0059: glibc-c-utf8-locale.patch
# Build libcrypt twice, with and without NSS.
Patch0060: glibc-rh1324623.patch
# Bug 13165: New condvar implementation.
Patch0062: glibc-swbz13165.patch
# Disable printers which are incompatible with nptl implementation changes.
Patch0099: glibc-fedora-disable-printers.patch
##############################################################################
#
# Patches from upstream
@ -875,9 +869,7 @@ microbenchmark tests on the system.
%patch2037 -p1
%patch2110 -p1
%patch2112 -p1
%patch0062 -p1
%patch2113 -p1
%patch0099 -p1
##############################################################################
# %%prep - Additional prep required...
@ -1038,6 +1030,7 @@ build()
--enable-multi-arch \
%endif
--enable-stack-protector=strong \
--enable-tunables \
--enable-obsolete-rpc \
--enable-systemtap \
${core_with_options} \
@ -2273,6 +2266,16 @@ rm -f *.filelist*
%endif
%changelog
* Mon Jan 02 2017 Florian Weimer <fweimer@redhat.com> - 2.24.90-27
- Auto-sync with upstream master,
commit 73dfd088936b9237599e4ab737c7ae2ea7d710e1:
- Enable tunables.
- Drop condvar-related patches applied upstream.
- Update DNS RR type definitions (swbz#20593)
- CVE-2015-5180: resolv: Fix crash with internal QTYPE (#1249603)
- sunrpc: Always obtain AF_INET addresses from NSS (swbz#20964)
* Mon Dec 26 2016 Florian Weimer <fweimer@redhat.com> - 2.24.90-26
- Auto-sync with upstream master,
commit cecbc7967f0bcac718b6f8f8942b58403c0e917c

View File

@ -1 +1 @@
SHA512 (glibc-2.24-531-gcecbc79.tar.gz) = 4c3875426a54b9fce817d1a4c7782e9f5b3b6d298107e8c75263dfe33c0164beafad2480eb5a1eed34401e1add6d608e99e55a9411d199770c9b3a98e3d7cffb
SHA512 (glibc-2.24-592-g73dfd08.tar.gz) = 35c610aafc89ddb53a227cbd928096ea701c7002460aba2c5b4c120a179aacde70d239df27d4d85070ac24ea6e85fc08ec039f4b97d8cfd813ce547b85f00423