Auto-sync with upstream release/2.24/master

Upstream commit: e9e69e468039fcd57276f783a16aa771a8e4214e
This commit is contained in:
Carlos O'Donell 2016-12-23 16:00:09 -05:00
parent 0a4bf01550
commit be6211a715
4 changed files with 36 additions and 19 deletions

View File

@ -24,30 +24,33 @@ Date: Thu Mar 31 11:26:55 2016 +0200
* elf/Makefile (tests): Add tst-dlsym-error.
(tst-dlsym-error): Link against libdl.
Index: b/elf/Makefile
Index: glibc-2.24-33-ge9e69e4/elf/Makefile
===================================================================
--- a/elf/Makefile
+++ b/elf/Makefile
--- glibc-2.24-33-ge9e69e4.orig/elf/Makefile
+++ glibc-2.24-33-ge9e69e4/elf/Makefile
@@ -149,7 +149,7 @@ tests += loadtest restest1 preloadtest l
tst-nodelete) \
tst-initorder tst-initorder2 tst-relsort1 tst-null-argv \
tst-ptrguard1 tst-tlsalign tst-tlsalign-extern tst-nodelete-opened \
- tst-nodelete2 tst-audit11 tst-audit12 tst-dlsym-error
+ tst-nodelete2 tst-audit11 tst-audit12
- tst-nodelete2 tst-audit11 tst-audit12 tst-dlsym-error \
+ tst-nodelete2 tst-audit11 tst-audit12 \
tst-nodelete-dlclose
# reldep9
ifeq ($(build-hardcoded-path-in-tests),yes)
tests += tst-dlopen-aout
@@ -1258,5 +1258,3 @@ $(objpfx)tst-prelink-cmp.out: tst-prelin
$(objpfx)tst-ldconfig-X.out : tst-ldconfig-X.sh $(objpfx)ldconfig
@@ -1268,8 +1268,6 @@ $(objpfx)tst-ldconfig-X.out : tst-ldconf
$(SHELL) $< '$(common-objpfx)' '$(test-wrapper)' '$(test-wrapper-env)' > $@; \
$(evaluate-test)
-
-$(objpfx)tst-dlsym-error: $(libdl)
Index: b/elf/dl-lookup.c
-
# The application depends on the DSO, and the DSO loads the plugin.
# The plugin also depends on the DSO. This creates the circular
# dependency via dlopen that we're testing to make sure works.
Index: glibc-2.24-33-ge9e69e4/elf/dl-lookup.c
===================================================================
--- a/elf/dl-lookup.c
+++ b/elf/dl-lookup.c
@@ -858,6 +858,7 @@ _dl_lookup_symbol_x (const char *undef_n
--- glibc-2.24-33-ge9e69e4.orig/elf/dl-lookup.c
+++ glibc-2.24-33-ge9e69e4/elf/dl-lookup.c
@@ -862,6 +862,7 @@ _dl_lookup_symbol_x (const char *undef_n
if (__glibc_unlikely (current_value.s == NULL))
{
if ((*ref == NULL || ELFW(ST_BIND) ((*ref)->st_info) != STB_WEAK)
@ -55,9 +58,9 @@ Index: b/elf/dl-lookup.c
&& !(GLRO(dl_debug_mask) & DL_DEBUG_UNUSED))
{
/* We could find no value for a strong reference. */
Index: b/elf/tst-dlsym-error.c
Index: glibc-2.24-33-ge9e69e4/elf/tst-dlsym-error.c
===================================================================
--- a/elf/tst-dlsym-error.c
--- glibc-2.24-33-ge9e69e4.orig/elf/tst-dlsym-error.c
+++ /dev/null
@@ -1,114 +0,0 @@
-/* Test error reporting for dlsym, dlvsym failures.

View File

@ -1,6 +1,6 @@
%define glibcsrcdir glibc-2.24-11-g8c716c2
%define glibcsrcdir glibc-2.24-33-ge9e69e4
%define glibcversion 2.24
%define glibcrelease 3%{?dist}
%define glibcrelease 4%{?dist}
# Pre-release tarballs are pulled in from git using a command that is
# effectively:
#
@ -2266,6 +2266,19 @@ rm -f *.filelist*
%endif
%changelog
* Fri Dec 23 2016 Carlos O'Donell <carlos@systemhalted.org> - 2.24-4
- Auto-sync with upstream release/2.24/master,
commit e9e69e468039fcd57276f783a16aa771a8e4214e, fixing:
- Shared object unload assert when calling dlclose (#1398370, swbz#11941)
- Fix runtime resolver routines in the presence of AVX512 (swbz#20508)
- Fix writes past the allocated array bounds in execvpe (swbz#20847)
- Fix building with GCC 6.2 on i686 with stack protector.
- Fix building with GCC 7.
- Fix POWER6 memset with recent binutils.
- Fix POWER math test expected failures.
- Fix cancellation in posix_spawn.
- Fix multiarch builds for POWER9.
* Thu Aug 18 2016 Florian Weimer <fweimer@redhat.com> - 2.24-3
- Auto-sync with upstream release/2.24/master,
commit 8c716c2e2f916bc18a3857129c181b96990a87d6, fixing:

View File

@ -1,9 +1,10 @@
#!/bin/bash
set -e
# Patches are in the current directory.
export QUILT_PATCHES=$PWD
# Extract source file name from sources file,
# and assume it's the same name as the directory.
source=`cat sources | sed -e 's,^.* ,,g'`
source=`cat sources | sed -e 's,^.*(\(.*\)).*,\1,g'`
srcdir=${source%.tar.gz}
if [ "$1" == "-f" ] && [ -d "$srcdir" ]; then
echo Cleaning up $srcdir

View File

@ -1 +1 @@
7c92fd0c951c2375df59579fc8f57756 glibc-2.24-11-g8c716c2.tar.gz
SHA512 (glibc-2.24-33-ge9e69e4.tar.gz) = 69e0d4097afb2b54048ba077ceb8f42a156207d43cb8d78578d4fb06800b2608b39037ebdb5c60c893f10194e6cccbf2fbcc0a54a02eca3a179849a86f60f8e7