This commit is contained in:
Andreas Schwab 2010-03-18 16:24:48 +00:00
parent aa786aadd5
commit ad84bab7d2
5 changed files with 136 additions and 65 deletions

View File

@ -1,2 +1,2 @@
glibc-2.11.1-4-g11c19d3-fedora.tar.bz2
glibc-2.11.1-4-g11c19d3.tar.bz2
glibc-2.11.1-4-g11c19d3-fedora.tar.bz2

View File

@ -1,6 +1,23 @@
--- glibc-2.11.1-4-g11c19d3/ChangeLog
+++ glibc-2.11.1-2/ChangeLog
@@ -1169,6 +1169,11 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
+++ glibc-2.11.1-4/ChangeLog
@@ -1,3 +1,16 @@
+2010-03-09 David S. Miller <davem@davemloft.net>
+
+ * sysdeps/sparc/sparc64/dl-machine.h (elf_machine_rela): Handling
+ of R_SPARC_TLS_LE_* needs to use 32-bit loads and stores, not
+ 64-bit ones.
+
+2009-10-27 Aurelien Jarno <aurelien@aurel32.net>
+
+ [BZ #10855]
+ * locale/programs/locarchive.c: use MMAP_SHARED to reserve memory
+ used later with MMAP_FIXED | MMAP_SHARED to cope with different
+ alignment restrictions.
+
2010-01-14 Ulrich Drepper <drepper@redhat.com>
[BZ #11127]
@@ -1169,6 +1182,11 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
* sysdeps/generic/ldsodefs.h (struct rtld_global): The map element in
the unique symbol hash table should not be const.
@ -12,7 +29,7 @@
2009-07-21 Ulrich Drepper <drepper@redhat.com>
* sysdeps/x86_64/multiarch/strstr.c: Minor cleanups. Remove
@@ -1434,6 +1439,11 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
@@ -1434,6 +1452,11 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
out common code into new function get_common_indeces. Determine
extended family and model for Intel processors.
@ -24,7 +41,7 @@
2009-06-26 Ulrich Drepper <drepper@redhat.com>
* resolv/resolv.h: Define RES_SNGLKUPREOP.
@@ -10127,6 +10137,10 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
@@ -10127,6 +10150,10 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
[BZ #4368]
* stdlib/stdlib.h: Remove obsolete part of comment for realpath.
@ -35,7 +52,7 @@
2007-04-16 Ulrich Drepper <drepper@redhat.com>
[BZ #4364]
@@ -11384,6 +11398,15 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
@@ -11384,6 +11411,15 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
separators also if no non-zero digits found.
* stdlib/Makefile (tests): Add tst-strtod3.
@ -52,7 +69,7 @@
[BZ #3632]
--- glibc-2.11.1-4-g11c19d3/ChangeLog.15
+++ glibc-2.11.1-2/ChangeLog.15
+++ glibc-2.11.1-4/ChangeLog.15
@@ -477,6 +477,14 @@
2004-11-26 Jakub Jelinek <jakub@redhat.com>
@ -119,7 +136,7 @@
* scripts/extract-abilist.awk: If `lastversion' variable defined, omit
--- glibc-2.11.1-4-g11c19d3/ChangeLog.16
+++ glibc-2.11.1-2/ChangeLog.16
+++ glibc-2.11.1-4/ChangeLog.16
@@ -2042,6 +2042,9 @@
(__MATHDECL_2): Use __REDIRECT_NTH instead of __REDIRECT
followed by __THROW.
@ -174,7 +191,7 @@
[BZ #1137]
--- glibc-2.11.1-4-g11c19d3/Makeconfig
+++ glibc-2.11.1-2/Makeconfig
+++ glibc-2.11.1-4/Makeconfig
@@ -780,12 +780,12 @@ endif
# The assembler can generate debug information too.
ifndef ASFLAGS
@ -192,7 +209,7 @@
ifndef BUILD_CC
BUILD_CC = $(CC)
--- glibc-2.11.1-4-g11c19d3/csu/Makefile
+++ glibc-2.11.1-2/csu/Makefile
+++ glibc-2.11.1-4/csu/Makefile
@@ -93,7 +93,8 @@ omit-deps += $(crtstuff)
$(crtstuff:%=$(objpfx)%.o): %.o: %.S $(objpfx)defs.h
$(compile.S) -g0 $(ASFLAGS-.os) -o $@
@ -204,7 +221,7 @@
vpath initfini.c $(sysdirs)
--- glibc-2.11.1-4-g11c19d3/csu/elf-init.c
+++ glibc-2.11.1-2/csu/elf-init.c
+++ glibc-2.11.1-4/csu/elf-init.c
@@ -63,6 +63,23 @@ extern void (*__init_array_end []) (int, char **, char **)
extern void (*__fini_array_start []) (void) attribute_hidden;
extern void (*__fini_array_end []) (void) attribute_hidden;
@ -230,7 +247,7 @@
/* These function symbols are provided for the .init/.fini section entry
points automagically by the linker. */
--- glibc-2.11.1-4-g11c19d3/debug/tst-chk1.c
+++ glibc-2.11.1-2/debug/tst-chk1.c
+++ glibc-2.11.1-4/debug/tst-chk1.c
@@ -17,6 +17,9 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@ -260,7 +277,7 @@
# else
# define O 1
--- glibc-2.11.1-4-g11c19d3/elf/ldconfig.c
+++ glibc-2.11.1-2/elf/ldconfig.c
+++ glibc-2.11.1-4/elf/ldconfig.c
@@ -1020,17 +1020,19 @@ search_dirs (void)
@ -343,7 +360,7 @@
if (! opt_ignore_aux_cache)
--- glibc-2.11.1-4-g11c19d3/elf/tst-stackguard1.c
+++ glibc-2.11.1-2/elf/tst-stackguard1.c
+++ glibc-2.11.1-4/elf/tst-stackguard1.c
@@ -160,17 +160,21 @@ do_test (void)
the 16 runs, something is very wrong. */
int ndifferences = 0;
@ -369,15 +386,15 @@
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.11.1-4-g11c19d3/include/bits/stdlib-ldbl.h
+++ glibc-2.11.1-2/include/bits/stdlib-ldbl.h
+++ glibc-2.11.1-4/include/bits/stdlib-ldbl.h
@@ -0,0 +1 @@
+#include <stdlib/bits/stdlib-ldbl.h>
--- glibc-2.11.1-4-g11c19d3/include/bits/wchar-ldbl.h
+++ glibc-2.11.1-2/include/bits/wchar-ldbl.h
+++ glibc-2.11.1-4/include/bits/wchar-ldbl.h
@@ -0,0 +1 @@
+#include <wcsmbs/bits/wchar-ldbl.h>
--- glibc-2.11.1-4-g11c19d3/include/features.h
+++ glibc-2.11.1-2/include/features.h
+++ glibc-2.11.1-4/include/features.h
@@ -299,8 +299,13 @@
#endif
@ -395,7 +412,7 @@
# else
# define __USE_FORTIFY_LEVEL 1
--- glibc-2.11.1-4-g11c19d3/intl/locale.alias
+++ glibc-2.11.1-2/intl/locale.alias
+++ glibc-2.11.1-4/intl/locale.alias
@@ -57,8 +57,6 @@ korean ko_KR.eucKR
korean.euc ko_KR.eucKR
ko_KR ko_KR.eucKR
@ -406,7 +423,7 @@
nynorsk nn_NO.ISO-8859-1
polish pl_PL.ISO-8859-2
--- glibc-2.11.1-4-g11c19d3/libio/stdio.h
+++ glibc-2.11.1-2/libio/stdio.h
+++ glibc-2.11.1-4/libio/stdio.h
@@ -145,10 +145,12 @@ typedef _G_fpos64_t fpos64_t;
extern struct _IO_FILE *stdin; /* Standard input stream. */
extern struct _IO_FILE *stdout; /* Standard output stream. */
@ -421,7 +438,7 @@
__BEGIN_NAMESPACE_STD
/* Remove file FILENAME. */
--- glibc-2.11.1-4-g11c19d3/locale/iso-4217.def
+++ glibc-2.11.1-2/locale/iso-4217.def
+++ glibc-2.11.1-4/locale/iso-4217.def
@@ -8,6 +8,7 @@
*
* !!! The list has to be sorted !!!
@ -514,7 +531,16 @@
DEFINE_INT_CURR("QAR") /* Qatar Rial */
DEFINE_INT_CURR("ROL") /* Romanian Leu */
--- glibc-2.11.1-4-g11c19d3/locale/programs/locarchive.c
+++ glibc-2.11.1-2/locale/programs/locarchive.c
+++ glibc-2.11.1-4/locale/programs/locarchive.c
@@ -134,7 +134,7 @@ create_archive (const char *archivefname, struct locarhandle *ah)
size_t reserved = RESERVE_MMAP_SIZE;
int xflags = 0;
if (total < reserved
- && ((p = mmap64 (NULL, reserved, PROT_NONE, MAP_PRIVATE | MAP_ANON,
+ && ((p = mmap64 (NULL, reserved, PROT_NONE, MAP_SHARED | MAP_ANON,
-1, 0)) != MAP_FAILED))
xflags = MAP_FIXED;
else
@@ -241,9 +241,9 @@ oldlocrecentcmp (const void *a, const void *b)
/* forward decls for below */
static uint32_t add_locale (struct locarhandle *ah, const char *name,
@ -528,6 +554,24 @@
static bool
@@ -396,7 +396,7 @@ enlarge_archive (struct locarhandle *ah, const struct locarhead *head)
size_t reserved = RESERVE_MMAP_SIZE;
int xflags = 0;
if (total < reserved
- && ((p = mmap64 (NULL, reserved, PROT_NONE, MAP_PRIVATE | MAP_ANON,
+ && ((p = mmap64 (NULL, reserved, PROT_NONE, MAP_SHARED | MAP_ANON,
-1, 0)) != MAP_FAILED))
xflags = MAP_FIXED;
else
@@ -614,7 +614,7 @@ open_archive (struct locarhandle *ah, bool readonly)
int xflags = 0;
void *p;
if (st.st_size < reserved
- && ((p = mmap64 (NULL, reserved, PROT_NONE, MAP_PRIVATE | MAP_ANON,
+ && ((p = mmap64 (NULL, reserved, PROT_NONE, MAP_SHARED | MAP_ANON,
-1, 0)) != MAP_FAILED))
xflags = MAP_FIXED;
else
@@ -649,7 +649,7 @@ close_archive (struct locarhandle *ah)
#include "../../intl/explodename.c"
#include "../../intl/l10nflist.c"
@ -547,7 +591,7 @@
const char *oldname, uint32_t *locrec_offset_p)
{
--- glibc-2.11.1-4-g11c19d3/localedata/Makefile
+++ glibc-2.11.1-2/localedata/Makefile
+++ glibc-2.11.1-4/localedata/Makefile
@@ -225,6 +225,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-locales-dir
echo -n '...'; \
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
@ -557,7 +601,7 @@
$(addprefix --prefix=,$(install_root)) $$locale; \
echo ' done'; \
--- glibc-2.11.1-4-g11c19d3/localedata/SUPPORTED
+++ glibc-2.11.1-2/localedata/SUPPORTED
+++ glibc-2.11.1-4/localedata/SUPPORTED
@@ -84,6 +84,7 @@ cy_GB.UTF-8/UTF-8 \
cy_GB/ISO-8859-14 \
da_DK.UTF-8/UTF-8 \
@ -600,7 +644,7 @@
te_IN/UTF-8 \
tg_TJ.UTF-8/UTF-8 \
--- glibc-2.11.1-4-g11c19d3/localedata/locales/cy_GB
+++ glibc-2.11.1-2/localedata/locales/cy_GB
+++ glibc-2.11.1-4/localedata/locales/cy_GB
@@ -248,8 +248,11 @@ mon "<U0049><U006F><U006E><U0061><U0077><U0072>";/
d_t_fmt "<U0044><U0079><U0064><U0064><U0020><U0025><U0041><U0020><U0025><U0064><U0020><U006d><U0069><U0073><U0020><U0025><U0042><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
d_fmt "<U0025><U0064><U002E><U0025><U006D><U002E><U0025><U0079>"
@ -616,7 +660,7 @@
LC_MESSAGES
--- glibc-2.11.1-4-g11c19d3/localedata/locales/en_GB
+++ glibc-2.11.1-2/localedata/locales/en_GB
+++ glibc-2.11.1-4/localedata/locales/en_GB
@@ -116,8 +116,8 @@ mon "<U004A><U0061><U006E><U0075><U0061><U0072><U0079>";/
d_t_fmt "<U0025><U0061><U0020><U0025><U0064><U0020><U0025><U0062><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
d_fmt "<U0025><U0064><U002F><U0025><U006D><U002F><U0025><U0079>"
@ -629,7 +673,7 @@
<U0020><U0025><U0048><U003A><U0025><U004D><U003A><U0025><U0053><U0020>/
<U0025><U005A><U0020><U0025><U0059>"
--- glibc-2.11.1-4-g11c19d3/localedata/locales/no_NO
+++ glibc-2.11.1-2/localedata/locales/no_NO
+++ glibc-2.11.1-4/localedata/locales/no_NO
@@ -0,0 +1,69 @@
+escape_char /
+comment_char %
@ -701,7 +745,7 @@
+copy "nb_NO"
+END LC_ADDRESS
--- glibc-2.11.1-4-g11c19d3/localedata/locales/zh_TW
+++ glibc-2.11.1-2/localedata/locales/zh_TW
+++ glibc-2.11.1-4/localedata/locales/zh_TW
@@ -1,7 +1,7 @@
comment_char %
escape_char /
@ -730,7 +774,7 @@
date "2000-08-02"
%
--- glibc-2.11.1-4-g11c19d3/malloc/mcheck.c
+++ glibc-2.11.1-2/malloc/mcheck.c
+++ glibc-2.11.1-4/malloc/mcheck.c
@@ -24,9 +24,25 @@
# include <mcheck.h>
# include <stdint.h>
@ -807,7 +851,7 @@
old_free_hook = __free_hook;
__free_hook = freehook;
--- glibc-2.11.1-4-g11c19d3/manual/libc.texinfo
+++ glibc-2.11.1-2/manual/libc.texinfo
+++ glibc-2.11.1-4/manual/libc.texinfo
@@ -5,7 +5,7 @@
@c setchapternewpage odd
@ -818,7 +862,7 @@
* Libc: (libc). C library.
@end direntry
--- glibc-2.11.1-4-g11c19d3/misc/sys/cdefs.h
+++ glibc-2.11.1-2/misc/sys/cdefs.h
+++ glibc-2.11.1-4/misc/sys/cdefs.h
@@ -132,7 +132,10 @@
#define __bos(ptr) __builtin_object_size (ptr, __USE_FORTIFY_LEVEL > 1)
#define __bos0(ptr) __builtin_object_size (ptr, 0)
@ -863,7 +907,7 @@
# define __va_arg_pack_len() __builtin_va_arg_pack_len ()
#endif
--- glibc-2.11.1-4-g11c19d3/nis/nss
+++ glibc-2.11.1-2/nis/nss
+++ glibc-2.11.1-4/nis/nss
@@ -25,4 +25,4 @@
# memory with every getXXent() call. Otherwise each getXXent() call
# might result into a network communication with the server to get
@ -871,7 +915,7 @@
-#SETENT_BATCH_READ=TRUE
+SETENT_BATCH_READ=TRUE
--- glibc-2.11.1-4-g11c19d3/nptl/ChangeLog
+++ glibc-2.11.1-2/nptl/ChangeLog
+++ glibc-2.11.1-4/nptl/ChangeLog
@@ -3739,6 +3739,15 @@
Use __sigfillset. Document that sigfillset does the right thing wrt
to SIGSETXID.
@ -913,7 +957,7 @@
* tst-cancel17.c (do_test): Check if aio_cancel failed.
--- glibc-2.11.1-4-g11c19d3/nptl/Makefile
+++ glibc-2.11.1-2/nptl/Makefile
+++ glibc-2.11.1-4/nptl/Makefile
@@ -339,7 +339,8 @@ endif
extra-objs += $(crti-objs) $(crtn-objs)
omit-deps += crti crtn
@ -947,7 +991,7 @@
$(addprefix $(objpfx),$(tests) $(test-srcs)): $(objpfx)libpthread.a
endif
--- glibc-2.11.1-4-g11c19d3/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.11.1-2/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.11.1-4/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
@@ -189,4 +189,7 @@
/* Typed memory objects are not available. */
#define _POSIX_TYPED_MEMORY_OBJECTS -1
@ -957,7 +1001,7 @@
+
#endif /* bits/posix_opt.h */
--- glibc-2.11.1-4-g11c19d3/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.11.1-2/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.11.1-4/nptl/sysdeps/unix/sysv/linux/kernel-features.h
@@ -0,0 +1,6 @@
+#include_next <kernel-features.h>
+
@ -966,7 +1010,7 @@
+# define __ASSUME_CLONE_THREAD_FLAGS 1
+#endif
--- glibc-2.11.1-4-g11c19d3/nptl/tst-stackguard1.c
+++ glibc-2.11.1-2/nptl/tst-stackguard1.c
+++ glibc-2.11.1-4/nptl/tst-stackguard1.c
@@ -190,17 +190,21 @@ do_test (void)
the 16 runs, something is very wrong. */
int ndifferences = 0;
@ -992,7 +1036,7 @@
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.11.1-4-g11c19d3/nscd/nscd.conf
+++ glibc-2.11.1-2/nscd/nscd.conf
+++ glibc-2.11.1-4/nscd/nscd.conf
@@ -33,7 +33,7 @@
# logfile /var/log/nscd.log
# threads 4
@ -1003,7 +1047,7 @@
debug-level 0
# reload-count 5
--- glibc-2.11.1-4-g11c19d3/nscd/nscd.init
+++ glibc-2.11.1-2/nscd/nscd.init
+++ glibc-2.11.1-4/nscd/nscd.init
@@ -9,6 +9,7 @@
# slow naming services like NIS, NIS+, LDAP, or hesiod.
# processname: /usr/sbin/nscd
@ -1076,7 +1120,7 @@
*)
echo $"Usage: $0 {start|stop|status|restart|reload|condrestart}"
--- glibc-2.11.1-4-g11c19d3/posix/Makefile
+++ glibc-2.11.1-2/posix/Makefile
+++ glibc-2.11.1-4/posix/Makefile
@@ -303,15 +303,8 @@ $(inst_libexecdir)/getconf: $(inst_bindir)/getconf \
mv -f $@/$$spec.new $@/$$spec; \
done < $(objpfx)getconf.speclist
@ -1098,7 +1142,7 @@
+ > $@.new
mv -f $@.new $@
--- glibc-2.11.1-4-g11c19d3/posix/getconf.speclist.h
+++ glibc-2.11.1-2/posix/getconf.speclist.h
+++ glibc-2.11.1-4/posix/getconf.speclist.h
@@ -0,0 +1,39 @@
+#include <unistd.h>
+const char *START_OF_STRINGS =
@ -1140,7 +1184,7 @@
+#endif
+"";
--- glibc-2.11.1-4-g11c19d3/streams/Makefile
+++ glibc-2.11.1-2/streams/Makefile
+++ glibc-2.11.1-4/streams/Makefile
@@ -21,7 +21,7 @@
#
subdir := streams
@ -1151,7 +1195,7 @@
include ../Rules
--- glibc-2.11.1-4-g11c19d3/sysdeps/generic/dl-cache.h
+++ glibc-2.11.1-2/sysdeps/generic/dl-cache.h
+++ glibc-2.11.1-4/sysdeps/generic/dl-cache.h
@@ -36,6 +36,14 @@
# define add_system_dir(dir) add_dir (dir)
#endif
@ -1168,7 +1212,7 @@
/* libc5 and glibc 2.0/2.1 use the same format. For glibc 2.2 another
--- glibc-2.11.1-4-g11c19d3/sysdeps/i386/Makefile
+++ glibc-2.11.1-2/sysdeps/i386/Makefile
+++ glibc-2.11.1-4/sysdeps/i386/Makefile
@@ -2,6 +2,8 @@
# Every i386 port in use uses gas syntax (I think).
asm-CPPFLAGS += -DGAS_SYNTAX
@ -1194,7 +1238,7 @@
ifeq ($(subdir),elf)
--- glibc-2.11.1-4-g11c19d3/sysdeps/ia64/Makefile
+++ glibc-2.11.1-2/sysdeps/ia64/Makefile
+++ glibc-2.11.1-4/sysdeps/ia64/Makefile
@@ -12,8 +12,8 @@ elide-routines.os += hp-timing
ifeq (yes,$(build-shared))
@ -1207,7 +1251,7 @@
endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.11.1-2/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.11.1-4/sysdeps/ia64/ia64libgcc.S
@@ -1,350 +0,0 @@
-/* From the Intel IA-64 Optimization Guide, choose the minimum latency
- alternative. */
@ -1560,7 +1604,7 @@
-
-#endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.11.1-2/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.11.1-4/sysdeps/ia64/libgcc-compat.c
@@ -0,0 +1,84 @@
+/* pre-.hidden libgcc compatibility
+ Copyright (C) 2002 Free Software Foundation, Inc.
@ -1647,7 +1691,7 @@
+
+#endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.11.1-2/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.11.1-4/sysdeps/powerpc/powerpc64/Makefile
@@ -30,6 +30,7 @@ ifneq ($(elf),no)
# we use -fpic instead which is much better.
CFLAGS-initfini.s += -fpic -O1
@ -1656,8 +1700,28 @@
endif
ifeq ($(subdir),elf)
--- glibc-2.11.1-4-g11c19d3/sysdeps/sparc/sparc64/dl-machine.h
+++ glibc-2.11.1-4/sysdeps/sparc/sparc64/dl-machine.h
@@ -623,11 +623,13 @@ elf_machine_rela (struct link_map *map, const Elf64_Rela *reloc,
value = sym->st_value - sym_map->l_tls_offset
+ reloc->r_addend;
if (r_type == R_SPARC_TLS_LE_HIX22)
- *reloc_addr = (*reloc_addr & 0xffc00000)
- | (((~value) >> 10) & 0x3fffff);
+ *(unsigned int *)reloc_addr =
+ ((*(unsigned int *)reloc_addr & 0xffc00000)
+ | (((~value) >> 10) & 0x3fffff));
else
- *reloc_addr = (*reloc_addr & 0xffffe000) | (value & 0x3ff)
- | 0x1c00;
+ *(unsigned int *)reloc_addr =
+ ((*(unsigned int *)reloc_addr & 0xffffe000) | (value & 0x3ff)
+ | 0x1c00);
}
break;
# endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/nice.c
+++ glibc-2.11.1-2/sysdeps/unix/nice.c
+++ glibc-2.11.1-4/sysdeps/unix/nice.c
@@ -42,7 +42,12 @@ nice (int incr)
__set_errno (save);
}
@ -1673,7 +1737,7 @@
{
if (errno == EACCES)
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.11.1-2/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/check_pf.c
@@ -27,13 +27,10 @@
#include <unistd.h>
#include <sys/socket.h>
@ -1690,7 +1754,7 @@
#ifndef IFA_F_HOMEADDRESS
# define IFA_F_HOMEADDRESS 0
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.11.1-2/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/dl-osinfo.h
@@ -17,10 +17,13 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@ -1739,7 +1803,7 @@
else
#endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.11.1-2/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/futimesat.c
@@ -37,14 +37,14 @@ futimesat (fd, file, tvp)
{
int result;
@ -1783,7 +1847,7 @@
size_t filelen = strlen (file);
if (__builtin_expect (filelen == 0, 0))
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/i386/clone.S
+++ glibc-2.11.1-2/sysdeps/unix/sysv/linux/i386/clone.S
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/i386/clone.S
@@ -120,9 +120,6 @@ L(pseudo_end):
ret
@ -1803,7 +1867,7 @@
cfi_startproc
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.11.1-2/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/i386/dl-cache.h
@@ -0,0 +1,59 @@
+/* Support for reading /etc/ld.so.cache files written by Linux ldconfig.
+ Copyright (C) 2004 Free Software Foundation, Inc.
@ -1865,7 +1929,7 @@
+
+#include_next <dl-cache.h>
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.11.1-2/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/ia64/dl-cache.h
@@ -22,4 +22,31 @@
#define _dl_cache_check_flags(flags) \
((flags) == _DL_CACHE_DEFAULT_ID)
@ -1899,7 +1963,7 @@
+
#include_next <dl-cache.h>
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.11.1-2/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
+#include <sysdeps/i386/dl-procinfo.c>
@ -1907,7 +1971,7 @@
+#include <sysdeps/generic/dl-procinfo.c>
+#endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.11.1-2/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
+#include <sysdeps/unix/sysv/linux/i386/dl-procinfo.h>
@ -1915,12 +1979,12 @@
+#include <sysdeps/generic/dl-procinfo.h>
+#endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.11.1-2/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
@@ -1 +1 @@
-s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 \2\3"_
+s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 /emul/ia32-linux\2\3"_
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.11.1-2/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/netlinkaccess.h
@@ -25,6 +25,24 @@
#include <kernel-features.h>
@ -1947,7 +2011,7 @@
struct netlink_res
{
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.11.1-2/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/paths.h
@@ -62,7 +62,7 @@
#define _PATH_TTY "/dev/tty"
#define _PATH_UNIX "/boot/vmlinux"
@ -1958,7 +2022,7 @@
/* Provide trailing slash, since mostly used for building pathnames. */
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/tcsetattr.c
+++ glibc-2.11.1-2/sysdeps/unix/sysv/linux/tcsetattr.c
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/tcsetattr.c
@@ -49,6 +49,7 @@ tcsetattr (fd, optional_actions, termios_p)
{
struct __kernel_termios k_termios;
@ -2005,7 +2069,7 @@
}
libc_hidden_def (tcsetattr)
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/x86_64/clone.S
+++ glibc-2.11.1-2/sysdeps/unix/sysv/linux/x86_64/clone.S
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/x86_64/clone.S
@@ -89,9 +89,6 @@ L(pseudo_end):
ret
@ -2025,7 +2089,7 @@
cfi_startproc;
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.11.1-4-g11c19d3/timezone/zic.c
+++ glibc-2.11.1-2/timezone/zic.c
+++ glibc-2.11.1-4/timezone/zic.c
@@ -1921,7 +1921,7 @@ const int zonecount;
if (stdrp != NULL && stdrp->r_hiyear == 2037)
return;

View File

@ -28,7 +28,7 @@
Summary: The GNU libc libraries
Name: glibc
Version: %{glibcversion}
Release: 2
Release: 4
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
# Things that are linked directly into dynamically linked programs
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
@ -1037,13 +1037,19 @@ rm -f *.filelist*
%endif
%changelog
* Wed Mar 17 2010 Andreas Schwab <schwab@redhat.com> - 2.11.1-2
* Wed Mar 17 2010 Andreas Schwab <schwab@redhat.com> - 2.11.1-4
- Update from 2.11 branch
- regcomp.c: do not ignore memory allocation failure (BZ#11127)
- Fix typo in feature selection macro use
- Avoid ELF lookup race
- Fix a few error cases in *name4_r lookup handling (#573904, BZ#11000)
* Thu Mar 09 2010 Dennis Gilmore <dennis@ausil.us> - 2.11.1-3
- add patch to fix sparc TLS reloc (BZ#571551).
* Wed Feb 10 2010 Dennis Gilmore <dennis@ausil.us> - 2.11.1-2
- add sparc locale patch commited upstream to the fedora branch
* Mon Dec 14 2009 Andreas Schwab <schwab@redhat.com> - 2.11.1-1
- Update to 2.11.1 release.
- Locale updates.

View File

@ -41,3 +41,4 @@ glibc-2_11-3:F-12:glibc-2.11-3.src.rpm:1259075120
glibc-2_11-4:F-12:glibc-2.11-4.src.rpm:1259591029
glibc-2_11_1-1:F-12:glibc-2.11.1-1.src.rpm:1262612086
glibc-2_11_1-2:F-12:glibc-2.11.1-2.src.rpm:1268927149
glibc-2_11_1-4:F-12:glibc-2.11.1-4.src.rpm:1268929381

View File

@ -1,2 +1,2 @@
6d039c73c8ba06daa3324e96dd392fef glibc-2.11.1-4-g11c19d3-fedora.tar.bz2
b7e765fa327700ae462e2b71e462ad87 glibc-2.11.1-4-g11c19d3.tar.bz2
f151d1400808362b0ebfa5c51814108b glibc-2.11.1-4-g11c19d3-fedora.tar.bz2