Resolves: #1462820
Auto-sync with upstream release/2.23/master Upstream commit: d990d79610362f823292f9d869b84b4ec4491159 - Ignore and remove LD_HWCAP_MASK for AT_SECURE programs (swbz#21209) - Correct collation rules for Malayalam (swbz#19922, swbz#19919) - fts: Fix symbol redirect for fts_set (swbz#21289) - powerpc: Fix write-after-destroy in lock elision (swbz#20822) - localedata: bs_BA: fix yesexpr/noexpr (swbz#20974)
This commit is contained in:
parent
e8c9660c30
commit
aa81e6c35b
@ -21,10 +21,11 @@
|
||||
# elf/rtld.c | 4 ----
|
||||
# 4 files changed, 7 insertions(+), 10 deletions(-)
|
||||
#
|
||||
diff -urN glibc-2.20-205-ga39208b/elf/dl-init.c glibc-2.20-205-ga39208b.mod/elf/dl-init.c
|
||||
--- glibc-2.20-205-ga39208b/elf/dl-init.c 2014-11-21 16:08:32.744913590 -0500
|
||||
+++ glibc-2.20-205-ga39208b.mod/elf/dl-init.c 2014-11-21 16:09:42.485708197 -0500
|
||||
@@ -119,8 +119,6 @@
|
||||
Index: b/elf/dl-init.c
|
||||
===================================================================
|
||||
--- a/elf/dl-init.c
|
||||
+++ b/elf/dl-init.c
|
||||
@@ -119,8 +119,6 @@ _dl_init (struct link_map *main_map, int
|
||||
while (i-- > 0)
|
||||
call_init (main_map->l_initfini[i], argc, argv, env);
|
||||
|
||||
@ -33,10 +34,11 @@ diff -urN glibc-2.20-205-ga39208b/elf/dl-init.c glibc-2.20-205-ga39208b.mod/elf/
|
||||
_dl_starting_up = 0;
|
||||
-#endif
|
||||
}
|
||||
diff -urN glibc-2.20-205-ga39208b/elf/dl-support.c glibc-2.20-205-ga39208b.mod/elf/dl-support.c
|
||||
--- glibc-2.20-205-ga39208b/elf/dl-support.c 2014-11-19 14:35:03.000000000 -0500
|
||||
+++ glibc-2.20-205-ga39208b.mod/elf/dl-support.c 2014-11-21 16:09:54.829671843 -0500
|
||||
@@ -118,10 +118,8 @@
|
||||
Index: b/elf/dl-support.c
|
||||
===================================================================
|
||||
--- a/elf/dl-support.c
|
||||
+++ b/elf/dl-support.c
|
||||
@@ -117,10 +117,8 @@ struct r_scope_elem _dl_initial_searchli
|
||||
.r_nlist = 1,
|
||||
};
|
||||
|
||||
@ -47,18 +49,19 @@ diff -urN glibc-2.20-205-ga39208b/elf/dl-support.c glibc-2.20-205-ga39208b.mod/e
|
||||
|
||||
/* Random data provided by the kernel. */
|
||||
void *_dl_random;
|
||||
diff -urN glibc-2.20-205-ga39208b/elf/rtld.c glibc-2.20-205-ga39208b.mod/elf/rtld.c
|
||||
--- glibc-2.20-205-ga39208b/elf/rtld.c 2014-11-21 16:08:32.745913587 -0500
|
||||
+++ glibc-2.20-205-ga39208b.mod/elf/rtld.c 2014-11-21 16:09:05.614816785 -0500
|
||||
@@ -107,7 +107,6 @@
|
||||
struct audit_list *next;
|
||||
} *audit_list;
|
||||
Index: b/elf/rtld.c
|
||||
===================================================================
|
||||
--- a/elf/rtld.c
|
||||
+++ b/elf/rtld.c
|
||||
@@ -214,7 +214,6 @@ audit_list_iter_next (struct audit_list_
|
||||
return iter->previous->name;
|
||||
}
|
||||
|
||||
-#ifndef HAVE_INLINED_SYSCALLS
|
||||
/* Set nonzero during loading and initialization of executable and
|
||||
libraries, cleared before the executable's entry point runs. This
|
||||
must not be initialized to nonzero, because the unused dynamic
|
||||
@@ -117,7 +116,6 @@
|
||||
@@ -224,7 +223,6 @@ audit_list_iter_next (struct audit_list_
|
||||
never be called. */
|
||||
int _dl_starting_up = 0;
|
||||
rtld_hidden_def (_dl_starting_up)
|
||||
@ -66,7 +69,7 @@ diff -urN glibc-2.20-205-ga39208b/elf/rtld.c glibc-2.20-205-ga39208b.mod/elf/rtl
|
||||
|
||||
/* This is the structure which defines all variables global to ld.so
|
||||
(except those which cannot be added for some reason). */
|
||||
@@ -776,10 +774,8 @@
|
||||
@@ -898,10 +896,8 @@ dl_main (const ElfW(Phdr) *phdr,
|
||||
/* Process the environment variable which control the behaviour. */
|
||||
process_envvars (&mode);
|
||||
|
||||
|
14
glibc.spec
14
glibc.spec
@ -1,6 +1,6 @@
|
||||
%define glibcsrcdir glibc-2.23-85-g422facf
|
||||
%define glibcsrcdir glibc-2.23-101-gd990d79
|
||||
%define glibcversion 2.23.1
|
||||
%define glibcrelease 11%{?dist}
|
||||
%define glibcrelease 12%{?dist}
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
#
|
||||
@ -2120,6 +2120,16 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jun 20 2017 Florian Weimer <fweimer@redhat.com> - 2.23.1-12
|
||||
- Auto-sync with upstream release/2.23/master,
|
||||
commit d990d79610362f823292f9d869b84b4ec4491159, fixing:
|
||||
- CVE-2017-1000366: Avoid large allocas in the dynamic linker (#1462820)
|
||||
- Ignore and remove LD_HWCAP_MASK for AT_SECURE programs (swbz#21209)
|
||||
- Correct collation rules for Malayalam (swbz#19922, swbz#19919)
|
||||
- fts: Fix symbol redirect for fts_set (swbz#21289)
|
||||
- powerpc: Fix write-after-destroy in lock elision (swbz#20822)
|
||||
- localedata: bs_BA: fix yesexpr/noexpr (swbz#20974)
|
||||
|
||||
* Wed Nov 02 2016 Florian Weimer <fweimer@redhat.com> - 2.23.1-11
|
||||
- Auto-sync with upstream release/2.23/master,
|
||||
commit 422facff9f2c4972e2dc46090a704d11b840b0c0, fixing:
|
||||
|
Loading…
Reference in New Issue
Block a user