Auto-sync with upstream branch release/2.26/master
Upstream commit: af7519f7b35024224c163e32a89fb247b0c446fc - Fix path length overflow in realpath (swbz#22786) - Fix stack overflow with huge PT_NOTE segment (swbz#20419) - Fix signed integer overflow in random_r (swbz#17343) - i386: Fix i386 sigaction sa_restorer initialization (swbz#21269) - nscd: Fix netgroup cache keys (swbz#22342) - Fix i386 memmove issue (swbz#22644) - Fix crash in resolver on memory allocation failure (swbz#23005) - getlogin_r: return early when linux sentinel value is set (swbz#23024) - resolv: Fully initialize struct mmsghdr in send_dg (swbz#23037)
This commit is contained in:
parent
a50c0ee87a
commit
9398a19ada
@ -1540,7 +1540,7 @@ index cc108aa2d64b616a..3529cf6fe509cfd1 100644
|
||||
bit fiddling. */
|
||||
return (int32_t) (in.s_addr << 16 | in.s_addr >> 16);
|
||||
diff --git a/sysdeps/unix/sysv/linux/getlogin_r.c b/sysdeps/unix/sysv/linux/getlogin_r.c
|
||||
index 05ac36b49186b29e..37a9255e03657728 100644
|
||||
index fe81fd196ab3be73..0eff10da7501fd30 100644
|
||||
--- a/sysdeps/unix/sysv/linux/getlogin_r.c
|
||||
+++ b/sysdeps/unix/sysv/linux/getlogin_r.c
|
||||
@@ -18,6 +18,7 @@
|
||||
@ -1551,9 +1551,9 @@ index 05ac36b49186b29e..37a9255e03657728 100644
|
||||
|
||||
#define STATIC static
|
||||
static int getlogin_r_fd0 (char *name, size_t namesize);
|
||||
@@ -54,28 +55,19 @@ __getlogin_r_loginuid (char *name, size_t namesize)
|
||||
endp == uidbuf || *endp != '\0'))
|
||||
return -1;
|
||||
@@ -63,28 +64,19 @@ __getlogin_r_loginuid (char *name, size_t namesize)
|
||||
return ENXIO;
|
||||
}
|
||||
|
||||
- size_t buflen = 1024;
|
||||
- char *buf = alloca (buflen);
|
||||
@ -1587,7 +1587,7 @@ index 05ac36b49186b29e..37a9255e03657728 100644
|
||||
}
|
||||
|
||||
if (res != 0 || tpwd == NULL)
|
||||
@@ -95,9 +87,7 @@ __getlogin_r_loginuid (char *name, size_t namesize)
|
||||
@@ -104,9 +96,7 @@ __getlogin_r_loginuid (char *name, size_t namesize)
|
||||
memcpy (name, pwd.pw_name, needed);
|
||||
|
||||
out:
|
||||
|
18
glibc.spec
18
glibc.spec
@ -1,6 +1,6 @@
|
||||
%define glibcsrcdir glibc-2.26-146-gd300041c53
|
||||
%define glibcsrcdir glibc-2.26-156-gaf7519f7b3
|
||||
%define glibcversion 2.26
|
||||
%define glibcrelease 27%{?dist}
|
||||
%define glibcrelease 28%{?dist}
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
#
|
||||
@ -2223,6 +2223,20 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri May 18 2018 Florian Weimer <fweimer@redhat.com> - 2.26-28
|
||||
- Do not run telinit u on upgrades (#1579225)
|
||||
- Auto-sync with upstream branch release/2.26/master,
|
||||
commit af7519f7b35024224c163e32a89fb247b0c446fc:
|
||||
- Fix path length overflow in realpath (swbz#22786)
|
||||
- Fix stack overflow with huge PT_NOTE segment (swbz#20419)
|
||||
- Fix signed integer overflow in random_r (swbz#17343)
|
||||
- i386: Fix i386 sigaction sa_restorer initialization (swbz#21269)
|
||||
- nscd: Fix netgroup cache keys (swbz#22342)
|
||||
- Fix i386 memmove issue (swbz#22644)
|
||||
- Fix crash in resolver on memory allocation failure (swbz#23005)
|
||||
- getlogin_r: return early when linux sentinel value is set (swbz#23024)
|
||||
- resolv: Fully initialize struct mmsghdr in send_dg (swbz#23037)
|
||||
|
||||
* Fri Mar 2 2018 Florian Weimer <fweimer@redhat.com> - 2.26-27
|
||||
- Restore unwind tables on POWER (#1550914)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (glibc-2.26-146-gd300041c53.tar.gz) = 5fceee4269fa0fe4cdb9208e13e15d97f0a53d869ceacdf419aaa6fdb0aaeaf56e8f094b593fdf0cbf22410805839f54821fcbafc4797370d281bfdcfa5cea56
|
||||
SHA512 (glibc-2.26-156-gaf7519f7b3.tar.gz) = 9e0854f89727fc1690c2e8601869cb0fa547d5f48834bca80b56359db592d0b34dc677a5e641a91ce1d3b07f78f3e6f7bee397b1969ac2bbf7a7af76652ea680
|
||||
|
Loading…
Reference in New Issue
Block a user