Auto-sync with upstream branch master

- Remove glibc-ld-readonly-revert.patch.

Upstream commit e037274c8ec86ca9d491331984b34f30701b23cf:

- stdlib: Fix tst-canon-bz26341 when the glibc build current working
  directory is itself using symlinks.
- powerpc: Remove backtrace implementation
- Correct access attribute on memfrob (bug 28475)
- debug: Add tests for _FORTIFY_SOURCE=3
- Make sure that the fortified function conditionals are constant
- Don't add access size hints to fortifiable functions
- glibcextract.py: Place un-assemblable @@@ in a comment
- nss: Unnest nested function add_key
- ld.so: Initialize bootstrap_map.l_ld_readonly [BZ #28340]
- timex: Use 64-bit fields on 32-bit TIMESIZE=64 systems (BZ #28469)
- manual: Update _TIME_BITS to clarify it's user defined
- nptl: Fix tst-cancel7 and tst-cancelx7 pidfile race
- elf: Fix elf_get_dynamic_info() for bootstrap
- hurd if_index: Explicitly use AF_INET for if index discovery
- hurd: Fix intr-msg parameter/stack kludge
- x86-64: Add test-vector-abi.h/test-vector-abi-sincos.h
- elf: Fix dynamic-link.h usage on rtld.c
This commit is contained in:
Carlos O'Donell 2021-10-20 17:35:57 -04:00
parent 09d2e07988
commit 8deb7f51cc
3 changed files with 26 additions and 508 deletions

View File

@ -1,504 +0,0 @@
Revert "ld.so: Replace DL_RO_DYN_SECTION with dl_relocate_ld [BZ #28340]"
This reverts commit b413280cfb16834450f66f554bc0d618bb513851 with changes to
adjust for the following subsequent commits:
490e6c62aa31a8 (elf: Avoid nested functions in the loader [BZ #27220])
4af6982e4c9fc4 (elf: Fix elf_get_dynamic_info definition)
It does not work on ppc64le:
Sorry, this does not appear to work: For !DONT_USE_BOOTSTRAP_MAP,
bootstrap_map.l_ld_readonly is not initialized during the initial
self-relocation. This is visible as a valgrind failure on
powerpc64le-linux-gnu:
+ /builddir/build/BUILDROOT/glibc-2.34.9000-9.fc36.ppc64le/lib64/ld64.so.2 --library-path /builddir/build/BUILDROOT/glibc-2.34.9000-9.fc36.ppc64le/lib64 /usr/bin/valgrind --error-exitcode=1 /builddir/build/BUILDROOT/glibc-2.34.9000-9.fc36.ppc64le/lib64/ld64.so.2 --library-path /builddir/build/BUILDROOT/glibc-2.34.9000-9.fc36.ppc64le/lib64 /usr/bin/true
==1924587== Memcheck, a memory error detector
==1924587== Copyright (C) 2002-2017, and GNU GPL'd, by Julian Seward et al.
==1924587== Using Valgrind-3.17.0 and LibVEX; rerun with -h for copyright info
==1924587== Command: /builddir/build/BUILDROOT/glibc-2.34.9000-9.fc36.ppc64le/lib64/ld64.so.2 --library-path /builddir/build/BUILDROOT/glibc-2.34.9000-9.fc36.ppc64le/lib64 /usr/bin/true
==1924587==
==1924587== Conditional jump or move depends on uninitialised value(s)
==1924587== at 0x191620: elf_get_dynamic_info (get-dynamic-info.h:73)
==1924587== by 0x191620: _dl_start (rtld.c:550)
==1924587== by 0x190677: (below main) (in /builddir/build/BUILDROOT/glibc-2.34.9000-9.fc36.ppc64le/lib64/ld64.so.2)
==1924587==
For DONT_USE_BOOTSTRAP_MAP, bootstrap_map.l_ld_readonly is always zero,
which is incorrect for RISC-V (which is PI_STATIC_AND_HIDDEN and thus
DONT_USE_BOOTSTRAP_MAP).
<https://sourceware.org/pipermail/libc-alpha/2021-September/131287.html>
diff --git a/elf/Makefile b/elf/Makefile
index 26986c0692..2236b6ec62 100644
--- a/elf/Makefile
+++ b/elf/Makefile
@@ -224,7 +224,7 @@ tests += restest1 preloadtest loadfail multiload origtest resolvfail \
tst-tls-ie tst-tls-ie-dlmopen argv0test \
tst-glibc-hwcaps tst-glibc-hwcaps-prepend tst-glibc-hwcaps-mask \
tst-tls20 tst-tls21 tst-dlmopen-dlerror tst-dlmopen-gethostbyname \
- tst-dl-is_dso tst-ro-dynamic
+ tst-dl-is_dso
# reldep9
tests-internal += loadtest unload unload2 circleload1 \
neededtest neededtest2 neededtest3 neededtest4 \
@@ -360,7 +360,7 @@ modules-names = testobj1 testobj2 testobj3 testobj4 testobj5 testobj6 \
libmarkermod4-1 libmarkermod4-2 libmarkermod4-3 libmarkermod4-4 \
tst-tls20mod-bad tst-tls21mod tst-dlmopen-dlerror-mod \
tst-auxvalmod \
- tst-dlmopen-gethostbyname-mod tst-ro-dynamic-mod \
+ tst-dlmopen-gethostbyname-mod \
# Most modules build with _ISOMAC defined, but those filtered out
# depend on internal headers.
@@ -1912,10 +1912,3 @@ $(objpfx)tst-getauxval-static.out: $(objpfx)tst-auxvalmod.so
tst-getauxval-static-ENV = LD_LIBRARY_PATH=$(objpfx):$(common-objpfx)
$(objpfx)tst-dlmopen-gethostbyname.out: $(objpfx)tst-dlmopen-gethostbyname-mod.so
-
-$(objpfx)tst-ro-dynamic: $(objpfx)tst-ro-dynamic-mod.so
-$(objpfx)tst-ro-dynamic-mod.so: $(objpfx)tst-ro-dynamic-mod.os \
- tst-ro-dynamic-mod.map
- $(LINK.o) -nostdlib -nostartfiles -shared -o $@ \
- -Wl,--script=tst-ro-dynamic-mod.map \
- $(objpfx)tst-ro-dynamic-mod.os
diff --git a/elf/dl-load.c b/elf/dl-load.c
index 335c79fad5..a8e7f2e9cb 100644
--- a/elf/dl-load.c
+++ b/elf/dl-load.c
@@ -1154,7 +1154,6 @@ _dl_map_object_from_fd (const char *name, const char *origname, int fd,
such a segment to avoid a crash later. */
l->l_ld = (void *) ph->p_vaddr;
l->l_ldnum = ph->p_memsz / sizeof (ElfW(Dyn));
- l->l_ld_readonly = (ph->p_flags & PF_W) == 0;
}
break;
@@ -1298,7 +1297,7 @@ _dl_map_object_from_fd (const char *name, const char *origname, int fd,
else
l->l_ld = (ElfW(Dyn) *) ((ElfW(Addr)) l->l_ld + l->l_addr);
- elf_get_dynamic_info (l, false);
+ elf_get_dynamic_info (l, NULL, false);
/* Make sure we are not dlopen'ing an object that has the
DF_1_NOOPEN flag set, or a PIE object. */
diff --git a/elf/dl-reloc-static-pie.c b/elf/dl-reloc-static-pie.c
index 8a99c4995b..efffc411cd 100644
--- a/elf/dl-reloc-static-pie.c
+++ b/elf/dl-reloc-static-pie.c
@@ -42,17 +42,7 @@ _dl_relocate_static_pie (void)
/* Read our own dynamic section and fill in the info array. */
main_map->l_ld = ((void *) main_map->l_addr + elf_machine_dynamic ());
-
- const ElfW(Phdr) *ph, *phdr = GL(dl_phdr);
- size_t phnum = GL(dl_phnum);
- for (ph = phdr; ph < &phdr[phnum]; ++ph)
- if (ph->p_type == PT_DYNAMIC)
- {
- main_map->l_ld_readonly = (ph->p_flags & PF_W) == 0;
- break;
- }
-
- elf_get_dynamic_info (main_map, false);
+ elf_get_dynamic_info (main_map, NULL, false);
# ifdef ELF_MACHINE_BEFORE_RTLD_RELOC
ELF_MACHINE_BEFORE_RTLD_RELOC (main_map, main_map->l_info);
diff --git a/elf/get-dynamic-info.h b/elf/get-dynamic-info.h
index d169099fbc..061466af71 100644
--- a/elf/get-dynamic-info.h
+++ b/elf/get-dynamic-info.h
@@ -25,7 +25,7 @@
#include <libc-diag.h>
static inline void __attribute__ ((unused, always_inline))
-elf_get_dynamic_info (struct link_map *l, bool check)
+elf_get_dynamic_info (struct link_map *l, ElfW(Dyn) *temp, bool check)
{
#if __ELF_NATIVE_CLASS == 32
typedef Elf32_Word d_tag_utype;
@@ -66,15 +66,28 @@ elf_get_dynamic_info (struct link_map *l, bool check)
info[i] = dyn;
}
+#define DL_RO_DYN_TEMP_CNT 8
+
+#ifndef DL_RO_DYN_SECTION
/* Don't adjust .dynamic unnecessarily. */
- if (l->l_addr != 0 && dl_relocate_ld (l))
+ if (l->l_addr != 0)
{
ElfW(Addr) l_addr = l->l_addr;
+ int cnt = 0;
# define ADJUST_DYN_INFO(tag) \
do \
if (info[tag] != NULL) \
- info[tag]->d_un.d_ptr += l_addr; \
+ { \
+ if (temp) \
+ { \
+ temp[cnt].d_tag = info[tag]->d_tag; \
+ temp[cnt].d_un.d_ptr = info[tag]->d_un.d_ptr + l_addr; \
+ info[tag] = temp + cnt++; \
+ } \
+ else \
+ info[tag]->d_un.d_ptr += l_addr; \
+ } \
while (0)
ADJUST_DYN_INFO (DT_HASH);
@@ -91,7 +104,9 @@ elf_get_dynamic_info (struct link_map *l, bool check)
ADJUST_DYN_INFO (VERSYMIDX (DT_VERSYM));
ADJUST_DYN_INFO (ADDRIDX (DT_GNU_HASH));
# undef ADJUST_DYN_INFO
+ assert (cnt <= DL_RO_DYN_TEMP_CNT);
}
+#endif
if (info[DT_PLTREL] != NULL)
{
#if ELF_MACHINE_NO_RELA
diff --git a/elf/rtld.c b/elf/rtld.c
index fe5ee9ec4d..de731a90d9 100644
--- a/elf/rtld.c
+++ b/elf/rtld.c
@@ -464,7 +464,6 @@ _dl_start_final (void *arg, struct dl_start_final_info *info)
#ifndef DONT_USE_BOOTSTRAP_MAP
GL(dl_rtld_map).l_addr = info->l.l_addr;
GL(dl_rtld_map).l_ld = info->l.l_ld;
- GL(dl_rtld_map).l_ld_readonly = info->l.l_ld_readonly;
memcpy (GL(dl_rtld_map).l_info, info->l.l_info,
sizeof GL(dl_rtld_map).l_info);
GL(dl_rtld_map).l_mach = info->l.l_mach;
@@ -548,7 +547,7 @@ _dl_start (void *arg)
/* Read our own dynamic section and fill in the info array. */
bootstrap_map.l_ld = (void *) bootstrap_map.l_addr + elf_machine_dynamic ();
- elf_get_dynamic_info (&bootstrap_map, true);
+ elf_get_dynamic_info (&bootstrap_map, NULL, true);
#if NO_TLS_OFFSET != 0
bootstrap_map.l_tls_offset = NO_TLS_OFFSET;
@@ -1470,7 +1469,6 @@ dl_main (const ElfW(Phdr) *phdr,
/* This tells us where to find the dynamic section,
which tells us everything we need to do. */
main_map->l_ld = (void *) main_map->l_addr + ph->p_vaddr;
- main_map->l_ld_readonly = (ph->p_flags & PF_W) == 0;
break;
case PT_INTERP:
/* This "interpreter segment" was used by the program loader to
@@ -1616,7 +1614,7 @@ dl_main (const ElfW(Phdr) *phdr,
if (! rtld_is_main)
{
/* Extract the contents of the dynamic section for easy access. */
- elf_get_dynamic_info (main_map, false);
+ elf_get_dynamic_info (main_map, NULL, false);
/* If the main map is libc.so, update the base namespace to
refer to this map. If libc.so is loaded later, this happens
diff --git a/elf/setup-vdso.h b/elf/setup-vdso.h
index 6fdffafcca..97de0f56a0 100644
--- a/elf/setup-vdso.h
+++ b/elf/setup-vdso.h
@@ -33,6 +33,8 @@ setup_vdso (struct link_map *main_map __attribute__ ((unused)),
0, LM_ID_BASE);
if (__glibc_likely (l != NULL))
{
+ static ElfW(Dyn) dyn_temp[DL_RO_DYN_TEMP_CNT] attribute_relro;
+
l->l_phdr = ((const void *) GLRO(dl_sysinfo_dso)
+ GLRO(dl_sysinfo_dso)->e_phoff);
l->l_phnum = GLRO(dl_sysinfo_dso)->e_phnum;
@@ -43,7 +45,6 @@ setup_vdso (struct link_map *main_map __attribute__ ((unused)),
{
l->l_ld = (void *) ph->p_vaddr;
l->l_ldnum = ph->p_memsz / sizeof (ElfW(Dyn));
- l->l_ld_readonly = (ph->p_flags & PF_W) == 0;
}
else if (ph->p_type == PT_LOAD)
{
@@ -64,7 +65,7 @@ setup_vdso (struct link_map *main_map __attribute__ ((unused)),
l->l_map_end += l->l_addr;
l->l_text_end += l->l_addr;
l->l_ld = (void *) ((ElfW(Addr)) l->l_ld + l->l_addr);
- elf_get_dynamic_info (l, false);
+ elf_get_dynamic_info (l, dyn_temp, false);
_dl_setup_hash (l);
l->l_relocated = 1;
diff --git a/elf/tst-ro-dynamic-mod.c b/elf/tst-ro-dynamic-mod.c
deleted file mode 100644
index 6d99925964..0000000000
--- a/elf/tst-ro-dynamic-mod.c
+++ /dev/null
@@ -1,19 +0,0 @@
-/* Test case for DSO with readonly dynamic section.
- Copyright (C) 2021 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <https://www.gnu.org/licenses/>. */
-
-int foo = -1;
diff --git a/elf/tst-ro-dynamic-mod.map b/elf/tst-ro-dynamic-mod.map
deleted file mode 100644
index 2fe4a2998c..0000000000
--- a/elf/tst-ro-dynamic-mod.map
+++ /dev/null
@@ -1,16 +0,0 @@
-SECTIONS
-{
- . = SIZEOF_HEADERS;
- .dynamic : { *(.dynamic) } :text :dynamic
- .rodata : { *(.data*) *(.bss*) } :text
- /DISCARD/ : {
- *(.note.gnu.property)
- }
- .note : { *(.note.*) } :text :note
-}
-PHDRS
-{
- text PT_LOAD FLAGS(5) FILEHDR PHDRS;
- dynamic PT_DYNAMIC FLAGS(4);
- note PT_NOTE FLAGS(4);
-}
diff --git a/elf/tst-ro-dynamic.c b/elf/tst-ro-dynamic.c
deleted file mode 100644
index 3a18f8789a..0000000000
--- a/elf/tst-ro-dynamic.c
+++ /dev/null
@@ -1,31 +0,0 @@
-/* Test case for DSO with readonly dynamic section.
- Copyright (C) 2021 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <https://www.gnu.org/licenses/>. */
-
-#include <support/check.h>
-#include <support/test-driver.h>
-
-extern int foo;
-
-static int
-do_test (void)
-{
- TEST_COMPARE (foo, -1);
- return 0;
-}
-
-#include <support/test-driver.c>
diff --git a/include/link.h b/include/link.h
index 484ee6cb1b..7b8250db36 100644
--- a/include/link.h
+++ b/include/link.h
@@ -205,7 +205,6 @@ struct link_map
unsigned int l_free_initfini:1; /* Nonzero if l_initfini can be
freed, ie. not allocated with
the dummy malloc in ld.so. */
- unsigned int l_ld_readonly:1; /* Nonzero if dynamic section is readonly. */
/* NODELETE status of the map. Only valid for maps of type
lt_loaded. Lazy binding sets l_nodelete_active directly,
@@ -343,8 +342,6 @@ struct link_map
unsigned long long int l_serial;
};
-#include <dl-relocate-ld.h>
-
/* Information used by audit modules. For most link maps, this data
immediate follows the link map in memory. For the dynamic linker,
it is allocated separately. See link_map_audit_state in
diff --git a/sysdeps/generic/dl-relocate-ld.h b/sysdeps/generic/dl-relocate-ld.h
deleted file mode 100644
index 5fae206db9..0000000000
--- a/sysdeps/generic/dl-relocate-ld.h
+++ /dev/null
@@ -1,32 +0,0 @@
-/* Check if dynamic section should be relocated. Generic version.
- Copyright (C) 2021 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <https://www.gnu.org/licenses/>. */
-
-#ifndef _DL_RELOCATE_LD_H
-#define _DL_RELOCATE_LD_H
-
-/* Return true if dynamic section in the shared library L should be
- relocated. */
-
-static inline bool
-dl_relocate_ld (const struct link_map *l)
-{
- /* Don't relocate dynamic section if it is readonly */
- return !l->l_ld_readonly;
-}
-
-#endif /* _DL_RELOCATE_LD_H */
diff --git a/sysdeps/generic/ldsodefs.h b/sysdeps/generic/ldsodefs.h
index 9ec1511bb0..637dfcc1e5 100644
--- a/sysdeps/generic/ldsodefs.h
+++ b/sysdeps/generic/ldsodefs.h
@@ -75,8 +75,11 @@ __BEGIN_DECLS
have to be accessed via the D_PTR macro. The macro is needed since for
most architectures the entry is already relocated - but for some not
and we need to relocate at access time. */
-#define D_PTR(map, i) \
- ((map)->i->d_un.d_ptr + (dl_relocate_ld (map) ? 0 : (map)->l_addr))
+#ifdef DL_RO_DYN_SECTION
+# define D_PTR(map, i) ((map)->i->d_un.d_ptr + (map)->l_addr)
+#else
+# define D_PTR(map, i) (map)->i->d_un.d_ptr
+#endif
/* Result of the lookup functions and how to retrieve the base address. */
typedef struct link_map *lookup_t;
diff --git a/sysdeps/mips/dl-relocate-ld.h b/sysdeps/mips/dl-relocate-ld.h
deleted file mode 100644
index 0c18d9a567..0000000000
--- a/sysdeps/mips/dl-relocate-ld.h
+++ /dev/null
@@ -1,32 +0,0 @@
-/* Check if dynamic section should be relocated. MIPS version.
- Copyright (C) 2021 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <https://www.gnu.org/licenses/>. */
-
-#ifndef _DL_RELOCATE_LD_H
-#define _DL_RELOCATE_LD_H
-
-/* Return true if dynamic section in the shared library L should be
- relocated. */
-
-static inline bool
-dl_relocate_ld (const struct link_map *l)
-{
- /* Never relocate dynamic section. */
- return false;
-}
-
-#endif /* _DL_RELOCATE_LD_H */
diff --git a/sysdeps/mips/ldsodefs.h b/sysdeps/mips/ldsodefs.h
index 36fd09a8bd..4db7c60e38 100644
--- a/sysdeps/mips/ldsodefs.h
+++ b/sysdeps/mips/ldsodefs.h
@@ -75,6 +75,10 @@ struct La_mips_64_retval;
struct La_mips_64_retval *, \
const char *);
+/* The MIPS ABI specifies that the dynamic section has to be read-only. */
+
+#define DL_RO_DYN_SECTION 1
+
#include_next <ldsodefs.h>
/* The 64-bit MIPS ELF ABI uses an unusual reloc format. Each
diff --git a/sysdeps/riscv/dl-relocate-ld.h b/sysdeps/riscv/dl-relocate-ld.h
deleted file mode 100644
index 10327454b1..0000000000
--- a/sysdeps/riscv/dl-relocate-ld.h
+++ /dev/null
@@ -1,32 +0,0 @@
-/* Check if dynamic section should be relocated. RISC-V version.
- Copyright (C) 2021 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <https://www.gnu.org/licenses/>. */
-
-#ifndef _DL_RELOCATE_LD_H
-#define _DL_RELOCATE_LD_H
-
-/* Return true if dynamic section in the shared library L should be
- relocated. */
-
-static inline bool
-dl_relocate_ld (const struct link_map *l)
-{
- /* Never relocate dynamic section for ABI compatibility. */
- return false;
-}
-
-#endif /* _DL_RELOCATE_LD_H */
diff --git a/sysdeps/riscv/ldsodefs.h b/sysdeps/riscv/ldsodefs.h
index 8947ffe4b5..0c696714a7 100644
--- a/sysdeps/riscv/ldsodefs.h
+++ b/sysdeps/riscv/ldsodefs.h
@@ -38,6 +38,11 @@ struct La_riscv_retval;
struct La_riscv_retval *, \
const char *);
+/* Although the RISC-V ABI does not specify that the dynamic section has
+ to be read-only, it needs to be kept for ABI compatibility. */
+
+#define DL_RO_DYN_SECTION 1
+
#include_next <ldsodefs.h>
#endif
--
2.31.1

View File

@ -1,4 +1,4 @@
%define glibcsrcdir glibc-2.34.9000-195-ge59ced2384
%define glibcsrcdir glibc-2.34.9000-212-ge037274c8e
%define glibcversion 2.34.9000
# Pre-release tarballs are pulled in from git using a command that is
# effectively:
@ -151,7 +151,7 @@ end \
Summary: The GNU libc libraries
Name: glibc
Version: %{glibcversion}
Release: 14%{?dist}
Release: 15%{?dist}
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
# libraries.
@ -229,7 +229,6 @@ Patch23: glibc-python3.patch
Patch29: glibc-fedora-nsswitch.patch
Patch30: glibc-deprecated-selinux-makedb.patch
Patch31: glibc-deprecated-selinux-nscd.patch
Patch32: glibc-ld-readonly-revert.patch
##############################################################################
# Continued list of core "glibc" package information:
@ -2261,6 +2260,29 @@ fi
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
%changelog
* Wed Oct 20 2021 Carlos O'Donell <carlos@redhat.com> - 2.34.9000-15
- Remove glibc-ld-readonly-revert.patch.
- Auto-sync with upstream branch master,
commit e037274c8ec86ca9d491331984b34f30701b23cf:
- stdlib: Fix tst-canon-bz26341 when the glibc build current working
directory is itself using symlinks.
- powerpc: Remove backtrace implementation
- Correct access attribute on memfrob (bug 28475)
- debug: Add tests for _FORTIFY_SOURCE=3
- Make sure that the fortified function conditionals are constant
- Don't add access size hints to fortifiable functions
- glibcextract.py: Place un-assemblable @@@ in a comment
- nss: Unnest nested function add_key
- ld.so: Initialize bootstrap_map.l_ld_readonly [BZ #28340]
- timex: Use 64-bit fields on 32-bit TIMESIZE=64 systems (BZ #28469)
- manual: Update _TIME_BITS to clarify it's user defined
- nptl: Fix tst-cancel7 and tst-cancelx7 pidfile race
- elf: Fix elf_get_dynamic_info() for bootstrap
- hurd if_index: Explicitly use AF_INET for if index discovery
- hurd: Fix intr-msg parameter/stack kludge
- x86-64: Add test-vector-abi.h/test-vector-abi-sincos.h
- elf: Fix dynamic-link.h usage on rtld.c
* Thu Oct 14 2021 Arjun Shankar <arjun@redhat.com> - 2.34.9000-14
- Adjust glibc-ld-readonly-revert.patch.
- Auto-sync with upstream branch master,

View File

@ -1 +1 @@
SHA512 (glibc-2.34.9000-195-ge59ced2384.tar.xz) = 6e9cb06a5c0667ded5efcfb214186fb4b66edefef76500e0946503fc0253647d7ab271e04375a32990ada2c885cd0534f4fc6edec0257692d6832ade2e9f2d1f
SHA512 (glibc-2.34.9000-212-ge037274c8e.tar.xz) = 82711ba512c5bdef272a29a8ab406679801050b5eb3feb305ad54de3c758d7a26867ab757f2ecab48b40a095bdc2d275c2c18a37b85326ac9a0f71c51b3e35b0