2.9.90-21
This commit is contained in:
parent
93a968fde9
commit
8b0aa33716
@ -1,2 +1,2 @@
|
||||
glibc-20090424T0747.tar.bz2
|
||||
glibc-fedora-20090424T0747.tar.bz2
|
||||
glibc-20090424T1908.tar.bz2
|
||||
glibc-fedora-20090424T1908.tar.bz2
|
||||
|
@ -2090,3 +2090,27 @@
|
||||
|
||||
cfi_startproc;
|
||||
PSEUDO_END (BP_SYM (__clone))
|
||||
--- libc/fedora/build-locale-archive.c 24 May 2007 10:33:02 -0000 1.1.2.4
|
||||
+++ libc/fedora/build-locale-archive.c 24 Apr 2009 20:06:55 -0000
|
||||
@@ -112,15 +112,16 @@ open_tmpl_archive (struct locarhandle *a
|
||||
error (EXIT_FAILURE, errno, "cannot read archive header");
|
||||
|
||||
ah->fd = fd;
|
||||
- ah->len = (head.sumhash_offset
|
||||
- + head.sumhash_size * sizeof (struct sumhashent));
|
||||
- if (ah->len > st.st_size)
|
||||
+ ah->mmaped = (head.sumhash_offset
|
||||
+ + head.sumhash_size * sizeof (struct sumhashent));
|
||||
+ if (ah->mmaped > st.st_size)
|
||||
error (EXIT_FAILURE, 0, "locale archite template file truncated");
|
||||
- ah->len = st.st_size;
|
||||
+ ah->mmaped = st.st_size;
|
||||
+ ah->reserved = st.st_size;
|
||||
|
||||
/* Now we know how large the administrative information part is.
|
||||
Map all of it. */
|
||||
- ah->addr = mmap64 (NULL, ah->len, PROT_READ, MAP_SHARED, fd, 0);
|
||||
+ ah->addr = mmap64 (NULL, ah->mmaped, PROT_READ, MAP_SHARED, fd, 0);
|
||||
if (ah->addr == MAP_FAILED)
|
||||
error (EXIT_FAILURE, errno, "cannot map archive header");
|
||||
}
|
||||
|
12
glibc.spec
12
glibc.spec
@ -1,6 +1,6 @@
|
||||
%define glibcdate 20090424T0747
|
||||
%define glibcdate 20090424T1908
|
||||
%define glibcname glibc
|
||||
%define glibcsrcdir glibc-20090424T0747
|
||||
%define glibcsrcdir glibc-20090424T1908
|
||||
%define glibc_release_tarballs 0
|
||||
%define run_glibc_tests 1
|
||||
%define auxarches i686 athlon sparcv9v sparc64v alphaev6
|
||||
@ -23,7 +23,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: 2.9.90
|
||||
Release: 20
|
||||
Release: 21
|
||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||
# Things that are linked directly into dynamically linked programs
|
||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||
@ -1013,6 +1013,12 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Apr 24 2009 Jakub Jelinek <jakub@redhat.com> 2.9.90-21
|
||||
- update from trunk
|
||||
- fix localedef
|
||||
- fix SHIFT_JIS iconv EILSEQ handling (#497267)
|
||||
- misc fixes (BZ#10093, BZ#10100)
|
||||
|
||||
* Fri Apr 24 2009 Jakub Jelinek <jakub@redhat.com> 2.9.90-20
|
||||
- update from trunk
|
||||
- fix p{read,write}v{,64} (#497429, #497434)
|
||||
|
@ -16,3 +16,4 @@ glibc-2_9_90-17:F-11:glibc-2.9.90-17.src.rpm:1239814311
|
||||
glibc-2_9_90-18:F-11:glibc-2.9.90-18.src.rpm:1239866900
|
||||
glibc-2_9_90-19:F-11:glibc-2.9.90-19.src.rpm:1239900585
|
||||
glibc-2_9_90-20:F-11:glibc-2.9.90-20.src.rpm:1240561264
|
||||
glibc-2_9_90-21:F-11:glibc-2.9.90-21.src.rpm:1240601486
|
||||
|
Loading…
Reference in New Issue
Block a user