2.10.90-14

This commit is contained in:
Andreas Schwab 2009-08-17 13:52:40 +00:00
parent 713def3ded
commit 860b0b0150
5 changed files with 137 additions and 132 deletions

View File

@ -1,2 +1,2 @@
glibc-2.10-271-gefa0569-fedora.tar.bz2
glibc-2.10-271-gefa0569.tar.bz2
glibc-2.10-277-g677760a-fedora.tar.bz2
glibc-2.10-277-g677760a.tar.bz2

View File

@ -1,6 +1,6 @@
--- glibc-2.10-271-gefa0569/ChangeLog
+++ glibc-2.10.90-12/ChangeLog
@@ -374,6 +374,11 @@
--- glibc-2.10-277-g677760a/ChangeLog
+++ glibc-2.10.90-13/ChangeLog
@@ -390,6 +390,11 @@
* sysdeps/generic/ldsodefs.h (struct rtld_global): The map element in
the unique symbol hash table should not be const.
@ -12,7 +12,7 @@
2009-07-21 Ulrich Drepper <drepper@redhat.com>
* sysdeps/x86_64/multiarch/strstr.c: Minor cleanups. Remove
@@ -639,6 +644,16 @@
@@ -655,6 +660,16 @@
out common code into new function get_common_indeces. Determine
extended family and model for Intel processors.
@ -29,7 +29,7 @@
2009-06-26 Ulrich Drepper <drepper@redhat.com>
* resolv/resolv.h: Define RES_SNGLKUPREOP.
@@ -9037,6 +9052,13 @@
@@ -9053,6 +9068,13 @@
* include/sys/cdefs.h: Redefine __nonnull so that test for
incorrect parameters in the libc code itself are not omitted.
@ -43,7 +43,7 @@
2007-05-09 Jakub Jelinek <jakub@redhat.com>
* sysdeps/ia64/fpu/fraiseexcpt.c (feraiseexcept): Don't raise overflow
@@ -9332,6 +9354,10 @@
@@ -9348,6 +9370,10 @@
[BZ #4368]
* stdlib/stdlib.h: Remove obsolete part of comment for realpath.
@ -54,7 +54,7 @@
2007-04-16 Ulrich Drepper <drepper@redhat.com>
[BZ #4364]
@@ -10589,6 +10615,15 @@
@@ -10605,6 +10631,15 @@
separators also if no non-zero digits found.
* stdlib/Makefile (tests): Add tst-strtod3.
@ -70,8 +70,8 @@
2006-12-09 Ulrich Drepper <drepper@redhat.com>
[BZ #3632]
--- glibc-2.10-271-gefa0569/ChangeLog.15
+++ glibc-2.10.90-12/ChangeLog.15
--- glibc-2.10-277-g677760a/ChangeLog.15
+++ glibc-2.10.90-13/ChangeLog.15
@@ -477,6 +477,14 @@
2004-11-26 Jakub Jelinek <jakub@redhat.com>
@ -137,8 +137,8 @@
2004-08-30 Roland McGrath <roland@frob.com>
* scripts/extract-abilist.awk: If `lastversion' variable defined, omit
--- glibc-2.10-271-gefa0569/ChangeLog.16
+++ glibc-2.10.90-12/ChangeLog.16
--- glibc-2.10-277-g677760a/ChangeLog.16
+++ glibc-2.10.90-13/ChangeLog.16
@@ -171,6 +171,11 @@
[BZ #2611]
* stdio-common/renameat.c (renameat): Fix typo.
@ -310,8 +310,8 @@
2005-02-10 Roland McGrath <roland@redhat.com>
[BZ #157]
--- glibc-2.10-271-gefa0569/Makeconfig
+++ glibc-2.10.90-12/Makeconfig
--- glibc-2.10-277-g677760a/Makeconfig
+++ glibc-2.10.90-13/Makeconfig
@@ -780,12 +780,12 @@ endif
# The assembler can generate debug information too.
ifndef ASFLAGS
@ -328,8 +328,8 @@
ifndef BUILD_CC
BUILD_CC = $(CC)
--- glibc-2.10-271-gefa0569/csu/Makefile
+++ glibc-2.10.90-12/csu/Makefile
--- glibc-2.10-277-g677760a/csu/Makefile
+++ glibc-2.10.90-13/csu/Makefile
@@ -93,7 +93,8 @@ omit-deps += $(crtstuff)
$(crtstuff:%=$(objpfx)%.o): %.o: %.S $(objpfx)defs.h
$(compile.S) -g0 $(ASFLAGS-.os) -o $@
@ -340,8 +340,8 @@
vpath initfini.c $(sysdirs)
--- glibc-2.10-271-gefa0569/csu/elf-init.c
+++ glibc-2.10.90-12/csu/elf-init.c
--- glibc-2.10-277-g677760a/csu/elf-init.c
+++ glibc-2.10.90-13/csu/elf-init.c
@@ -63,6 +63,23 @@ extern void (*__init_array_end []) (int, char **, char **)
extern void (*__fini_array_start []) (void) attribute_hidden;
extern void (*__fini_array_end []) (void) attribute_hidden;
@ -366,8 +366,8 @@
/* These function symbols are provided for the .init/.fini section entry
points automagically by the linker. */
--- glibc-2.10-271-gefa0569/debug/tst-chk1.c
+++ glibc-2.10.90-12/debug/tst-chk1.c
--- glibc-2.10-277-g677760a/debug/tst-chk1.c
+++ glibc-2.10.90-13/debug/tst-chk1.c
@@ -17,6 +17,9 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@ -396,8 +396,8 @@
# define O 0
# else
# define O 1
--- glibc-2.10-271-gefa0569/elf/ldconfig.c
+++ glibc-2.10.90-12/elf/ldconfig.c
--- glibc-2.10-277-g677760a/elf/ldconfig.c
+++ glibc-2.10.90-13/elf/ldconfig.c
@@ -1020,17 +1020,19 @@ search_dirs (void)
@ -479,8 +479,8 @@
}
if (! opt_ignore_aux_cache)
--- glibc-2.10-271-gefa0569/elf/tst-stackguard1.c
+++ glibc-2.10.90-12/elf/tst-stackguard1.c
--- glibc-2.10-277-g677760a/elf/tst-stackguard1.c
+++ glibc-2.10.90-13/elf/tst-stackguard1.c
@@ -160,17 +160,21 @@ do_test (void)
the 16 runs, something is very wrong. */
int ndifferences = 0;
@ -505,16 +505,16 @@
{
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.10-271-gefa0569/include/bits/stdlib-ldbl.h
+++ glibc-2.10.90-12/include/bits/stdlib-ldbl.h
--- glibc-2.10-277-g677760a/include/bits/stdlib-ldbl.h
+++ glibc-2.10.90-13/include/bits/stdlib-ldbl.h
@@ -0,0 +1 @@
+#include <stdlib/bits/stdlib-ldbl.h>
--- glibc-2.10-271-gefa0569/include/bits/wchar-ldbl.h
+++ glibc-2.10.90-12/include/bits/wchar-ldbl.h
--- glibc-2.10-277-g677760a/include/bits/wchar-ldbl.h
+++ glibc-2.10.90-13/include/bits/wchar-ldbl.h
@@ -0,0 +1 @@
+#include <wcsmbs/bits/wchar-ldbl.h>
--- glibc-2.10-271-gefa0569/include/features.h
+++ glibc-2.10.90-12/include/features.h
--- glibc-2.10-277-g677760a/include/features.h
+++ glibc-2.10.90-13/include/features.h
@@ -299,8 +299,13 @@
#endif
@ -531,8 +531,8 @@
# define __USE_FORTIFY_LEVEL 2
# else
# define __USE_FORTIFY_LEVEL 1
--- glibc-2.10-271-gefa0569/intl/locale.alias
+++ glibc-2.10.90-12/intl/locale.alias
--- glibc-2.10-277-g677760a/intl/locale.alias
+++ glibc-2.10.90-13/intl/locale.alias
@@ -57,8 +57,6 @@ korean ko_KR.eucKR
korean.euc ko_KR.eucKR
ko_KR ko_KR.eucKR
@ -542,8 +542,8 @@
norwegian nb_NO.ISO-8859-1
nynorsk nn_NO.ISO-8859-1
polish pl_PL.ISO-8859-2
--- glibc-2.10-271-gefa0569/libio/stdio.h
+++ glibc-2.10.90-12/libio/stdio.h
--- glibc-2.10-277-g677760a/libio/stdio.h
+++ glibc-2.10.90-13/libio/stdio.h
@@ -145,10 +145,12 @@ typedef _G_fpos64_t fpos64_t;
extern struct _IO_FILE *stdin; /* Standard input stream. */
extern struct _IO_FILE *stdout; /* Standard output stream. */
@ -557,8 +557,8 @@
__BEGIN_NAMESPACE_STD
/* Remove file FILENAME. */
--- glibc-2.10-271-gefa0569/locale/iso-4217.def
+++ glibc-2.10.90-12/locale/iso-4217.def
--- glibc-2.10-277-g677760a/locale/iso-4217.def
+++ glibc-2.10.90-13/locale/iso-4217.def
@@ -8,6 +8,7 @@
*
* !!! The list has to be sorted !!!
@ -650,8 +650,8 @@
DEFINE_INT_CURR("PYG") /* Paraguay Guarani */
DEFINE_INT_CURR("QAR") /* Qatar Rial */
DEFINE_INT_CURR("ROL") /* Romanian Leu */
--- glibc-2.10-271-gefa0569/locale/programs/locarchive.c
+++ glibc-2.10.90-12/locale/programs/locarchive.c
--- glibc-2.10-277-g677760a/locale/programs/locarchive.c
+++ glibc-2.10.90-13/locale/programs/locarchive.c
@@ -241,9 +241,9 @@ oldlocrecentcmp (const void *a, const void *b)
/* forward decls for below */
static uint32_t add_locale (struct locarhandle *ah, const char *name,
@ -683,8 +683,8 @@
add_alias (struct locarhandle *ah, const char *alias, bool replace,
const char *oldname, uint32_t *locrec_offset_p)
{
--- glibc-2.10-271-gefa0569/localedata/Makefile
+++ glibc-2.10.90-12/localedata/Makefile
--- glibc-2.10-277-g677760a/localedata/Makefile
+++ glibc-2.10.90-13/localedata/Makefile
@@ -225,6 +225,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-locales-dir
echo -n '...'; \
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
@ -693,8 +693,8 @@
-i locales/$$input -c -f charmaps/$$charset \
$(addprefix --prefix=,$(install_root)) $$locale; \
echo ' done'; \
--- glibc-2.10-271-gefa0569/localedata/SUPPORTED
+++ glibc-2.10.90-12/localedata/SUPPORTED
--- glibc-2.10-277-g677760a/localedata/SUPPORTED
+++ glibc-2.10.90-13/localedata/SUPPORTED
@@ -84,6 +84,7 @@ cy_GB.UTF-8/UTF-8 \
cy_GB/ISO-8859-14 \
da_DK.UTF-8/UTF-8 \
@ -736,8 +736,8 @@
ta_IN/UTF-8 \
te_IN/UTF-8 \
tg_TJ.UTF-8/UTF-8 \
--- glibc-2.10-271-gefa0569/localedata/locales/cy_GB
+++ glibc-2.10.90-12/localedata/locales/cy_GB
--- glibc-2.10-277-g677760a/localedata/locales/cy_GB
+++ glibc-2.10.90-13/localedata/locales/cy_GB
@@ -248,8 +248,11 @@ mon "<U0049><U006F><U006E><U0061><U0077><U0072>";/
d_t_fmt "<U0044><U0079><U0064><U0064><U0020><U0025><U0041><U0020><U0025><U0064><U0020><U006d><U0069><U0073><U0020><U0025><U0042><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
d_fmt "<U0025><U0064><U002E><U0025><U006D><U002E><U0025><U0079>"
@ -752,8 +752,8 @@
END LC_TIME
LC_MESSAGES
--- glibc-2.10-271-gefa0569/localedata/locales/en_GB
+++ glibc-2.10.90-12/localedata/locales/en_GB
--- glibc-2.10-277-g677760a/localedata/locales/en_GB
+++ glibc-2.10.90-13/localedata/locales/en_GB
@@ -116,8 +116,8 @@ mon "<U004A><U0061><U006E><U0075><U0061><U0072><U0079>";/
d_t_fmt "<U0025><U0061><U0020><U0025><U0064><U0020><U0025><U0062><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
d_fmt "<U0025><U0064><U002F><U0025><U006D><U002F><U0025><U0079>"
@ -765,8 +765,8 @@
date_fmt "<U0025><U0061><U0020><U0025><U0062><U0020><U0025><U0065>/
<U0020><U0025><U0048><U003A><U0025><U004D><U003A><U0025><U0053><U0020>/
<U0025><U005A><U0020><U0025><U0059>"
--- glibc-2.10-271-gefa0569/localedata/locales/no_NO
+++ glibc-2.10.90-12/localedata/locales/no_NO
--- glibc-2.10-277-g677760a/localedata/locales/no_NO
+++ glibc-2.10.90-13/localedata/locales/no_NO
@@ -0,0 +1,69 @@
+escape_char /
+comment_char %
@ -837,8 +837,8 @@
+LC_ADDRESS
+copy "nb_NO"
+END LC_ADDRESS
--- glibc-2.10-271-gefa0569/localedata/locales/zh_TW
+++ glibc-2.10.90-12/localedata/locales/zh_TW
--- glibc-2.10-277-g677760a/localedata/locales/zh_TW
+++ glibc-2.10.90-13/localedata/locales/zh_TW
@@ -1,7 +1,7 @@
comment_char %
escape_char /
@ -866,8 +866,8 @@
revision "0.2"
date "2000-08-02"
%
--- glibc-2.10-271-gefa0569/malloc/mcheck.c
+++ glibc-2.10.90-12/malloc/mcheck.c
--- glibc-2.10-277-g677760a/malloc/mcheck.c
+++ glibc-2.10.90-13/malloc/mcheck.c
@@ -24,9 +24,25 @@
# include <mcheck.h>
# include <stdint.h>
@ -943,8 +943,8 @@
old_free_hook = __free_hook;
__free_hook = freehook;
--- glibc-2.10-271-gefa0569/manual/libc.texinfo
+++ glibc-2.10.90-12/manual/libc.texinfo
--- glibc-2.10-277-g677760a/manual/libc.texinfo
+++ glibc-2.10.90-13/manual/libc.texinfo
@@ -5,7 +5,7 @@
@c setchapternewpage odd
@ -954,8 +954,8 @@
@direntry
* Libc: (libc). C library.
@end direntry
--- glibc-2.10-271-gefa0569/misc/sys/cdefs.h
+++ glibc-2.10.90-12/misc/sys/cdefs.h
--- glibc-2.10-277-g677760a/misc/sys/cdefs.h
+++ glibc-2.10.90-13/misc/sys/cdefs.h
@@ -132,7 +132,10 @@
#define __bos(ptr) __builtin_object_size (ptr, __USE_FORTIFY_LEVEL > 1)
#define __bos0(ptr) __builtin_object_size (ptr, 0)
@ -999,17 +999,17 @@
# define __va_arg_pack() __builtin_va_arg_pack ()
# define __va_arg_pack_len() __builtin_va_arg_pack_len ()
#endif
--- glibc-2.10-271-gefa0569/nis/nss
+++ glibc-2.10.90-12/nis/nss
--- glibc-2.10-277-g677760a/nis/nss
+++ glibc-2.10.90-13/nis/nss
@@ -25,4 +25,4 @@
# memory with every getXXent() call. Otherwise each getXXent() call
# might result into a network communication with the server to get
# the next entry.
-#SETENT_BATCH_READ=TRUE
+SETENT_BATCH_READ=TRUE
--- glibc-2.10-271-gefa0569/nptl/ChangeLog
+++ glibc-2.10.90-12/nptl/ChangeLog
@@ -3666,6 +3666,15 @@
--- glibc-2.10-277-g677760a/nptl/ChangeLog
+++ glibc-2.10.90-13/nptl/ChangeLog
@@ -3683,6 +3683,15 @@
Use __sigfillset. Document that sigfillset does the right thing wrt
to SIGSETXID.
@ -1025,7 +1025,7 @@
2005-07-11 Jakub Jelinek <jakub@redhat.com>
[BZ #1102]
@@ -4402,6 +4411,11 @@
@@ -4419,6 +4428,11 @@
Move definition inside libpthread, libc, librt check. Provide
definition for rtld.
@ -1037,7 +1037,7 @@
2004-09-02 Ulrich Drepper <drepper@redhat.com>
* sysdeps/alpha/jmpbuf-unwind.h: Define __libc_unwind_longjmp.
@@ -6476,6 +6490,11 @@
@@ -6493,6 +6507,11 @@
* Makefile [$(build-shared) = yes] (tests): Depend on $(test-modules).
@ -1049,8 +1049,8 @@
2003-07-25 Jakub Jelinek <jakub@redhat.com>
* tst-cancel17.c (do_test): Check if aio_cancel failed.
--- glibc-2.10-271-gefa0569/nptl/Makefile
+++ glibc-2.10.90-12/nptl/Makefile
--- glibc-2.10-277-g677760a/nptl/Makefile
+++ glibc-2.10.90-13/nptl/Makefile
@@ -339,7 +339,8 @@ endif
extra-objs += $(crti-objs) $(crtn-objs)
omit-deps += crti crtn
@ -1083,8 +1083,8 @@
else
$(addprefix $(objpfx),$(tests) $(test-srcs)): $(objpfx)libpthread.a
endif
--- glibc-2.10-271-gefa0569/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.10.90-12/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
--- glibc-2.10-277-g677760a/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.10.90-13/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
@@ -187,4 +187,7 @@
/* Typed memory objects are not available. */
#define _POSIX_TYPED_MEMORY_OBJECTS -1
@ -1093,8 +1093,8 @@
+#define _XOPEN_STREAMS -1
+
#endif /* bits/posix_opt.h */
--- glibc-2.10-271-gefa0569/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.10.90-12/nptl/sysdeps/unix/sysv/linux/kernel-features.h
--- glibc-2.10-277-g677760a/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.10.90-13/nptl/sysdeps/unix/sysv/linux/kernel-features.h
@@ -0,0 +1,6 @@
+#include_next <kernel-features.h>
+
@ -1102,8 +1102,8 @@
+#ifndef __ASSUME_CLONE_THREAD_FLAGS
+# define __ASSUME_CLONE_THREAD_FLAGS 1
+#endif
--- glibc-2.10-271-gefa0569/nptl/tst-stackguard1.c
+++ glibc-2.10.90-12/nptl/tst-stackguard1.c
--- glibc-2.10-277-g677760a/nptl/tst-stackguard1.c
+++ glibc-2.10.90-13/nptl/tst-stackguard1.c
@@ -190,17 +190,21 @@ do_test (void)
the 16 runs, something is very wrong. */
int ndifferences = 0;
@ -1128,8 +1128,8 @@
{
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.10-271-gefa0569/nscd/nscd.conf
+++ glibc-2.10.90-12/nscd/nscd.conf
--- glibc-2.10-277-g677760a/nscd/nscd.conf
+++ glibc-2.10.90-13/nscd/nscd.conf
@@ -33,7 +33,7 @@
# logfile /var/log/nscd.log
# threads 4
@ -1139,8 +1139,8 @@
# stat-user somebody
debug-level 0
# reload-count 5
--- glibc-2.10-271-gefa0569/nscd/nscd.init
+++ glibc-2.10.90-12/nscd/nscd.init
--- glibc-2.10-277-g677760a/nscd/nscd.init
+++ glibc-2.10.90-13/nscd/nscd.init
@@ -9,6 +9,7 @@
# slow naming services like NIS, NIS+, LDAP, or hesiod.
# processname: /usr/sbin/nscd
@ -1197,8 +1197,8 @@
;;
*)
echo $"Usage: $0 {start|stop|status|restart|reload|condrestart}"
--- glibc-2.10-271-gefa0569/posix/Makefile
+++ glibc-2.10.90-12/posix/Makefile
--- glibc-2.10-277-g677760a/posix/Makefile
+++ glibc-2.10.90-13/posix/Makefile
@@ -301,15 +301,8 @@ $(inst_libexecdir)/getconf: $(inst_bindir)/getconf \
mv -f $@/$$spec.new $@/$$spec; \
done < $(objpfx)getconf.speclist
@ -1219,8 +1219,8 @@
+ | sed -n -e '/START_OF_STRINGS/,$${/\(POSIX_V[67]\|_XBS5\)_/{s/^[^"]*"//;s/".*$$//;p}}' \
+ > $@.new
mv -f $@.new $@
--- glibc-2.10-271-gefa0569/posix/getconf.speclist.h
+++ glibc-2.10.90-12/posix/getconf.speclist.h
--- glibc-2.10-277-g677760a/posix/getconf.speclist.h
+++ glibc-2.10.90-13/posix/getconf.speclist.h
@@ -0,0 +1,39 @@
+#include <unistd.h>
+const char *START_OF_STRINGS =
@ -1261,8 +1261,8 @@
+"XBS5_LPBIG_OFFBIG"
+#endif
+"";
--- glibc-2.10-271-gefa0569/streams/Makefile
+++ glibc-2.10.90-12/streams/Makefile
--- glibc-2.10-277-g677760a/streams/Makefile
+++ glibc-2.10.90-13/streams/Makefile
@@ -21,7 +21,7 @@
#
subdir := streams
@ -1272,8 +1272,8 @@
routines = isastream getmsg getpmsg putmsg putpmsg fattach fdetach
include ../Rules
--- glibc-2.10-271-gefa0569/sysdeps/generic/dl-cache.h
+++ glibc-2.10.90-12/sysdeps/generic/dl-cache.h
--- glibc-2.10-277-g677760a/sysdeps/generic/dl-cache.h
+++ glibc-2.10.90-13/sysdeps/generic/dl-cache.h
@@ -36,6 +36,14 @@
# define add_system_dir(dir) add_dir (dir)
#endif
@ -1289,8 +1289,8 @@
#define CACHEMAGIC "ld.so-1.7.0"
/* libc5 and glibc 2.0/2.1 use the same format. For glibc 2.2 another
--- glibc-2.10-271-gefa0569/sysdeps/i386/Makefile
+++ glibc-2.10.90-12/sysdeps/i386/Makefile
--- glibc-2.10-277-g677760a/sysdeps/i386/Makefile
+++ glibc-2.10.90-13/sysdeps/i386/Makefile
@@ -2,6 +2,8 @@
# Every i386 port in use uses gas syntax (I think).
asm-CPPFLAGS += -DGAS_SYNTAX
@ -1315,8 +1315,8 @@
endif
ifeq ($(subdir),elf)
--- glibc-2.10-271-gefa0569/sysdeps/ia64/Makefile
+++ glibc-2.10.90-12/sysdeps/ia64/Makefile
--- glibc-2.10-277-g677760a/sysdeps/ia64/Makefile
+++ glibc-2.10.90-13/sysdeps/ia64/Makefile
@@ -12,8 +12,8 @@ elide-routines.os += hp-timing
ifeq (yes,$(build-shared))
@ -1328,8 +1328,8 @@
endif
endif
--- glibc-2.10-271-gefa0569/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.10.90-12/sysdeps/ia64/ia64libgcc.S
--- glibc-2.10-277-g677760a/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.10.90-13/sysdeps/ia64/ia64libgcc.S
@@ -1,350 +0,0 @@
-/* From the Intel IA-64 Optimization Guide, choose the minimum latency
- alternative. */
@ -1681,8 +1681,8 @@
- .symver ___multi3, __multi3@GLIBC_2.2
-
-#endif
--- glibc-2.10-271-gefa0569/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.10.90-12/sysdeps/ia64/libgcc-compat.c
--- glibc-2.10-277-g677760a/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.10.90-13/sysdeps/ia64/libgcc-compat.c
@@ -0,0 +1,84 @@
+/* pre-.hidden libgcc compatibility
+ Copyright (C) 2002 Free Software Foundation, Inc.
@ -1768,8 +1768,8 @@
+symbol_version (INTUSE (__multi3), __multi3, GLIBC_2.2);
+
+#endif
--- glibc-2.10-271-gefa0569/sysdeps/powerpc/powerpc32/____longjmp_chk.S
+++ glibc-2.10.90-12/sysdeps/powerpc/powerpc32/____longjmp_chk.S
--- glibc-2.10-277-g677760a/sysdeps/powerpc/powerpc32/____longjmp_chk.S
+++ glibc-2.10.90-13/sysdeps/powerpc/powerpc32/____longjmp_chk.S
@@ -49,8 +49,16 @@
#define CHECK_SP(reg) \
cmplw reg, r1; \
@ -1787,8 +1787,8 @@
.Lok:
#include <__longjmp-common.S>
--- glibc-2.10-271-gefa0569/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.10.90-12/sysdeps/powerpc/powerpc64/Makefile
--- glibc-2.10-277-g677760a/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.10.90-13/sysdeps/powerpc/powerpc64/Makefile
@@ -30,6 +30,7 @@ ifneq ($(elf),no)
# we use -fpic instead which is much better.
CFLAGS-initfini.s += -fpic -O1
@ -1797,8 +1797,8 @@
endif
ifeq ($(subdir),elf)
--- glibc-2.10-271-gefa0569/sysdeps/powerpc/powerpc64/____longjmp_chk.S
+++ glibc-2.10.90-12/sysdeps/powerpc/powerpc64/____longjmp_chk.S
--- glibc-2.10-277-g677760a/sysdeps/powerpc/powerpc64/____longjmp_chk.S
+++ glibc-2.10.90-13/sysdeps/powerpc/powerpc64/____longjmp_chk.S
@@ -32,8 +32,16 @@
#define CHECK_SP(reg) \
cmpld reg, r1; \
@ -1816,8 +1816,8 @@
.Lok:
#include <__longjmp-common.S>
--- glibc-2.10-271-gefa0569/sysdeps/unix/nice.c
+++ glibc-2.10.90-12/sysdeps/unix/nice.c
--- glibc-2.10-277-g677760a/sysdeps/unix/nice.c
+++ glibc-2.10.90-13/sysdeps/unix/nice.c
@@ -42,7 +42,12 @@ nice (int incr)
__set_errno (save);
}
@ -1832,8 +1832,8 @@
if (result == -1)
{
if (errno == EACCES)
--- glibc-2.10-271-gefa0569/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.10.90-12/sysdeps/unix/sysv/linux/check_pf.c
--- glibc-2.10-277-g677760a/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.10.90-13/sysdeps/unix/sysv/linux/check_pf.c
@@ -27,13 +27,10 @@
#include <unistd.h>
#include <sys/socket.h>
@ -1849,8 +1849,8 @@
#ifndef IFA_F_HOMEADDRESS
# define IFA_F_HOMEADDRESS 0
--- glibc-2.10-271-gefa0569/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.10.90-12/sysdeps/unix/sysv/linux/dl-osinfo.h
--- glibc-2.10-277-g677760a/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.10.90-13/sysdeps/unix/sysv/linux/dl-osinfo.h
@@ -17,10 +17,13 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@ -1898,8 +1898,8 @@
}
else
#endif
--- glibc-2.10-271-gefa0569/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.10.90-12/sysdeps/unix/sysv/linux/futimesat.c
--- glibc-2.10-277-g677760a/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.10.90-13/sysdeps/unix/sysv/linux/futimesat.c
@@ -37,14 +37,14 @@ futimesat (fd, file, tvp)
{
int result;
@ -1942,8 +1942,8 @@
{
size_t filelen = strlen (file);
static const char procfd[] = "/proc/self/fd/%d/%s";
--- glibc-2.10-271-gefa0569/sysdeps/unix/sysv/linux/i386/clone.S
+++ glibc-2.10.90-12/sysdeps/unix/sysv/linux/i386/clone.S
--- glibc-2.10-277-g677760a/sysdeps/unix/sysv/linux/i386/clone.S
+++ glibc-2.10.90-13/sysdeps/unix/sysv/linux/i386/clone.S
@@ -120,9 +120,6 @@ L(pseudo_end):
ret
@ -1962,8 +1962,8 @@
cfi_startproc
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.10-271-gefa0569/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.10.90-12/sysdeps/unix/sysv/linux/i386/dl-cache.h
--- glibc-2.10-277-g677760a/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.10.90-13/sysdeps/unix/sysv/linux/i386/dl-cache.h
@@ -0,0 +1,59 @@
+/* Support for reading /etc/ld.so.cache files written by Linux ldconfig.
+ Copyright (C) 2004 Free Software Foundation, Inc.
@ -2024,8 +2024,8 @@
+ } while (0)
+
+#include_next <dl-cache.h>
--- glibc-2.10-271-gefa0569/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.10.90-12/sysdeps/unix/sysv/linux/ia64/dl-cache.h
--- glibc-2.10-277-g677760a/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.10.90-13/sysdeps/unix/sysv/linux/ia64/dl-cache.h
@@ -22,4 +22,31 @@
#define _dl_cache_check_flags(flags) \
((flags) == _DL_CACHE_DEFAULT_ID)
@ -2058,29 +2058,29 @@
+ } while (0)
+
#include_next <dl-cache.h>
--- glibc-2.10-271-gefa0569/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.10.90-12/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
--- glibc-2.10-277-g677760a/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.10.90-13/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
+#include <sysdeps/i386/dl-procinfo.c>
+#else
+#include <sysdeps/generic/dl-procinfo.c>
+#endif
--- glibc-2.10-271-gefa0569/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.10.90-12/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
--- glibc-2.10-277-g677760a/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.10.90-13/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
+#include <sysdeps/unix/sysv/linux/i386/dl-procinfo.h>
+#else
+#include <sysdeps/generic/dl-procinfo.h>
+#endif
--- glibc-2.10-271-gefa0569/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.10.90-12/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
--- glibc-2.10-277-g677760a/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.10.90-13/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
@@ -1 +1 @@
-s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 \2\3"_
+s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 /emul/ia32-linux\2\3"_
--- glibc-2.10-271-gefa0569/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.10.90-12/sysdeps/unix/sysv/linux/netlinkaccess.h
--- glibc-2.10-277-g677760a/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.10.90-13/sysdeps/unix/sysv/linux/netlinkaccess.h
@@ -25,6 +25,24 @@
#include <kernel-features.h>
@ -2106,8 +2106,8 @@
struct netlink_res
{
--- glibc-2.10-271-gefa0569/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.10.90-12/sysdeps/unix/sysv/linux/paths.h
--- glibc-2.10-277-g677760a/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.10.90-13/sysdeps/unix/sysv/linux/paths.h
@@ -62,7 +62,7 @@
#define _PATH_TTY "/dev/tty"
#define _PATH_UNIX "/boot/vmlinux"
@ -2117,8 +2117,8 @@
#define _PATH_WTMP "/var/log/wtmp"
/* Provide trailing slash, since mostly used for building pathnames. */
--- glibc-2.10-271-gefa0569/sysdeps/unix/sysv/linux/tcsetattr.c
+++ glibc-2.10.90-12/sysdeps/unix/sysv/linux/tcsetattr.c
--- glibc-2.10-277-g677760a/sysdeps/unix/sysv/linux/tcsetattr.c
+++ glibc-2.10.90-13/sysdeps/unix/sysv/linux/tcsetattr.c
@@ -49,6 +49,7 @@ tcsetattr (fd, optional_actions, termios_p)
{
struct __kernel_termios k_termios;
@ -2164,8 +2164,8 @@
+ return retval;
}
libc_hidden_def (tcsetattr)
--- glibc-2.10-271-gefa0569/sysdeps/unix/sysv/linux/x86_64/clone.S
+++ glibc-2.10.90-12/sysdeps/unix/sysv/linux/x86_64/clone.S
--- glibc-2.10-277-g677760a/sysdeps/unix/sysv/linux/x86_64/clone.S
+++ glibc-2.10.90-13/sysdeps/unix/sysv/linux/x86_64/clone.S
@@ -89,9 +89,6 @@ L(pseudo_end):
ret
@ -2184,8 +2184,8 @@
cfi_startproc;
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.10-271-gefa0569/timezone/zic.c
+++ glibc-2.10.90-12/timezone/zic.c
--- glibc-2.10-277-g677760a/timezone/zic.c
+++ glibc-2.10.90-13/timezone/zic.c
@@ -1921,7 +1921,7 @@ const int zonecount;
if (stdrp != NULL && stdrp->r_hiyear == 2037)
return;

View File

@ -1,4 +1,4 @@
%define glibcsrcdir glibc-2.10-271-gefa0569
%define glibcsrcdir glibc-2.10-277-g677760a
%define glibcversion 2.10.90
### glibc.spec.in follows:
%define run_glibc_tests 1
@ -24,7 +24,7 @@
Summary: The GNU libc libraries
Name: glibc
Version: %{glibcversion}
Release: 13
Release: 14
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
# Things that are linked directly into dynamically linked programs
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
@ -1026,6 +1026,10 @@ rm -f *.filelist*
%endif
%changelog
* Mon Aug 17 2009 Andreas Schwab <schwab@redhat.com> - 2.10.90-14
- Update from master.
- fix pthread_cond_signal (#516469)
* Mon Aug 10 2009 Andreas Schwab <schwab@redhat.com> - 2.10.90-13
- Update from master.
- fix rehashing of unique symbols (#515677)

View File

@ -21,3 +21,4 @@ glibc-2_10_90-10:HEAD:glibc-2.10.90-10.src.rpm:1248773458
glibc-2_10_90-11:HEAD:glibc-2.10.90-11.src.rpm:1248961080
glibc-2_10_90-12:HEAD:glibc-2.10.90-12.src.rpm:1249300698
glibc-2_10_90-13:HEAD:glibc-2.10.90-13.src.rpm:1249897909
glibc-2_10_90-14:HEAD:glibc-2.10.90-14.src.rpm:1250516718

View File

@ -1,2 +1,2 @@
86e8369c526f7d5db7d49f934809e2ae glibc-2.10-271-gefa0569-fedora.tar.bz2
2a91b24cc1d16c795b50fe8f03853765 glibc-2.10-271-gefa0569.tar.bz2
41e4a4c404fc8eece82f2f06d3d88412 glibc-2.10-277-g677760a-fedora.tar.bz2
3c2a0514ce198c7b9c47e538187bff0c glibc-2.10-277-g677760a.tar.bz2