2.12.90-20
This commit is contained in:
parent
f0a4b53705
commit
7dc6703b31
6
.gitignore
vendored
6
.gitignore
vendored
@ -1,3 +1,3 @@
|
|||||||
/glibc-2.12-216-g3540d66-fedora.tar.xz
|
/glibc-2.12-232-gdbb0472-fedora.tar.xz
|
||||||
/glibc-2.12-216-g3540d66.tar.xz
|
/glibc-2.12-232-gdbb0472.tar.xz
|
||||||
/glibc-ports-2.12-40-g3ef5824.tar.xz
|
/glibc-ports-2.12-45-g8349564.tar.xz
|
||||||
|
File diff suppressed because it is too large
Load Diff
@ -1,12 +0,0 @@
|
|||||||
diff -up glibc-2.12-192-g7c08a05/sysdeps/ieee754/ldbl-128/s_fmal.c.orig glibc-2.12-192-g7c08a05/sysdeps/ieee754/ldbl-128/s_fmal.c
|
|
||||||
--- glibc-2.12-192-g7c08a05/sysdeps/ieee754/ldbl-128/s_fmal.c.orig 2010-10-27 09:29:29.257597749 -0400
|
|
||||||
+++ glibc-2.12-192-g7c08a05/sysdeps/ieee754/ldbl-128/s_fmal.c 2010-10-27 09:29:38.897491500 -0400
|
|
||||||
@@ -176,7 +176,7 @@ __fmal (long double x, long double y, lo
|
|
||||||
u.ieee.mantissa3 |= fetestexcept (FE_INEXACT) != 0;
|
|
||||||
v.d = a1 + u.d;
|
|
||||||
/* Ensure the addition is not scheduled after fetestexcept call. */
|
|
||||||
- asm volatile ("" : "m" (v));
|
|
||||||
+ asm volatile ("" : : "m" (v));
|
|
||||||
int j = fetestexcept (FE_INEXACT) != 0;
|
|
||||||
feupdateenv (&env);
|
|
||||||
/* Ensure the following computations are performed in default rounding
|
|
46
glibc.spec
46
glibc.spec
@ -1,6 +1,6 @@
|
|||||||
%define glibcsrcdir glibc-2.12-216-g3540d66
|
%define glibcsrcdir glibc-2.12-232-gdbb0472
|
||||||
%define glibcversion 2.12.90
|
%define glibcversion 2.12.90
|
||||||
%define glibcportsdir glibc-ports-2.12-40-g3ef5824
|
%define glibcportsdir glibc-ports-2.12-45-g8349564
|
||||||
### glibc.spec.in follows:
|
### glibc.spec.in follows:
|
||||||
%define run_glibc_tests 1
|
%define run_glibc_tests 1
|
||||||
%define auxarches athlon alphaev6
|
%define auxarches athlon alphaev6
|
||||||
@ -24,7 +24,7 @@
|
|||||||
Summary: The GNU libc libraries
|
Summary: The GNU libc libraries
|
||||||
Name: glibc
|
Name: glibc
|
||||||
Version: %{glibcversion}
|
Version: %{glibcversion}
|
||||||
Release: 19.1
|
Release: 20
|
||||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||||
# Things that are linked directly into dynamically linked programs
|
# Things that are linked directly into dynamically linked programs
|
||||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||||
@ -38,8 +38,6 @@ Source1: %{?glibc_release_url}%{glibcportsdir}.tar.xz
|
|||||||
Source2: %{glibcsrcdir}-fedora.tar.xz
|
Source2: %{glibcsrcdir}-fedora.tar.xz
|
||||||
Patch0: %{name}-fedora.patch
|
Patch0: %{name}-fedora.patch
|
||||||
Patch1: %{name}-ia64-lib64.patch
|
Patch1: %{name}-ia64-lib64.patch
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=645910
|
|
||||||
Patch2: %{name}-s390.patch
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Obsoletes: glibc-profile < 2.4
|
Obsoletes: glibc-profile < 2.4
|
||||||
Provides: ldconfig
|
Provides: ldconfig
|
||||||
@ -253,7 +251,6 @@ rm -rf %{glibcportsdir}
|
|||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
# A lot of programs still misuse memcpy when they have to use
|
# A lot of programs still misuse memcpy when they have to use
|
||||||
# memmove. The memcpy implementation below is not tolerant at
|
# memmove. The memcpy implementation below is not tolerant at
|
||||||
@ -544,10 +541,12 @@ install -m 700 build-%{nptl_target_cpu}-linuxnptl/glibc_post_upgrade.%{_target_c
|
|||||||
|
|
||||||
strip -g $RPM_BUILD_ROOT%{_prefix}/%{_lib}/*.o
|
strip -g $RPM_BUILD_ROOT%{_prefix}/%{_lib}/*.o
|
||||||
|
|
||||||
|
%if 0%{?_enable_debug_packages}
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_prefix}/%{_lib}
|
mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_prefix}/%{_lib}
|
||||||
cp -a $RPM_BUILD_ROOT%{_prefix}/%{_lib}/*.a \
|
cp -a $RPM_BUILD_ROOT%{_prefix}/%{_lib}/*.a \
|
||||||
$RPM_BUILD_ROOT%{_prefix}/lib/debug%{_prefix}/%{_lib}/
|
$RPM_BUILD_ROOT%{_prefix}/lib/debug%{_prefix}/%{_lib}/
|
||||||
rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_prefix}/%{_lib}/*_p.a
|
rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_prefix}/%{_lib}/*_p.a
|
||||||
|
%endif
|
||||||
|
|
||||||
# rquota.x and rquota.h are now provided by quota
|
# rquota.x and rquota.h are now provided by quota
|
||||||
rm -f $RPM_BUILD_ROOT%{_prefix}/include/rpcsvc/rquota.[hx]
|
rm -f $RPM_BUILD_ROOT%{_prefix}/include/rpcsvc/rquota.[hx]
|
||||||
@ -868,21 +867,9 @@ mkdir -p $RPM_BUILD_ROOT/var/cache/ldconfig
|
|||||||
%pre -p <lua>
|
%pre -p <lua>
|
||||||
-- Check that the running kernel is new enough
|
-- Check that the running kernel is new enough
|
||||||
required = '%{enablekernel}'
|
required = '%{enablekernel}'
|
||||||
f = io.open("/proc/sys/kernel/osrelease")
|
rel = posix.uname("%r")
|
||||||
if f then
|
if rpm.vercmp(rel, required) < 0 then
|
||||||
rel = {}
|
error("FATAL: kernel too old", 0)
|
||||||
for v in string.gmatch(f:read(), '%%d+') do
|
|
||||||
table.insert(rel, tonumber(v))
|
|
||||||
end
|
|
||||||
i = 1
|
|
||||||
for r in string.gmatch(required, '%%d+') do
|
|
||||||
if rel[i] == nil or tonumber(r) > rel[i] then
|
|
||||||
print("FATAL: kernel too old")
|
|
||||||
os.exit(1)
|
|
||||||
end
|
|
||||||
if tonumber(r) < rel[i] then break end
|
|
||||||
i = i + 1
|
|
||||||
end
|
|
||||||
end
|
end
|
||||||
|
|
||||||
%post -p /usr/sbin/glibc_post_upgrade.%{_target_cpu}
|
%post -p /usr/sbin/glibc_post_upgrade.%{_target_cpu}
|
||||||
@ -1047,13 +1034,24 @@ rm -f *.filelist*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Nov 15 2010 Dan Horák <dan[at]danny.cz> - 2.12.90-19.1
|
* Mon Dec 13 2010 Andreas Schwab <schwab@redhat.com> - 2.12.90-20
|
||||||
- fix build on s390(x) using http://sources.redhat.com/ml/libc-hacker/2010-10/msg00009.html
|
- Update from master
|
||||||
|
- Declare wcpcpy and wcpncpy only under _GNU_SOURCE
|
||||||
|
- Fix use of restrict in wchar.h and string.h
|
||||||
|
- Fix race in qsort_r initialization (BZ#11655)
|
||||||
|
- Don't ignore zero TTL in DNS answers
|
||||||
|
- Allow aux_cache_file open()ing to fail silently even in the chroot
|
||||||
|
mode (BZ#11149)
|
||||||
|
- Fix multiple nss_compat initgroups() bugs (BZ#10085)
|
||||||
|
- Define MAP_HUGETLB and SWAP_FLAG_DISCARD
|
||||||
|
- Remove .UTF-8 suffix from locale names when it is the only supported
|
||||||
|
codeset (#657556)
|
||||||
|
- Don't ignore $ORIGIN in libraries
|
||||||
|
|
||||||
* Fri Nov 12 2010 Andreas Schwab <schwab@redhat.com> - 2.12.90-19
|
* Fri Nov 12 2010 Andreas Schwab <schwab@redhat.com> - 2.12.90-19
|
||||||
- Update from master
|
- Update from master
|
||||||
- Fix memory leak in fnmatch
|
- Fix memory leak in fnmatch
|
||||||
- Support Intel processor model 6 and model 0x2
|
- Support Intel processor model 6 and model 0x2c
|
||||||
- Fix comparison in sqrtl for IBM long double
|
- Fix comparison in sqrtl for IBM long double
|
||||||
- Fix one exit path in x86-64 SSE4.2 str{,n}casecmp (BZ#12205, #651638)
|
- Fix one exit path in x86-64 SSE4.2 str{,n}casecmp (BZ#12205, #651638)
|
||||||
- Fix warnings in __bswap_16 (BZ#12194)
|
- Fix warnings in __bswap_16 (BZ#12194)
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
5837ad99b7fd9b38835c42afb5f2e112 glibc-2.12-216-g3540d66-fedora.tar.xz
|
c571afbb5f53c9d1e9ac3e315a332e09 glibc-2.12-232-gdbb0472-fedora.tar.xz
|
||||||
d8d3964701bbab04eaeff50a5ea6f134 glibc-2.12-216-g3540d66.tar.xz
|
b7b064c5830c596a3e4127a1fc524127 glibc-2.12-232-gdbb0472.tar.xz
|
||||||
fd9c36a241babd8d6998f27fe58afcbe glibc-ports-2.12-40-g3ef5824.tar.xz
|
fc53ab6e6f026d43b1ca297ab2ee1ad8 glibc-ports-2.12-45-g8349564.tar.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user