Use vpath in crypt-glibc/Makefile to obtain the test input file

Reported by Stefan Liebler.
This commit is contained in:
Florian Weimer 2017-01-25 16:46:01 +01:00
parent 574cbae985
commit 7463f6a220
2 changed files with 4 additions and 2 deletions

View File

@ -10,7 +10,7 @@ Index: b/crypt-glibc/Makefile
===================================================================
--- /dev/null
+++ b/crypt-glibc/Makefile
@@ -0,0 +1,60 @@
@@ -0,0 +1,61 @@
+# Build libcrypt against internal cryptographic algorithms.
+# Copyright (C) 1996-2016 Free Software Foundation, Inc.
+# This file is part of the GNU C Library.
@ -41,6 +41,7 @@ Index: b/crypt-glibc/Makefile
+
+# Use the sources in the crypt subdirectory.
+vpath %.c ../crypt
+vpath %.input ../crypt
+
+libcrypt-routines := \
+ crypt-entry md5-crypt sha256-crypt sha512-crypt crypt crypt_util
@ -85,7 +86,7 @@ Index: b/crypt/sha256.c
===================================================================
--- a/crypt/sha256.c
+++ b/crypt/sha256.c
@@ -212,4 +212,4 @@ __sha256_process_bytes (const void *buff
@@ -211,4 +211,4 @@ __sha256_process_bytes (const void *buff
}
}

View File

@ -2259,6 +2259,7 @@ rm -f *.filelist*
%changelog
* Wed Jan 25 2017 Florian Weimer <fweimer@redhat.com> - 2.24.90-29
- Use vpath in crypt-glibc/Makefile to obtain the test input file.
- Auto-sync with upstream master,
commit 5653ab12b4ae15b32d41de7c56b2a4626cd0437a, fixing:
- ARM fpu_control.h for assemblers requiring VFP insn names (swbz#21047)