- Fix option rotate when one IPV6 server is enabled (#804630)
- Reenable slow/uberslow path taps slowpow/slowexp.
This commit is contained in:
parent
f7dfce46ed
commit
6d522a8eb2
23
glibc-rh804630.patch
Normal file
23
glibc-rh804630.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -rup c/resolv/res_send.c d/resolv/res_send.c
|
||||
--- c/resolv/res_send.c 2012-01-01 05:16:32.000000000 -0700
|
||||
+++ d/resolv/res_send.c 2012-03-30 12:39:30.862467628 -0600
|
||||
@@ -409,6 +409,7 @@ __libc_res_nsend(res_state statp, const
|
||||
*/
|
||||
if (EXT(statp).nsinit == 0) {
|
||||
unsigned char map[MAXNS];
|
||||
+ unsigned int ext_total_nscount;
|
||||
|
||||
memset (map, MAXNS, sizeof (map));
|
||||
for (n = 0; n < MAXNS; n++) {
|
||||
@@ -422,8 +423,9 @@ __libc_res_nsend(res_state statp, const
|
||||
}
|
||||
}
|
||||
n = statp->nscount;
|
||||
- if (statp->nscount > EXT(statp).nscount)
|
||||
- for (n = EXT(statp).nscount, ns = 0;
|
||||
+ ext_total_nscount = EXT(statp).nscount + EXT(statp).nscount6;
|
||||
+ if (statp->nscount > ext_total_nscount)
|
||||
+ for (n = ext_total_nscount, ns = 0;
|
||||
n < statp->nscount; n++) {
|
||||
while (ns < MAXNS
|
||||
&& EXT(statp).nsmap[ns] != MAXNS)
|
12
glibc.spec
12
glibc.spec
@ -28,7 +28,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||
# Things that are linked directly into dynamically linked programs
|
||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||
@ -163,6 +163,9 @@ Patch2032: %{name}-rh682500.patch
|
||||
# Upstream BZ 13761
|
||||
Patch2033: %{name}-rh788989-2.patch
|
||||
|
||||
# Upstream BZ 13027
|
||||
Patch2034: %{name}-rh804630.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Obsoletes: glibc-profile < 2.4
|
||||
Obsoletes: nss_db
|
||||
@ -405,11 +408,12 @@ rm -rf %{glibcportsdir}
|
||||
%patch2026 -p1
|
||||
%patch2027 -p1
|
||||
%patch2028 -p1
|
||||
#%patch0029 -p1
|
||||
%patch0029 -p1
|
||||
%patch2030 -p1
|
||||
%patch2031 -p1
|
||||
%patch2032 -p1
|
||||
%patch2033 -p1
|
||||
%patch2034 -p1
|
||||
|
||||
# A lot of programs still misuse memcpy when they have to use
|
||||
# memmove. The memcpy implementation below is not tolerant at
|
||||
@ -1267,6 +1271,10 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed May 23 2012 Jeff Law <law@redhat.com> - 2.15.90-2
|
||||
- Fix option rotate when one IPV6 server is enabled (#804630)
|
||||
- Reenable slow/uberslow path taps slowpow/slowexp.
|
||||
|
||||
* Wed May 23 2012 Jeff Law <law@redhat.com> - 2.15.90-1
|
||||
- Resync with upstream sources.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user