Remove downstream-only workaround patch for ppc64le
This commit is contained in:
parent
b9831c9524
commit
5683acda27
@ -1,40 +0,0 @@
|
||||
Temporary workaround until this GCC bug is fixed:
|
||||
|
||||
-mlong-double-64 should override a previous -mabi=ibmlongdouble
|
||||
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104208>
|
||||
|
||||
diff --git a/sysdeps/ieee754/ldbl-opt/Makefile b/sysdeps/ieee754/ldbl-opt/Makefile
|
||||
index 1d01846476..0e06abf9f1 100644
|
||||
--- a/sysdeps/ieee754/ldbl-opt/Makefile
|
||||
+++ b/sysdeps/ieee754/ldbl-opt/Makefile
|
||||
@@ -186,8 +186,8 @@ CFLAGS-nldbl-y0.c = -fno-builtin-y0l
|
||||
CFLAGS-nldbl-y1.c = -fno-builtin-y1l
|
||||
CFLAGS-nldbl-yn.c = -fno-builtin-ynl
|
||||
|
||||
-tests += test-narrow-macros-ldbl-64 test-nldbl-redirect \
|
||||
- test-redirection-ldbl-64
|
||||
+#tests += test-narrow-macros-ldbl-64 test-nldbl-redirect \
|
||||
+# test-redirection-ldbl-64
|
||||
CFLAGS-test-narrow-macros-ldbl-64.c += -mlong-double-64
|
||||
CFLAGS-test-nldbl-redirect.c += -mlong-double-64
|
||||
CFLAGS-test-redirection-ldbl-64.c += -mlong-double-64
|
||||
@@ -198,7 +198,7 @@ endif
|
||||
|
||||
# Tests for argp.h functions (reusing the relevant tests from argp/)
|
||||
ifeq ($(subdir),argp)
|
||||
-tests-internal += tst-nldbl-argp
|
||||
+#tests-internal += tst-nldbl-argp
|
||||
|
||||
$(objpfx)tst-nldbl-argp.c: tst-ldbl-argp.c
|
||||
cp $< $@
|
||||
@@ -209,8 +209,8 @@ endif
|
||||
# Tests for err.h and error.h functions (reusing the relevant tests from
|
||||
# misc/).
|
||||
ifeq ($(subdir), misc)
|
||||
-tests-internal += tst-nldbl-warn
|
||||
-tests-internal += tst-nldbl-error
|
||||
+#tests-internal += tst-nldbl-warn
|
||||
+#tests-internal += tst-nldbl-error
|
||||
|
||||
$(objpfx)tst-nldbl-warn.c: tst-ldbl-warn.c
|
||||
cp $< $@
|
@ -226,10 +226,6 @@ Patch23: glibc-python3.patch
|
||||
Patch30: glibc-deprecated-selinux-makedb.patch
|
||||
Patch31: glibc-localedef-handle-symlinks.patch
|
||||
|
||||
# Temporary until gcc is patched to have -mlong-double-64 override
|
||||
# -mabi=ibmlongdouble instead of conflict with it.
|
||||
Patch99: glibc-temp-ibmldbl64.patch
|
||||
|
||||
##############################################################################
|
||||
# Continued list of core "glibc" package information:
|
||||
##############################################################################
|
||||
|
Loading…
Reference in New Issue
Block a user