- Remove most of fedora-nscd patch as we no longer use the
old init files, but systemd instead. - Remove path-to-vi patch. With the usr-move changes that patch is totally unnecessary. - Remove i686-nopl patch. Gas was changed back in 2011 to avoid nopl. - Move gai-rfc1918 patch to submitted upstream status
This commit is contained in:
parent
384f5b1f91
commit
55a30785d4
@ -1,36 +0,0 @@
|
||||
From b82207b25ed05d2e31563859382036ec385fc650 Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schwab <schwab@redhat.com>
|
||||
Date: Mon, 21 Jun 2010 16:54:50 +0200
|
||||
Subject: [PATCH] Workaround assembler bug sneaking in nopl
|
||||
|
||||
* sysdeps/i386/i686/Makefile: Don't pass -mtune to assembler.
|
||||
|
||||
---
|
||||
ChangeLog | 4 ++++
|
||||
sysdeps/i386/i686/Makefile | 16 ----------------
|
||||
2 files changed, 4 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/sysdeps/i386/i686/Makefile b/sysdeps/i386/i686/Makefile
|
||||
index e6b2924..dbcf1c3 100644
|
||||
--- a/sysdeps/i386/i686/Makefile
|
||||
+++ b/sysdeps/i386/i686/Makefile
|
||||
@@ -9,19 +9,3 @@ stack-align-test-flags += -msse
|
||||
ifeq ($(subdir),string)
|
||||
sysdep_routines += cacheinfo
|
||||
endif
|
||||
-
|
||||
-ifeq (yes,$(config-asflags-i686))
|
||||
-CFLAGS-.o += -Wa,-mtune=i686
|
||||
-CFLAGS-.os += -Wa,-mtune=i686
|
||||
-CFLAGS-.op += -Wa,-mtune=i686
|
||||
-CFLAGS-.og += -Wa,-mtune=i686
|
||||
-CFLAGS-.ob += -Wa,-mtune=i686
|
||||
-CFLAGS-.oS += -Wa,-mtune=i686
|
||||
-
|
||||
-ASFLAGS-.o += -Wa,-mtune=i686
|
||||
-ASFLAGS-.os += -Wa,-mtune=i686
|
||||
-ASFLAGS-.op += -Wa,-mtune=i686
|
||||
-ASFLAGS-.og += -Wa,-mtune=i686
|
||||
-ASFLAGS-.ob += -Wa,-mtune=i686
|
||||
-ASFLAGS-.oS += -Wa,-mtune=i686
|
||||
-endif
|
@ -10,82 +10,3 @@ diff -Nrup a/nscd/nscd.conf b/nscd/nscd.conf
|
||||
# stat-user somebody
|
||||
debug-level 0
|
||||
# reload-count 5
|
||||
diff -Nrup a/nscd/nscd.init b/nscd/nscd.init
|
||||
--- a/nscd/nscd.init 2012-06-05 07:42:49.000000000 -0600
|
||||
+++ b/nscd/nscd.init 2012-06-07 12:15:21.818318670 -0600
|
||||
@@ -9,6 +9,7 @@
|
||||
# slow naming services like NIS, NIS+, LDAP, or hesiod.
|
||||
# processname: /usr/sbin/nscd
|
||||
# config: /etc/nscd.conf
|
||||
+# config: /etc/sysconfig/nscd
|
||||
#
|
||||
### BEGIN INIT INFO
|
||||
# Provides: nscd
|
||||
@@ -28,20 +29,8 @@
|
||||
# Source function library.
|
||||
. /etc/init.d/functions
|
||||
|
||||
-# nscd does not run on any kernel lower than 2.2.0 because of threading
|
||||
-# problems, so we require that in first place.
|
||||
-case $(uname -r) in
|
||||
- 2.[2-9].*)
|
||||
- # this is okay
|
||||
- ;;
|
||||
- [3-9]*)
|
||||
- # these are of course also okay
|
||||
- ;;
|
||||
- *)
|
||||
- #this is not
|
||||
- exit 1
|
||||
- ;;
|
||||
-esac
|
||||
+# Source an auxiliary options file if we have one, and pick up NSCD_OPTIONS.
|
||||
+[ -r /etc/sysconfig/nscd ] && . /etc/sysconfig/nscd
|
||||
|
||||
RETVAL=0
|
||||
prog=nscd
|
||||
@@ -50,7 +39,7 @@ start () {
|
||||
[ -d /var/run/nscd ] || mkdir /var/run/nscd
|
||||
[ -d /var/db/nscd ] || mkdir /var/db/nscd
|
||||
echo -n $"Starting $prog: "
|
||||
- daemon /usr/sbin/nscd
|
||||
+ daemon /usr/sbin/nscd $NSCD_OPTIONS
|
||||
RETVAL=$?
|
||||
echo
|
||||
[ $RETVAL -eq 0 ] && touch /var/lock/subsys/nscd
|
||||
@@ -83,11 +72,11 @@ restart() {
|
||||
# See how we were called.
|
||||
case "$1" in
|
||||
start)
|
||||
- start
|
||||
+ [ -e /var/lock/subsys/nscd ] || start
|
||||
RETVAL=$?
|
||||
;;
|
||||
stop)
|
||||
- stop
|
||||
+ [ ! -e /var/lock/subsys/nscd ] || stop
|
||||
RETVAL=$?
|
||||
;;
|
||||
status)
|
||||
@@ -99,14 +88,17 @@ case "$1" in
|
||||
RETVAL=$?
|
||||
;;
|
||||
try-restart | condrestart)
|
||||
- [ -e /var/lock/subsys/nscd ] && restart
|
||||
+ [ ! -e /var/lock/subsys/nscd ] || restart
|
||||
RETVAL=$?
|
||||
;;
|
||||
force-reload | reload)
|
||||
echo -n $"Reloading $prog: "
|
||||
- killproc /usr/sbin/nscd -HUP
|
||||
- RETVAL=$?
|
||||
- echo
|
||||
+ RETVAL=0
|
||||
+ /usr/sbin/nscd -i passwd || RETVAL=$?
|
||||
+ /usr/sbin/nscd -i group || RETVAL=$?
|
||||
+ /usr/sbin/nscd -i hosts || RETVAL=$?
|
||||
+ /usr/sbin/nscd -i services || RETVAL=$?
|
||||
+ echo
|
||||
;;
|
||||
*)
|
||||
echo $"Usage: $0 {start|stop|status|restart|reload|condrestart}"
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -Nrup a/sysdeps/unix/sysv/linux/paths.h b/sysdeps/unix/sysv/linux/paths.h
|
||||
--- a/sysdeps/unix/sysv/linux/paths.h 2012-06-05 07:42:49.000000000 -0600
|
||||
+++ b/sysdeps/unix/sysv/linux/paths.h 2012-06-07 12:15:21.831318623 -0600
|
||||
@@ -62,7 +62,7 @@
|
||||
#define _PATH_TTY "/dev/tty"
|
||||
#define _PATH_UNIX "/boot/vmlinux"
|
||||
#define _PATH_UTMP "/var/run/utmp"
|
||||
-#define _PATH_VI "/usr/bin/vi"
|
||||
+#define _PATH_VI "/bin/vi"
|
||||
#define _PATH_WTMP "/var/log/wtmp"
|
||||
|
||||
/* Provide trailing slash, since mostly used for building pathnames. */
|
22
glibc.spec
22
glibc.spec
@ -27,7 +27,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 14%{?dist}
|
||||
Release: 15%{?dist}
|
||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||
# Things that are linked directly into dynamically linked programs
|
||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||
@ -105,11 +105,9 @@ Patch0033: %{name}-fedora-elf-ORIGIN.patch
|
||||
Patch0034: %{name}-fedora-elf-init-hidden_undef.patch
|
||||
Patch0035: %{name}-fedora-elf-rh737223.patch
|
||||
Patch0036: %{name}-fedora-gai-canonical.patch
|
||||
Patch0037: %{name}-fedora-gai-rfc1918.patch
|
||||
Patch0038: %{name}-fedora-getconf.patch
|
||||
Patch0039: %{name}-fedora-getrlimit-PLT.patch
|
||||
Patch0040: %{name}-fedora-i386-tls-direct-seg-refs.patch
|
||||
Patch0041: %{name}-fedora-i686-nopl.patch
|
||||
Patch0042: %{name}-fedora-include-bits-ldbl.patch
|
||||
Patch0043: %{name}-fedora-ldd.patch
|
||||
Patch0044: %{name}-fedora-linux-tcsetattr.patch
|
||||
@ -124,7 +122,6 @@ Patch0052: %{name}-fedora-nis-rh188246.patch
|
||||
Patch0053: %{name}-fedora-nptl-linklibc.patch
|
||||
Patch0054: %{name}-fedora-nscd.patch
|
||||
Patch0055: %{name}-fedora-nss-files-overflow-fix.patch
|
||||
Patch0056: %{name}-fedora-path-vi.patch
|
||||
Patch0057: %{name}-fedora-ppc-unwind.patch
|
||||
Patch0058: %{name}-fedora-pt_chown.patch
|
||||
Patch0059: %{name}-fedora-regcomp-sw11561.patch
|
||||
@ -183,7 +180,6 @@ Patch2023: %{name}-rh827510.patch
|
||||
|
||||
Patch2024: %{name}-rh803286.patch
|
||||
|
||||
|
||||
# Upstream BZ 13761
|
||||
Patch2025: %{name}-rh788989-2.patch
|
||||
|
||||
@ -196,6 +192,9 @@ Patch2027: %{name}-rh819430.patch
|
||||
# See http://sourceware.org/ml/libc-alpha/2012-06/msg00074.html
|
||||
Patch2028: %{name}-rh767693-2.patch
|
||||
|
||||
# Upstream BZ 11438
|
||||
Patch2037: %{name}-fedora-gai-rfc1918.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Obsoletes: glibc-profile < 2.4
|
||||
Obsoletes: nss_db
|
||||
@ -454,11 +453,10 @@ package or when debugging this package.
|
||||
%patch0034 -p1
|
||||
%patch0035 -p1
|
||||
%patch0036 -p1
|
||||
%patch0037 -p1
|
||||
%patch2037 -p1
|
||||
%patch0038 -p1
|
||||
%patch0039 -p1
|
||||
%patch0040 -p1
|
||||
%patch0041 -p1
|
||||
%patch0042 -p1
|
||||
%patch0043 -p1
|
||||
%patch0044 -p1
|
||||
@ -473,7 +471,6 @@ package or when debugging this package.
|
||||
%patch0053 -p1
|
||||
%patch0054 -p1
|
||||
%patch0055 -p1
|
||||
%patch0056 -p1
|
||||
%patch0057 -p1
|
||||
%patch0058 -p1
|
||||
%patch0059 -p1
|
||||
@ -1280,6 +1277,15 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Sep 21 2012 Jeff Law <law@redhat.com> - 2.16.90-15
|
||||
- Remove most of fedora-nscd patch as we no longer use the
|
||||
old init files, but systemd instead.
|
||||
- Remove path-to-vi patch. With the usr-move changes that
|
||||
patch is totally unnecessary.
|
||||
- Remove i686-nopl patch. Gas was changed back in 2011 to
|
||||
avoid nopl.
|
||||
- Move gai-rfc1918 patch to submitted upstream status
|
||||
|
||||
* Fri Sep 21 2012 Jeff Law <law@redhat.com> - 2.16.90-14
|
||||
- Revert patch for 816647, it's blatently broken.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user