2.10.90-4

This commit is contained in:
Andreas Schwab 2009-07-20 13:24:45 +00:00
parent 2f2f29e8b7
commit 50a003794b
5 changed files with 143 additions and 133 deletions

View File

@ -1,2 +1,2 @@
glibc-2.10-131-g2fd0cd8-fedora.tar.bz2
glibc-2.10-131-g2fd0cd8.tar.bz2
glibc-2.10-181-g42e69bc-fedora.tar.bz2
glibc-2.10-181-g42e69bc.tar.bz2

View File

@ -1,6 +1,6 @@
--- glibc-2.10-131-g2fd0cd8/ChangeLog
+++ glibc-2.10.90-2/ChangeLog
@@ -21,6 +21,16 @@
--- glibc-2.10-181-g42e69bc/ChangeLog
+++ glibc-2.10.90-4/ChangeLog
@@ -222,6 +222,16 @@
out common code into new function get_common_indeces. Determine
extended family and model for Intel processors.
@ -17,7 +17,7 @@
2009-06-26 Ulrich Drepper <drepper@redhat.com>
* resolv/resolv.h: Define RES_SNGLKUPREOP.
@@ -8419,6 +8429,13 @@
@@ -8620,6 +8630,13 @@
* include/sys/cdefs.h: Redefine __nonnull so that test for
incorrect parameters in the libc code itself are not omitted.
@ -31,7 +31,7 @@
2007-05-09 Jakub Jelinek <jakub@redhat.com>
* sysdeps/ia64/fpu/fraiseexcpt.c (feraiseexcept): Don't raise overflow
@@ -8714,6 +8731,10 @@
@@ -8915,6 +8932,10 @@
[BZ #4368]
* stdlib/stdlib.h: Remove obsolete part of comment for realpath.
@ -42,7 +42,7 @@
2007-04-16 Ulrich Drepper <drepper@redhat.com>
[BZ #4364]
@@ -9971,6 +9992,15 @@
@@ -10172,6 +10193,15 @@
separators also if no non-zero digits found.
* stdlib/Makefile (tests): Add tst-strtod3.
@ -58,8 +58,8 @@
2006-12-09 Ulrich Drepper <drepper@redhat.com>
[BZ #3632]
--- glibc-2.10-131-g2fd0cd8/ChangeLog.15
+++ glibc-2.10.90-2/ChangeLog.15
--- glibc-2.10-181-g42e69bc/ChangeLog.15
+++ glibc-2.10.90-4/ChangeLog.15
@@ -477,6 +477,14 @@
2004-11-26 Jakub Jelinek <jakub@redhat.com>
@ -125,8 +125,8 @@
2004-08-30 Roland McGrath <roland@frob.com>
* scripts/extract-abilist.awk: If `lastversion' variable defined, omit
--- glibc-2.10-131-g2fd0cd8/ChangeLog.16
+++ glibc-2.10.90-2/ChangeLog.16
--- glibc-2.10-181-g42e69bc/ChangeLog.16
+++ glibc-2.10.90-4/ChangeLog.16
@@ -171,6 +171,11 @@
[BZ #2611]
* stdio-common/renameat.c (renameat): Fix typo.
@ -298,8 +298,8 @@
2005-02-10 Roland McGrath <roland@redhat.com>
[BZ #157]
--- glibc-2.10-131-g2fd0cd8/csu/Makefile
+++ glibc-2.10.90-2/csu/Makefile
--- glibc-2.10-181-g42e69bc/csu/Makefile
+++ glibc-2.10.90-4/csu/Makefile
@@ -93,7 +93,8 @@ omit-deps += $(crtstuff)
$(crtstuff:%=$(objpfx)%.o): %.o: %.S $(objpfx)defs.h
$(compile.S) -g0 $(ASFLAGS-.os) -o $@
@ -310,8 +310,8 @@
vpath initfini.c $(sysdirs)
--- glibc-2.10-131-g2fd0cd8/csu/elf-init.c
+++ glibc-2.10.90-2/csu/elf-init.c
--- glibc-2.10-181-g42e69bc/csu/elf-init.c
+++ glibc-2.10.90-4/csu/elf-init.c
@@ -63,6 +63,23 @@ extern void (*__init_array_end []) (int, char **, char **)
extern void (*__fini_array_start []) (void) attribute_hidden;
extern void (*__fini_array_end []) (void) attribute_hidden;
@ -336,8 +336,8 @@
/* These function symbols are provided for the .init/.fini section entry
points automagically by the linker. */
--- glibc-2.10-131-g2fd0cd8/debug/tst-chk1.c
+++ glibc-2.10.90-2/debug/tst-chk1.c
--- glibc-2.10-181-g42e69bc/debug/tst-chk1.c
+++ glibc-2.10.90-4/debug/tst-chk1.c
@@ -17,6 +17,9 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@ -366,8 +366,8 @@
# define O 0
# else
# define O 1
--- glibc-2.10-131-g2fd0cd8/elf/ldconfig.c
+++ glibc-2.10.90-2/elf/ldconfig.c
--- glibc-2.10-181-g42e69bc/elf/ldconfig.c
+++ glibc-2.10.90-4/elf/ldconfig.c
@@ -1020,17 +1020,19 @@ search_dirs (void)
@ -449,8 +449,8 @@
}
if (! opt_ignore_aux_cache)
--- glibc-2.10-131-g2fd0cd8/elf/tst-stackguard1.c
+++ glibc-2.10.90-2/elf/tst-stackguard1.c
--- glibc-2.10-181-g42e69bc/elf/tst-stackguard1.c
+++ glibc-2.10.90-4/elf/tst-stackguard1.c
@@ -160,17 +160,21 @@ do_test (void)
the 16 runs, something is very wrong. */
int ndifferences = 0;
@ -475,16 +475,16 @@
{
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.10-131-g2fd0cd8/include/bits/stdlib-ldbl.h
+++ glibc-2.10.90-2/include/bits/stdlib-ldbl.h
--- glibc-2.10-181-g42e69bc/include/bits/stdlib-ldbl.h
+++ glibc-2.10.90-4/include/bits/stdlib-ldbl.h
@@ -0,0 +1 @@
+#include <stdlib/bits/stdlib-ldbl.h>
--- glibc-2.10-131-g2fd0cd8/include/bits/wchar-ldbl.h
+++ glibc-2.10.90-2/include/bits/wchar-ldbl.h
--- glibc-2.10-181-g42e69bc/include/bits/wchar-ldbl.h
+++ glibc-2.10.90-4/include/bits/wchar-ldbl.h
@@ -0,0 +1 @@
+#include <wcsmbs/bits/wchar-ldbl.h>
--- glibc-2.10-131-g2fd0cd8/include/features.h
+++ glibc-2.10.90-2/include/features.h
--- glibc-2.10-181-g42e69bc/include/features.h
+++ glibc-2.10.90-4/include/features.h
@@ -299,8 +299,13 @@
#endif
@ -501,8 +501,8 @@
# define __USE_FORTIFY_LEVEL 2
# else
# define __USE_FORTIFY_LEVEL 1
--- glibc-2.10-131-g2fd0cd8/intl/locale.alias
+++ glibc-2.10.90-2/intl/locale.alias
--- glibc-2.10-181-g42e69bc/intl/locale.alias
+++ glibc-2.10.90-4/intl/locale.alias
@@ -57,8 +57,6 @@ korean ko_KR.eucKR
korean.euc ko_KR.eucKR
ko_KR ko_KR.eucKR
@ -512,8 +512,8 @@
norwegian nb_NO.ISO-8859-1
nynorsk nn_NO.ISO-8859-1
polish pl_PL.ISO-8859-2
--- glibc-2.10-131-g2fd0cd8/libio/stdio.h
+++ glibc-2.10.90-2/libio/stdio.h
--- glibc-2.10-181-g42e69bc/libio/stdio.h
+++ glibc-2.10.90-4/libio/stdio.h
@@ -145,10 +145,12 @@ typedef _G_fpos64_t fpos64_t;
extern struct _IO_FILE *stdin; /* Standard input stream. */
extern struct _IO_FILE *stdout; /* Standard output stream. */
@ -527,8 +527,8 @@
__BEGIN_NAMESPACE_STD
/* Remove file FILENAME. */
--- glibc-2.10-131-g2fd0cd8/locale/iso-4217.def
+++ glibc-2.10.90-2/locale/iso-4217.def
--- glibc-2.10-181-g42e69bc/locale/iso-4217.def
+++ glibc-2.10.90-4/locale/iso-4217.def
@@ -8,6 +8,7 @@
*
* !!! The list has to be sorted !!!
@ -620,8 +620,8 @@
DEFINE_INT_CURR("PYG") /* Paraguay Guarani */
DEFINE_INT_CURR("QAR") /* Qatar Rial */
DEFINE_INT_CURR("ROL") /* Romanian Leu */
--- glibc-2.10-131-g2fd0cd8/locale/programs/locarchive.c
+++ glibc-2.10.90-2/locale/programs/locarchive.c
--- glibc-2.10-181-g42e69bc/locale/programs/locarchive.c
+++ glibc-2.10.90-4/locale/programs/locarchive.c
@@ -241,9 +241,9 @@ oldlocrecentcmp (const void *a, const void *b)
/* forward decls for below */
static uint32_t add_locale (struct locarhandle *ah, const char *name,
@ -653,8 +653,8 @@
add_alias (struct locarhandle *ah, const char *alias, bool replace,
const char *oldname, uint32_t *locrec_offset_p)
{
--- glibc-2.10-131-g2fd0cd8/localedata/Makefile
+++ glibc-2.10.90-2/localedata/Makefile
--- glibc-2.10-181-g42e69bc/localedata/Makefile
+++ glibc-2.10.90-4/localedata/Makefile
@@ -225,6 +225,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-locales-dir
echo -n '...'; \
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
@ -663,8 +663,8 @@
-i locales/$$input -c -f charmaps/$$charset \
$(addprefix --prefix=,$(install_root)) $$locale; \
echo ' done'; \
--- glibc-2.10-131-g2fd0cd8/localedata/SUPPORTED
+++ glibc-2.10.90-2/localedata/SUPPORTED
--- glibc-2.10-181-g42e69bc/localedata/SUPPORTED
+++ glibc-2.10.90-4/localedata/SUPPORTED
@@ -84,6 +84,7 @@ cy_GB.UTF-8/UTF-8 \
cy_GB/ISO-8859-14 \
da_DK.UTF-8/UTF-8 \
@ -706,8 +706,8 @@
ta_IN/UTF-8 \
te_IN/UTF-8 \
tg_TJ.UTF-8/UTF-8 \
--- glibc-2.10-131-g2fd0cd8/localedata/locales/cy_GB
+++ glibc-2.10.90-2/localedata/locales/cy_GB
--- glibc-2.10-181-g42e69bc/localedata/locales/cy_GB
+++ glibc-2.10.90-4/localedata/locales/cy_GB
@@ -248,8 +248,11 @@ mon "<U0049><U006F><U006E><U0061><U0077><U0072>";/
d_t_fmt "<U0044><U0079><U0064><U0064><U0020><U0025><U0041><U0020><U0025><U0064><U0020><U006d><U0069><U0073><U0020><U0025><U0042><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
d_fmt "<U0025><U0064><U002E><U0025><U006D><U002E><U0025><U0079>"
@ -722,8 +722,8 @@
END LC_TIME
LC_MESSAGES
--- glibc-2.10-131-g2fd0cd8/localedata/locales/en_GB
+++ glibc-2.10.90-2/localedata/locales/en_GB
--- glibc-2.10-181-g42e69bc/localedata/locales/en_GB
+++ glibc-2.10.90-4/localedata/locales/en_GB
@@ -116,8 +116,8 @@ mon "<U004A><U0061><U006E><U0075><U0061><U0072><U0079>";/
d_t_fmt "<U0025><U0061><U0020><U0025><U0064><U0020><U0025><U0062><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
d_fmt "<U0025><U0064><U002F><U0025><U006D><U002F><U0025><U0079>"
@ -735,8 +735,8 @@
date_fmt "<U0025><U0061><U0020><U0025><U0062><U0020><U0025><U0065>/
<U0020><U0025><U0048><U003A><U0025><U004D><U003A><U0025><U0053><U0020>/
<U0025><U005A><U0020><U0025><U0059>"
--- glibc-2.10-131-g2fd0cd8/localedata/locales/no_NO
+++ glibc-2.10.90-2/localedata/locales/no_NO
--- glibc-2.10-181-g42e69bc/localedata/locales/no_NO
+++ glibc-2.10.90-4/localedata/locales/no_NO
@@ -0,0 +1,69 @@
+escape_char /
+comment_char %
@ -807,8 +807,8 @@
+LC_ADDRESS
+copy "nb_NO"
+END LC_ADDRESS
--- glibc-2.10-131-g2fd0cd8/localedata/locales/zh_TW
+++ glibc-2.10.90-2/localedata/locales/zh_TW
--- glibc-2.10-181-g42e69bc/localedata/locales/zh_TW
+++ glibc-2.10.90-4/localedata/locales/zh_TW
@@ -1,7 +1,7 @@
comment_char %
escape_char /
@ -836,8 +836,8 @@
revision "0.2"
date "2000-08-02"
%
--- glibc-2.10-131-g2fd0cd8/malloc/mcheck.c
+++ glibc-2.10.90-2/malloc/mcheck.c
--- glibc-2.10-181-g42e69bc/malloc/mcheck.c
+++ glibc-2.10.90-4/malloc/mcheck.c
@@ -24,9 +24,25 @@
# include <mcheck.h>
# include <stdint.h>
@ -913,8 +913,8 @@
old_free_hook = __free_hook;
__free_hook = freehook;
--- glibc-2.10-131-g2fd0cd8/manual/libc.texinfo
+++ glibc-2.10.90-2/manual/libc.texinfo
--- glibc-2.10-181-g42e69bc/manual/libc.texinfo
+++ glibc-2.10.90-4/manual/libc.texinfo
@@ -5,7 +5,7 @@
@c setchapternewpage odd
@ -924,8 +924,8 @@
@direntry
* Libc: (libc). C library.
@end direntry
--- glibc-2.10-131-g2fd0cd8/misc/sys/cdefs.h
+++ glibc-2.10.90-2/misc/sys/cdefs.h
--- glibc-2.10-181-g42e69bc/misc/sys/cdefs.h
+++ glibc-2.10.90-4/misc/sys/cdefs.h
@@ -132,7 +132,10 @@
#define __bos(ptr) __builtin_object_size (ptr, __USE_FORTIFY_LEVEL > 1)
#define __bos0(ptr) __builtin_object_size (ptr, 0)
@ -969,17 +969,17 @@
# define __va_arg_pack() __builtin_va_arg_pack ()
# define __va_arg_pack_len() __builtin_va_arg_pack_len ()
#endif
--- glibc-2.10-131-g2fd0cd8/nis/nss
+++ glibc-2.10.90-2/nis/nss
--- glibc-2.10-181-g42e69bc/nis/nss
+++ glibc-2.10.90-4/nis/nss
@@ -25,4 +25,4 @@
# memory with every getXXent() call. Otherwise each getXXent() call
# might result into a network communication with the server to get
# the next entry.
-#SETENT_BATCH_READ=TRUE
+SETENT_BATCH_READ=TRUE
--- glibc-2.10-131-g2fd0cd8/nptl/ChangeLog
+++ glibc-2.10.90-2/nptl/ChangeLog
@@ -3524,6 +3524,15 @@
--- glibc-2.10-181-g42e69bc/nptl/ChangeLog
+++ glibc-2.10.90-4/nptl/ChangeLog
@@ -3584,6 +3584,15 @@
Use __sigfillset. Document that sigfillset does the right thing wrt
to SIGSETXID.
@ -995,7 +995,7 @@
2005-07-11 Jakub Jelinek <jakub@redhat.com>
[BZ #1102]
@@ -4260,6 +4269,11 @@
@@ -4320,6 +4329,11 @@
Move definition inside libpthread, libc, librt check. Provide
definition for rtld.
@ -1007,7 +1007,7 @@
2004-09-02 Ulrich Drepper <drepper@redhat.com>
* sysdeps/alpha/jmpbuf-unwind.h: Define __libc_unwind_longjmp.
@@ -6334,6 +6348,11 @@
@@ -6394,6 +6408,11 @@
* Makefile [$(build-shared) = yes] (tests): Depend on $(test-modules).
@ -1019,8 +1019,8 @@
2003-07-25 Jakub Jelinek <jakub@redhat.com>
* tst-cancel17.c (do_test): Check if aio_cancel failed.
--- glibc-2.10-131-g2fd0cd8/nptl/Makefile
+++ glibc-2.10.90-2/nptl/Makefile
--- glibc-2.10-181-g42e69bc/nptl/Makefile
+++ glibc-2.10.90-4/nptl/Makefile
@@ -339,7 +339,8 @@ endif
extra-objs += $(crti-objs) $(crtn-objs)
omit-deps += crti crtn
@ -1031,7 +1031,7 @@
endif
CFLAGS-flockfile.c = -D_IO_MTSAFE_IO
@@ -523,15 +524,19 @@ $(addprefix $(objpfx), \
@@ -525,15 +526,19 @@ $(addprefix $(objpfx), \
$(tests) $(xtests) $(test-srcs))): $(objpfx)libpthread.so \
$(objpfx)libpthread_nonshared.a
$(objpfx)tst-unload: $(common-objpfx)dlfcn/libdl.so
@ -1053,8 +1053,8 @@
else
$(addprefix $(objpfx),$(tests) $(test-srcs)): $(objpfx)libpthread.a
endif
--- glibc-2.10-131-g2fd0cd8/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.10.90-2/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
--- glibc-2.10-181-g42e69bc/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.10.90-4/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
@@ -187,4 +187,7 @@
/* Typed memory objects are not available. */
#define _POSIX_TYPED_MEMORY_OBJECTS -1
@ -1063,8 +1063,8 @@
+#define _XOPEN_STREAMS -1
+
#endif /* bits/posix_opt.h */
--- glibc-2.10-131-g2fd0cd8/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.10.90-2/nptl/sysdeps/unix/sysv/linux/kernel-features.h
--- glibc-2.10-181-g42e69bc/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.10.90-4/nptl/sysdeps/unix/sysv/linux/kernel-features.h
@@ -0,0 +1,6 @@
+#include_next <kernel-features.h>
+
@ -1072,8 +1072,8 @@
+#ifndef __ASSUME_CLONE_THREAD_FLAGS
+# define __ASSUME_CLONE_THREAD_FLAGS 1
+#endif
--- glibc-2.10-131-g2fd0cd8/nptl/tst-stackguard1.c
+++ glibc-2.10.90-2/nptl/tst-stackguard1.c
--- glibc-2.10-181-g42e69bc/nptl/tst-stackguard1.c
+++ glibc-2.10.90-4/nptl/tst-stackguard1.c
@@ -190,17 +190,21 @@ do_test (void)
the 16 runs, something is very wrong. */
int ndifferences = 0;
@ -1098,8 +1098,8 @@
{
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.10-131-g2fd0cd8/nscd/nscd.conf
+++ glibc-2.10.90-2/nscd/nscd.conf
--- glibc-2.10-181-g42e69bc/nscd/nscd.conf
+++ glibc-2.10.90-4/nscd/nscd.conf
@@ -33,7 +33,7 @@
# logfile /var/log/nscd.log
# threads 4
@ -1109,8 +1109,8 @@
# stat-user somebody
debug-level 0
# reload-count 5
--- glibc-2.10-131-g2fd0cd8/nscd/nscd.init
+++ glibc-2.10.90-2/nscd/nscd.init
--- glibc-2.10-181-g42e69bc/nscd/nscd.init
+++ glibc-2.10.90-4/nscd/nscd.init
@@ -9,6 +9,7 @@
# slow naming services like NIS, NIS+, LDAP, or hesiod.
# processname: /usr/sbin/nscd
@ -1167,8 +1167,8 @@
;;
*)
echo $"Usage: $0 {start|stop|status|restart|reload|condrestart}"
--- glibc-2.10-131-g2fd0cd8/posix/Makefile
+++ glibc-2.10.90-2/posix/Makefile
--- glibc-2.10-181-g42e69bc/posix/Makefile
+++ glibc-2.10.90-4/posix/Makefile
@@ -301,15 +301,8 @@ $(inst_libexecdir)/getconf: $(inst_bindir)/getconf \
mv -f $@/$$spec.new $@/$$spec; \
done < $(objpfx)getconf.speclist
@ -1189,8 +1189,8 @@
+ | sed -n -e '/START_OF_STRINGS/,$${/\(POSIX_V[67]\|_XBS5\)_/{s/^[^"]*"//;s/".*$$//;p}}' \
+ > $@.new
mv -f $@.new $@
--- glibc-2.10-131-g2fd0cd8/posix/getconf.speclist.h
+++ glibc-2.10.90-2/posix/getconf.speclist.h
--- glibc-2.10-181-g42e69bc/posix/getconf.speclist.h
+++ glibc-2.10.90-4/posix/getconf.speclist.h
@@ -0,0 +1,39 @@
+#include <unistd.h>
+const char *START_OF_STRINGS =
@ -1231,8 +1231,8 @@
+"XBS5_LPBIG_OFFBIG"
+#endif
+"";
--- glibc-2.10-131-g2fd0cd8/streams/Makefile
+++ glibc-2.10.90-2/streams/Makefile
--- glibc-2.10-181-g42e69bc/streams/Makefile
+++ glibc-2.10.90-4/streams/Makefile
@@ -21,7 +21,7 @@
#
subdir := streams
@ -1242,8 +1242,8 @@
routines = isastream getmsg getpmsg putmsg putpmsg fattach fdetach
include ../Rules
--- glibc-2.10-131-g2fd0cd8/sysdeps/generic/dl-cache.h
+++ glibc-2.10.90-2/sysdeps/generic/dl-cache.h
--- glibc-2.10-181-g42e69bc/sysdeps/generic/dl-cache.h
+++ glibc-2.10.90-4/sysdeps/generic/dl-cache.h
@@ -36,6 +36,14 @@
# define add_system_dir(dir) add_dir (dir)
#endif
@ -1259,8 +1259,8 @@
#define CACHEMAGIC "ld.so-1.7.0"
/* libc5 and glibc 2.0/2.1 use the same format. For glibc 2.2 another
--- glibc-2.10-131-g2fd0cd8/sysdeps/i386/Makefile
+++ glibc-2.10.90-2/sysdeps/i386/Makefile
--- glibc-2.10-181-g42e69bc/sysdeps/i386/Makefile
+++ glibc-2.10.90-4/sysdeps/i386/Makefile
@@ -64,6 +64,14 @@ endif
ifneq (,$(filter -mno-tls-direct-seg-refs,$(CFLAGS)))
@ -1276,8 +1276,8 @@
endif
ifeq ($(subdir),elf)
--- glibc-2.10-131-g2fd0cd8/sysdeps/ia64/Makefile
+++ glibc-2.10.90-2/sysdeps/ia64/Makefile
--- glibc-2.10-181-g42e69bc/sysdeps/ia64/Makefile
+++ glibc-2.10.90-4/sysdeps/ia64/Makefile
@@ -12,8 +12,8 @@ elide-routines.os += hp-timing
ifeq (yes,$(build-shared))
@ -1289,8 +1289,8 @@
endif
endif
--- glibc-2.10-131-g2fd0cd8/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.10.90-2/sysdeps/ia64/ia64libgcc.S
--- glibc-2.10-181-g42e69bc/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.10.90-4/sysdeps/ia64/ia64libgcc.S
@@ -1,350 +0,0 @@
-/* From the Intel IA-64 Optimization Guide, choose the minimum latency
- alternative. */
@ -1642,8 +1642,8 @@
- .symver ___multi3, __multi3@GLIBC_2.2
-
-#endif
--- glibc-2.10-131-g2fd0cd8/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.10.90-2/sysdeps/ia64/libgcc-compat.c
--- glibc-2.10-181-g42e69bc/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.10.90-4/sysdeps/ia64/libgcc-compat.c
@@ -0,0 +1,84 @@
+/* pre-.hidden libgcc compatibility
+ Copyright (C) 2002 Free Software Foundation, Inc.
@ -1729,8 +1729,8 @@
+symbol_version (INTUSE (__multi3), __multi3, GLIBC_2.2);
+
+#endif
--- glibc-2.10-131-g2fd0cd8/sysdeps/powerpc/powerpc32/____longjmp_chk.S
+++ glibc-2.10.90-2/sysdeps/powerpc/powerpc32/____longjmp_chk.S
--- glibc-2.10-181-g42e69bc/sysdeps/powerpc/powerpc32/____longjmp_chk.S
+++ glibc-2.10.90-4/sysdeps/powerpc/powerpc32/____longjmp_chk.S
@@ -49,8 +49,16 @@
#define CHECK_SP(reg) \
cmplw reg, r1; \
@ -1748,8 +1748,8 @@
.Lok:
#include <__longjmp-common.S>
--- glibc-2.10-131-g2fd0cd8/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.10.90-2/sysdeps/powerpc/powerpc64/Makefile
--- glibc-2.10-181-g42e69bc/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.10.90-4/sysdeps/powerpc/powerpc64/Makefile
@@ -30,6 +30,7 @@ ifneq ($(elf),no)
# we use -fpic instead which is much better.
CFLAGS-initfini.s += -fpic -O1
@ -1758,8 +1758,8 @@
endif
ifeq ($(subdir),elf)
--- glibc-2.10-131-g2fd0cd8/sysdeps/powerpc/powerpc64/____longjmp_chk.S
+++ glibc-2.10.90-2/sysdeps/powerpc/powerpc64/____longjmp_chk.S
--- glibc-2.10-181-g42e69bc/sysdeps/powerpc/powerpc64/____longjmp_chk.S
+++ glibc-2.10.90-4/sysdeps/powerpc/powerpc64/____longjmp_chk.S
@@ -32,8 +32,16 @@
#define CHECK_SP(reg) \
cmpld reg, r1; \
@ -1777,8 +1777,8 @@
.Lok:
#include <__longjmp-common.S>
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/nice.c
+++ glibc-2.10.90-2/sysdeps/unix/nice.c
--- glibc-2.10-181-g42e69bc/sysdeps/unix/nice.c
+++ glibc-2.10.90-4/sysdeps/unix/nice.c
@@ -42,7 +42,12 @@ nice (int incr)
__set_errno (save);
}
@ -1793,8 +1793,8 @@
if (result == -1)
{
if (errno == EACCES)
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.10.90-2/sysdeps/unix/sysv/linux/check_pf.c
--- glibc-2.10-181-g42e69bc/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.10.90-4/sysdeps/unix/sysv/linux/check_pf.c
@@ -27,13 +27,10 @@
#include <unistd.h>
#include <sys/socket.h>
@ -1810,8 +1810,8 @@
#ifndef IFA_F_HOMEADDRESS
# define IFA_F_HOMEADDRESS 0
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.10.90-2/sysdeps/unix/sysv/linux/dl-osinfo.h
--- glibc-2.10-181-g42e69bc/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.10.90-4/sysdeps/unix/sysv/linux/dl-osinfo.h
@@ -17,10 +17,13 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@ -1859,8 +1859,8 @@
}
else
#endif
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.10.90-2/sysdeps/unix/sysv/linux/futimesat.c
--- glibc-2.10-181-g42e69bc/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.10.90-4/sysdeps/unix/sysv/linux/futimesat.c
@@ -37,14 +37,14 @@ futimesat (fd, file, tvp)
{
int result;
@ -1903,8 +1903,8 @@
{
size_t filelen = strlen (file);
static const char procfd[] = "/proc/self/fd/%d/%s";
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/sysv/linux/i386/clone.S
+++ glibc-2.10.90-2/sysdeps/unix/sysv/linux/i386/clone.S
--- glibc-2.10-181-g42e69bc/sysdeps/unix/sysv/linux/i386/clone.S
+++ glibc-2.10.90-4/sysdeps/unix/sysv/linux/i386/clone.S
@@ -120,9 +120,6 @@ L(pseudo_end):
ret
@ -1923,8 +1923,8 @@
cfi_startproc
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.10.90-2/sysdeps/unix/sysv/linux/i386/dl-cache.h
--- glibc-2.10-181-g42e69bc/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.10.90-4/sysdeps/unix/sysv/linux/i386/dl-cache.h
@@ -0,0 +1,59 @@
+/* Support for reading /etc/ld.so.cache files written by Linux ldconfig.
+ Copyright (C) 2004 Free Software Foundation, Inc.
@ -1985,8 +1985,8 @@
+ } while (0)
+
+#include_next <dl-cache.h>
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.10.90-2/sysdeps/unix/sysv/linux/ia64/dl-cache.h
--- glibc-2.10-181-g42e69bc/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.10.90-4/sysdeps/unix/sysv/linux/ia64/dl-cache.h
@@ -22,4 +22,31 @@
#define _dl_cache_check_flags(flags) \
((flags) == _DL_CACHE_DEFAULT_ID)
@ -2019,29 +2019,29 @@
+ } while (0)
+
#include_next <dl-cache.h>
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.10.90-2/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
--- glibc-2.10-181-g42e69bc/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.10.90-4/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
+#include <sysdeps/i386/dl-procinfo.c>
+#else
+#include <sysdeps/generic/dl-procinfo.c>
+#endif
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.10.90-2/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
--- glibc-2.10-181-g42e69bc/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.10.90-4/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
+#include <sysdeps/unix/sysv/linux/i386/dl-procinfo.h>
+#else
+#include <sysdeps/generic/dl-procinfo.h>
+#endif
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.10.90-2/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
--- glibc-2.10-181-g42e69bc/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.10.90-4/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
@@ -1 +1 @@
-s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 \2\3"_
+s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 /emul/ia32-linux\2\3"_
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.10.90-2/sysdeps/unix/sysv/linux/netlinkaccess.h
--- glibc-2.10-181-g42e69bc/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.10.90-4/sysdeps/unix/sysv/linux/netlinkaccess.h
@@ -25,6 +25,24 @@
#include <kernel-features.h>
@ -2067,8 +2067,8 @@
struct netlink_res
{
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.10.90-2/sysdeps/unix/sysv/linux/paths.h
--- glibc-2.10-181-g42e69bc/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.10.90-4/sysdeps/unix/sysv/linux/paths.h
@@ -62,7 +62,7 @@
#define _PATH_TTY "/dev/tty"
#define _PATH_UNIX "/boot/vmlinux"
@ -2078,8 +2078,8 @@
#define _PATH_WTMP "/var/log/wtmp"
/* Provide trailing slash, since mostly used for building pathnames. */
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/sysv/linux/tcsetattr.c
+++ glibc-2.10.90-2/sysdeps/unix/sysv/linux/tcsetattr.c
--- glibc-2.10-181-g42e69bc/sysdeps/unix/sysv/linux/tcsetattr.c
+++ glibc-2.10.90-4/sysdeps/unix/sysv/linux/tcsetattr.c
@@ -49,6 +49,7 @@ tcsetattr (fd, optional_actions, termios_p)
{
struct __kernel_termios k_termios;
@ -2125,8 +2125,8 @@
+ return retval;
}
libc_hidden_def (tcsetattr)
--- glibc-2.10-131-g2fd0cd8/sysdeps/unix/sysv/linux/x86_64/clone.S
+++ glibc-2.10.90-2/sysdeps/unix/sysv/linux/x86_64/clone.S
--- glibc-2.10-181-g42e69bc/sysdeps/unix/sysv/linux/x86_64/clone.S
+++ glibc-2.10.90-4/sysdeps/unix/sysv/linux/x86_64/clone.S
@@ -89,9 +89,6 @@ L(pseudo_end):
ret
@ -2145,8 +2145,8 @@
cfi_startproc;
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.10-131-g2fd0cd8/timezone/zic.c
+++ glibc-2.10.90-2/timezone/zic.c
--- glibc-2.10-181-g42e69bc/timezone/zic.c
+++ glibc-2.10.90-4/timezone/zic.c
@@ -1921,7 +1921,7 @@ const int zonecount;
if (stdrp != NULL && stdrp->r_hiyear == 2037)
return;

View File

@ -1,8 +1,8 @@
%define glibcsrcdir glibc-2.10-131-g2fd0cd8
%define glibcsrcdir glibc-2.10-181-g42e69bc
%define glibcversion 2.10.90
### glibc.spec.in follows:
%define run_glibc_tests 1
%define auxarches i686 athlon sparcv9v sparc64v alphaev6
%define auxarches athlon sparcv9v sparc64v alphaev6
%define xenarches i686 athlon
%ifarch %{xenarches}
%define buildxen 1
@ -17,14 +17,14 @@
%define buildpower6 0
%endif
%define rtkaioarches %{ix86} x86_64 ia64 ppc ppc64 s390 s390x
%define debuginfocommonarches %{ix86} alpha alphaev6 sparc sparcv9 sparcv9v sparc64 sparc64v
%define debuginfocommonarches alpha alphaev6 sparc sparcv9 sparcv9v sparc64 sparc64v
%define multiarcharches %{ix86} x86_64
%define _unpackaged_files_terminate_build 0
Summary: The GNU libc libraries
Name: glibc
Version: %{glibcversion}
Release: 3
Release: 4
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
# Things that are linked directly into dynamically linked programs
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
@ -144,6 +144,7 @@ Provides: %{name}-headers(%{_target_cpu})
# If both -m32 and -m64 is to be supported on AMD64, x86_64 glibc-headers
# have to be installed, not i586 ones.
Obsoletes: %{name}-headers(i586)
Obsoletes: %{name}-headers(i686)
%endif
Requires(pre): kernel-headers
Requires: kernel-headers >= 2.2.1, %{name} = %{version}-%{release}
@ -203,6 +204,10 @@ Group: Development/Debug
AutoReqProv: no
%ifarch %{debuginfocommonarches}
Requires: glibc-debuginfo-common = %{version}-%{release}
%else
%ifarch %{ix86}
Obsoletes: glibc-debuginfo-common
%endif
%endif
%description debuginfo
@ -800,7 +805,7 @@ list_debug_archives()
%ifarch %{debuginfocommonarches}
%ifarch %{ix86}
%define basearch i586
%define basearch i686
%endif
%ifarch alpha alphaev6
%define basearch alpha
@ -1025,6 +1030,10 @@ rm -f *.filelist*
%endif
%changelog
* Mon Jul 20 2009 Andreas Schwab <schwab@redhat.com> - 2.10.90-4
- Update from master.
- Don't build separate i686 package.
* Wed Jul 8 2009 Andreas Schwab <schwab@redhat.com> 2.10.90-3
- Reenable setuid on pt_chown.

View File

@ -13,3 +13,4 @@ glibc-2_9_90-14:HEAD:glibc-2.9.90-14.src.rpm:1239208984
glibc-2_9_90-15:HEAD:glibc-2.9.90-15.src.rpm:1239312092
glibc-2_9_90-16:HEAD:glibc-2.9.90-16.src.rpm:1239744476
glibc-2_10_90-1:HEAD:glibc-2.10.90-1.src.rpm:1246030924
glibc-2_10_90-4:HEAD:glibc-2.10.90-4.src.rpm:1248096214

View File

@ -1,2 +1,2 @@
a8a59dbfbdb7a5a0e6ce27ce590f0f13 glibc-2.10-131-g2fd0cd8-fedora.tar.bz2
6392e85caaafd28eb49273e8cd6a14f9 glibc-2.10-131-g2fd0cd8.tar.bz2
398270f200e1ec186de374bb041c3b1e glibc-2.10-181-g42e69bc-fedora.tar.bz2
fffd37bec445c6f7599ea5796914b4b7 glibc-2.10-181-g42e69bc.tar.bz2