This commit is contained in:
Andreas Schwab 2010-04-16 12:32:47 +00:00
parent db81461ad2
commit 3dc3bab477
5 changed files with 136 additions and 137 deletions

View File

@ -1,6 +1,11 @@
--- glibc-2.11.1-4-g11c19d3/ChangeLog
+++ glibc-2.11.1-4/ChangeLog
@@ -1,3 +1,16 @@
+++ glibc-2.11.1-6/ChangeLog
@@ -1,3 +1,21 @@
+2010-03-25 Andreas Schwab <schwab@redhat.com>
+
+ * sysdeps/posix/getaddrinfo.c (gaih_inet): Reset no_data before
+ each action.
+
+2010-03-09 David S. Miller <davem@davemloft.net>
+
+ * sysdeps/sparc/sparc64/dl-machine.h (elf_machine_rela): Handling
@ -17,7 +22,7 @@
2010-01-14 Ulrich Drepper <drepper@redhat.com>
[BZ #11127]
@@ -1169,6 +1182,11 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
@@ -1169,6 +1187,11 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
* sysdeps/generic/ldsodefs.h (struct rtld_global): The map element in
the unique symbol hash table should not be const.
@ -29,7 +34,7 @@
2009-07-21 Ulrich Drepper <drepper@redhat.com>
* sysdeps/x86_64/multiarch/strstr.c: Minor cleanups. Remove
@@ -1434,6 +1452,11 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
@@ -1434,6 +1457,11 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
out common code into new function get_common_indeces. Determine
extended family and model for Intel processors.
@ -41,7 +46,7 @@
2009-06-26 Ulrich Drepper <drepper@redhat.com>
* resolv/resolv.h: Define RES_SNGLKUPREOP.
@@ -10127,6 +10150,10 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
@@ -10127,6 +10155,10 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
[BZ #4368]
* stdlib/stdlib.h: Remove obsolete part of comment for realpath.
@ -52,7 +57,7 @@
2007-04-16 Ulrich Drepper <drepper@redhat.com>
[BZ #4364]
@@ -11384,6 +11411,15 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
@@ -11384,6 +11416,15 @@ d2009-10-30 Ulrich Drepper <drepper@redhat.com>
separators also if no non-zero digits found.
* stdlib/Makefile (tests): Add tst-strtod3.
@ -69,7 +74,7 @@
[BZ #3632]
--- glibc-2.11.1-4-g11c19d3/ChangeLog.15
+++ glibc-2.11.1-4/ChangeLog.15
+++ glibc-2.11.1-6/ChangeLog.15
@@ -477,6 +477,14 @@
2004-11-26 Jakub Jelinek <jakub@redhat.com>
@ -136,7 +141,7 @@
* scripts/extract-abilist.awk: If `lastversion' variable defined, omit
--- glibc-2.11.1-4-g11c19d3/ChangeLog.16
+++ glibc-2.11.1-4/ChangeLog.16
+++ glibc-2.11.1-6/ChangeLog.16
@@ -2042,6 +2042,9 @@
(__MATHDECL_2): Use __REDIRECT_NTH instead of __REDIRECT
followed by __THROW.
@ -191,7 +196,7 @@
[BZ #1137]
--- glibc-2.11.1-4-g11c19d3/Makeconfig
+++ glibc-2.11.1-4/Makeconfig
+++ glibc-2.11.1-6/Makeconfig
@@ -780,12 +780,12 @@ endif
# The assembler can generate debug information too.
ifndef ASFLAGS
@ -209,7 +214,7 @@
ifndef BUILD_CC
BUILD_CC = $(CC)
--- glibc-2.11.1-4-g11c19d3/csu/Makefile
+++ glibc-2.11.1-4/csu/Makefile
+++ glibc-2.11.1-6/csu/Makefile
@@ -93,7 +93,8 @@ omit-deps += $(crtstuff)
$(crtstuff:%=$(objpfx)%.o): %.o: %.S $(objpfx)defs.h
$(compile.S) -g0 $(ASFLAGS-.os) -o $@
@ -221,7 +226,7 @@
vpath initfini.c $(sysdirs)
--- glibc-2.11.1-4-g11c19d3/csu/elf-init.c
+++ glibc-2.11.1-4/csu/elf-init.c
+++ glibc-2.11.1-6/csu/elf-init.c
@@ -63,6 +63,23 @@ extern void (*__init_array_end []) (int, char **, char **)
extern void (*__fini_array_start []) (void) attribute_hidden;
extern void (*__fini_array_end []) (void) attribute_hidden;
@ -247,7 +252,7 @@
/* These function symbols are provided for the .init/.fini section entry
points automagically by the linker. */
--- glibc-2.11.1-4-g11c19d3/debug/tst-chk1.c
+++ glibc-2.11.1-4/debug/tst-chk1.c
+++ glibc-2.11.1-6/debug/tst-chk1.c
@@ -17,6 +17,9 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@ -277,7 +282,7 @@
# else
# define O 1
--- glibc-2.11.1-4-g11c19d3/elf/ldconfig.c
+++ glibc-2.11.1-4/elf/ldconfig.c
+++ glibc-2.11.1-6/elf/ldconfig.c
@@ -1020,17 +1020,19 @@ search_dirs (void)
@ -360,7 +365,7 @@
if (! opt_ignore_aux_cache)
--- glibc-2.11.1-4-g11c19d3/elf/tst-stackguard1.c
+++ glibc-2.11.1-4/elf/tst-stackguard1.c
+++ glibc-2.11.1-6/elf/tst-stackguard1.c
@@ -160,17 +160,21 @@ do_test (void)
the 16 runs, something is very wrong. */
int ndifferences = 0;
@ -386,15 +391,15 @@
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.11.1-4-g11c19d3/include/bits/stdlib-ldbl.h
+++ glibc-2.11.1-4/include/bits/stdlib-ldbl.h
+++ glibc-2.11.1-6/include/bits/stdlib-ldbl.h
@@ -0,0 +1 @@
+#include <stdlib/bits/stdlib-ldbl.h>
--- glibc-2.11.1-4-g11c19d3/include/bits/wchar-ldbl.h
+++ glibc-2.11.1-4/include/bits/wchar-ldbl.h
+++ glibc-2.11.1-6/include/bits/wchar-ldbl.h
@@ -0,0 +1 @@
+#include <wcsmbs/bits/wchar-ldbl.h>
--- glibc-2.11.1-4-g11c19d3/include/features.h
+++ glibc-2.11.1-4/include/features.h
+++ glibc-2.11.1-6/include/features.h
@@ -299,8 +299,13 @@
#endif
@ -412,7 +417,7 @@
# else
# define __USE_FORTIFY_LEVEL 1
--- glibc-2.11.1-4-g11c19d3/intl/locale.alias
+++ glibc-2.11.1-4/intl/locale.alias
+++ glibc-2.11.1-6/intl/locale.alias
@@ -57,8 +57,6 @@ korean ko_KR.eucKR
korean.euc ko_KR.eucKR
ko_KR ko_KR.eucKR
@ -423,7 +428,7 @@
nynorsk nn_NO.ISO-8859-1
polish pl_PL.ISO-8859-2
--- glibc-2.11.1-4-g11c19d3/libio/stdio.h
+++ glibc-2.11.1-4/libio/stdio.h
+++ glibc-2.11.1-6/libio/stdio.h
@@ -145,10 +145,12 @@ typedef _G_fpos64_t fpos64_t;
extern struct _IO_FILE *stdin; /* Standard input stream. */
extern struct _IO_FILE *stdout; /* Standard output stream. */
@ -438,7 +443,7 @@
__BEGIN_NAMESPACE_STD
/* Remove file FILENAME. */
--- glibc-2.11.1-4-g11c19d3/locale/iso-4217.def
+++ glibc-2.11.1-4/locale/iso-4217.def
+++ glibc-2.11.1-6/locale/iso-4217.def
@@ -8,6 +8,7 @@
*
* !!! The list has to be sorted !!!
@ -531,7 +536,7 @@
DEFINE_INT_CURR("QAR") /* Qatar Rial */
DEFINE_INT_CURR("ROL") /* Romanian Leu */
--- glibc-2.11.1-4-g11c19d3/locale/programs/locarchive.c
+++ glibc-2.11.1-4/locale/programs/locarchive.c
+++ glibc-2.11.1-6/locale/programs/locarchive.c
@@ -134,7 +134,7 @@ create_archive (const char *archivefname, struct locarhandle *ah)
size_t reserved = RESERVE_MMAP_SIZE;
int xflags = 0;
@ -591,7 +596,7 @@
const char *oldname, uint32_t *locrec_offset_p)
{
--- glibc-2.11.1-4-g11c19d3/localedata/Makefile
+++ glibc-2.11.1-4/localedata/Makefile
+++ glibc-2.11.1-6/localedata/Makefile
@@ -225,6 +225,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-locales-dir
echo -n '...'; \
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
@ -601,7 +606,7 @@
$(addprefix --prefix=,$(install_root)) $$locale; \
echo ' done'; \
--- glibc-2.11.1-4-g11c19d3/localedata/SUPPORTED
+++ glibc-2.11.1-4/localedata/SUPPORTED
+++ glibc-2.11.1-6/localedata/SUPPORTED
@@ -84,6 +84,7 @@ cy_GB.UTF-8/UTF-8 \
cy_GB/ISO-8859-14 \
da_DK.UTF-8/UTF-8 \
@ -644,7 +649,7 @@
te_IN/UTF-8 \
tg_TJ.UTF-8/UTF-8 \
--- glibc-2.11.1-4-g11c19d3/localedata/locales/cy_GB
+++ glibc-2.11.1-4/localedata/locales/cy_GB
+++ glibc-2.11.1-6/localedata/locales/cy_GB
@@ -248,8 +248,11 @@ mon "<U0049><U006F><U006E><U0061><U0077><U0072>";/
d_t_fmt "<U0044><U0079><U0064><U0064><U0020><U0025><U0041><U0020><U0025><U0064><U0020><U006d><U0069><U0073><U0020><U0025><U0042><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
d_fmt "<U0025><U0064><U002E><U0025><U006D><U002E><U0025><U0079>"
@ -660,7 +665,7 @@
LC_MESSAGES
--- glibc-2.11.1-4-g11c19d3/localedata/locales/en_GB
+++ glibc-2.11.1-4/localedata/locales/en_GB
+++ glibc-2.11.1-6/localedata/locales/en_GB
@@ -116,8 +116,8 @@ mon "<U004A><U0061><U006E><U0075><U0061><U0072><U0079>";/
d_t_fmt "<U0025><U0061><U0020><U0025><U0064><U0020><U0025><U0062><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
d_fmt "<U0025><U0064><U002F><U0025><U006D><U002F><U0025><U0079>"
@ -673,7 +678,7 @@
<U0020><U0025><U0048><U003A><U0025><U004D><U003A><U0025><U0053><U0020>/
<U0025><U005A><U0020><U0025><U0059>"
--- glibc-2.11.1-4-g11c19d3/localedata/locales/no_NO
+++ glibc-2.11.1-4/localedata/locales/no_NO
+++ glibc-2.11.1-6/localedata/locales/no_NO
@@ -0,0 +1,69 @@
+escape_char /
+comment_char %
@ -745,7 +750,7 @@
+copy "nb_NO"
+END LC_ADDRESS
--- glibc-2.11.1-4-g11c19d3/localedata/locales/zh_TW
+++ glibc-2.11.1-4/localedata/locales/zh_TW
+++ glibc-2.11.1-6/localedata/locales/zh_TW
@@ -1,7 +1,7 @@
comment_char %
escape_char /
@ -774,7 +779,7 @@
date "2000-08-02"
%
--- glibc-2.11.1-4-g11c19d3/malloc/mcheck.c
+++ glibc-2.11.1-4/malloc/mcheck.c
+++ glibc-2.11.1-6/malloc/mcheck.c
@@ -24,9 +24,25 @@
# include <mcheck.h>
# include <stdint.h>
@ -851,7 +856,7 @@
old_free_hook = __free_hook;
__free_hook = freehook;
--- glibc-2.11.1-4-g11c19d3/manual/libc.texinfo
+++ glibc-2.11.1-4/manual/libc.texinfo
+++ glibc-2.11.1-6/manual/libc.texinfo
@@ -5,7 +5,7 @@
@c setchapternewpage odd
@ -862,7 +867,7 @@
* Libc: (libc). C library.
@end direntry
--- glibc-2.11.1-4-g11c19d3/misc/sys/cdefs.h
+++ glibc-2.11.1-4/misc/sys/cdefs.h
+++ glibc-2.11.1-6/misc/sys/cdefs.h
@@ -132,7 +132,10 @@
#define __bos(ptr) __builtin_object_size (ptr, __USE_FORTIFY_LEVEL > 1)
#define __bos0(ptr) __builtin_object_size (ptr, 0)
@ -907,7 +912,7 @@
# define __va_arg_pack_len() __builtin_va_arg_pack_len ()
#endif
--- glibc-2.11.1-4-g11c19d3/nis/nss
+++ glibc-2.11.1-4/nis/nss
+++ glibc-2.11.1-6/nis/nss
@@ -25,4 +25,4 @@
# memory with every getXXent() call. Otherwise each getXXent() call
# might result into a network communication with the server to get
@ -915,7 +920,7 @@
-#SETENT_BATCH_READ=TRUE
+SETENT_BATCH_READ=TRUE
--- glibc-2.11.1-4-g11c19d3/nptl/ChangeLog
+++ glibc-2.11.1-4/nptl/ChangeLog
+++ glibc-2.11.1-6/nptl/ChangeLog
@@ -3739,6 +3739,15 @@
Use __sigfillset. Document that sigfillset does the right thing wrt
to SIGSETXID.
@ -957,7 +962,7 @@
* tst-cancel17.c (do_test): Check if aio_cancel failed.
--- glibc-2.11.1-4-g11c19d3/nptl/Makefile
+++ glibc-2.11.1-4/nptl/Makefile
+++ glibc-2.11.1-6/nptl/Makefile
@@ -339,7 +339,8 @@ endif
extra-objs += $(crti-objs) $(crtn-objs)
omit-deps += crti crtn
@ -991,7 +996,7 @@
$(addprefix $(objpfx),$(tests) $(test-srcs)): $(objpfx)libpthread.a
endif
--- glibc-2.11.1-4-g11c19d3/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.11.1-4/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.11.1-6/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
@@ -189,4 +189,7 @@
/* Typed memory objects are not available. */
#define _POSIX_TYPED_MEMORY_OBJECTS -1
@ -1001,7 +1006,7 @@
+
#endif /* bits/posix_opt.h */
--- glibc-2.11.1-4-g11c19d3/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.11.1-4/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.11.1-6/nptl/sysdeps/unix/sysv/linux/kernel-features.h
@@ -0,0 +1,6 @@
+#include_next <kernel-features.h>
+
@ -1010,7 +1015,7 @@
+# define __ASSUME_CLONE_THREAD_FLAGS 1
+#endif
--- glibc-2.11.1-4-g11c19d3/nptl/tst-stackguard1.c
+++ glibc-2.11.1-4/nptl/tst-stackguard1.c
+++ glibc-2.11.1-6/nptl/tst-stackguard1.c
@@ -190,17 +190,21 @@ do_test (void)
the 16 runs, something is very wrong. */
int ndifferences = 0;
@ -1036,7 +1041,7 @@
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.11.1-4-g11c19d3/nscd/nscd.conf
+++ glibc-2.11.1-4/nscd/nscd.conf
+++ glibc-2.11.1-6/nscd/nscd.conf
@@ -33,7 +33,7 @@
# logfile /var/log/nscd.log
# threads 4
@ -1047,7 +1052,7 @@
debug-level 0
# reload-count 5
--- glibc-2.11.1-4-g11c19d3/nscd/nscd.init
+++ glibc-2.11.1-4/nscd/nscd.init
+++ glibc-2.11.1-6/nscd/nscd.init
@@ -9,6 +9,7 @@
# slow naming services like NIS, NIS+, LDAP, or hesiod.
# processname: /usr/sbin/nscd
@ -1120,7 +1125,7 @@
*)
echo $"Usage: $0 {start|stop|status|restart|reload|condrestart}"
--- glibc-2.11.1-4-g11c19d3/posix/Makefile
+++ glibc-2.11.1-4/posix/Makefile
+++ glibc-2.11.1-6/posix/Makefile
@@ -303,15 +303,8 @@ $(inst_libexecdir)/getconf: $(inst_bindir)/getconf \
mv -f $@/$$spec.new $@/$$spec; \
done < $(objpfx)getconf.speclist
@ -1142,7 +1147,7 @@
+ > $@.new
mv -f $@.new $@
--- glibc-2.11.1-4-g11c19d3/posix/getconf.speclist.h
+++ glibc-2.11.1-4/posix/getconf.speclist.h
+++ glibc-2.11.1-6/posix/getconf.speclist.h
@@ -0,0 +1,39 @@
+#include <unistd.h>
+const char *START_OF_STRINGS =
@ -1184,7 +1189,7 @@
+#endif
+"";
--- glibc-2.11.1-4-g11c19d3/streams/Makefile
+++ glibc-2.11.1-4/streams/Makefile
+++ glibc-2.11.1-6/streams/Makefile
@@ -21,7 +21,7 @@
#
subdir := streams
@ -1195,7 +1200,7 @@
include ../Rules
--- glibc-2.11.1-4-g11c19d3/sysdeps/generic/dl-cache.h
+++ glibc-2.11.1-4/sysdeps/generic/dl-cache.h
+++ glibc-2.11.1-6/sysdeps/generic/dl-cache.h
@@ -36,6 +36,14 @@
# define add_system_dir(dir) add_dir (dir)
#endif
@ -1212,7 +1217,7 @@
/* libc5 and glibc 2.0/2.1 use the same format. For glibc 2.2 another
--- glibc-2.11.1-4-g11c19d3/sysdeps/i386/Makefile
+++ glibc-2.11.1-4/sysdeps/i386/Makefile
+++ glibc-2.11.1-6/sysdeps/i386/Makefile
@@ -2,6 +2,8 @@
# Every i386 port in use uses gas syntax (I think).
asm-CPPFLAGS += -DGAS_SYNTAX
@ -1238,7 +1243,7 @@
ifeq ($(subdir),elf)
--- glibc-2.11.1-4-g11c19d3/sysdeps/ia64/Makefile
+++ glibc-2.11.1-4/sysdeps/ia64/Makefile
+++ glibc-2.11.1-6/sysdeps/ia64/Makefile
@@ -12,8 +12,8 @@ elide-routines.os += hp-timing
ifeq (yes,$(build-shared))
@ -1251,7 +1256,7 @@
endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.11.1-4/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.11.1-6/sysdeps/ia64/ia64libgcc.S
@@ -1,350 +0,0 @@
-/* From the Intel IA-64 Optimization Guide, choose the minimum latency
- alternative. */
@ -1604,7 +1609,7 @@
-
-#endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.11.1-4/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.11.1-6/sysdeps/ia64/libgcc-compat.c
@@ -0,0 +1,84 @@
+/* pre-.hidden libgcc compatibility
+ Copyright (C) 2002 Free Software Foundation, Inc.
@ -1690,8 +1695,18 @@
+symbol_version (INTUSE (__multi3), __multi3, GLIBC_2.2);
+
+#endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/posix/getaddrinfo.c
+++ glibc-2.11.1-6/sysdeps/posix/getaddrinfo.c
@@ -702,6 +702,7 @@ gaih_inet (const char *name, const struct gaih_service *service,
while (!no_more)
{
+ no_data = 0;
nss_gethostbyname4_r fct4
= __nss_lookup_function (nip, "gethostbyname4_r");
if (fct4 != NULL)
--- glibc-2.11.1-4-g11c19d3/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.11.1-4/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.11.1-6/sysdeps/powerpc/powerpc64/Makefile
@@ -30,6 +30,7 @@ ifneq ($(elf),no)
# we use -fpic instead which is much better.
CFLAGS-initfini.s += -fpic -O1
@ -1701,7 +1716,7 @@
ifeq ($(subdir),elf)
--- glibc-2.11.1-4-g11c19d3/sysdeps/sparc/sparc64/dl-machine.h
+++ glibc-2.11.1-4/sysdeps/sparc/sparc64/dl-machine.h
+++ glibc-2.11.1-6/sysdeps/sparc/sparc64/dl-machine.h
@@ -623,11 +623,13 @@ elf_machine_rela (struct link_map *map, const Elf64_Rela *reloc,
value = sym->st_value - sym_map->l_tls_offset
+ reloc->r_addend;
@ -1721,7 +1736,7 @@
break;
# endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/nice.c
+++ glibc-2.11.1-4/sysdeps/unix/nice.c
+++ glibc-2.11.1-6/sysdeps/unix/nice.c
@@ -42,7 +42,12 @@ nice (int incr)
__set_errno (save);
}
@ -1737,7 +1752,7 @@
{
if (errno == EACCES)
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/check_pf.c
@@ -27,13 +27,10 @@
#include <unistd.h>
#include <sys/socket.h>
@ -1754,7 +1769,7 @@
#ifndef IFA_F_HOMEADDRESS
# define IFA_F_HOMEADDRESS 0
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/dl-osinfo.h
@@ -17,10 +17,13 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@ -1803,7 +1818,7 @@
else
#endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/futimesat.c
@@ -37,14 +37,14 @@ futimesat (fd, file, tvp)
{
int result;
@ -1847,7 +1862,7 @@
size_t filelen = strlen (file);
if (__builtin_expect (filelen == 0, 0))
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/i386/clone.S
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/i386/clone.S
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/i386/clone.S
@@ -120,9 +120,6 @@ L(pseudo_end):
ret
@ -1867,7 +1882,7 @@
cfi_startproc
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/i386/dl-cache.h
@@ -0,0 +1,59 @@
+/* Support for reading /etc/ld.so.cache files written by Linux ldconfig.
+ Copyright (C) 2004 Free Software Foundation, Inc.
@ -1929,7 +1944,7 @@
+
+#include_next <dl-cache.h>
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/ia64/dl-cache.h
@@ -22,4 +22,31 @@
#define _dl_cache_check_flags(flags) \
((flags) == _DL_CACHE_DEFAULT_ID)
@ -1963,7 +1978,7 @@
+
#include_next <dl-cache.h>
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
+#include <sysdeps/i386/dl-procinfo.c>
@ -1971,7 +1986,7 @@
+#include <sysdeps/generic/dl-procinfo.c>
+#endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
+#include <sysdeps/unix/sysv/linux/i386/dl-procinfo.h>
@ -1979,12 +1994,12 @@
+#include <sysdeps/generic/dl-procinfo.h>
+#endif
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
@@ -1 +1 @@
-s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 \2\3"_
+s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 /emul/ia32-linux\2\3"_
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/netlinkaccess.h
@@ -25,6 +25,24 @@
#include <kernel-features.h>
@ -2011,7 +2026,7 @@
struct netlink_res
{
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/paths.h
@@ -62,7 +62,7 @@
#define _PATH_TTY "/dev/tty"
#define _PATH_UNIX "/boot/vmlinux"
@ -2021,8 +2036,60 @@
#define _PATH_WTMP "/var/log/wtmp"
/* Provide trailing slash, since mostly used for building pathnames. */
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/sparc/sparc64/msgrcv.c
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/sparc/sparc64/msgrcv.c
@@ -0,0 +1,49 @@
+/* Copyright (C) 2010 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+
+ The GNU C Library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2.1 of the License, or (at your option) any later version.
+
+ The GNU C Library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with the GNU C Library; if not, write to the Free
+ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+ 02111-1307 USA. */
+
+#include <errno.h>
+#include <sys/msg.h>
+#include <ipc_priv.h>
+
+#include <sysdep-cancel.h>
+#include <sys/syscall.h>
+
+#include <bp-checks.h>
+
+ssize_t
+__libc_msgrcv (msqid, msgp, msgsz, msgtyp, msgflg)
+ int msqid;
+ void *msgp;
+ size_t msgsz;
+ long int msgtyp;
+ int msgflg;
+{
+ if (SINGLE_THREAD_P)
+ return INLINE_SYSCALL (ipc, 6, IPCOP_msgrcv, msqid, msgsz, msgflg,
+ CHECK_N (msgp, msgsz), msgtyp);
+
+ int oldtype = LIBC_CANCEL_ASYNC ();
+
+ ssize_t result = INLINE_SYSCALL (ipc, 6, IPCOP_msgrcv, msqid, msgsz, msgflg,
+ CHECK_N (msgp, msgsz), msgtyp);
+
+ LIBC_CANCEL_RESET (oldtype);
+
+ return result;
+}
+weak_alias (__libc_msgrcv, msgrcv)
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/tcsetattr.c
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/tcsetattr.c
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/tcsetattr.c
@@ -49,6 +49,7 @@ tcsetattr (fd, optional_actions, termios_p)
{
struct __kernel_termios k_termios;
@ -2069,7 +2136,7 @@
}
libc_hidden_def (tcsetattr)
--- glibc-2.11.1-4-g11c19d3/sysdeps/unix/sysv/linux/x86_64/clone.S
+++ glibc-2.11.1-4/sysdeps/unix/sysv/linux/x86_64/clone.S
+++ glibc-2.11.1-6/sysdeps/unix/sysv/linux/x86_64/clone.S
@@ -89,9 +89,6 @@ L(pseudo_end):
ret
@ -2089,7 +2156,7 @@
cfi_startproc;
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.11.1-4-g11c19d3/timezone/zic.c
+++ glibc-2.11.1-4/timezone/zic.c
+++ glibc-2.11.1-6/timezone/zic.c
@@ -1921,7 +1921,7 @@ const int zonecount;
if (stdrp != NULL && stdrp->r_hiyear == 2037)
return;

View File

@ -1,70 +0,0 @@
commit 321029f1c35db68c9d2e15408871030a36694541
Author: Aurelien Jarno <aurelien@aurel32.net>
Date: Wed Mar 3 02:11:46 2010 -0800
sparc64: Fix msgrcv()
msgrcv() does not work on sparc64, as it passes the 6th argument using
the ipc kludge, while the kernel waits for a 6 arguments syscall. This
patches fixes the problem by using a sparc64 specific version of
msgrcv.c.
2010-03-03 Aurelien Jarno <aurelien@aurel32.net>
* sysdeps/unix/sysv/linux/sparc/sparc64/msgrcv.c: New file.
diff --git a/sysdeps/unix/sysv/linux/sparc/sparc64/msgrcv.c b/sysdeps/unix/sysv/linux/sparc/sparc64/msgrcv.c
new file mode 100644
index 0000000..117762c
--- /dev/null
+++ b/sysdeps/unix/sysv/linux/sparc/sparc64/msgrcv.c
@@ -0,0 +1,49 @@
+/* Copyright (C) 2010 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+
+ The GNU C Library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2.1 of the License, or (at your option) any later version.
+
+ The GNU C Library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with the GNU C Library; if not, write to the Free
+ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+ 02111-1307 USA. */
+
+#include <errno.h>
+#include <sys/msg.h>
+#include <ipc_priv.h>
+
+#include <sysdep-cancel.h>
+#include <sys/syscall.h>
+
+#include <bp-checks.h>
+
+ssize_t
+__libc_msgrcv (msqid, msgp, msgsz, msgtyp, msgflg)
+ int msqid;
+ void *msgp;
+ size_t msgsz;
+ long int msgtyp;
+ int msgflg;
+{
+ if (SINGLE_THREAD_P)
+ return INLINE_SYSCALL (ipc, 6, IPCOP_msgrcv, msqid, msgsz, msgflg,
+ CHECK_N (msgp, msgsz), msgtyp);
+
+ int oldtype = LIBC_CANCEL_ASYNC ();
+
+ ssize_t result = INLINE_SYSCALL (ipc, 6, IPCOP_msgrcv, msqid, msgsz, msgflg,
+ CHECK_N (msgp, msgsz), msgtyp);
+
+ LIBC_CANCEL_RESET (oldtype);
+
+ return result;
+}
+weak_alias (__libc_msgrcv, msgrcv)

View File

@ -28,7 +28,7 @@
Summary: The GNU libc libraries
Name: glibc
Version: %{glibcversion}
Release: 5
Release: 6
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
# Things that are linked directly into dynamically linked programs
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
@ -41,7 +41,6 @@ Source0: %{?glibc_release_url}%{glibcsrcdir}.tar.bz2
Source1: %{glibcsrcdir}-fedora.tar.bz2
Patch0: %{name}-fedora.patch
Patch1: %{name}-ia64-lib64.patch
Patch2: %{name}-sparc64-msgrcv-fix.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Obsoletes: glibc-profile < 2.4
Provides: ldconfig
@ -252,7 +251,6 @@ package or when debugging this package.
%patch1 -p1
%endif
%endif
%patch2 -p1
# A lot of programs still misuse memcpy when they have to use
# memmove. The memcpy implementation below is not tolerant at
@ -1039,6 +1037,9 @@ rm -f *.filelist*
%endif
%changelog
* Fri Apr 16 2010 Andreas Schwab <schwab@redhat.com> - 2.11.1-6
- Fix spurious UNAVAIL status in getaddrinfo (#576667, #581673)
* Wed Mar 31 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 2.11.1-5
- Fix for sparc64 msgrcv from upstream trunk

View File

@ -42,3 +42,4 @@ glibc-2_11-4:F-12:glibc-2.11-4.src.rpm:1259591029
glibc-2_11_1-1:F-12:glibc-2.11.1-1.src.rpm:1262612086
glibc-2_11_1-2:F-12:glibc-2.11.1-2.src.rpm:1268927149
glibc-2_11_1-4:F-12:glibc-2.11.1-4.src.rpm:1268929381
glibc-2_11_1-6:F-12:glibc-2.11.1-6.src.rpm:1271420717

View File

@ -1,2 +1,2 @@
b7e765fa327700ae462e2b71e462ad87 glibc-2.11.1-4-g11c19d3.tar.bz2
f151d1400808362b0ebfa5c51814108b glibc-2.11.1-4-g11c19d3-fedora.tar.bz2
6f17bca00ff53b4a94b742d3c968b8d7 glibc-2.11.1-4-g11c19d3-fedora.tar.bz2