Sync with upstream master

We've sped past 2.19 now.
This commit is contained in:
Siddhesh Poyarekar 2014-02-18 22:48:17 +05:30
parent c90adf8884
commit 372014ca28
3 changed files with 14 additions and 15 deletions

View File

@ -12,7 +12,7 @@ diff -Nrup a/posix/fnmatch.c b/posix/fnmatch.c
@@ -356,10 +357,8 @@ fnmatch (pattern, string, flags)
alloca_used);
n = mbsrtowcs (wpattern, &p, n + 1, &ps);
if (__builtin_expect (n == (size_t) -1, 0))
if (__glibc_unlikely (n == (size_t) -1))
- /* Something wrong.
- XXX Do we have to set `errno' to something which mbsrtows hasn't
- already done? */
@ -25,20 +25,20 @@ diff -Nrup a/posix/fnmatch.c b/posix/fnmatch.c
@@ -371,10 +370,8 @@ fnmatch (pattern, string, flags)
prepare_wpattern:
n = mbsrtowcs (NULL, &pattern, 0, &ps);
if (__builtin_expect (n == (size_t) -1, 0))
if (__glibc_unlikely (n == (size_t) -1))
- /* Something wrong.
- XXX Do we have to set `errno' to something which mbsrtows hasn't
- already done? */
- return -1;
+ /*Something wrong: Fall back to single byte matching. */
+ goto try_singlebyte;
if (__builtin_expect (n >= (size_t) -1 / sizeof (wchar_t), 0))
if (__glibc_unlikely (n >= (size_t) -1 / sizeof (wchar_t)))
{
__set_errno (ENOMEM);
@@ -401,14 +398,8 @@ fnmatch (pattern, string, flags)
alloca_used);
n = mbsrtowcs (wstring, &p, n + 1, &ps);
if (__builtin_expect (n == (size_t) -1, 0))
if (__glibc_unlikely (n == (size_t) -1))
- {
- /* Something wrong.
- XXX Do we have to set `errno' to something which
@ -55,14 +55,14 @@ diff -Nrup a/posix/fnmatch.c b/posix/fnmatch.c
@@ -420,10 +411,8 @@ fnmatch (pattern, string, flags)
prepare_wstring:
n = mbsrtowcs (NULL, &string, 0, &ps);
if (__builtin_expect (n == (size_t) -1, 0))
if (__glibc_unlikely (n == (size_t) -1))
- /* Something wrong.
- XXX Do we have to set `errno' to something which mbsrtows hasn't
- already done? */
- goto free_return;
+ /* Something wrong: Fall back to singlebyte matching. */
+ goto free_and_try_singlebyte;
if (__builtin_expect (n >= (size_t) -1 / sizeof (wchar_t), 0))
if (__glibc_unlikely (n >= (size_t) -1 / sizeof (wchar_t)))
{
free (wpattern_malloc);
@@ -450,6 +439,10 @@ fnmatch (pattern, string, flags)

View File

@ -37,8 +37,8 @@ diff -urN glibc-2.17-c758a686/string/Makefile tmp/glibc-2.17-c758a686/string/Mak
+CFLAGS-.oS += -fno-tree-loop-distribute-patterns
+
ifeq ($(run-built-tests),yes)
tests: $(objpfx)tst-svc.out
$(objpfx)tst-svc.out: tst-svc.input $(objpfx)tst-svc
tests: $(objpfx)tst-svc-cmp.out
$(objpfx)tst-svc-cmp.out: tst-svc.expect $(objpfx)tst-svc.out
diff -urN glibc-2.17-c758a686/elf/Makefile tmp/glibc-2.17-c758a686/elf/Makefile
--- glibc-2.17-c758a686/elf/Makefile 2013-02-27 18:07:13.812055613 -0500
+++ tmp/glibc-2.17-c758a686/elf/Makefile 2013-02-27 18:08:16.075796160 -0500

View File

@ -1,6 +1,6 @@
%define glibcsrcdir glibc-2.18-880-gdc98b8f
%define glibcversion 2.18.90
%define glibcrelease 27%{?dist}
%define glibcsrcdir glibc-2.19-58-ga4fb786
%define glibcversion 2.19.90
%define glibcrelease 1%{?dist}
# Pre-release tarballs are pulled in from git using a command that is
# effectively:
#
@ -211,9 +211,6 @@ Patch2027: %{name}-rh819430.patch
# Fix nscd to use permission names not constants.
Patch2028: %{name}-rh1025126.patch
# Upstream BZ 16398
Patch2029: %{name}-rh1052846.patch
##############################################################################
# End of glibc patches.
##############################################################################
@ -538,7 +535,6 @@ package or when debugging this package.
%patch0044 -p1
%patch0046 -p1
%patch2028 -p1
%patch2029 -p1
##############################################################################
# %%prep - Additional prep required...
@ -1625,6 +1621,9 @@ rm -f *.filelist*
%endif
%changelog
* Tue Feb 18 2014 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.19.90-1
- Sync with upstream master.
* Tue Feb 04 2014 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.18.90-27
- Sync with upstream master.