Auto-sync with upstream branch release/2.29/master
Upstream commit: 067fc32968b601493f4b247a3ac00caeea3f3d61 - Drop glibc-rh1674280.patch. Different fix applied upstream. (#1674280) - nptl: Fix invalid Systemtap probe in pthread_join (#1674280)
This commit is contained in:
parent
b82e3b3f85
commit
1c5b89063f
@ -1,26 +0,0 @@
|
|||||||
Fix a user-after-free bug in the Systemtap probe in
|
|
||||||
__pthread_timedjoin_ex:
|
|
||||||
|
|
||||||
/* Free the TCB. */
|
|
||||||
__free_tcb (pd);
|
|
||||||
}
|
|
||||||
else
|
|
||||||
pd->joinid = NULL;
|
|
||||||
|
|
||||||
LIBC_PROBE (pthread_join_ret, 3, threadid, result, pd->result);
|
|
||||||
|
|
||||||
__free_tcb has freed the stack, the access pd->result is invalid.
|
|
||||||
|
|
||||||
diff --git a/nptl/pthread_join_common.c b/nptl/pthread_join_common.c
|
|
||||||
index ecb78ffba5861bdc..45deba6a74c5efd2 100644
|
|
||||||
--- a/nptl/pthread_join_common.c
|
|
||||||
+++ b/nptl/pthread_join_common.c
|
|
||||||
@@ -101,7 +101,7 @@ __pthread_timedjoin_ex (pthread_t threadid, void **thread_return,
|
|
||||||
else
|
|
||||||
pd->joinid = NULL;
|
|
||||||
|
|
||||||
- LIBC_PROBE (pthread_join_ret, 3, threadid, result, pd->result);
|
|
||||||
+ LIBC_PROBE (pthread_join_ret, 3, threadid, result, result);
|
|
||||||
|
|
||||||
return result;
|
|
||||||
}
|
|
11
glibc.spec
11
glibc.spec
@ -1,4 +1,4 @@
|
|||||||
%define glibcsrcdir glibc-2.29-5-gc096b008d2
|
%define glibcsrcdir glibc-2.29-6-g067fc32968
|
||||||
%define glibcversion 2.29
|
%define glibcversion 2.29
|
||||||
# Pre-release tarballs are pulled in from git using a command that is
|
# Pre-release tarballs are pulled in from git using a command that is
|
||||||
# effectively:
|
# effectively:
|
||||||
@ -87,7 +87,7 @@
|
|||||||
Summary: The GNU libc libraries
|
Summary: The GNU libc libraries
|
||||||
Name: glibc
|
Name: glibc
|
||||||
Version: %{glibcversion}
|
Version: %{glibcversion}
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
|
|
||||||
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
||||||
# libraries.
|
# libraries.
|
||||||
@ -158,7 +158,6 @@ Patch18: glibc-c-utf8-locale.patch
|
|||||||
Patch23: glibc-python3.patch
|
Patch23: glibc-python3.patch
|
||||||
Patch28: glibc-rh1615608.patch
|
Patch28: glibc-rh1615608.patch
|
||||||
Patch29: glibc-rh1670028.patch
|
Patch29: glibc-rh1670028.patch
|
||||||
Patch99: glibc-rh1674280.patch
|
|
||||||
|
|
||||||
##############################################################################
|
##############################################################################
|
||||||
# Continued list of core "glibc" package information:
|
# Continued list of core "glibc" package information:
|
||||||
@ -1890,6 +1889,12 @@ fi
|
|||||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 19 2019 Florian Weimer <fweimer@redhat.com> - 2.29-8
|
||||||
|
- Drop glibc-rh1674280.patch. Different fix applied upstream. (#1674280)
|
||||||
|
- Auto-sync with upstream branch release/2.29/master,
|
||||||
|
commit 067fc32968b601493f4b247a3ac00caeea3f3d61:
|
||||||
|
- nptl: Fix invalid Systemtap probe in pthread_join (#1674280)
|
||||||
|
|
||||||
* Mon Feb 11 2019 Florian Weimer <fweimer@redhat.com> - 2.29-7
|
* Mon Feb 11 2019 Florian Weimer <fweimer@redhat.com> - 2.29-7
|
||||||
- Hotfix for invalid Systemtap probe in pthread_join (#1674280)
|
- Hotfix for invalid Systemtap probe in pthread_join (#1674280)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (glibc-2.29-5-gc096b008d2.tar.xz) = b2caff098709183f3c02dabbb75926d067006f442ab15531c14a33f2a4b04e064fce2e4bdfb27dd9f148122de057e4884f8fdc426bd7aa9315d4e67d60c6b4c5
|
SHA512 (glibc-2.29-6-g067fc32968.tar.xz) = c26330756b920d4d58e6c04de459b8239c707c49d1c38c6f35becbf4fe0a1e455c57029b08a9105347e064d041255ad5dcf2039c0ae795cd10a7819318913e95
|
||||||
|
Loading…
Reference in New Issue
Block a user