Auto-sync with upstream branch master
commit 2ef427168818ce04b03cecb7b739f9db0156e3e4 - Require GCC 5 or later to build glibc (swbz#23993) - Only build libm with -fno-math-errno (swbz#24024) - sysdeps/ieee754: prevent maybe-uninitialized errors with -O (swbz#19444) - Multiple locales: Use the correct 12-hour time formats (swbz#10496) - sq_AL: Use the correct date and time formats (swbz#10496, swbz#23724) - en_US: define date_fmt (swbz#24046) - Remove executable bit from localedata/locales/bi_VU (swbz#23995) - malloc: Always call memcpy in _int_realloc (swbz#24027) - ARM: fix kernel assisted atomics with GCC 8 (swbz#24034) - S390: Unify 31/64bit mem{set,cmp,cpy,pcpy}, bzero with ifunc handling - S390: Refactor ifunc handling for several str* and wc* functions - posix: Clear close-on-exec for posix_spawn adddup2 (swbz#23640) - termios: Define TIOCSER_TEMT with __USE_MISC (swbz#17783) - termios: Consolidate Baud Rate Selection definitions (swbz#23783) - Y2038: add __{localtime64,gmttime64,ctime64}[_r] functions - Y2038: make __difftime compatible with 64-bit time
This commit is contained in:
parent
650d554f72
commit
1aba59b258
@ -9,32 +9,32 @@ python3 during a transitional phase.
|
||||
Author: Carlos O'Donell <carlos@redhat.com>
|
||||
|
||||
diff --git a/benchtests/scripts/compare_bench.py b/benchtests/scripts/compare_bench.py
|
||||
index ea25f778c09bba9d..b53beb3c6e32c3cf 100755
|
||||
index c1c438a1c9f0eae6..b7d3d7bcee87969d 100755
|
||||
--- a/benchtests/scripts/compare_bench.py
|
||||
+++ b/benchtests/scripts/compare_bench.py
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/python
|
||||
+#!/usr/bin/python3
|
||||
# Copyright (C) 2015-2018 Free Software Foundation, Inc.
|
||||
# Copyright (C) 2015-2019 Free Software Foundation, Inc.
|
||||
# This file is part of the GNU C Library.
|
||||
#
|
||||
diff --git a/benchtests/scripts/import_bench.py b/benchtests/scripts/import_bench.py
|
||||
index 602b3f954d4801a6..76bf1528a5418748 100644
|
||||
index 7a55d19f038e64d4..72e6034243a8c9b6 100644
|
||||
--- a/benchtests/scripts/import_bench.py
|
||||
+++ b/benchtests/scripts/import_bench.py
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/python
|
||||
+#!/usr/bin/python3
|
||||
# Copyright (C) 2015-2018 Free Software Foundation, Inc.
|
||||
# Copyright (C) 2015-2019 Free Software Foundation, Inc.
|
||||
# This file is part of the GNU C Library.
|
||||
#
|
||||
diff --git a/benchtests/scripts/validate_benchout.py b/benchtests/scripts/validate_benchout.py
|
||||
index 6147f05bec3a4844..9a5c7947ee4ed7e9 100755
|
||||
index 55d07c6bce5b5184..04129f9c26c2874c 100755
|
||||
--- a/benchtests/scripts/validate_benchout.py
|
||||
+++ b/benchtests/scripts/validate_benchout.py
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/python
|
||||
+#!/usr/bin/python3
|
||||
# Copyright (C) 2014-2018 Free Software Foundation, Inc.
|
||||
# Copyright (C) 2014-2019 Free Software Foundation, Inc.
|
||||
# This file is part of the GNU C Library.
|
||||
#
|
||||
|
24
glibc.spec
24
glibc.spec
@ -1,6 +1,6 @@
|
||||
%define glibcsrcdir glibc-2.28.9000-400-g6bbfc5c09f
|
||||
%define glibcsrcdir glibc-2.28.9000-551-g2ef4271688
|
||||
%define glibcversion 2.28.9000
|
||||
%define glibcrelease 28%{?dist}
|
||||
%define glibcrelease 29%{?dist}
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
#
|
||||
@ -1905,6 +1905,26 @@ fi
|
||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||
|
||||
%changelog
|
||||
* Mon Jan 07 2019 Arjun Shankar <arjun@redhat.com> - 2.28.9000-29
|
||||
- Auto-sync with upstream branch master,
|
||||
commit 2ef427168818ce04b03cecb7b739f9db0156e3e4.
|
||||
- Require GCC 5 or later to build glibc (swbz#23993)
|
||||
- Only build libm with -fno-math-errno (swbz#24024)
|
||||
- sysdeps/ieee754: prevent maybe-uninitialized errors with -O (swbz#19444)
|
||||
- Multiple locales: Use the correct 12-hour time formats (swbz#10496)
|
||||
- sq_AL: Use the correct date and time formats (swbz#10496, swbz#23724)
|
||||
- en_US: define date_fmt (swbz#24046)
|
||||
- Remove executable bit from localedata/locales/bi_VU (swbz#23995)
|
||||
- malloc: Always call memcpy in _int_realloc (swbz#24027)
|
||||
- ARM: fix kernel assisted atomics with GCC 8 (swbz#24034)
|
||||
- S390: Unify 31/64bit mem{set,cmp,cpy,pcpy}, bzero with ifunc handling
|
||||
- S390: Refactor ifunc handling for several str* and wc* functions
|
||||
- posix: Clear close-on-exec for posix_spawn adddup2 (swbz#23640)
|
||||
- termios: Define TIOCSER_TEMT with __USE_MISC (swbz#17783)
|
||||
- termios: Consolidate Baud Rate Selection definitions (swbz#23783)
|
||||
- Y2038: add __{localtime64,gmttime64,ctime64}[_r] functions
|
||||
- Y2038: make __difftime compatible with 64-bit time
|
||||
|
||||
* Mon Dec 17 2018 DJ Delorie <dj@redhat.com> - 2.28.9000-28
|
||||
- Auto-sync with upstream branch master,
|
||||
commit 6bbfc5c09fc5b5e3d4a0cddbbd4e2e457767dae7.
|
||||
|
Loading…
Reference in New Issue
Block a user