Resolves: #1335011
Back out glibc-rh1333945.patch, glibc-rh1333945-2.patch because they cause a regression in ASAN.
This commit is contained in:
parent
55dbe293ce
commit
10fdc4382b
@ -1,24 +0,0 @@
|
||||
commit e91bd7465816f474617dcb4bbfe72f3594c5783c
|
||||
Author: Adhemerval Zanella <adhemerval.zanella@linaro.com>
|
||||
Date: Thu Mar 31 10:51:51 2016 -0300
|
||||
|
||||
Fix tst-dlsym-error build
|
||||
|
||||
This patch fixes the new test tst-dlsym-error build on aarch64
|
||||
(and possible other architectures as well) due missing strchrnul
|
||||
definition.
|
||||
|
||||
* elf/tst-dlsym-error.c: Include <string.h> for strchrnul.
|
||||
|
||||
diff --git a/elf/tst-dlsym-error.c b/elf/tst-dlsym-error.c
|
||||
index 11b0358..fb084c5 100644
|
||||
--- a/elf/tst-dlsym-error.c
|
||||
+++ b/elf/tst-dlsym-error.c
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <gnu/lib-names.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
|
||||
/* Used to disambiguate symbol names. */
|
||||
static int counter;
|
@ -1,162 +0,0 @@
|
||||
commit 7d45c163d00c88d5875a112343c4ea3e61349e6b
|
||||
Author: Florian Weimer <fweimer@redhat.com>
|
||||
Date: Thu Mar 31 11:26:55 2016 +0200
|
||||
|
||||
Report dlsym, dlvsym lookup errors using dlerror [BZ #19509]
|
||||
|
||||
* elf/dl-lookup.c (_dl_lookup_symbol_x): Report error even if
|
||||
skip_map != NULL.
|
||||
* elf/tst-dlsym-error.c: New file.
|
||||
* elf/Makefile (tests): Add tst-dlsym-error.
|
||||
(tst-dlsym-error): Link against libdl.
|
||||
|
||||
Index: b/elf/Makefile
|
||||
===================================================================
|
||||
--- a/elf/Makefile
|
||||
+++ b/elf/Makefile
|
||||
@@ -148,7 +148,8 @@ tests += loadtest restest1 preloadtest l
|
||||
tst-unique1 tst-unique2 $(if $(CXX),tst-unique3 tst-unique4 \
|
||||
tst-nodelete) \
|
||||
tst-initorder tst-initorder2 tst-relsort1 tst-null-argv \
|
||||
- tst-ptrguard1 tst-tlsalign tst-tlsalign-extern tst-nodelete-opened
|
||||
+ tst-ptrguard1 tst-tlsalign tst-tlsalign-extern tst-nodelete-opened \
|
||||
+ tst-dlsym-error
|
||||
# reldep9
|
||||
ifeq ($(build-hardcoded-path-in-tests),yes)
|
||||
tests += tst-dlopen-aout
|
||||
@@ -1205,3 +1206,5 @@ $(objpfx)tst-unused-dep.out: $(objpfx)te
|
||||
$(objpfx)tst-unused-dep-cmp.out: $(objpfx)tst-unused-dep.out
|
||||
cmp $< /dev/null > $@; \
|
||||
$(evaluate-test)
|
||||
+
|
||||
+$(objpfx)tst-dlsym-error: $(libdl)
|
||||
Index: b/elf/dl-lookup.c
|
||||
===================================================================
|
||||
--- a/elf/dl-lookup.c
|
||||
+++ b/elf/dl-lookup.c
|
||||
@@ -858,7 +858,6 @@ _dl_lookup_symbol_x (const char *undef_n
|
||||
if (__glibc_unlikely (current_value.s == NULL))
|
||||
{
|
||||
if ((*ref == NULL || ELFW(ST_BIND) ((*ref)->st_info) != STB_WEAK)
|
||||
- && skip_map == NULL
|
||||
&& !(GLRO(dl_debug_mask) & DL_DEBUG_UNUSED))
|
||||
{
|
||||
/* We could find no value for a strong reference. */
|
||||
Index: b/elf/tst-dlsym-error.c
|
||||
===================================================================
|
||||
--- /dev/null
|
||||
+++ b/elf/tst-dlsym-error.c
|
||||
@@ -0,0 +1,113 @@
|
||||
+/* Test error reporting for dlsym, dlvsym failures.
|
||||
+ Copyright (C) 2016 Free Software Foundation, Inc.
|
||||
+ This file is part of the GNU C Library.
|
||||
+
|
||||
+ The GNU C Library is free software; you can redistribute it and/or
|
||||
+ modify it under the terms of the GNU Lesser General Public
|
||||
+ License as published by the Free Software Foundation; either
|
||||
+ version 2.1 of the License, or (at your option) any later version.
|
||||
+
|
||||
+ The GNU C Library is distributed in the hope that it will be useful,
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
+ Lesser General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU Lesser General Public
|
||||
+ License along with the GNU C Library; if not, see
|
||||
+ <http://www.gnu.org/licenses/>. */
|
||||
+
|
||||
+#include <dlfcn.h>
|
||||
+#include <gnu/lib-names.h>
|
||||
+#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
+
|
||||
+/* Used to disambiguate symbol names. */
|
||||
+static int counter;
|
||||
+
|
||||
+static void
|
||||
+test_one (void *handle, const char *name, void *(func) (void *, const char *),
|
||||
+ const char *suffix)
|
||||
+{
|
||||
+ ++counter;
|
||||
+ char symbol[32];
|
||||
+ snprintf (symbol, sizeof (symbol), "no_such_symbol_%d", counter);
|
||||
+ char *expected_message;
|
||||
+ if (asprintf (&expected_message, ": undefined symbol: %s%s",
|
||||
+ symbol, suffix) < 0)
|
||||
+ {
|
||||
+ printf ("error: asprintf: %m\n");
|
||||
+ abort ();
|
||||
+ }
|
||||
+
|
||||
+ void *addr = func (handle, symbol);
|
||||
+ if (addr != NULL)
|
||||
+ {
|
||||
+ printf ("error: %s: found symbol \"no_such_symbol\"\n", name);
|
||||
+ abort ();
|
||||
+ }
|
||||
+ const char *message = dlerror ();
|
||||
+ if (message == NULL)
|
||||
+ {
|
||||
+ printf ("error: %s: missing error message\n", name);
|
||||
+ abort ();
|
||||
+ }
|
||||
+ const char *message_without_path = strchrnul (message, ':');
|
||||
+ if (strcmp (message_without_path, expected_message) != 0)
|
||||
+ {
|
||||
+ printf ("error: %s: unexpected error message: %s\n", name, message);
|
||||
+ abort ();
|
||||
+ }
|
||||
+ free (expected_message);
|
||||
+
|
||||
+ message = dlerror ();
|
||||
+ if (message != NULL)
|
||||
+ {
|
||||
+ printf ("error: %s: unexpected error message: %s\n", name, message);
|
||||
+ abort ();
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
+test_handles (const char *name, void *(func) (void *, const char *),
|
||||
+ const char *suffix)
|
||||
+{
|
||||
+ test_one (RTLD_DEFAULT, name, func, suffix);
|
||||
+ test_one (RTLD_NEXT, name, func, suffix);
|
||||
+
|
||||
+ void *handle = dlopen (LIBC_SO, RTLD_LAZY);
|
||||
+ if (handle == NULL)
|
||||
+ {
|
||||
+ printf ("error: cannot dlopen %s: %s\n", LIBC_SO, dlerror ());
|
||||
+ abort ();
|
||||
+ }
|
||||
+ test_one (handle, name, func, suffix);
|
||||
+ dlclose (handle);
|
||||
+}
|
||||
+
|
||||
+static void *
|
||||
+dlvsym_no_such_version (void *handle, const char *name)
|
||||
+{
|
||||
+ return dlvsym (handle, name, "NO_SUCH_VERSION");
|
||||
+}
|
||||
+
|
||||
+static void *
|
||||
+dlvsym_glibc_private (void *handle, const char *name)
|
||||
+{
|
||||
+ return dlvsym (handle, name, "GLIBC_PRIVATE");
|
||||
+}
|
||||
+
|
||||
+static int
|
||||
+do_test (void)
|
||||
+{
|
||||
+ test_handles ("dlsym", dlsym, "");
|
||||
+ test_handles ("dlvsym", dlvsym_no_such_version,
|
||||
+ ", version NO_SUCH_VERSION");
|
||||
+ test_handles ("dlvsym", dlvsym_glibc_private,
|
||||
+ ", version GLIBC_PRIVATE");
|
||||
+
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
+
|
||||
+#define TEST_FUNCTION do_test ()
|
||||
+#include "../test-skeleton.c"
|
10
glibc.spec
10
glibc.spec
@ -1,6 +1,6 @@
|
||||
%define glibcsrcdir glibc-2.22
|
||||
%define glibcversion 2.22
|
||||
%define glibcrelease 15%{?dist}
|
||||
%define glibcrelease 16%{?dist}
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
#
|
||||
@ -245,8 +245,6 @@ Patch1022: glibc-rh1333901-4.patch
|
||||
Patch1023: glibc-rh1333901-5.patch
|
||||
Patch1024: glibc-rh1315648-1.patch
|
||||
Patch1025: glibc-rh1315648-2.patch
|
||||
Patch1026: glibc-rh1333945.patch
|
||||
Patch1027: glibc-rh1333945-2.patch
|
||||
Patch1028: glibc-rh1332917-1.patch
|
||||
Patch1029: glibc-rh1332917-2.patch
|
||||
Patch1030: glibc-rh1332917-3.patch
|
||||
@ -710,8 +708,6 @@ microbenchmark tests on the system.
|
||||
%patch1023 -p1
|
||||
%patch1024 -p1
|
||||
%patch1025 -p1
|
||||
%patch1026 -p1
|
||||
%patch1027 -p1
|
||||
%patch1028 -p1
|
||||
%patch1029 -p1
|
||||
%patch1030 -p1
|
||||
@ -1951,6 +1947,10 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed May 11 2016 Florian Weimer <fweimer@redhat.com> - 2.22-16
|
||||
- Back out dlsym (RTLD_NEXT)/dlerror change (#1333945)
|
||||
because it reveals an ASAN bug (#1335011)
|
||||
|
||||
* Sat May 7 2016 Florian Weimer <fweimer@redhat.com> - 2.22-15
|
||||
- Change first day of the week for es_CL to Monday (#1321372)
|
||||
- CVE-2015-8779: unbounded stack allocation in catopen (#1300314)
|
||||
|
Loading…
Reference in New Issue
Block a user