2.10.90-10

This commit is contained in:
Andreas Schwab 2009-07-28 09:34:51 +00:00
parent 96d4f4139d
commit 0e925c16c2
5 changed files with 80 additions and 73 deletions

View File

@ -1,2 +1,2 @@
glibc-2.10-214-g16d2ea4-fedora.tar.bz2
glibc-2.10-214-g16d2ea4.tar.bz2
glibc-2.10-221-ge73e694-fedora.tar.bz2
glibc-2.10-221-ge73e694.tar.bz2

View File

@ -1,6 +1,6 @@
--- glibc-2.10-214-g16d2ea4/ChangeLog
--- glibc-2.10-221-ge73e694/ChangeLog
+++ glibc-2.10.90-9/ChangeLog
@@ -121,6 +121,11 @@
@@ -150,6 +150,11 @@
* sysdeps/generic/ldsodefs.h (struct rtld_global): The map element in
the unique symbol hash table should not be const.
@ -12,7 +12,7 @@
2009-07-21 Ulrich Drepper <drepper@redhat.com>
* sysdeps/x86_64/multiarch/strstr.c: Minor cleanups. Remove
@@ -386,6 +391,16 @@
@@ -415,6 +420,16 @@
out common code into new function get_common_indeces. Determine
extended family and model for Intel processors.
@ -29,7 +29,7 @@
2009-06-26 Ulrich Drepper <drepper@redhat.com>
* resolv/resolv.h: Define RES_SNGLKUPREOP.
@@ -8784,6 +8799,13 @@
@@ -8813,6 +8828,13 @@
* include/sys/cdefs.h: Redefine __nonnull so that test for
incorrect parameters in the libc code itself are not omitted.
@ -43,7 +43,7 @@
2007-05-09 Jakub Jelinek <jakub@redhat.com>
* sysdeps/ia64/fpu/fraiseexcpt.c (feraiseexcept): Don't raise overflow
@@ -9079,6 +9101,10 @@
@@ -9108,6 +9130,10 @@
[BZ #4368]
* stdlib/stdlib.h: Remove obsolete part of comment for realpath.
@ -54,7 +54,7 @@
2007-04-16 Ulrich Drepper <drepper@redhat.com>
[BZ #4364]
@@ -10336,6 +10362,15 @@
@@ -10365,6 +10391,15 @@
separators also if no non-zero digits found.
* stdlib/Makefile (tests): Add tst-strtod3.
@ -70,7 +70,7 @@
2006-12-09 Ulrich Drepper <drepper@redhat.com>
[BZ #3632]
--- glibc-2.10-214-g16d2ea4/ChangeLog.15
--- glibc-2.10-221-ge73e694/ChangeLog.15
+++ glibc-2.10.90-9/ChangeLog.15
@@ -477,6 +477,14 @@
@ -137,7 +137,7 @@
2004-08-30 Roland McGrath <roland@frob.com>
* scripts/extract-abilist.awk: If `lastversion' variable defined, omit
--- glibc-2.10-214-g16d2ea4/ChangeLog.16
--- glibc-2.10-221-ge73e694/ChangeLog.16
+++ glibc-2.10.90-9/ChangeLog.16
@@ -171,6 +171,11 @@
[BZ #2611]
@ -310,7 +310,7 @@
2005-02-10 Roland McGrath <roland@redhat.com>
[BZ #157]
--- glibc-2.10-214-g16d2ea4/Makeconfig
--- glibc-2.10-221-ge73e694/Makeconfig
+++ glibc-2.10.90-9/Makeconfig
@@ -780,12 +780,12 @@ endif
# The assembler can generate debug information too.
@ -328,7 +328,7 @@
ifndef BUILD_CC
BUILD_CC = $(CC)
--- glibc-2.10-214-g16d2ea4/csu/Makefile
--- glibc-2.10-221-ge73e694/csu/Makefile
+++ glibc-2.10.90-9/csu/Makefile
@@ -93,7 +93,8 @@ omit-deps += $(crtstuff)
$(crtstuff:%=$(objpfx)%.o): %.o: %.S $(objpfx)defs.h
@ -340,7 +340,7 @@
vpath initfini.c $(sysdirs)
--- glibc-2.10-214-g16d2ea4/csu/elf-init.c
--- glibc-2.10-221-ge73e694/csu/elf-init.c
+++ glibc-2.10.90-9/csu/elf-init.c
@@ -63,6 +63,23 @@ extern void (*__init_array_end []) (int, char **, char **)
extern void (*__fini_array_start []) (void) attribute_hidden;
@ -366,7 +366,7 @@
/* These function symbols are provided for the .init/.fini section entry
points automagically by the linker. */
--- glibc-2.10-214-g16d2ea4/debug/tst-chk1.c
--- glibc-2.10-221-ge73e694/debug/tst-chk1.c
+++ glibc-2.10.90-9/debug/tst-chk1.c
@@ -17,6 +17,9 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
@ -396,7 +396,7 @@
# define O 0
# else
# define O 1
--- glibc-2.10-214-g16d2ea4/elf/ldconfig.c
--- glibc-2.10-221-ge73e694/elf/ldconfig.c
+++ glibc-2.10.90-9/elf/ldconfig.c
@@ -1020,17 +1020,19 @@ search_dirs (void)
@ -479,7 +479,7 @@
}
if (! opt_ignore_aux_cache)
--- glibc-2.10-214-g16d2ea4/elf/tst-stackguard1.c
--- glibc-2.10-221-ge73e694/elf/tst-stackguard1.c
+++ glibc-2.10.90-9/elf/tst-stackguard1.c
@@ -160,17 +160,21 @@ do_test (void)
the 16 runs, something is very wrong. */
@ -505,15 +505,15 @@
{
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.10-214-g16d2ea4/include/bits/stdlib-ldbl.h
--- glibc-2.10-221-ge73e694/include/bits/stdlib-ldbl.h
+++ glibc-2.10.90-9/include/bits/stdlib-ldbl.h
@@ -0,0 +1 @@
+#include <stdlib/bits/stdlib-ldbl.h>
--- glibc-2.10-214-g16d2ea4/include/bits/wchar-ldbl.h
--- glibc-2.10-221-ge73e694/include/bits/wchar-ldbl.h
+++ glibc-2.10.90-9/include/bits/wchar-ldbl.h
@@ -0,0 +1 @@
+#include <wcsmbs/bits/wchar-ldbl.h>
--- glibc-2.10-214-g16d2ea4/include/features.h
--- glibc-2.10-221-ge73e694/include/features.h
+++ glibc-2.10.90-9/include/features.h
@@ -299,8 +299,13 @@
#endif
@ -531,7 +531,7 @@
# define __USE_FORTIFY_LEVEL 2
# else
# define __USE_FORTIFY_LEVEL 1
--- glibc-2.10-214-g16d2ea4/intl/locale.alias
--- glibc-2.10-221-ge73e694/intl/locale.alias
+++ glibc-2.10.90-9/intl/locale.alias
@@ -57,8 +57,6 @@ korean ko_KR.eucKR
korean.euc ko_KR.eucKR
@ -542,7 +542,7 @@
norwegian nb_NO.ISO-8859-1
nynorsk nn_NO.ISO-8859-1
polish pl_PL.ISO-8859-2
--- glibc-2.10-214-g16d2ea4/libio/stdio.h
--- glibc-2.10-221-ge73e694/libio/stdio.h
+++ glibc-2.10.90-9/libio/stdio.h
@@ -145,10 +145,12 @@ typedef _G_fpos64_t fpos64_t;
extern struct _IO_FILE *stdin; /* Standard input stream. */
@ -557,7 +557,7 @@
__BEGIN_NAMESPACE_STD
/* Remove file FILENAME. */
--- glibc-2.10-214-g16d2ea4/locale/iso-4217.def
--- glibc-2.10-221-ge73e694/locale/iso-4217.def
+++ glibc-2.10.90-9/locale/iso-4217.def
@@ -8,6 +8,7 @@
*
@ -650,7 +650,7 @@
DEFINE_INT_CURR("PYG") /* Paraguay Guarani */
DEFINE_INT_CURR("QAR") /* Qatar Rial */
DEFINE_INT_CURR("ROL") /* Romanian Leu */
--- glibc-2.10-214-g16d2ea4/locale/programs/locarchive.c
--- glibc-2.10-221-ge73e694/locale/programs/locarchive.c
+++ glibc-2.10.90-9/locale/programs/locarchive.c
@@ -241,9 +241,9 @@ oldlocrecentcmp (const void *a, const void *b)
/* forward decls for below */
@ -683,7 +683,7 @@
add_alias (struct locarhandle *ah, const char *alias, bool replace,
const char *oldname, uint32_t *locrec_offset_p)
{
--- glibc-2.10-214-g16d2ea4/localedata/Makefile
--- glibc-2.10-221-ge73e694/localedata/Makefile
+++ glibc-2.10.90-9/localedata/Makefile
@@ -225,6 +225,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-locales-dir
echo -n '...'; \
@ -693,7 +693,7 @@
-i locales/$$input -c -f charmaps/$$charset \
$(addprefix --prefix=,$(install_root)) $$locale; \
echo ' done'; \
--- glibc-2.10-214-g16d2ea4/localedata/SUPPORTED
--- glibc-2.10-221-ge73e694/localedata/SUPPORTED
+++ glibc-2.10.90-9/localedata/SUPPORTED
@@ -84,6 +84,7 @@ cy_GB.UTF-8/UTF-8 \
cy_GB/ISO-8859-14 \
@ -736,7 +736,7 @@
ta_IN/UTF-8 \
te_IN/UTF-8 \
tg_TJ.UTF-8/UTF-8 \
--- glibc-2.10-214-g16d2ea4/localedata/locales/cy_GB
--- glibc-2.10-221-ge73e694/localedata/locales/cy_GB
+++ glibc-2.10.90-9/localedata/locales/cy_GB
@@ -248,8 +248,11 @@ mon "<U0049><U006F><U006E><U0061><U0077><U0072>";/
d_t_fmt "<U0044><U0079><U0064><U0064><U0020><U0025><U0041><U0020><U0025><U0064><U0020><U006d><U0069><U0073><U0020><U0025><U0042><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
@ -752,7 +752,7 @@
END LC_TIME
LC_MESSAGES
--- glibc-2.10-214-g16d2ea4/localedata/locales/en_GB
--- glibc-2.10-221-ge73e694/localedata/locales/en_GB
+++ glibc-2.10.90-9/localedata/locales/en_GB
@@ -116,8 +116,8 @@ mon "<U004A><U0061><U006E><U0075><U0061><U0072><U0079>";/
d_t_fmt "<U0025><U0061><U0020><U0025><U0064><U0020><U0025><U0062><U0020><U0025><U0059><U0020><U0025><U0054><U0020><U0025><U005A>"
@ -765,7 +765,7 @@
date_fmt "<U0025><U0061><U0020><U0025><U0062><U0020><U0025><U0065>/
<U0020><U0025><U0048><U003A><U0025><U004D><U003A><U0025><U0053><U0020>/
<U0025><U005A><U0020><U0025><U0059>"
--- glibc-2.10-214-g16d2ea4/localedata/locales/no_NO
--- glibc-2.10-221-ge73e694/localedata/locales/no_NO
+++ glibc-2.10.90-9/localedata/locales/no_NO
@@ -0,0 +1,69 @@
+escape_char /
@ -837,7 +837,7 @@
+LC_ADDRESS
+copy "nb_NO"
+END LC_ADDRESS
--- glibc-2.10-214-g16d2ea4/localedata/locales/zh_TW
--- glibc-2.10-221-ge73e694/localedata/locales/zh_TW
+++ glibc-2.10.90-9/localedata/locales/zh_TW
@@ -1,7 +1,7 @@
comment_char %
@ -866,7 +866,7 @@
revision "0.2"
date "2000-08-02"
%
--- glibc-2.10-214-g16d2ea4/malloc/mcheck.c
--- glibc-2.10-221-ge73e694/malloc/mcheck.c
+++ glibc-2.10.90-9/malloc/mcheck.c
@@ -24,9 +24,25 @@
# include <mcheck.h>
@ -943,7 +943,7 @@
old_free_hook = __free_hook;
__free_hook = freehook;
--- glibc-2.10-214-g16d2ea4/manual/libc.texinfo
--- glibc-2.10-221-ge73e694/manual/libc.texinfo
+++ glibc-2.10.90-9/manual/libc.texinfo
@@ -5,7 +5,7 @@
@c setchapternewpage odd
@ -954,7 +954,7 @@
@direntry
* Libc: (libc). C library.
@end direntry
--- glibc-2.10-214-g16d2ea4/misc/sys/cdefs.h
--- glibc-2.10-221-ge73e694/misc/sys/cdefs.h
+++ glibc-2.10.90-9/misc/sys/cdefs.h
@@ -132,7 +132,10 @@
#define __bos(ptr) __builtin_object_size (ptr, __USE_FORTIFY_LEVEL > 1)
@ -999,7 +999,7 @@
# define __va_arg_pack() __builtin_va_arg_pack ()
# define __va_arg_pack_len() __builtin_va_arg_pack_len ()
#endif
--- glibc-2.10-214-g16d2ea4/nis/nss
--- glibc-2.10-221-ge73e694/nis/nss
+++ glibc-2.10.90-9/nis/nss
@@ -25,4 +25,4 @@
# memory with every getXXent() call. Otherwise each getXXent() call
@ -1007,9 +1007,9 @@
# the next entry.
-#SETENT_BATCH_READ=TRUE
+SETENT_BATCH_READ=TRUE
--- glibc-2.10-214-g16d2ea4/nptl/ChangeLog
--- glibc-2.10-221-ge73e694/nptl/ChangeLog
+++ glibc-2.10.90-9/nptl/ChangeLog
@@ -3604,6 +3604,15 @@
@@ -3603,6 +3603,15 @@
Use __sigfillset. Document that sigfillset does the right thing wrt
to SIGSETXID.
@ -1025,7 +1025,7 @@
2005-07-11 Jakub Jelinek <jakub@redhat.com>
[BZ #1102]
@@ -4340,6 +4349,11 @@
@@ -4339,6 +4348,11 @@
Move definition inside libpthread, libc, librt check. Provide
definition for rtld.
@ -1037,7 +1037,7 @@
2004-09-02 Ulrich Drepper <drepper@redhat.com>
* sysdeps/alpha/jmpbuf-unwind.h: Define __libc_unwind_longjmp.
@@ -6414,6 +6428,11 @@
@@ -6413,6 +6427,11 @@
* Makefile [$(build-shared) = yes] (tests): Depend on $(test-modules).
@ -1049,7 +1049,7 @@
2003-07-25 Jakub Jelinek <jakub@redhat.com>
* tst-cancel17.c (do_test): Check if aio_cancel failed.
--- glibc-2.10-214-g16d2ea4/nptl/Makefile
--- glibc-2.10-221-ge73e694/nptl/Makefile
+++ glibc-2.10.90-9/nptl/Makefile
@@ -339,7 +339,8 @@ endif
extra-objs += $(crti-objs) $(crtn-objs)
@ -1083,7 +1083,7 @@
else
$(addprefix $(objpfx),$(tests) $(test-srcs)): $(objpfx)libpthread.a
endif
--- glibc-2.10-214-g16d2ea4/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
--- glibc-2.10-221-ge73e694/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+++ glibc-2.10.90-9/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
@@ -187,4 +187,7 @@
/* Typed memory objects are not available. */
@ -1093,7 +1093,7 @@
+#define _XOPEN_STREAMS -1
+
#endif /* bits/posix_opt.h */
--- glibc-2.10-214-g16d2ea4/nptl/sysdeps/unix/sysv/linux/kernel-features.h
--- glibc-2.10-221-ge73e694/nptl/sysdeps/unix/sysv/linux/kernel-features.h
+++ glibc-2.10.90-9/nptl/sysdeps/unix/sysv/linux/kernel-features.h
@@ -0,0 +1,6 @@
+#include_next <kernel-features.h>
@ -1102,7 +1102,7 @@
+#ifndef __ASSUME_CLONE_THREAD_FLAGS
+# define __ASSUME_CLONE_THREAD_FLAGS 1
+#endif
--- glibc-2.10-214-g16d2ea4/nptl/tst-stackguard1.c
--- glibc-2.10-221-ge73e694/nptl/tst-stackguard1.c
+++ glibc-2.10.90-9/nptl/tst-stackguard1.c
@@ -190,17 +190,21 @@ do_test (void)
the 16 runs, something is very wrong. */
@ -1128,7 +1128,7 @@
{
puts ("stack guard canaries are not randomized enough");
puts ("nor equal to the default canary value");
--- glibc-2.10-214-g16d2ea4/nscd/nscd.conf
--- glibc-2.10-221-ge73e694/nscd/nscd.conf
+++ glibc-2.10.90-9/nscd/nscd.conf
@@ -33,7 +33,7 @@
# logfile /var/log/nscd.log
@ -1139,7 +1139,7 @@
# stat-user somebody
debug-level 0
# reload-count 5
--- glibc-2.10-214-g16d2ea4/nscd/nscd.init
--- glibc-2.10-221-ge73e694/nscd/nscd.init
+++ glibc-2.10.90-9/nscd/nscd.init
@@ -9,6 +9,7 @@
# slow naming services like NIS, NIS+, LDAP, or hesiod.
@ -1197,7 +1197,7 @@
;;
*)
echo $"Usage: $0 {start|stop|status|restart|reload|condrestart}"
--- glibc-2.10-214-g16d2ea4/posix/Makefile
--- glibc-2.10-221-ge73e694/posix/Makefile
+++ glibc-2.10.90-9/posix/Makefile
@@ -301,15 +301,8 @@ $(inst_libexecdir)/getconf: $(inst_bindir)/getconf \
mv -f $@/$$spec.new $@/$$spec; \
@ -1219,7 +1219,7 @@
+ | sed -n -e '/START_OF_STRINGS/,$${/\(POSIX_V[67]\|_XBS5\)_/{s/^[^"]*"//;s/".*$$//;p}}' \
+ > $@.new
mv -f $@.new $@
--- glibc-2.10-214-g16d2ea4/posix/getconf.speclist.h
--- glibc-2.10-221-ge73e694/posix/getconf.speclist.h
+++ glibc-2.10.90-9/posix/getconf.speclist.h
@@ -0,0 +1,39 @@
+#include <unistd.h>
@ -1261,7 +1261,7 @@
+"XBS5_LPBIG_OFFBIG"
+#endif
+"";
--- glibc-2.10-214-g16d2ea4/streams/Makefile
--- glibc-2.10-221-ge73e694/streams/Makefile
+++ glibc-2.10.90-9/streams/Makefile
@@ -21,7 +21,7 @@
#
@ -1272,7 +1272,7 @@
routines = isastream getmsg getpmsg putmsg putpmsg fattach fdetach
include ../Rules
--- glibc-2.10-214-g16d2ea4/sysdeps/generic/dl-cache.h
--- glibc-2.10-221-ge73e694/sysdeps/generic/dl-cache.h
+++ glibc-2.10.90-9/sysdeps/generic/dl-cache.h
@@ -36,6 +36,14 @@
# define add_system_dir(dir) add_dir (dir)
@ -1289,7 +1289,7 @@
#define CACHEMAGIC "ld.so-1.7.0"
/* libc5 and glibc 2.0/2.1 use the same format. For glibc 2.2 another
--- glibc-2.10-214-g16d2ea4/sysdeps/i386/Makefile
--- glibc-2.10-221-ge73e694/sysdeps/i386/Makefile
+++ glibc-2.10.90-9/sysdeps/i386/Makefile
@@ -2,6 +2,8 @@
# Every i386 port in use uses gas syntax (I think).
@ -1315,7 +1315,7 @@
endif
ifeq ($(subdir),elf)
--- glibc-2.10-214-g16d2ea4/sysdeps/ia64/Makefile
--- glibc-2.10-221-ge73e694/sysdeps/ia64/Makefile
+++ glibc-2.10.90-9/sysdeps/ia64/Makefile
@@ -12,8 +12,8 @@ elide-routines.os += hp-timing
@ -1328,7 +1328,7 @@
endif
endif
--- glibc-2.10-214-g16d2ea4/sysdeps/ia64/ia64libgcc.S
--- glibc-2.10-221-ge73e694/sysdeps/ia64/ia64libgcc.S
+++ glibc-2.10.90-9/sysdeps/ia64/ia64libgcc.S
@@ -1,350 +0,0 @@
-/* From the Intel IA-64 Optimization Guide, choose the minimum latency
@ -1681,7 +1681,7 @@
- .symver ___multi3, __multi3@GLIBC_2.2
-
-#endif
--- glibc-2.10-214-g16d2ea4/sysdeps/ia64/libgcc-compat.c
--- glibc-2.10-221-ge73e694/sysdeps/ia64/libgcc-compat.c
+++ glibc-2.10.90-9/sysdeps/ia64/libgcc-compat.c
@@ -0,0 +1,84 @@
+/* pre-.hidden libgcc compatibility
@ -1768,7 +1768,7 @@
+symbol_version (INTUSE (__multi3), __multi3, GLIBC_2.2);
+
+#endif
--- glibc-2.10-214-g16d2ea4/sysdeps/powerpc/powerpc32/____longjmp_chk.S
--- glibc-2.10-221-ge73e694/sysdeps/powerpc/powerpc32/____longjmp_chk.S
+++ glibc-2.10.90-9/sysdeps/powerpc/powerpc32/____longjmp_chk.S
@@ -49,8 +49,16 @@
#define CHECK_SP(reg) \
@ -1787,7 +1787,7 @@
.Lok:
#include <__longjmp-common.S>
--- glibc-2.10-214-g16d2ea4/sysdeps/powerpc/powerpc64/Makefile
--- glibc-2.10-221-ge73e694/sysdeps/powerpc/powerpc64/Makefile
+++ glibc-2.10.90-9/sysdeps/powerpc/powerpc64/Makefile
@@ -30,6 +30,7 @@ ifneq ($(elf),no)
# we use -fpic instead which is much better.
@ -1797,7 +1797,7 @@
endif
ifeq ($(subdir),elf)
--- glibc-2.10-214-g16d2ea4/sysdeps/powerpc/powerpc64/____longjmp_chk.S
--- glibc-2.10-221-ge73e694/sysdeps/powerpc/powerpc64/____longjmp_chk.S
+++ glibc-2.10.90-9/sysdeps/powerpc/powerpc64/____longjmp_chk.S
@@ -32,8 +32,16 @@
#define CHECK_SP(reg) \
@ -1816,7 +1816,7 @@
.Lok:
#include <__longjmp-common.S>
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/nice.c
--- glibc-2.10-221-ge73e694/sysdeps/unix/nice.c
+++ glibc-2.10.90-9/sysdeps/unix/nice.c
@@ -42,7 +42,12 @@ nice (int incr)
__set_errno (save);
@ -1832,7 +1832,7 @@
if (result == -1)
{
if (errno == EACCES)
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/sysv/linux/check_pf.c
--- glibc-2.10-221-ge73e694/sysdeps/unix/sysv/linux/check_pf.c
+++ glibc-2.10.90-9/sysdeps/unix/sysv/linux/check_pf.c
@@ -27,13 +27,10 @@
#include <unistd.h>
@ -1849,7 +1849,7 @@
#ifndef IFA_F_HOMEADDRESS
# define IFA_F_HOMEADDRESS 0
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/sysv/linux/dl-osinfo.h
--- glibc-2.10-221-ge73e694/sysdeps/unix/sysv/linux/dl-osinfo.h
+++ glibc-2.10.90-9/sysdeps/unix/sysv/linux/dl-osinfo.h
@@ -17,10 +17,13 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
@ -1898,7 +1898,7 @@
}
else
#endif
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/sysv/linux/futimesat.c
--- glibc-2.10-221-ge73e694/sysdeps/unix/sysv/linux/futimesat.c
+++ glibc-2.10.90-9/sysdeps/unix/sysv/linux/futimesat.c
@@ -37,14 +37,14 @@ futimesat (fd, file, tvp)
{
@ -1942,7 +1942,7 @@
{
size_t filelen = strlen (file);
static const char procfd[] = "/proc/self/fd/%d/%s";
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/sysv/linux/i386/clone.S
--- glibc-2.10-221-ge73e694/sysdeps/unix/sysv/linux/i386/clone.S
+++ glibc-2.10.90-9/sysdeps/unix/sysv/linux/i386/clone.S
@@ -120,9 +120,6 @@ L(pseudo_end):
ret
@ -1962,7 +1962,7 @@
cfi_startproc
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/sysv/linux/i386/dl-cache.h
--- glibc-2.10-221-ge73e694/sysdeps/unix/sysv/linux/i386/dl-cache.h
+++ glibc-2.10.90-9/sysdeps/unix/sysv/linux/i386/dl-cache.h
@@ -0,0 +1,59 @@
+/* Support for reading /etc/ld.so.cache files written by Linux ldconfig.
@ -2024,7 +2024,7 @@
+ } while (0)
+
+#include_next <dl-cache.h>
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/sysv/linux/ia64/dl-cache.h
--- glibc-2.10-221-ge73e694/sysdeps/unix/sysv/linux/ia64/dl-cache.h
+++ glibc-2.10.90-9/sysdeps/unix/sysv/linux/ia64/dl-cache.h
@@ -22,4 +22,31 @@
#define _dl_cache_check_flags(flags) \
@ -2058,7 +2058,7 @@
+ } while (0)
+
#include_next <dl-cache.h>
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
--- glibc-2.10-221-ge73e694/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
+++ glibc-2.10.90-9/sysdeps/unix/sysv/linux/ia64/dl-procinfo.c
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
@ -2066,7 +2066,7 @@
+#else
+#include <sysdeps/generic/dl-procinfo.c>
+#endif
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
--- glibc-2.10-221-ge73e694/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
+++ glibc-2.10.90-9/sysdeps/unix/sysv/linux/ia64/dl-procinfo.h
@@ -0,0 +1,5 @@
+#ifdef IS_IN_ldconfig
@ -2074,12 +2074,12 @@
+#else
+#include <sysdeps/generic/dl-procinfo.h>
+#endif
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
--- glibc-2.10-221-ge73e694/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
+++ glibc-2.10.90-9/sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
@@ -1 +1 @@
-s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 \2\3"_
+s_^\(RTLDLIST=\)\([^ ]*\)-ia64\(\.so\.[0-9.]*\)[ ]*$_\1"\2-ia64\3 /emul/ia32-linux\2\3"_
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/sysv/linux/netlinkaccess.h
--- glibc-2.10-221-ge73e694/sysdeps/unix/sysv/linux/netlinkaccess.h
+++ glibc-2.10.90-9/sysdeps/unix/sysv/linux/netlinkaccess.h
@@ -25,6 +25,24 @@
@ -2106,7 +2106,7 @@
struct netlink_res
{
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/sysv/linux/paths.h
--- glibc-2.10-221-ge73e694/sysdeps/unix/sysv/linux/paths.h
+++ glibc-2.10.90-9/sysdeps/unix/sysv/linux/paths.h
@@ -62,7 +62,7 @@
#define _PATH_TTY "/dev/tty"
@ -2117,7 +2117,7 @@
#define _PATH_WTMP "/var/log/wtmp"
/* Provide trailing slash, since mostly used for building pathnames. */
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/sysv/linux/tcsetattr.c
--- glibc-2.10-221-ge73e694/sysdeps/unix/sysv/linux/tcsetattr.c
+++ glibc-2.10.90-9/sysdeps/unix/sysv/linux/tcsetattr.c
@@ -49,6 +49,7 @@ tcsetattr (fd, optional_actions, termios_p)
{
@ -2164,7 +2164,7 @@
+ return retval;
}
libc_hidden_def (tcsetattr)
--- glibc-2.10-214-g16d2ea4/sysdeps/unix/sysv/linux/x86_64/clone.S
--- glibc-2.10-221-ge73e694/sysdeps/unix/sysv/linux/x86_64/clone.S
+++ glibc-2.10.90-9/sysdeps/unix/sysv/linux/x86_64/clone.S
@@ -89,9 +89,6 @@ L(pseudo_end):
ret
@ -2184,7 +2184,7 @@
cfi_startproc;
PSEUDO_END (BP_SYM (__clone))
--- glibc-2.10-214-g16d2ea4/timezone/zic.c
--- glibc-2.10-221-ge73e694/timezone/zic.c
+++ glibc-2.10.90-9/timezone/zic.c
@@ -1921,7 +1921,7 @@ const int zonecount;
if (stdrp != NULL && stdrp->r_hiyear == 2037)

View File

@ -1,4 +1,4 @@
%define glibcsrcdir glibc-2.10-214-g16d2ea4
%define glibcsrcdir glibc-2.10-221-ge73e694
%define glibcversion 2.10.90
### glibc.spec.in follows:
%define run_glibc_tests 1
@ -24,7 +24,7 @@
Summary: The GNU libc libraries
Name: glibc
Version: %{glibcversion}
Release: 9
Release: 10
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
# Things that are linked directly into dynamically linked programs
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
@ -1037,6 +1037,12 @@ rm -f *.filelist*
%endif
%changelog
* Tue Jul 28 2009 Andreas Schwab <schwab@redhat.com> - 2.10.90-10
- Update from master.
* fix memory ordering in pthread_mutex_unlock (BZ#10418)
* implement RES_USE_DNSSEC option in resolver (#205842)
* fix hang in ldd -r (#513945)
* Mon Jul 27 2009 Andreas Schwab <schwab@redhat.com> - 2.10.90-9
- Update from master.

View File

@ -17,3 +17,4 @@ glibc-2_10_90-4:HEAD:glibc-2.10.90-4.src.rpm:1248096214
glibc-2_10_90-5:HEAD:glibc-2.10.90-5.src.rpm:1248267823
glibc-2_10_90-7:HEAD:glibc-2.10.90-7.src.rpm:1248367427
glibc-2_10_90-9:HEAD:glibc-2.10.90-9.src.rpm:1248700754
glibc-2_10_90-10:HEAD:glibc-2.10.90-10.src.rpm:1248773458

View File

@ -1,2 +1,2 @@
1c6e81b1f2100c55b32e9c298e7cce59 glibc-2.10-214-g16d2ea4-fedora.tar.bz2
973e7a5fc0a6273a6da70f7d36f6b8b4 glibc-2.10-214-g16d2ea4.tar.bz2
8925f5aaf39135b91b82cadea1dbbb35 glibc-2.10-221-ge73e694-fedora.tar.bz2
48861ec98c147d503490376ce8fafa4b glibc-2.10-221-ge73e694.tar.bz2