This commit is contained in:
Matthias Clasen 2008-11-24 15:27:29 +00:00
parent e16d20d277
commit f92026bb3b
6 changed files with 7 additions and 243 deletions

View File

@ -1 +1 @@
glib-2.18.2.tar.bz2
glib-2.18.3.tar.bz2

View File

@ -1,139 +0,0 @@
--- trunk/docs/reference/gio/gio-sections.txt 2008/07/24 01:13:33 7251
+++ trunk/docs/reference/gio/gio-sections.txt 2008/07/24 21:21:22 7252
@@ -816,6 +816,7 @@
g_mount_eject_finish
g_mount_guess_content_type
g_mount_guess_content_type_finish
+g_mount_guess_content_type_sync
<SUBSECTION Standard>
G_IS_MOUNT
G_MOUNT
--- trunk/gio/gio.symbols 2008/07/24 01:13:33 7251
+++ trunk/gio/gio.symbols 2008/07/24 21:21:22 7252
@@ -718,6 +718,7 @@
g_mount_remount_finish
g_mount_guess_content_type
g_mount_guess_content_type_finish
+g_mount_guess_content_type_sync
#endif
#endif
--- trunk/gio/gmount.c 2008/07/24 01:13:33 7251
+++ trunk/gio/gmount.c 2008/07/24 21:21:22 7252
@@ -570,9 +570,10 @@
* memory cards. See the <ulink url="http://www.freedesktop.org/wiki/Specifications/shared-mime-info-spec">shared-mime-info</ulink>
* specification for more on x-content types.
*
- * This is an asynchronous operation, and is finished by calling
- * g_mount_guess_content_type_finish() with the @mount and #GAsyncResult
- * data returned in the @callback.
+ * This is an asynchronous operation (see
+ * g_mount_guess_content_type_sync() for the synchronous version), and
+ * is finished by calling g_mount_guess_content_type_finish() with the
+ * @mount and #GAsyncResult data returned in the @callback.
*
* Since: 2.18
*/
@@ -644,6 +645,55 @@
return (* iface->guess_content_type_finish) (mount, result, error);
}
+/**
+ * g_mount_guess_content_type_sync:
+ * @mount: a #GMount
+ * @force_rescan: Whether to force a rescan of the content.
+ * Otherwise a cached result will be used if available
+ * @cancellable: optional #GCancellable object, %NULL to ignore
+ * @error: a #GError location to store the error occuring, or %NULL to
+ * ignore
+ *
+ * Tries to guess the type of content stored on @mount. Returns one or
+ * more textual identifiers of well-known content types (typically
+ * prefixed with "x-content/"), e.g. x-content/image-dcf for camera
+ * memory cards. See the <ulink url="http://www.freedesktop.org/wiki/Specifications/shared-mime-info-spec">shared-mime-info</ulink>
+ * specification for more on x-content types.
+ *
+ * This is an synchronous operation and as such may block doing IO;
+ * see g_mount_guess_content_type() for the asynchronous version.
+ *
+ * Returns: a %NULL-terminated array of content types or %NULL on error.
+ * Caller should free this array with g_strfreev() when done with it.
+ *
+ * Since: 2.18
+ */
+char **
+g_mount_guess_content_type_sync (GMount *mount,
+ gboolean force_rescan,
+ GCancellable *cancellable,
+ GError **error)
+{
+ GMountIface *iface;
+
+ g_return_val_if_fail (G_IS_MOUNT (mount), NULL);
+
+ iface = G_MOUNT_GET_IFACE (mount);
+
+ if (iface->guess_content_type_sync == NULL)
+ {
+ g_set_error_literal (error,
+ G_IO_ERROR, G_IO_ERROR_NOT_SUPPORTED,
+ /* Translators: This is an error
+ * message for mount objects that
+ * don't implement content type guessing. */
+ _("mount doesn't implement synchronous content type guessing"));
+
+ return NULL;
+ }
+
+ return (* iface->guess_content_type_sync) (mount, force_rescan, cancellable, error);
+}
#define __G_MOUNT_C__
#include "gioaliasdef.c"
--- trunk/gio/gmount.h 2008/07/24 01:13:33 7251
+++ trunk/gio/gmount.h 2008/07/24 21:21:22 7252
@@ -119,6 +119,11 @@
gchar ** (*guess_content_type_finish) (GMount *mount,
GAsyncResult *result,
GError **error);
+
+ gchar ** (*guess_content_type_sync) (GMount *mount,
+ gboolean force_rescan,
+ GCancellable *cancellable,
+ GError **error);
};
GType g_mount_get_type (void) G_GNUC_CONST;
@@ -166,6 +171,11 @@
GAsyncResult *result,
GError **error);
+gchar ** g_mount_guess_content_type_sync (GMount *mount,
+ gboolean force_rescan,
+ GCancellable *cancellable,
+ GError **error);
+
G_END_DECLS
#endif /* __G_MOUNT_H__ */
--- trunk/configure.in 2008/07/21 17:56:17 7234
+++ trunk/configure.in 2008/07/21 18:07:55 7236
@@ -23,7 +23,7 @@
#
m4_define([glib_major_version], [2])
m4_define([glib_minor_version], [17])
-m4_define([glib_micro_version], [4])
+m4_define([glib_micro_version], [5])
m4_define([glib_interface_age], [0])
m4_define([glib_binary_age],
[m4_eval(100 * glib_minor_version + glib_micro_version)])
--- trunk/tests/Makefile.am 2008/07/20 02:09:05 7209
+++ trunk/tests/Makefile.am 2008/07/23 16:22:32 7243
@@ -186,7 +186,6 @@
module_test_LDFLAGS = $(G_MODULE_LDFLAGS)
node_test_LDADD = $(progs_ldadd)
onceinit_LDADD = $(thread_ldadd)
-option_test_LDADD = $(progs_ldadd)
printf_test_LDADD = $(progs_ldadd)
queue_test_LDADD = $(progs_ldadd)
asyncqueue_test_LDADD = $(thread_ldadd)

View File

@ -1,19 +0,0 @@
Index: gio/glocalfileinfo.c
===================================================================
--- gio/glocalfileinfo.c (revision 7620)
+++ gio/glocalfileinfo.c (revision 7621)
@@ -1577,12 +1577,8 @@ _g_local_file_info_get (const char
if (S_ISDIR (statbuf.st_mode))
type_icon = "folder";
- else if (statbuf.st_mode & S_IXUSR)
- type_icon = "application-x-executable";
- else
- type_icon = "text-x-generic";
-
- g_themed_icon_append_name (G_THEMED_ICON (icon), type_icon);
+ if (type_icon)
+ g_themed_icon_append_name (G_THEMED_ICON (icon), type_icon);
}
}

View File

@ -2,8 +2,8 @@
Summary: A library of handy utility functions
Name: glib2
Version: 2.18.2
Release: 3%{?dist}
Version: 2.18.3
Release: 1%{?dist}
License: LGPLv2+
Group: System Environment/Libraries
URL: http://www.gtk.org
@ -22,8 +22,6 @@ BuildRequires: glibc-devel
# https://bugzilla.redhat.com/show_bug.cgi?id=442835
# http://bugzilla.gnome.org/show_bug.cgi?id=528670
Patch2: gio-2.18-always-pass-fuse-file-uri.patch
# http://bugzilla.gnome.org/show_bug.cgi?id=528320 (from svn)
Patch3: glib-2.18.2-no-generic-icons.patch
Patch4: glib-i386-atomic.patch
@ -62,7 +60,6 @@ of version 2 of the GLib library.
%prep
%setup -q -n glib-%{version}
%patch2 -p1 -b .always-pass-fuse-file-uri
%patch3 -p0 -b .no-generic-icons
%patch4 -p1 -b .i386-atomic
autoreconf
@ -140,6 +137,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/lib*.a
%changelog
* Mon Nov 24 2008 Matthias Clasen <mclasen@redhat.com> - 2.18.3-1
- Update to 2.18.3
* Mon Oct 27 2008 Matthias Clasen <mclasen@redhat.com> - 2.18.2-3
- Use asm implementation for atomic ops on x86

View File

@ -1 +1 @@
d11a5cc5e08cff53349a3481816fdaff glib-2.18.2.tar.bz2
f13996a7bd57525d796a6593f26a7771 glib-2.18.3.tar.bz2

View File

@ -1,78 +0,0 @@
diff -up glib-2.17.4/configure.in.statfs-check glib-2.17.4/configure.in
--- glib-2.17.4/configure.in.statfs-check 2008-07-21 18:24:45.000000000 -0400
+++ glib-2.17.4/configure.in 2008-07-21 18:25:19.000000000 -0400
@@ -847,6 +847,7 @@ AC_CHECK_HEADERS([mntent.h sys/mnttab.h
AC_CHECK_MEMBERS([struct stat.st_mtimensec, struct stat.st_mtim.tv_nsec, struct stat.st_atimensec, struct stat.st_atim.tv_nsec, struct stat.st_ctimensec, struct stat.st_ctim.tv_nsec])
AC_CHECK_MEMBERS([struct stat.st_blksize, struct stat.st_blocks, struct statfs.f_fstypename, struct statfs.f_bavail],,, [#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/statfs.h>
#include <unistd.h>
#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>
diff -up glib-2.17.4/configure.statfs-check glib-2.17.4/configure
--- glib-2.17.4/configure.statfs-check 2008-07-21 18:25:36.000000000 -0400
+++ glib-2.17.4/configure 2008-07-21 18:25:47.000000000 -0400
@@ -33300,6 +33300,7 @@ cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/statfs.h>
#include <unistd.h>
#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>
@@ -33349,6 +33350,7 @@ cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/statfs.h>
#include <unistd.h>
#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>
@@ -33421,6 +33423,7 @@ cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/statfs.h>
#include <unistd.h>
#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>
@@ -33470,6 +33473,7 @@ cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/statfs.h>
#include <unistd.h>
#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>
@@ -33542,6 +33546,7 @@ cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/statfs.h>
#include <unistd.h>
#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>
@@ -33591,6 +33596,7 @@ cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/statfs.h>
#include <unistd.h>
#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>
@@ -33663,6 +33669,7 @@ cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/statfs.h>
#include <unistd.h>
#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>
@@ -33712,6 +33719,7 @@ cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/statfs.h>
#include <unistd.h>
#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>