Update to 2.46.2
This commit is contained in:
parent
605fc8b850
commit
c059c40ded
@ -1,73 +0,0 @@
|
|||||||
From 24a4b33ffe7f4ef3487316e85060dd37b907941d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Olivier Fourdan <ofourdan@redhat.com>
|
|
||||||
Date: Tue, 15 Sep 2015 09:22:12 +0200
|
|
||||||
Subject: [PATCH] GDesktopAppInfo: Do not set the DISPLAY in gio
|
|
||||||
|
|
||||||
The environment variable DISPLAY makes sense only for X11, it should
|
|
||||||
not be set in gio.
|
|
||||||
|
|
||||||
Beside, if the backend is not X11 but Wayland, forcing the value of
|
|
||||||
DISPLAY to the Wayland display will confuse the backend selection and
|
|
||||||
possibly crash the applications.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=754983
|
|
||||||
---
|
|
||||||
gio/gdesktopappinfo.c | 13 ++-----------
|
|
||||||
1 file changed, 2 insertions(+), 11 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/gio/gdesktopappinfo.c b/gio/gdesktopappinfo.c
|
|
||||||
index b229788..cbfe556 100644
|
|
||||||
--- a/gio/gdesktopappinfo.c
|
|
||||||
+++ b/gio/gdesktopappinfo.c
|
|
||||||
@@ -2669,7 +2669,7 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
|
|
||||||
GPid pid;
|
|
||||||
GList *launched_uris;
|
|
||||||
GList *iter;
|
|
||||||
- char *display, *sn_id = NULL;
|
|
||||||
+ char *sn_id = NULL;
|
|
||||||
|
|
||||||
old_uris = uris;
|
|
||||||
if (!expand_application_parameters (info, exec_line, &uris, &argc, &argv, error))
|
|
||||||
@@ -2708,18 +2708,11 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
|
|
||||||
data.pid_envvar = NULL;
|
|
||||||
}
|
|
||||||
|
|
||||||
- display = NULL;
|
|
||||||
sn_id = NULL;
|
|
||||||
if (launch_context)
|
|
||||||
{
|
|
||||||
GList *launched_files = create_files_for_uris (launched_uris);
|
|
||||||
|
|
||||||
- display = g_app_launch_context_get_display (launch_context,
|
|
||||||
- G_APP_INFO (info),
|
|
||||||
- launched_files);
|
|
||||||
- if (display)
|
|
||||||
- envp = g_environ_setenv (envp, "DISPLAY", display, TRUE);
|
|
||||||
-
|
|
||||||
if (info->startup_notify)
|
|
||||||
{
|
|
||||||
sn_id = g_app_launch_context_get_startup_notify_id (launch_context,
|
|
||||||
@@ -2744,7 +2737,6 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
|
|
||||||
if (sn_id)
|
|
||||||
g_app_launch_context_launch_failed (launch_context, sn_id);
|
|
||||||
|
|
||||||
- g_free (display);
|
|
||||||
g_free (sn_id);
|
|
||||||
g_list_free (launched_uris);
|
|
||||||
|
|
||||||
@@ -2771,11 +2763,10 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
|
|
||||||
notify_desktop_launch (session_bus,
|
|
||||||
info,
|
|
||||||
pid,
|
|
||||||
- display,
|
|
||||||
+ NULL,
|
|
||||||
sn_id,
|
|
||||||
launched_uris);
|
|
||||||
|
|
||||||
- g_free (display);
|
|
||||||
g_free (sn_id);
|
|
||||||
g_list_free (launched_uris);
|
|
||||||
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
10
glib2.spec
10
glib2.spec
@ -2,15 +2,13 @@
|
|||||||
|
|
||||||
Summary: A library of handy utility functions
|
Summary: A library of handy utility functions
|
||||||
Name: glib2
|
Name: glib2
|
||||||
Version: 2.46.1
|
Version: 2.46.2
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.gtk.org
|
URL: http://www.gtk.org
|
||||||
#VCS: git:git://git.gnome.org/glib
|
#VCS: git:git://git.gnome.org/glib
|
||||||
Source: http://download.gnome.org/sources/glib/2.46/glib-%{version}.tar.xz
|
Source: http://download.gnome.org/sources/glib/2.46/glib-%{version}.tar.xz
|
||||||
# Backported from upstream
|
|
||||||
Patch0: 0001-GDesktopAppInfo-Do-not-set-the-DISPLAY-in-gio.patch
|
|
||||||
|
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -83,7 +81,6 @@ the functionality of the installed glib2 package.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n glib-%{version}
|
%setup -q -n glib-%{version}
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Support builds of both git snapshots and tarballs packed with autogoo
|
# Support builds of both git snapshots and tarballs packed with autogoo
|
||||||
@ -221,6 +218,9 @@ gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules
|
|||||||
%{_datadir}/installed-tests
|
%{_datadir}/installed-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 09 2015 Kalev Lember <klember@redhat.com> - 2.46.2-1
|
||||||
|
- Update to 2.46.2
|
||||||
|
|
||||||
* Mon Oct 19 2015 Kalev Lember <klember@redhat.com> - 2.46.1-2
|
* Mon Oct 19 2015 Kalev Lember <klember@redhat.com> - 2.46.1-2
|
||||||
- Backport an upstream fix for app launching under wayland (#1273146)
|
- Backport an upstream fix for app launching under wayland (#1273146)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user