Update to 2.35.1
... and drop upstreamed codegen-in-datadir.patch.
This commit is contained in:
parent
995dd9991b
commit
3c181fd35e
@ -1,56 +0,0 @@
|
|||||||
From 24af7308b1268f1b4a6cae74ce68ee283bcb2a62 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Colin Walters <walters@verbum.org>
|
|
||||||
Date: Thu, 27 Sep 2012 20:11:27 -0400
|
|
||||||
Subject: [PATCH] codegen: Install Python files in $(datadir)/glib-2.0, rather
|
|
||||||
than $(libdir)
|
|
||||||
|
|
||||||
These files are actually architecture-indepdendent; using $(libdir)
|
|
||||||
for them means that /usr/bin/gdbus-codegen varies between
|
|
||||||
architectures, which is problematic for (mis)uses of multilib.
|
|
||||||
|
|
||||||
See https://bugzilla.redhat.com/show_bug.cgi?id=718404
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=685012
|
|
||||||
---
|
|
||||||
gio/gdbus-2.0/codegen/Makefile.am | 4 ++--
|
|
||||||
gio/gdbus-2.0/codegen/gdbus-codegen.in | 2 +-
|
|
||||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/gio/gdbus-2.0/codegen/Makefile.am b/gio/gdbus-2.0/codegen/Makefile.am
|
|
||||||
index 39349ce..5111487 100644
|
|
||||||
--- a/gio/gdbus-2.0/codegen/Makefile.am
|
|
||||||
+++ b/gio/gdbus-2.0/codegen/Makefile.am
|
|
||||||
@@ -5,7 +5,7 @@ bin_SCRIPTS =
|
|
||||||
CLEANFILES =
|
|
||||||
EXTRA_DIST =
|
|
||||||
|
|
||||||
-codegendir = $(libdir)/gdbus-2.0/codegen
|
|
||||||
+codegendir = $(datadir)/glib-2.0/codegen
|
|
||||||
codegen_PYTHON = \
|
|
||||||
__init__.py \
|
|
||||||
codegen.py \
|
|
||||||
@@ -24,7 +24,7 @@ CLEANFILES += gdbus-codegen
|
|
||||||
EXTRA_DIST += gdbus-codegen.in
|
|
||||||
|
|
||||||
gdbus-codegen: gdbus-codegen.in Makefile $(codegen_PYTHON)
|
|
||||||
- $(AM_V_GEN) sed -e 's,@libdir\@,$(libdir),' -e 's,@PYTHON\@,$(PYTHON),' $< > $@.tmp && mv $@.tmp $@
|
|
||||||
+ $(AM_V_GEN) sed -e 's,@datadir\@,$(datadir),' -e 's,@PYTHON\@,$(PYTHON),' $< > $@.tmp && mv $@.tmp $@
|
|
||||||
@chmod a+x $@
|
|
||||||
|
|
||||||
clean-local:
|
|
||||||
diff --git a/gio/gdbus-2.0/codegen/gdbus-codegen.in b/gio/gdbus-2.0/codegen/gdbus-codegen.in
|
|
||||||
index 217c755..253d151 100644
|
|
||||||
--- a/gio/gdbus-2.0/codegen/gdbus-codegen.in
|
|
||||||
+++ b/gio/gdbus-2.0/codegen/gdbus-codegen.in
|
|
||||||
@@ -33,7 +33,7 @@ elif os.name == 'nt':
|
|
||||||
# Makes gdbus-codegen 'relocatable' at runtime on Windows.
|
|
||||||
path = os.path.join(os.path.dirname(__file__), '..', 'lib', 'gdbus-2.0')
|
|
||||||
else:
|
|
||||||
- path = os.path.join('@libdir@', 'gdbus-2.0')
|
|
||||||
+ path = os.path.join('@datadir@', 'glib-2.0')
|
|
||||||
|
|
||||||
sys.path.insert(0, os.path.abspath(path))
|
|
||||||
from codegen import codegen_main
|
|
||||||
--
|
|
||||||
1.7.11.4
|
|
||||||
|
|
14
glib2.spec
14
glib2.spec
@ -1,14 +1,12 @@
|
|||||||
Summary: A library of handy utility functions
|
Summary: A library of handy utility functions
|
||||||
Name: glib2
|
Name: glib2
|
||||||
Version: 2.34.1
|
Version: 2.35.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.gtk.org
|
URL: http://www.gtk.org
|
||||||
#VCS: git:git://git.gnome.org/glib
|
#VCS: git:git://git.gnome.org/glib
|
||||||
Source: http://download.gnome.org/sources/glib/2.34/glib-%{version}.tar.xz
|
Source: http://download.gnome.org/sources/glib/2.35/glib-%{version}.tar.xz
|
||||||
|
|
||||||
Patch0: codegen-in-datadir.patch
|
|
||||||
|
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -66,12 +64,8 @@ The glib2-fam package contains the FAM (File Alteration Monitor) module for GIO.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n glib-%{version}
|
%setup -q -n glib-%{version}
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Rerun autotools for the above patch
|
|
||||||
rm -f configure
|
|
||||||
|
|
||||||
# Support builds of both git snapshots and tarballs packed with autogoo
|
# Support builds of both git snapshots and tarballs packed with autogoo
|
||||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
||||||
%configure $CONFIGFLAGS \
|
%configure $CONFIGFLAGS \
|
||||||
@ -190,6 +184,10 @@ gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules
|
|||||||
%{_libdir}/gio/modules/libgiofam.so
|
%{_libdir}/gio/modules/libgiofam.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 08 2012 Kalev Lember <kalevlember@gmail.com> - 2.35.1-1
|
||||||
|
- Update to 2.35.1
|
||||||
|
- Drop upstreamed codegen-in-datadir.patch
|
||||||
|
|
||||||
* Tue Oct 16 2012 Kalev Lember <kalevlember@gmail.com> - 2.34.1-1
|
* Tue Oct 16 2012 Kalev Lember <kalevlember@gmail.com> - 2.34.1-1
|
||||||
- Update to 2.34.1
|
- Update to 2.34.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user