Merge branch 'master' into f21
Conflicts: glib2.spec
This commit is contained in:
commit
3553513d03
29
gio-Fix-regression-encoding-an-array-of-doubles.patch
Normal file
29
gio-Fix-regression-encoding-an-array-of-doubles.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From 869a5d38d6004d3f636f3a01e029a81e545c1c51 Mon Sep 17 00:00:00 2001
|
||||
From: Stef Walter <stefw@gnome.org>
|
||||
Date: Tue, 22 Jul 2014 21:29:27 +0200
|
||||
Subject: [PATCH] gio: Fix regression encoding an array of doubles
|
||||
|
||||
Take the simple slow path in this case. Encoding a double
|
||||
takes special precautions as you can see in append_value_to_blob()
|
||||
and friends.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=732754
|
||||
---
|
||||
gio/gdbusmessage.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gio/gdbusmessage.c b/gio/gdbusmessage.c
|
||||
index cd995b8..4173bcc 100644
|
||||
--- a/gio/gdbusmessage.c
|
||||
+++ b/gio/gdbusmessage.c
|
||||
@@ -1219,7 +1219,7 @@ get_type_fixed_size (const GVariantType *type)
|
||||
return 2;
|
||||
case 'i': case 'u': case 'h':
|
||||
return 4;
|
||||
- case 'x': case 't': case 'd':
|
||||
+ case 'x': case 't':
|
||||
return 8;
|
||||
default:
|
||||
return 0;
|
||||
--
|
||||
1.9.3
|
@ -3,13 +3,15 @@
|
||||
Summary: A library of handy utility functions
|
||||
Name: glib2
|
||||
Version: 2.41.2
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.gtk.org
|
||||
#VCS: git:git://git.gnome.org/glib
|
||||
Source: http://download.gnome.org/sources/glib/2.41/glib-%{version}.tar.xz
|
||||
|
||||
Patch1: gio-Fix-regression-encoding-an-array-of-doubles.patch
|
||||
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: gettext
|
||||
BuildRequires: libattr-devel
|
||||
@ -81,6 +83,7 @@ the functionality of the installed glib2 package.
|
||||
|
||||
%prep
|
||||
%setup -q -n glib-%{version}
|
||||
%patch1 -p1
|
||||
|
||||
# Workaround wrong gtk-doc.make timestamp
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=700350
|
||||
@ -223,6 +226,9 @@ gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules
|
||||
%{_datadir}/installed-tests
|
||||
|
||||
%changelog
|
||||
* Wed Jul 23 2014 Stef Walter <stefw@redhat.com> - 2.41.2-2
|
||||
- Fix regression with GDBus array encoding rhbz#1122128
|
||||
|
||||
* Mon Jul 14 2014 Kalev Lember <kalevlember@gmail.com> - 2.41.2-1
|
||||
- Update to 2.41.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user