Update to 2.41.3

This commit is contained in:
Kalev Lember 2014-08-16 21:01:16 +02:00
parent 645db3d1a4
commit 1a9d86986e
3 changed files with 6 additions and 39 deletions

View File

@ -1,29 +0,0 @@
From 869a5d38d6004d3f636f3a01e029a81e545c1c51 Mon Sep 17 00:00:00 2001
From: Stef Walter <stefw@gnome.org>
Date: Tue, 22 Jul 2014 21:29:27 +0200
Subject: [PATCH] gio: Fix regression encoding an array of doubles
Take the simple slow path in this case. Encoding a double
takes special precautions as you can see in append_value_to_blob()
and friends.
https://bugzilla.gnome.org/show_bug.cgi?id=732754
---
gio/gdbusmessage.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/gio/gdbusmessage.c b/gio/gdbusmessage.c
index cd995b8..4173bcc 100644
--- a/gio/gdbusmessage.c
+++ b/gio/gdbusmessage.c
@@ -1219,7 +1219,7 @@ get_type_fixed_size (const GVariantType *type)
return 2;
case 'i': case 'u': case 'h':
return 4;
- case 'x': case 't': case 'd':
+ case 'x': case 't':
return 8;
default:
return 0;
--
1.9.3

View File

@ -2,16 +2,14 @@
Summary: A library of handy utility functions
Name: glib2
Version: 2.41.2
Release: 3%{?dist}
Version: 2.41.3
Release: 1%{?dist}
License: LGPLv2+
Group: System Environment/Libraries
URL: http://www.gtk.org
#VCS: git:git://git.gnome.org/glib
Source: http://download.gnome.org/sources/glib/2.41/glib-%{version}.tar.xz
Patch1: gio-Fix-regression-encoding-an-array-of-doubles.patch
BuildRequires: pkgconfig
BuildRequires: gettext
BuildRequires: libattr-devel
@ -83,11 +81,6 @@ the functionality of the installed glib2 package.
%prep
%setup -q -n glib-%{version}
%patch1 -p1
# Workaround wrong gtk-doc.make timestamp
# https://bugzilla.gnome.org/show_bug.cgi?id=700350
touch -r Makefile.am gtk-doc.make
%build
# Support builds of both git snapshots and tarballs packed with autogoo
@ -226,6 +219,9 @@ gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules
%{_datadir}/installed-tests
%changelog
* Sat Aug 16 2014 Kalev Lember <kalevlember@gmail.com> - 2.41.3-1
- Update to 2.41.3
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.41.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild

View File

@ -1 +1 @@
9636f60e99b98fd0fdb5239f905ac008 glib-2.41.2.tar.xz
30d5a113e9126ffb544f60184a7a15be glib-2.41.3.tar.xz