689 lines
22 KiB
RPMSpec
689 lines
22 KiB
RPMSpec
%define _enable_python %{?enable_python:%{enable_python}}%{?!enable_python:1}
|
||
%define _enable_mp %{?enable_mp:%{enable_mp}}%{?!enable_mp:1}
|
||
%define _enable_static %{?enable_static:%{enable_static}}%{?!enable_static:1}
|
||
%define _enable_print %{?enable_print:%{enable_print}}%{?!enable_print:0}
|
||
%define _enable_convenience %{?enable_convenience:%{enable_convenience}}%{?!enable_convenience:1}
|
||
|
||
Summary: The GNU Image Manipulation Program
|
||
Name: gimp
|
||
Version: 2.2.4
|
||
%define binver 2.2
|
||
%define gimp_lang_ver 20
|
||
%define interfacever 2.0
|
||
%define age 0
|
||
%define minorver 200
|
||
%define microver %(ver=%{version}; echo ${ver##*.*.})
|
||
#define prever pre2
|
||
Release: %{?prever:0.0.%{prever}.}10
|
||
Epoch: 2
|
||
License: GPL, LGPL
|
||
Group: Applications/Multimedia
|
||
URL: http://www.gimp.org/
|
||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||
Obsoletes: gimp2 gimp-beta <= %{version}
|
||
Obsoletes: gimp-perl < 2:2.0
|
||
BuildRequires: glib2-devel >= 2.4.8
|
||
BuildRequires: gtk2-devel >= 2.4.14
|
||
BuildRequires: pango-devel >= 1.6.0
|
||
BuildRequires: fontconfig-devel >= 2.2.0
|
||
BuildRequires: gtkhtml2-devel
|
||
BuildRequires: python-devel
|
||
BuildRequires: pygtk2-devel
|
||
BuildRequires: librsvg2-devel
|
||
BuildRequires: libjpeg-devel
|
||
BuildRequires: libtiff-devel
|
||
BuildRequires: libpng-devel
|
||
BuildRequires: libmng-devel
|
||
BuildRequires: libexif-devel
|
||
BuildRequires: xorg-x11-devel
|
||
BuildRequires: gimp-print-devel >= 4.2.0
|
||
BuildRequires: automake >= 1.7
|
||
BuildRequires: autoconf >= 2.54
|
||
BuildRequires: libtool >= 1.5
|
||
BuildRequires: perl
|
||
BuildRequires: libwmf-devel >= 0.2.8
|
||
BuildRequires: intltool
|
||
PreReq: desktop-file-utils >= 0.9
|
||
Requires: glib2 >= 2.4.8
|
||
Requires: gtk2 >= 2.4.14
|
||
Requires: pango >= 1.6.0
|
||
Requires: fontconfig >= 2.2.0
|
||
Requires: gimp-print >= 4.2.0
|
||
Requires(post): /sbin/ldconfig /usr/bin/update-desktop-database
|
||
Requires(postun): /sbin/ldconfig /usr/bin/update-desktop-database
|
||
Source0: ftp://ftp.gimp.org/pub/gimp/v%{binver}/%{?prever:testing/}gimp-%{version}%{?prever:-%{prever}}.tar.bz2
|
||
Patch0: gimp-2.0pre3-buildroot.patch
|
||
Patch1: gimp-2.0.1-gimphelpmissing.patch
|
||
Patch2: gimp-2.2.3-icontheme.patch
|
||
Patch3: gimp-2.2.4-gcc4.patch
|
||
Patch4: gimp-2.2.4-gifload.patch
|
||
|
||
%description
|
||
The GIMP (GNU Image Manipulation Program) is a powerful image
|
||
composition and editing program, which can be extremely useful for
|
||
creating logos and other graphics for webpages. The GIMP has many of
|
||
the tools and filters you would expect to find in similar commercial
|
||
offerings, and some interesting extras as well. The GIMP provides a
|
||
large image manipulation toolbox, including channel operations and
|
||
layers, effects, sub-pixel imaging and anti-aliasing, and conversions,
|
||
all with multi-level undo.
|
||
|
||
%package devel
|
||
Summary: GIMP plugin and extension development kit
|
||
Group: Applications/Multimedia
|
||
Requires: gtk2-devel, %{name} = %{epoch}:%{version}-%{release}
|
||
Obsoletes: gimp2-devel gimp-beta-devel <= %{version}
|
||
%description devel
|
||
The gimp-devel package contains the static libraries and header files
|
||
for writing GNU Image Manipulation Program (GIMP) plug-ins and
|
||
extensions.
|
||
|
||
%prep
|
||
%setup -q -n gimp-%{version}%{?prever:-%{prever}}
|
||
%patch0 -p1 -b .buildroot
|
||
%patch1 -p1 -b .gimphelpmissing
|
||
%patch2 -p1 -b .icontheme
|
||
%patch3 -p1 -b .gcc4
|
||
%patch4 -p1 -b .gifload
|
||
|
||
%build
|
||
libtoolize --copy --force
|
||
intltoolize --automake --copy --force
|
||
aclocal -I m4macros
|
||
#perl -pi -e 's/require +XML::Parser/;/g;' aclocal.m4
|
||
automake
|
||
autoconf
|
||
LIBAA="disable"; export LIBAA
|
||
if [ ! -f configure ]; then
|
||
CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --quiet $MYARCH_FLAGS --prefix=%{_prefix}
|
||
fi
|
||
%configure \
|
||
--disable-perl \
|
||
%if %_enable_python
|
||
--enable-python \
|
||
%else
|
||
--disable-python \
|
||
%endif
|
||
%if %_enable_mp
|
||
--enable-mp \
|
||
%else
|
||
--disable-mp \
|
||
%endif
|
||
%if %_enable_static
|
||
--enable-static \
|
||
%else
|
||
--disable-static \
|
||
%endif
|
||
%if %_enable_print
|
||
--enable-print \
|
||
%else
|
||
--disable-print \
|
||
%endif
|
||
;
|
||
|
||
make %{?_smp_mflags}
|
||
|
||
%install
|
||
export PATH="$PATH:$PWD/bin"
|
||
[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
|
||
mkdir -p $RPM_BUILD_ROOT/%{_infodir} $RPM_BUILD_ROOT/%{_includedir} \
|
||
$RPM_BUILD_ROOT/%{_libdir} $RPM_BUILD_ROOT/%{_bindir} \
|
||
$RPM_BUILD_ROOT/%{_libdir}/gimp/%{interfacever}/plug-ins \
|
||
$RPM_BUILD_ROOT/%{_datadir}/{applications,application-registry,mime-info,icons/hicolor/48x48/apps}
|
||
|
||
# makeinstall macro won't work here - libexec is overriden
|
||
make DESTDIR=$RPM_BUILD_ROOT install
|
||
|
||
# symlink desktop icon
|
||
ln -s ../../../../gimp/%{interfacever}/images/wilber-icon.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/48x48/apps/gimp.png
|
||
|
||
#
|
||
# Plugins and modules change often (grab the executeable ones)
|
||
#
|
||
echo "%defattr (-, root, root)" > gimp-plugin-files
|
||
find $RPM_BUILD_ROOT/%{_libdir}/gimp/%{interfacever} -type f -exec file {} \; | grep -v perl | cut -d':' -f 1 | sed "s@^$RPM_BUILD_ROOT@@g" | grep -v /usr/lib/gimp/%{interfacever}/modules/.*\.a$ >>gimp-plugin-files
|
||
|
||
#
|
||
# Auto detect the lang files.
|
||
#
|
||
if [ -f /usr/lib/rpm/find-lang.sh ] ; then
|
||
/usr/lib/rpm/find-lang.sh $RPM_BUILD_ROOT gimp%{gimp_lang_ver}
|
||
/usr/lib/rpm/find-lang.sh $RPM_BUILD_ROOT gimp%{gimp_lang_ver}-std-plug-ins
|
||
/usr/lib/rpm/find-lang.sh $RPM_BUILD_ROOT gimp%{gimp_lang_ver}-script-fu
|
||
/usr/lib/rpm/find-lang.sh $RPM_BUILD_ROOT gimp%{gimp_lang_ver}-libgimp
|
||
cat gimp%{gimp_lang_ver}.lang gimp%{gimp_lang_ver}-std-plug-ins.lang gimp%{gimp_lang_ver}-script-fu.lang gimp%{gimp_lang_ver}-libgimp.lang > gimp-all.lang
|
||
else
|
||
echo '%{_datadir}/locale/*/*/*' > gimp-all.lang
|
||
fi
|
||
|
||
#
|
||
# Build the master filelists generated from the above mess.
|
||
#
|
||
cat gimp-plugin-files gimp-all.lang > gimp.files
|
||
|
||
%if %_enable_convenience
|
||
# install convenience symlinks
|
||
ln -snf gimp-%{binver} %{buildroot}/%{_bindir}/gimp
|
||
ln -snf gimp-%{binver}.1 %{buildroot}/%{_mandir}/man1/gimp.1
|
||
ln -snf gimp-remote-%{binver} %{buildroot}/%{_bindir}/gimp-remote
|
||
ln -snf gimp-remote-%{binver}.1 %{buildroot}/%{_mandir}/man1/gimp-remote.1
|
||
ln -snf gimptool-%{interfacever} %{buildroot}/%{_bindir}/gimptool
|
||
ln -snf gimptool-%{binver}.5 %{buildroot}/%{_mandir}/man5/gimptool.5
|
||
%endif
|
||
|
||
%clean
|
||
[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
|
||
|
||
%post
|
||
/sbin/ldconfig
|
||
/usr/bin/update-desktop-database %{_datadir}/applications
|
||
if [ -x %{_sbindir}/xsane-install-gimp-plugin ]; then
|
||
%{_sbindir}/xsane-install-gimp-plugin --install %{interfacever}
|
||
fi
|
||
touch --no-create %{_datadir}/icons/hicolor
|
||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||
gtk-update-icon-cache %{_datadir}/icons/hicolor
|
||
fi
|
||
|
||
%preun
|
||
# Do this always, because interfacever could be different
|
||
if [ -x %{_sbindir}/xsane-install-gimp-plugin ]; then
|
||
%{_sbindir}/xsane-install-gimp-plugin --uninstall %{interfacever}
|
||
fi
|
||
|
||
%postun
|
||
/sbin/ldconfig
|
||
if [ "$1" = "0" ]; then
|
||
/usr/bin/update-desktop-database %{_datadir}/applications
|
||
fi
|
||
touch --no-create %{_datadir}/icons/hicolor
|
||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||
gtk-update-icon-cache %{_datadir}/icons/hicolor
|
||
fi
|
||
|
||
%files -f gimp.files
|
||
%defattr(-, root, root, 0755)
|
||
%doc AUTHORS COPYING ChangeLog NEWS README
|
||
%doc docs/*.txt docs/*.ps docs/*.xcf* docs/*.svg README.i18n README.win32
|
||
#%attr(-,root,root) %config(missingok) /%{_datadir}/applications/gimp.desktop
|
||
#%attr(-,root,root) %config(missingok) /%{_datadir}/mc/templates/gimp.desktop
|
||
%{_datadir}/applications/*.desktop
|
||
%{_datadir}/application-registry/*.applications
|
||
%{_datadir}/mime-info/*.keys
|
||
|
||
%dir %{_datadir}/gimp
|
||
%dir %{_datadir}/gimp/%{interfacever}
|
||
%{_datadir}/gimp/%{interfacever}/tips/
|
||
%{_datadir}/gimp/%{interfacever}/misc/
|
||
%{_datadir}/gimp/%{interfacever}/menus/
|
||
%dir %{_libdir}/gimp
|
||
%dir %{_libdir}/gimp/%{interfacever}
|
||
%dir %{_libdir}/gimp/%{interfacever}/environ
|
||
#%dir %{_libdir}/gimp/%{interfacever}/fonts
|
||
%dir %{_libdir}/gimp/%{interfacever}/modules
|
||
%dir %{_libdir}/gimp/%{interfacever}/plug-ins
|
||
%dir %{_libdir}/gimp/%{interfacever}/python
|
||
#%dir %{_libdir}/gimp/%{interfacever}/tool-plug-ins
|
||
|
||
%{_datadir}/gimp/%{interfacever}/brushes/
|
||
%{_datadir}/gimp/%{interfacever}/fractalexplorer/
|
||
%{_datadir}/gimp/%{interfacever}/gfig/
|
||
%{_datadir}/gimp/%{interfacever}/gflare/
|
||
%{_datadir}/gimp/%{interfacever}/gimpressionist/
|
||
%{_datadir}/gimp/%{interfacever}/gradients/
|
||
# %{_datadir}/gimp/%{interfacever}/help/
|
||
%{_datadir}/gimp/%{interfacever}/images/
|
||
%{_datadir}/gimp/%{interfacever}/palettes/
|
||
%{_datadir}/gimp/%{interfacever}/patterns/
|
||
%{_datadir}/gimp/%{interfacever}/scripts/
|
||
%{_datadir}/gimp/%{interfacever}/themes/
|
||
|
||
%dir %{_sysconfdir}/gimp
|
||
%dir %{_sysconfdir}/gimp/%{interfacever}
|
||
%config(noreplace) %{_sysconfdir}/gimp/%{interfacever}/controllerrc
|
||
%config(noreplace) %{_sysconfdir}/gimp/%{interfacever}/gimprc
|
||
#%config(noreplace) %{_sysconfdir}/gimp/%{interfacever}/gimprc_user
|
||
%config(noreplace) %{_sysconfdir}/gimp/%{interfacever}/gtkrc
|
||
#%config(noreplace) %{_sysconfdir}/gimp/%{interfacever}/gtkrc_user
|
||
%config(noreplace) %{_sysconfdir}/gimp/%{interfacever}/unitrc
|
||
%config(noreplace) %{_sysconfdir}/gimp/%{interfacever}/ps-menurc
|
||
%config(noreplace) %{_sysconfdir}/gimp/%{interfacever}/sessionrc
|
||
%config(noreplace) %{_sysconfdir}/gimp/%{interfacever}/templaterc
|
||
|
||
#%{_datadir}/locale/*/*/*
|
||
|
||
#%{_libdir}/libgck-%{interfacever}.so.%{age}.%{minorver}.%{microver}
|
||
#%{_libdir}/libgck-%{interfacever}.so.%{age}
|
||
%{_libdir}/libgimp-%{interfacever}.so.%{age}.%{minorver}.%{microver}
|
||
%{_libdir}/libgimp-%{interfacever}.so.%{age}
|
||
%{_libdir}/libgimpbase-%{interfacever}.so.%{age}.%{minorver}.%{microver}
|
||
%{_libdir}/libgimpbase-%{interfacever}.so.%{age}
|
||
%{_libdir}/libgimpcolor-%{interfacever}.so.%{age}.%{minorver}.%{microver}
|
||
%{_libdir}/libgimpcolor-%{interfacever}.so.%{age}
|
||
%{_libdir}/libgimpmath-%{interfacever}.so.%{age}.%{minorver}.%{microver}
|
||
%{_libdir}/libgimpmath-%{interfacever}.so.%{age}
|
||
%{_libdir}/libgimpmodule-%{interfacever}.so.%{age}.%{minorver}.%{microver}
|
||
%{_libdir}/libgimpmodule-%{interfacever}.so.%{age}
|
||
%{_libdir}/libgimpthumb-%{interfacever}.so.%{age}.%{minorver}.%{microver}
|
||
%{_libdir}/libgimpthumb-%{interfacever}.so.%{age}
|
||
%{_libdir}/libgimpui-%{interfacever}.so.%{age}.%{minorver}.%{microver}
|
||
%{_libdir}/libgimpui-%{interfacever}.so.%{age}
|
||
%{_libdir}/libgimpwidgets-%{interfacever}.so.%{age}.%{minorver}.%{microver}
|
||
%{_libdir}/libgimpwidgets-%{interfacever}.so.%{age}
|
||
#%{_libdir}/libgimpproxy-%{interfacever}.so.%{age}.%{minorver}.%{microver}
|
||
#%{_libdir}/libgimpproxy-%{interfacever}.so.%{age}
|
||
#%{_libdir}/libgimptool-%{interfacever}.so.%{age}.%{minorver}.%{microver}
|
||
#%{_libdir}/libgimptool-%{interfacever}.so.%{age}
|
||
|
||
%{_bindir}/gimp-%{binver}
|
||
%{_bindir}/gimp-remote-%{binver}
|
||
%{_bindir}/gimptool-%{interfacever}
|
||
#%{_bindir}/embedxpm
|
||
#%{_bindir}/escputil-%{interfacever}
|
||
|
||
%if %_enable_convenience
|
||
%{_bindir}/gimp
|
||
%{_bindir}/gimp-remote
|
||
%{_bindir}/gimptool
|
||
%endif
|
||
|
||
%defattr (-, root, root)
|
||
%{_mandir}/man1/gimp-%{binver}.1*
|
||
%{_mandir}/man1/gimp-remote-%{binver}.1*
|
||
%{_mandir}/man1/gimptool-%{interfacever}.1*
|
||
#%{_mandir}/man1/escputil-%{interfacever}.1.*
|
||
%{_mandir}/man5/gimprc-%{binver}.5*
|
||
|
||
%{_datadir}/icons/hicolor/48x48/apps/gimp.png
|
||
|
||
%files devel
|
||
%defattr (-, root, root, 0755)
|
||
#%{_bindir}/gimp-config-1.4
|
||
%{_libdir}/*.so
|
||
%{_libdir}/*.la
|
||
%{_libdir}/gimp/%{interfacever}/modules/*.la
|
||
|
||
%defattr (-, root, root, 0755)
|
||
%doc HACKING
|
||
%doc %{_datadir}/gtk-doc/*
|
||
%{_datadir}/aclocal/*.m4
|
||
%{_libdir}/*.a
|
||
%{_libdir}/gimp/%{interfacever}/modules/*.a
|
||
%{_includedir}/gimp-%{interfacever}
|
||
%{_libdir}/pkgconfig/*
|
||
|
||
%changelog
|
||
* Tue Mar 29 2005 Nils Philippsen <nphilipp@redhat.com>
|
||
- revert gtk requirement change
|
||
|
||
* Mon Mar 28 2005 Matthias Clasen <mclasen@redhat.com>
|
||
- Rebuild against newer libexif
|
||
|
||
* Mon Mar 28 2005 Christopher Aillon <caillon@redhat.com>
|
||
- rebuilt
|
||
|
||
* Fri Mar 25 2005 Christopher Aillon <caillon@redhat.com>
|
||
- Update the GTK+ theme icon cache on (un)install
|
||
|
||
* Tue Mar 22 2005 Nils Philippsen <nphilipp@redhat.com>
|
||
- install convenience symlinks for man pages
|
||
|
||
* Fri Mar 11 2005 Nils Philippsen <nphilipp@redhat.com>
|
||
- don't refer to freefonts and sharefonts in %%description
|
||
|
||
* Wed Mar 09 2005 Nils Philippsen <nphilipp@redhat.com>
|
||
- prevent gifload plugin from crashing when loading files with bogus frame size
|
||
(#150677, #150678)
|
||
|
||
* Wed Mar 02 2005 Nils Philippsen <nphilipp@redhat.com>
|
||
- don't barf when building with gcc 4.0
|
||
|
||
* Wed Feb 23 2005 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.2.4
|
||
- require newer versions of gtk2 (#143840), glib2 and pango
|
||
|
||
* Sat Jan 29 2005 Nils Philippsen <nphilipp@redhat.com>
|
||
- make desktop icon themeable (#146486)
|
||
|
||
* Mon Jan 24 2005 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.2.3
|
||
- remove exifmarkerlength patch (improved version applied upstream)
|
||
|
||
* Mon Jan 17 2005 Nils Philippsen <nphilipp@redhat.com>
|
||
- clip thumbnail quality at 75 and don't barf on saving images at quality 0
|
||
(fix patch for #145100)
|
||
|
||
* Fri Jan 14 2005 Nils Philippsen <nphilipp@redhat.com>
|
||
- avoid writing excessively long EXIF markers (#145100)
|
||
|
||
* Tue Jan 11 2005 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.2.2
|
||
- autogenerate %%microver
|
||
|
||
* Wed Dec 29 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.2.1
|
||
- pygimp-logo.png included in tarball again
|
||
|
||
* Mon Dec 20 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.2.0
|
||
- include pygimp-logo.png missing from tarball
|
||
|
||
* Fri Dec 10 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- use xsane plugin (un)install script if available
|
||
|
||
* Mon Nov 22 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.2-pre2
|
||
|
||
* Thu Nov 18 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- obsolete fixed gimp-perl version to be able to reintroduce it at a
|
||
later point
|
||
- use correct dir in source URL
|
||
|
||
* Wed Nov 03 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.2-pre1
|
||
|
||
* Sun Oct 24 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- remove unnecessary echo statement
|
||
|
||
* Fri Oct 15 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.1.7 unstable
|
||
|
||
* Thu Oct 14 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- catch wrong values of bpp in BMP plugin (#135675), don't forget 1bpp and
|
||
24bpp (d'oh)
|
||
|
||
* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com>
|
||
- PreReq desktop-file-utils >= 0.9
|
||
|
||
* Sun Sep 26 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- fix post/postun requirements
|
||
|
||
* Sat Sep 25 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.0.5
|
||
|
||
* Thu Sep 16 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- rename desktop title (#132548)
|
||
|
||
* Thu Aug 26 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- add MimeType to desktop file
|
||
- run update-desktop-database in %%post/%%postun
|
||
- don't make stunts with -32 or -64 postfixed binaries anymore
|
||
- require /sbin/ldconfig and /usr/bin/update-desktop-database
|
||
|
||
* Tue Aug 10 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- build requires libwmf-devel
|
||
|
||
* Fri Aug 06 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.0.4
|
||
|
||
* Wed Aug 04 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- rebuild to pick up new libcroco
|
||
|
||
* Thu Jul 22 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.0.3
|
||
- buildreq gtk2-devel >= 2.4.0
|
||
- use -32 or -64 postfixed binaries if available
|
||
|
||
* Fri Jul 02 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- use included desktop (#126723), application-registry, mime-info and
|
||
icon files
|
||
- remove perl cruft (Gimp-Perl is an external package now)
|
||
- further spec file cleaning
|
||
|
||
* Thu Jun 24 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.0.2
|
||
- fix summary (#126682)
|
||
|
||
* Tue Jun 22 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- build with gcc34 patch (sopwith)
|
||
|
||
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||
- rebuilt
|
||
|
||
* Mon May 31 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- rebuild for Rawhide
|
||
|
||
* Wed May 26 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- add libjpeg-devel to BuildRequires (#121236)
|
||
- spit out slightly more informative help message if gimp-help is missing
|
||
(#124307)
|
||
|
||
* Fri May 21 2004 Matthias Clasen <mclasen@redhat.com>
|
||
- rebuild
|
||
|
||
* Wed Apr 21 2004 Seth Nickell <snickell@redhat.com>
|
||
- Rename menu entry for .desktop file to "GIMP Image Editor"
|
||
|
||
* Tue Apr 20 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- update BuildRequires/Requires (#121236)
|
||
|
||
* Wed Apr 14 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.0.1
|
||
|
||
* Sun Mar 28 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- fix slide script-fu
|
||
|
||
* Sat Mar 27 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- bump some Build/Requires: versions
|
||
- change desktop file to actually run gimp-2.0
|
||
|
||
* Wed Mar 24 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.0.0
|
||
|
||
* Tue Mar 23 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.0rc1
|
||
|
||
* Wed Mar 17 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.0pre4
|
||
|
||
* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
|
||
- rebuilt
|
||
|
||
* Wed Feb 18 2004 Tim Waugh <twaugh@redhat.com>
|
||
- Added epoch to gimp-perl obsoletes tag.
|
||
|
||
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||
- rebuilt
|
||
|
||
* Fri Feb 13 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- fix typo in %%_enable_print macro
|
||
- install convenience symlinks (gimp, gimp-remote, gimptool)
|
||
|
||
* Sun Feb 08 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- require gtk2, glib2 >= 2.3.0, pango >= 1.3.0
|
||
|
||
* Fri Feb 06 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.0pre3
|
||
- update buildroot patch
|
||
- enable building static libs (old default)
|
||
- have '--define'able enable_*
|
||
- disable building of print plugin, it's in another package
|
||
|
||
* Fri Jan 30 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- rebuild against new libcroco
|
||
|
||
* Sat Jan 24 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- require %%{epoch}:%%{version}-%%{release} of base package in sub packages
|
||
- rather use %%{?smp_mflags} to actually exploit SMP build systems
|
||
|
||
* Fri Jan 23 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- set epoch to 1 to upgrade old gimp rpms
|
||
- obsolete gimp2-devel, gimp-beta-devel to allow upgrade of 3rd party repo
|
||
packages, gimp-perl to upgrade old package
|
||
|
||
* Fri Jan 23 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- fix binary name in desktop file ("gimp-1.3" until gimp-2.0 becomes final, to
|
||
allow coexistence with old gimp-1.x packages)
|
||
- system intltool buildrequires perl-XML-Parser, work around that, yay
|
||
|
||
* Thu Jan 22 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- build as gimp, not gimp-beta
|
||
- remove all the beta blurbs
|
||
- fix automake dependency
|
||
- fix libtool usage
|
||
|
||
* Tue Jan 20 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.0pre2
|
||
|
||
* Sun Jan 11 2004 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 2.0pre1
|
||
|
||
* Tue Nov 25 2003 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 1.3.23 beta
|
||
|
||
* Fri Nov 21 2003 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 1.3.22 beta
|
||
|
||
* Thu Oct 16 2003 Nils Philippsen <nphilipp@redhat.com>
|
||
- leave gtk-doc documentation in place
|
||
- move gimptool to main package
|
||
- own some directories previously not owned
|
||
|
||
* Tue Oct 07 2003 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 1.3.21 beta
|
||
|
||
* Thu Sep 11 2003 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 1.3.20 beta
|
||
|
||
* Mon Aug 11 2003 Nils Philippsen <nphilipp@redhat.com>
|
||
- version 1.3.18 beta
|
||
|
||
* Thu Jul 10 2003 Nils Philippsen <nphilipp@redhat.com>
|
||
- don't specify file modes with defattr
|
||
|
||
* Wed Jul 09 2003 Nils Philippsen <nphilipp@redhat.com>
|
||
- use system libtool
|
||
|
||
* Fri Jul 04 2003 Nils Philippsen <nils@redhat.de>
|
||
- version 1.3.16 beta
|
||
- update buildroot patch
|
||
|
||
* Tue Mar 25 2003 Nils Philippsen <nils@lisas.de>
|
||
- version 1.3.13 beta
|
||
- use automake-1.7
|
||
|
||
* Tue Feb 18 2003 Nils Philippsen <nils@lisas.de>
|
||
- version 1.3.12 beta
|
||
|
||
* Fri Oct 25 2002 Nils Philippsen <nils@lisas.de>
|
||
- version 1.3.9 beta
|
||
- move desktop file to /usr/share/applications
|
||
|
||
* Wed Aug 28 2002 Nils Philippsen <nils@redhat.de>
|
||
- version 1.3.8 beta
|
||
- update and fix buildroot patch, don't run automake/autoconf
|
||
|
||
* Mon Jul 08 2002 Nils Philippsen <nils@redhat.de>
|
||
- version 1.3.7 beta
|
||
- use automake 1.5 and autoconf 2.53
|
||
|
||
* Fri Mar 15 2002 Nils Philippsen <nils@redhat.de>
|
||
- version 1.3.4 beta
|
||
|
||
* Thu Jul 19 2001 Tim Powers <timp@redhat.com>
|
||
- remove the perl temp files to pacify rpmlint
|
||
|
||
* Tue Jun 19 2001 Matt Wilson <msw@redhat.com>
|
||
- added versioned requires to gimp-devel and gimp-perl
|
||
|
||
* Tue Apr 3 2001 Matt Wilson <msw@redhat.com>
|
||
- added gimp-1.2.1-locale.patch, which I've checked in to gimp CVS, to
|
||
correctly set up the locale in plug-ins (#34214)
|
||
|
||
* Mon Apr 2 2001 Preston Brown <pbrown@redhat.com>
|
||
- some gimp-perl files weren't defattr'd (#34325)
|
||
|
||
* Fri Mar 30 2001 Trond Eivind Glomsr<73>d <teg@redhat.com>
|
||
- Don't include embedxpm, as it depends on a non-included perl module (#=33249)
|
||
- move gimpdoc and xcftopnm to gimp-perl, as they are dependant on the perl Gimp
|
||
module
|
||
|
||
* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
|
||
- Rebuild for GTK+-1.2.9 include paths
|
||
|
||
* Mon Jan 22 2001 Matt Wilson <msw@redhat.com>
|
||
- 1.2.1
|
||
|
||
* Mon Dec 25 2000 Matt Wilson <msw@redhat.com>
|
||
- 1.2.0
|
||
|
||
* Wed Dec 20 2000 Matt Wilson <msw@redhat.com>
|
||
- 1.1.31
|
||
|
||
* Thu Dec 14 2000 Matt Wilson <msw@redhat.com>
|
||
- 1.1.30
|
||
- merge changes from CVS into rpm-4.0 style spec file
|
||
- removed va_arg patch
|
||
|
||
* Mon Aug 21 2000 Matt Wilson <msw@redhat.com>
|
||
- 1.1.25
|
||
|
||
* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
|
||
- Up Epoch and release
|
||
|
||
* Tue Aug 8 2000 Matt Wilson <msw@redhat.com>
|
||
- fixed directory mode on %%{_defaultdocdir}/gimp-%%{version}
|
||
|
||
* Wed Aug 2 2000 Matt Wilson <msw@redhat.com>
|
||
- rebuild against new libpng
|
||
|
||
* Mon Jul 31 2000 Matt Wilson <msw@redhat.com>
|
||
- muck with modules filelist generation to avoid getting files owned by
|
||
two packages
|
||
|
||
* Mon Jul 17 2000 Matt Wilson <msw@redhat.com>
|
||
- disable aa plugin
|
||
- moved the group back to Applications/Multimedia
|
||
- added desktop entry back into the file list
|
||
|
||
* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
|
||
- automatic rebuild
|
||
|
||
* Fri Jul 1 2000 Matt Wilson <msw@redhat.com>
|
||
- 1.1.24
|
||
|
||
* Sat Jun 17 2000 Matt Wilson <msw@redhat.com>
|
||
- use root, not bin for the default owner.
|
||
|
||
* Fri Jun 16 2000 Preston Brown <pbrown@redhat.com>
|
||
- add back missing system .desktop entry
|
||
|
||
* Sat Jun 10 2000 Matt Wilson <msw@redhat.com>
|
||
- rebuilt against fixed gcc
|
||
|
||
* Mon Jun 5 2000 Matt Wilson <msw@redhat.com>
|
||
- defattr for gimp-perl
|
||
|
||
* Sun Jun 4 2000 Matt Wilson <msw@redhat.com>
|
||
- drop out all of \.a$ from the main package list
|
||
|
||
* Sat Jun 3 2000 Matt Wilson <msw@redhat.com>
|
||
- 1.1.23
|
||
- use __NO_MATH_INLINES for now on ix86
|
||
- massive FHS surgery
|
||
|
||
* Tue May 16 2000 Matt Wilson <msw@redhat.com>
|
||
- 1.1.22
|
||
|
||
* Mon Apr 24 2000 Matt Wilson <msw@redhat.com>
|
||
- 1.1.20
|
||
|
||
* Fri Apr 14 2000 Matt Wilson <msw@redhat.com>
|
||
- include subdirs in the help find
|
||
- remove gimp-help-files generation
|
||
- both gimp and gimp-perl own prefix/lib/gimp/1.1/plug-ins
|
||
- both gimp and gimp-devel own prefix/lib/gimp/1.1/modules
|
||
|
||
* Thu Apr 13 2000 Matt Wilson <msw@redhat.com>
|
||
- 1.1.19
|
||
- get all .mo files
|
||
|
||
* Wed Jan 19 2000 Gregory McLean <gregm@comstar.net>
|
||
- Version 1.1.15
|
||
|
||
* Wed Dec 22 1999 Gregory McLean <gregm@comstar.net>
|
||
- Version 1.1.14
|
||
- Added some auto %files section generation scriptlets
|
||
|
||
|