9caa47fcac
Signed-off-by: Nils Philippsen <nils@tiptoe.de>
87 lines
4.2 KiB
Diff
87 lines
4.2 KiB
Diff
diff --git a/app/tools/gimpoperationtool.c b/app/tools/gimpoperationtool.c
|
|
index 82f6096b55..f427ee9019 100644
|
|
--- a/app/tools/gimpoperationtool.c
|
|
+++ b/app/tools/gimpoperationtool.c
|
|
@@ -103,8 +103,7 @@ static void gimp_operation_tool_add_gui (GimpOperationTool *tool)
|
|
static AuxInput * gimp_operation_tool_aux_input_new (GimpOperationTool *tool,
|
|
GeglNode *operation,
|
|
const gchar *input_pad,
|
|
- const gchar *label,
|
|
- const gchar *description);
|
|
+ const gchar *label);
|
|
static void gimp_operation_tool_aux_input_detach(AuxInput *input);
|
|
static void gimp_operation_tool_aux_input_clear (AuxInput *input);
|
|
static void gimp_operation_tool_aux_input_free (AuxInput *input);
|
|
@@ -550,20 +549,15 @@ gimp_operation_tool_create_gui (GimpOperationTool *op_tool)
|
|
|
|
g_return_if_fail (regex != NULL);
|
|
|
|
- label = g_strdup (gegl_node_get_pad_label (filter_tool->operation, input_pads[i]));
|
|
-
|
|
- if (label == NULL)
|
|
- label = g_regex_replace (regex,
|
|
- input_pads[i], -1, 0,
|
|
- /* Translators: don't translate "Aux" */
|
|
- _("Aux\\1 Input"),
|
|
- 0, NULL);
|
|
+ /* Translators: don't translate "Aux" */
|
|
+ label = g_regex_replace (regex,
|
|
+ input_pads[i], -1, 0,
|
|
+ _("Aux\\1 Input"),
|
|
+ 0, NULL);
|
|
|
|
input = gimp_operation_tool_aux_input_new (op_tool,
|
|
filter_tool->operation,
|
|
- input_pads[i], label,
|
|
- gegl_node_get_pad_description (filter_tool->operation,
|
|
- input_pads[i]));
|
|
+ input_pads[i], label);
|
|
|
|
op_tool->aux_inputs = g_list_prepend (op_tool->aux_inputs, input);
|
|
|
|
@@ -663,8 +657,7 @@ static AuxInput *
|
|
gimp_operation_tool_aux_input_new (GimpOperationTool *op_tool,
|
|
GeglNode *operation,
|
|
const gchar *input_pad,
|
|
- const gchar *label,
|
|
- const gchar *description)
|
|
+ const gchar *label)
|
|
{
|
|
AuxInput *input = g_slice_new (AuxInput);
|
|
GimpContext *context;
|
|
@@ -681,8 +674,6 @@ gimp_operation_tool_aux_input_new (GimpOperationTool *op_tool,
|
|
context = GIMP_CONTEXT (GIMP_TOOL_GET_OPTIONS (op_tool));
|
|
|
|
input->box = gimp_buffer_source_box_new (context, input->node, label);
|
|
- if (description)
|
|
- gtk_widget_set_tooltip_text (input->box, description);
|
|
|
|
/* make AuxInput owner of the box */
|
|
g_object_ref_sink (input->box);
|
|
diff --git a/app/sanity.c b/app/sanity.c
|
|
index 80f9537172..cc1c0c7bd8 100644
|
|
--- a/app/sanity.c
|
|
+++ b/app/sanity.c
|
|
@@ -502,7 +502,7 @@ sanity_check_gegl (void)
|
|
|
|
#define GEGL_REQUIRED_MAJOR 0
|
|
#define GEGL_REQUIRED_MINOR 4
|
|
-#define GEGL_REQUIRED_MICRO 49
|
|
+#define GEGL_REQUIRED_MICRO 48
|
|
|
|
gegl_get_version (&gegl_major_version,
|
|
&gegl_minor_version,
|
|
diff --git a/meson.build b/meson.build
|
|
index f120965244..2605b17649 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -384,7 +384,7 @@ freetype2_minver = '2.1.7'
|
|
freetype2 = dependency('freetype2', version: '>='+freetype2_minver)
|
|
gdk_pixbuf_minver = '2.30.8'
|
|
gdk_pixbuf = dependency('gdk-pixbuf-2.0', version: '>='+gdk_pixbuf_minver)
|
|
-gegl_minver = '0.4.49'
|
|
+gegl_minver = '0.4.48'
|
|
gegl = dependency('gegl-0.4', version: '>='+gegl_minver)
|
|
exiv2_minver = '0.27.4'
|
|
exiv2 = dependency('exiv2', version: '>='+exiv2_minver)
|