45 lines
1.0 KiB
Diff
45 lines
1.0 KiB
Diff
From 1b5d01f6376d7b128e75636f3f158376f606686f Mon Sep 17 00:00:00 2001
|
|
From: Nils Philippsen <nils@redhat.com>
|
|
Date: Wed, 15 Jul 2015 17:55:45 +0200
|
|
Subject: [PATCH] patch: link-z-now
|
|
|
|
Squashed commit of the following:
|
|
|
|
commit 4483698c0444e01afce89fcf7610d29e7670a326
|
|
Author: Michael Natterer <mitch@gimp.org>
|
|
Date: Mon Feb 16 19:35:00 2015 +0100
|
|
|
|
app: link against -lm, whatever new linker version seems to need is
|
|
|
|
(cherry picked from commit 4c7338c0974096dca8566a1d570ed51fbe721ae6)
|
|
---
|
|
app/Makefile.am | 5 ++++-
|
|
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/app/Makefile.am b/app/Makefile.am
|
|
index 243f08a..f3f5ba5 100644
|
|
--- a/app/Makefile.am
|
|
+++ b/app/Makefile.am
|
|
@@ -95,6 +95,8 @@ endif
|
|
|
|
if OS_WIN32
|
|
win32_ldflags = -mwindows -Wl,--tsaware $(WIN32_LARGE_ADDRESS_AWARE)
|
|
+else
|
|
+libm = -lm
|
|
endif
|
|
|
|
if USE_BINRELOC
|
|
@@ -181,7 +183,8 @@ gimpconsoleldadd = \
|
|
$(GEGL_LIBS) \
|
|
$(GLIB_LIBS) \
|
|
$(INTLLIBS) \
|
|
- $(RT_LIBS)
|
|
+ $(RT_LIBS) \
|
|
+ $(libm)
|
|
|
|
gimp_2_8_LDFLAGS = \
|
|
$(AM_LDFLAGS) \
|
|
--
|
|
2.4.3
|
|
|