plugins/script-fu: add missing explicit libraries
This commit is contained in:
parent
a63f72293d
commit
e4503b975e
@ -1,10 +1,16 @@
|
||||
From 22e091bebc9e4eac7c9f2f8a3928618d6fb0e334 Mon Sep 17 00:00:00 2001
|
||||
From ac973162e15a9aef0c39a28207f185fd12e7f1de Mon Sep 17 00:00:00 2001
|
||||
From: Nils Philippsen <nils@redhat.com>
|
||||
Date: Wed, 24 Feb 2010 12:51:01 +0100
|
||||
Date: Wed, 24 Feb 2010 15:43:26 +0100
|
||||
Subject: [PATCH] patch: gold
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit abbb6a2472e7e31e3aaa30c772f8f5dbaaf476c5
|
||||
Author: Nils Philippsen <nils@redhat.com>
|
||||
Date: Wed Feb 24 15:40:50 2010 +0100
|
||||
|
||||
script-fu: explicitly specify library dependencies
|
||||
|
||||
commit da5ee1fe718d9bbbda6c786ebf0f4ded43a7a246
|
||||
Author: Manish Singh <yosh@gimp.org>
|
||||
Date: Wed Sep 9 17:41:20 2009 -0700
|
||||
@ -30,7 +36,8 @@ Date: Sun May 24 10:42:39 2009 -0700
|
||||
plug-ins/common/mkgen.pl | 11 ++++++-----
|
||||
plug-ins/help-browser/Makefile.am | 1 +
|
||||
plug-ins/metadata/Makefile.am | 5 ++++-
|
||||
5 files changed, 21 insertions(+), 12 deletions(-)
|
||||
plug-ins/script-fu/Makefile.am | 14 ++++++++------
|
||||
6 files changed, 29 insertions(+), 18 deletions(-)
|
||||
|
||||
diff --git a/libgimpthumb/Makefile.am b/libgimpthumb/Makefile.am
|
||||
index 2e7b531..ee26219 100644
|
||||
@ -144,6 +151,40 @@ index dd9bb3d..935b069 100644
|
||||
$(GTK_LIBS) \
|
||||
$(RT_LIBS) \
|
||||
$(INTLLIBS)
|
||||
diff --git a/plug-ins/script-fu/Makefile.am b/plug-ins/script-fu/Makefile.am
|
||||
index 3075b83..824d62d 100644
|
||||
--- a/plug-ins/script-fu/Makefile.am
|
||||
+++ b/plug-ins/script-fu/Makefile.am
|
||||
@@ -1,21 +1,23 @@
|
||||
## Process this file with automake to produce Makefile.in
|
||||
|
||||
+if OS_WIN32
|
||||
+mwindows = -mwindows
|
||||
+WINSOCK_LIBS = -lws2_32
|
||||
+else
|
||||
+libm = -lm
|
||||
+endif
|
||||
+
|
||||
libgimpui = $(top_builddir)/libgimp/libgimpui-$(GIMP_API_VERSION).la
|
||||
libgimpwidgets = $(top_builddir)/libgimpwidgets/libgimpwidgets-$(GIMP_API_VERSION).la
|
||||
libgimp = $(top_builddir)/libgimp/libgimp-$(GIMP_API_VERSION).la
|
||||
libgimpcolor = $(top_builddir)/libgimpcolor/libgimpcolor-$(GIMP_API_VERSION).la
|
||||
libgimpbase = $(top_builddir)/libgimpbase/libgimpbase-$(GIMP_API_VERSION).la
|
||||
libgimpconfig = $(top_builddir)/libgimpconfig/libgimpconfig-$(GIMP_API_VERSION).la
|
||||
-libgimpmath = $(top_builddir)/libgimpmath/libgimpmath-$(GIMP_API_VERSION).la
|
||||
+libgimpmath = $(top_builddir)/libgimpmath/libgimpmath-$(GIMP_API_VERSION).la $(libm)
|
||||
|
||||
libtinyscheme=tinyscheme/libtinyscheme.a
|
||||
libftx=ftx/libftx.a
|
||||
|
||||
-if OS_WIN32
|
||||
-mwindows = -mwindows
|
||||
-WINSOCK_LIBS = -lws2_32
|
||||
-endif
|
||||
-
|
||||
AM_CFLAGS = \
|
||||
-DSTANDALONE=0 \
|
||||
-DUSE_INTERFACE=1 \
|
||||
--
|
||||
1.6.6.1
|
||||
|
||||
|
@ -505,6 +505,7 @@ fi
|
||||
%changelog
|
||||
* Wed Feb 24 2010 Nils Philippsen <nils@redhat.com> - 2:2.6.8-4
|
||||
- backport: fix building with "gold" linker
|
||||
- add missing explicit libraries
|
||||
|
||||
* Wed Jan 27 2010 Nils Philippsen <nils@redhat.com> - 2:2.6.8-3
|
||||
- remove wrong dependency (#558836)
|
||||
|
Loading…
Reference in New Issue
Block a user