backport fix for saving indexed PNM files (#605615)

This commit is contained in:
Nils Philippsen 2010-06-18 14:24:54 +00:00
parent b2191576bb
commit c31a9c9609
2 changed files with 60 additions and 0 deletions

View File

@ -0,0 +1,54 @@
From 2bb143afdefb20b51ed6643f84e4862482d0e7dc Mon Sep 17 00:00:00 2001
From: Nils Philippsen <nils@redhat.com>
Date: Fri, 18 Jun 2010 16:20:51 +0200
Subject: [PATCH] patch: indexed-pnm
Squashed commit of the following:
commit 83e5714e44d4c14ff162de2450a311dcbeb10ce7
Author: Sven Neumann <sven@gimp.org>
Date: Sat Jan 9 12:12:12 2010 +0100
Bug 606372 - Saving to .ppm fails on indexed colorspace
Don't change the pointer to the colormap and then attempt to free it.
(cherry picked from commit b883d59411dfde28fb0704fa2790e602999f7f6f)
---
plug-ins/common/file-pnm.c | 11 ++++++-----
1 files changed, 6 insertions(+), 5 deletions(-)
diff --git a/plug-ins/common/file-pnm.c b/plug-ins/common/file-pnm.c
index 2cd8443..8359f0a 100644
--- a/plug-ins/common/file-pnm.c
+++ b/plug-ins/common/file-pnm.c
@@ -1103,13 +1103,14 @@ save_image (const gchar *filename,
}
else
{
- gint i;
+ const guchar *c = cmap;
+ gint i;
for (i = 0; i < num_colors; i++)
{
- red[i] = *cmap++;
- grn[i] = *cmap++;
- blu[i] = *cmap++;
+ red[i] = *c++;
+ grn[i] = *c++;
+ blu[i] = *c++;
}
rowinfo.red = red;
@@ -1155,7 +1156,7 @@ save_image (const gchar *filename,
d = data;
}
- (*saverow)(&rowinfo, d);
+ saverow (&rowinfo, d);
d += xres * (np ? np : 1);
if ((ypos % 20) == 0)
--
1.7.0.1

View File

@ -132,6 +132,8 @@ Patch3: gimp-2.6.8-gold.patch
Patch4: gimp-2.6.8-gtk219.patch
# distro-specific: add --stack-trace-mode=never to desktop file
Patch5: gimp-2.6.8-never-stack-trace-desktop.patch
# backport: fix saving indexed PNM files (#605615)
Patch6: gimp-2.6.8-indexed-pnm.patch
# Makefile.in files generated by Makefile.am changed in patches
Patch10: gimp-2.6.8-4-automake.patch.bz2
@ -219,6 +221,7 @@ EOF
%patch3 -p1 -b .gold
%patch4 -p1 -b .gtk219
%patch5 -p1 -b .never-stack-trace-desktop
%patch6 -p1 -b .indexed-pnm
%patch10 -p1 -b .automake
%build
@ -510,6 +513,9 @@ fi
%{_libdir}/gimp/%{interfacever}/plug-ins/help-browser
%changelog
* Fri Jun 18 2010 Nils Philippsen <nils@redhat.com> - 2:2.6.8-8
- backport fix for saving indexed PNM files (#605615)
* Mon Apr 19 2010 Nils Philippsen <nils@redhat.com> - 2:2.6.8-7
- add --stack-trace-mode=never to desktop file