fix linking problem
This commit is contained in:
parent
04067b59cd
commit
ac238f701f
1
.gitignore
vendored
1
.gitignore
vendored
@ -19,3 +19,4 @@ gimp-2.6.10-1-autoreconf.patch.bz2
|
||||
/gimp-2.8.10.tar.bz2
|
||||
/gimp-2.8.12.tar.bz2
|
||||
/gimp-2.8.14.tar.bz2
|
||||
/gimp-2.8.14-2-autofoo.patch.xz
|
||||
|
44
gimp-2.8.14-link-z-now.patch
Normal file
44
gimp-2.8.14-link-z-now.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From 1b5d01f6376d7b128e75636f3f158376f606686f Mon Sep 17 00:00:00 2001
|
||||
From: Nils Philippsen <nils@redhat.com>
|
||||
Date: Wed, 15 Jul 2015 17:55:45 +0200
|
||||
Subject: [PATCH] patch: link-z-now
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit 4483698c0444e01afce89fcf7610d29e7670a326
|
||||
Author: Michael Natterer <mitch@gimp.org>
|
||||
Date: Mon Feb 16 19:35:00 2015 +0100
|
||||
|
||||
app: link against -lm, whatever new linker version seems to need is
|
||||
|
||||
(cherry picked from commit 4c7338c0974096dca8566a1d570ed51fbe721ae6)
|
||||
---
|
||||
app/Makefile.am | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/app/Makefile.am b/app/Makefile.am
|
||||
index 243f08a..f3f5ba5 100644
|
||||
--- a/app/Makefile.am
|
||||
+++ b/app/Makefile.am
|
||||
@@ -95,6 +95,8 @@ endif
|
||||
|
||||
if OS_WIN32
|
||||
win32_ldflags = -mwindows -Wl,--tsaware $(WIN32_LARGE_ADDRESS_AWARE)
|
||||
+else
|
||||
+libm = -lm
|
||||
endif
|
||||
|
||||
if USE_BINRELOC
|
||||
@@ -181,7 +183,8 @@ gimpconsoleldadd = \
|
||||
$(GEGL_LIBS) \
|
||||
$(GLIB_LIBS) \
|
||||
$(INTLLIBS) \
|
||||
- $(RT_LIBS)
|
||||
+ $(RT_LIBS) \
|
||||
+ $(libm)
|
||||
|
||||
gimp_2_8_LDFLAGS = \
|
||||
$(AM_LDFLAGS) \
|
||||
--
|
||||
2.4.3
|
||||
|
13
gimp.spec
13
gimp.spec
@ -207,6 +207,13 @@ Patch1: gimp-2.8.2-cm-system-monitor-profile-by-default.patch
|
||||
# Upstream commit 908f4e69d656e5a1cd4b23310a16e287e8ae72f7.
|
||||
Patch2: gimp-2.8.14-export-dialog-destroyed-crash.patch
|
||||
|
||||
# New linker flags need this.
|
||||
# Upstream commit 670fb5602d097be5b53654ff100dbd98bc11cb28.
|
||||
Patch3: gimp-2.8.14-link-z-now.patch
|
||||
|
||||
# Rebuilt autofoo files
|
||||
Patch50: gimp-2.8.14-2-autofoo.patch.xz
|
||||
|
||||
# use external help browser directly if help browser plug-in is not built
|
||||
Patch100: gimp-2.8.6-external-help-browser.patch
|
||||
|
||||
@ -297,6 +304,9 @@ EOF
|
||||
|
||||
%patch1 -p1 -b .cm-system-monitor-profile-by-default
|
||||
%patch2 -p1 -b .export-dialog-destroyed-crash
|
||||
%patch3 -p1 -b .link-z-now
|
||||
|
||||
%patch50 -p1 -b .autofoo
|
||||
|
||||
%if ! %{with helpbrowser}
|
||||
%patch100 -p1 -b .external-help-browser
|
||||
@ -658,6 +668,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jul 14 2015 Nils Philippsen <nils@redhat.com> - 2:2.8.14-2
|
||||
- fix linking problem
|
||||
|
||||
* Tue Jul 14 2015 Nils Philippsen <nils@redhat.com> - 2:2.8.14-2
|
||||
- avoid destroying dialog and occasional crashes while exporting (#1215905)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user