Update to a 2024-08-22 git snapshot

Signed-off-by: Nils Philippsen <nils@tiptoe.de>
This commit is contained in:
Nils Philippsen 2024-08-22 16:34:47 +02:00
parent edcc3d0259
commit 9caa47fcac
5 changed files with 30 additions and 77 deletions

1
.gitignore vendored
View File

@ -46,3 +46,4 @@ gimp-2.6.10-1-autoreconf.patch.bz2
/gimp-2.99.19-gitd38362c9a0.tar.xz
/gimp-splash.png
/gimp-2.99.19-git5814d9ed30.tar.xz
/gimp-2.99.19-git4542c0156e.tar.xz

View File

@ -1,48 +0,0 @@
From c7e1b11bed0d001323471e774564f065bcfd62f6 Mon Sep 17 00:00:00 2001
From: Nils Philippsen <nils@tiptoe.de>
Date: Mon, 19 Aug 2024 16:16:31 +0200
Subject: [PATCH] libgimp: Use namespaced doc reference
Otherwise, building the devel docs errors out like this:
```
FAILED: devel-docs/reference/gimp/libgimp-3.0
...
WARNING: Unknown namespace ExportReturn
[enum@ExportReturn.EXPORT].
^~~~~~~~~~~~~~~~~~~~~~~~~~
```
Signed-off-by: Nils Philippsen <nils@tiptoe.de>
---
libgimp/gimpexportoptions.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/libgimp/gimpexportoptions.c b/libgimp/gimpexportoptions.c
index 22fca36c2d..5ffae2a1b1 100644
--- a/libgimp/gimpexportoptions.c
+++ b/libgimp/gimpexportoptions.c
@@ -537,17 +537,17 @@ export_action_perform (const ExportAction *action,
*
* If necessary, a copy is created, converted and modified, @image
* changed to point to the new image and the procedure returns
- * [enum@ExportReturn.EXPORT].
+ * [enum@Gimp.ExportReturn.EXPORT].
* In this case, you must take care of deleting the created image using
* [method@Image.delete] once the image has been exported, unless you
* were planning to display it with [ctor@Display.new], or you will leak
* memory.
*
- * If [enum@ExportReturn.IGNORE] is returned, then @image is still the
+ * If [enum@Gimp.ExportReturn.IGNORE] is returned, then @image is still the
* original image. You should neither modify it, nor should you delete
* it in the end. If you wish to temporarily modify the image before
* export anyway, call [method@Image.duplicate] when
- * [enum@ExportReturn.IGNORE] was returned.
+ * [enum@Gimp.ExportReturn.IGNORE] was returned.
*
* Returns: An enum of #GimpExportReturn.
*
--
2.46.0

View File

@ -1,19 +1,3 @@
From 54231e7d405bfd674f75f2d87ff5ce3ad025b45c Mon Sep 17 00:00:00 2001
From: Nils Philippsen <nils@tiptoe.de>
Date: Wed, 14 Aug 2024 13:44:21 +0200
Subject: [PATCH] =?UTF-8?q?Don=E2=80=99t=20require=20unreleased=20gegl=20v?=
=?UTF-8?q?ersion?=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
This reverts commit c28fa121480d2ea34139c9cc794add4236e99eb7.
Signed-off-by: Nils Philippsen <nils@tiptoe.de>
---
app/tools/gimpoperationtool.c | 25 ++++++++-----------------
1 file changed, 8 insertions(+), 17 deletions(-)
diff --git a/app/tools/gimpoperationtool.c b/app/tools/gimpoperationtool.c
index 82f6096b55..f427ee9019 100644
--- a/app/tools/gimpoperationtool.c
@ -74,6 +58,29 @@ index 82f6096b55..f427ee9019 100644
/* make AuxInput owner of the box */
g_object_ref_sink (input->box);
--
2.46.0
diff --git a/app/sanity.c b/app/sanity.c
index 80f9537172..cc1c0c7bd8 100644
--- a/app/sanity.c
+++ b/app/sanity.c
@@ -502,7 +502,7 @@ sanity_check_gegl (void)
#define GEGL_REQUIRED_MAJOR 0
#define GEGL_REQUIRED_MINOR 4
-#define GEGL_REQUIRED_MICRO 49
+#define GEGL_REQUIRED_MICRO 48
gegl_get_version (&gegl_major_version,
&gegl_minor_version,
diff --git a/meson.build b/meson.build
index f120965244..2605b17649 100644
--- a/meson.build
+++ b/meson.build
@@ -384,7 +384,7 @@ freetype2_minver = '2.1.7'
freetype2 = dependency('freetype2', version: '>='+freetype2_minver)
gdk_pixbuf_minver = '2.30.8'
gdk_pixbuf = dependency('gdk-pixbuf-2.0', version: '>='+gdk_pixbuf_minver)
-gegl_minver = '0.4.49'
+gegl_minver = '0.4.48'
gegl = dependency('gegl-0.4', version: '>='+gegl_minver)
exiv2_minver = '0.27.4'
exiv2 = dependency('exiv2', version: '>='+exiv2_minver)

View File

@ -58,7 +58,7 @@ gimp:app / ui
Summary: GNU Image Manipulation Program
Name: gimp
Epoch: 2
Version: 2.99.19^20240819git5814d9ed30
Version: 2.99.19^20240822git4542c0156e
Release: %autorelease
# Compute some version related macros.
@ -232,13 +232,7 @@ Patch2: gimp-2.99.19-no-phone-home-default.patch
Patch3: gimp-2.99.19-external-help-browser.patch
# Dont require an unreleased gegl version
Patch4: 0001-Don-t-require-unreleased-gegl-version.patch
# Submitted upstream:
# libgimp: Use namespaced doc reference
# https://gitlab.gnome.org/GNOME/gimp/-/merge_requests/1789
Patch5: 0001-libgimp-Use-namespaced-doc-reference.patch
Patch4: gimp-2.99.19-don-t-require-unreleased-gegl-version.patch
%description
GIMP (GNU Image Manipulation Program) is a powerful image composition and
@ -303,7 +297,6 @@ EOF
%patch 2 -p1 -b .no-phone-home-default
%patch 3 -p1 -b .external-help-browser
%patch 4 -p1 -b .don-t-require-unreleased-gegl-version
%patch 5 -p1 -b .namespace-docs-refs
# Verify the splash file source hasnt changed
sha256sum -c %{SOURCE2}

View File

@ -1,2 +1,2 @@
SHA512 (gimp-2.99.19-git5814d9ed30.tar.xz) = 7a531bca4d1638d88bb9c8e83aa838e7c9941b84ae7113b193a4c9de0f12b221bce4d31196035b3f5988c31c291b935eb07477dbd637971df0ef23f2fbbbc40a
SHA512 (gimp-2.99.19-git4542c0156e.tar.xz) = 583cf4cb8150106e4f16c7ba778a17aca872610b1486d06059b1e20543293a82752fe351a069c3bad77e26a20a174327b66eb5fe92a7a6e64ad08e9879cd10ec
SHA512 (gimp-splash.png) = e4443fa1c4eaf50ce4a89681d436d9c23ccae7e3a6cac1e853bba05d851c815c59c53d52c9f3e159460d52e03b492cc48f366f6e194b7ca8c740692eb0c2d963