version 2.6.9 remove obsolete gtk219, never-stack-trace-desktop,
indexed-pnm patches don't manually provide "gimp-libs%{?_isa}" in gimp-libs don't package %{_datadir}/gtk-doc/html, but dirs beneath
This commit is contained in:
parent
361273dba7
commit
7db05d00a5
@ -1,2 +1,2 @@
|
||||
gimp-2.6.8.tar.bz2
|
||||
gimp-2.6.8-4-automake.patch.bz2
|
||||
gimp-2.6.9-1-automake.patch.bz2
|
||||
gimp-2.6.9.tar.bz2
|
||||
|
@ -1,79 +0,0 @@
|
||||
From 59f3ad346b22c85618b0c7cffcce4d1c816ca3b6 Mon Sep 17 00:00:00 2001
|
||||
From: Nils Philippsen <nils@redhat.com>
|
||||
Date: Wed, 24 Mar 2010 18:08:01 +0100
|
||||
Subject: [PATCH] patch: gtk219
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit 726878e604e663488757a3220246c2054f54b843
|
||||
Author: Nils Philippsen <nils@redhat.com>
|
||||
Date: Wed Mar 24 15:43:10 2010 +0100
|
||||
|
||||
backport statusbar code needed for GTK+ >= 2.19.1
|
||||
|
||||
Use the hbox that is provided via gtk_statusbar_get_message_area()
|
||||
since GTK+ 2.19.1.
|
||||
---
|
||||
app/display/gimpstatusbar.c | 32 +++++++++++++++++++++++++-------
|
||||
1 files changed, 25 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/app/display/gimpstatusbar.c b/app/display/gimpstatusbar.c
|
||||
index 5e89427..36651cd 100644
|
||||
--- a/app/display/gimpstatusbar.c
|
||||
+++ b/app/display/gimpstatusbar.c
|
||||
@@ -49,6 +49,9 @@
|
||||
/* maximal width of the string holding the cursor-coordinates */
|
||||
#define CURSOR_LEN 256
|
||||
|
||||
+/* the spacing of the hbox */
|
||||
+#define HBOX_SPACING 1
|
||||
+
|
||||
/* spacing between the icon and the statusbar label */
|
||||
#define ICON_SPACING 2
|
||||
|
||||
@@ -152,6 +155,7 @@ static void
|
||||
gimp_statusbar_init (GimpStatusbar *statusbar)
|
||||
{
|
||||
GtkWidget *hbox;
|
||||
+ GtkWidget *label;
|
||||
GtkWidget *image;
|
||||
GimpUnitStore *store;
|
||||
|
||||
@@ -171,13 +175,27 @@ gimp_statusbar_init (GimpStatusbar *statusbar)
|
||||
statusbar->progress_active = FALSE;
|
||||
statusbar->progress_shown = FALSE;
|
||||
|
||||
- /* remove the label and insert a hbox */
|
||||
- gtk_container_remove (GTK_CONTAINER (GTK_STATUSBAR (statusbar)->frame),
|
||||
- g_object_ref (GTK_STATUSBAR (statusbar)->label));
|
||||
-
|
||||
- hbox = gtk_hbox_new (FALSE, 1);
|
||||
- gtk_container_add (GTK_CONTAINER (GTK_STATUSBAR (statusbar)->frame), hbox);
|
||||
- gtk_widget_show (hbox);
|
||||
+ label = g_object_ref (GTK_STATUSBAR (statusbar)->label);
|
||||
+
|
||||
+ /* remove the message area or label and insert a hbox */
|
||||
+#if GTK_CHECK_VERSION (2, 19, 1)
|
||||
+ {
|
||||
+ hbox = gtk_statusbar_get_message_area (GTK_STATUSBAR (statusbar));
|
||||
+ gtk_box_set_spacing (GTK_BOX (hbox), HBOX_SPACING);
|
||||
+ gtk_container_remove (GTK_CONTAINER (hbox), label);
|
||||
+ }
|
||||
+#else
|
||||
+ {
|
||||
+ GtkWidget *label_parent;
|
||||
+
|
||||
+ label_parent = gtk_widget_get_parent (label);
|
||||
+ gtk_container_remove (GTK_CONTAINER (label_parent), label);
|
||||
+
|
||||
+ hbox = gtk_hbox_new (FALSE, HBOX_SPACING);
|
||||
+ gtk_container_add (GTK_CONTAINER (label_parent), hbox);
|
||||
+ gtk_widget_show (hbox);
|
||||
+ }
|
||||
+#endif
|
||||
|
||||
statusbar->cursor_label = gtk_label_new ("8888, 8888");
|
||||
gtk_misc_set_alignment (GTK_MISC (statusbar->cursor_label), 0.5, 0.5);
|
||||
--
|
||||
1.6.6.1
|
||||
|
@ -1,54 +0,0 @@
|
||||
From 2bb143afdefb20b51ed6643f84e4862482d0e7dc Mon Sep 17 00:00:00 2001
|
||||
From: Nils Philippsen <nils@redhat.com>
|
||||
Date: Fri, 18 Jun 2010 16:20:51 +0200
|
||||
Subject: [PATCH] patch: indexed-pnm
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit 83e5714e44d4c14ff162de2450a311dcbeb10ce7
|
||||
Author: Sven Neumann <sven@gimp.org>
|
||||
Date: Sat Jan 9 12:12:12 2010 +0100
|
||||
|
||||
Bug 606372 - Saving to .ppm fails on indexed colorspace
|
||||
|
||||
Don't change the pointer to the colormap and then attempt to free it.
|
||||
(cherry picked from commit b883d59411dfde28fb0704fa2790e602999f7f6f)
|
||||
---
|
||||
plug-ins/common/file-pnm.c | 11 ++++++-----
|
||||
1 files changed, 6 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/plug-ins/common/file-pnm.c b/plug-ins/common/file-pnm.c
|
||||
index 2cd8443..8359f0a 100644
|
||||
--- a/plug-ins/common/file-pnm.c
|
||||
+++ b/plug-ins/common/file-pnm.c
|
||||
@@ -1103,13 +1103,14 @@ save_image (const gchar *filename,
|
||||
}
|
||||
else
|
||||
{
|
||||
- gint i;
|
||||
+ const guchar *c = cmap;
|
||||
+ gint i;
|
||||
|
||||
for (i = 0; i < num_colors; i++)
|
||||
{
|
||||
- red[i] = *cmap++;
|
||||
- grn[i] = *cmap++;
|
||||
- blu[i] = *cmap++;
|
||||
+ red[i] = *c++;
|
||||
+ grn[i] = *c++;
|
||||
+ blu[i] = *c++;
|
||||
}
|
||||
|
||||
rowinfo.red = red;
|
||||
@@ -1155,7 +1156,7 @@ save_image (const gchar *filename,
|
||||
d = data;
|
||||
}
|
||||
|
||||
- (*saverow)(&rowinfo, d);
|
||||
+ saverow (&rowinfo, d);
|
||||
d += xres * (np ? np : 1);
|
||||
|
||||
if ((ypos % 20) == 0)
|
||||
--
|
||||
1.7.0.1
|
||||
|
@ -1,32 +0,0 @@
|
||||
From 0939c40c21d6750e5d65f2c2b34bf8caaad263f5 Mon Sep 17 00:00:00 2001
|
||||
From: Nils Philippsen <nils@redhat.com>
|
||||
Date: Mon, 19 Apr 2010 18:05:41 +0200
|
||||
Subject: [PATCH] patch: never-stack-trace-desktop
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit 9cb13a72dea56cc16d92b2c71ae16803d229b4ec
|
||||
Author: Nils Philippsen <nils@redhat.com>
|
||||
Date: Mon Apr 19 18:04:19 2010 +0200
|
||||
|
||||
add --stack-trace-mode=never to desktop file
|
||||
---
|
||||
desktop/gimp.desktop.in.in | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/desktop/gimp.desktop.in.in b/desktop/gimp.desktop.in.in
|
||||
index 776e4ee..639e987 100644
|
||||
--- a/desktop/gimp.desktop.in.in
|
||||
+++ b/desktop/gimp.desktop.in.in
|
||||
@@ -4,7 +4,7 @@ Type=Application
|
||||
_Name=GNU Image Manipulation Program
|
||||
_GenericName=Image Editor
|
||||
_Comment=Create images and edit photographs
|
||||
-Exec=@GIMP_COMMAND@ %U
|
||||
+Exec=@GIMP_COMMAND@ --stack-trace-mode=never %U
|
||||
TryExec=gimp-@GIMP_APP_VERSION@
|
||||
Icon=gimp
|
||||
Terminal=false
|
||||
--
|
||||
1.6.6.1
|
||||
|
@ -1,79 +0,0 @@
|
||||
#!/bin/bash
|
||||
|
||||
shopt -s nullglob
|
||||
|
||||
GIMPPLUGINDIR="@GIMPPLUGINDIR@"
|
||||
EXITVAL=0
|
||||
|
||||
showhelp () {
|
||||
cat << EOF
|
||||
Usage: gimp-plugin-mgr <mode> [<pluginname> [<pluginname> [...]]
|
||||
Mode can be:
|
||||
--install|-i: install plugin(s)
|
||||
--uninstall|-u: uninstall plugin(s)
|
||||
--help|-h: show this message
|
||||
EOF
|
||||
}
|
||||
|
||||
install_uninstall () {
|
||||
local action="$1"
|
||||
shift
|
||||
local plugins="$@"
|
||||
pushd "$GIMPPLUGINDIR/plug-ins" >&/dev/null
|
||||
if [ "$plugins" == "*" ]; then
|
||||
pushd "/etc/gimp/plugins.d" >&/dev/null
|
||||
plugins=""
|
||||
for file in *; do
|
||||
plugins="$plugins ${file%.conf}"
|
||||
done
|
||||
popd >&/dev/null
|
||||
fi
|
||||
|
||||
for plugin in $plugins; do
|
||||
PLUGINFILE=
|
||||
if [ ! -r "/etc/gimp/plugins.d/${plugin}.conf" ]; then
|
||||
echo "gimp-plugin-mgr: can't read /etc/gimp/plugins.d/${plugin}.conf" >&2
|
||||
EXITVAL=$(( $EXITVAL + 1 ))
|
||||
continue
|
||||
fi
|
||||
. "/etc/gimp/plugins.d/${plugin}.conf"
|
||||
case "$action" in
|
||||
install)
|
||||
if [ ! "$PLUGINFILE" ]; then
|
||||
echo "gimp-plugin-mgr: PLUGINFILE not defined for $plugin" >&2
|
||||
EXITVAL=$(( $EXITVAL + 1 ))
|
||||
continue
|
||||
fi
|
||||
ln -snf "$PLUGINFILE" "$GIMPPLUGINDIR/plug-ins/$plugin"
|
||||
;;
|
||||
uninstall)
|
||||
if [ ! -L "$GIMPPLUGINDIR/plug-ins/$plugin" ]; then
|
||||
echo "gimp-plugin-mgr: $GIMPPLUGINDIR/plug-ins/$plugin not a symbolic link" >&2
|
||||
EXITVAL=$(( $EXITVAL + 1 ))
|
||||
continue
|
||||
fi
|
||||
rm -f "$plugin"
|
||||
;;
|
||||
esac
|
||||
done
|
||||
popd >&/dev/null
|
||||
}
|
||||
|
||||
case "$1" in
|
||||
--install|-i)
|
||||
shift
|
||||
install_uninstall install "$@"
|
||||
;;
|
||||
--uninstall|-u)
|
||||
shift
|
||||
install_uninstall uninstall "$@"
|
||||
;;
|
||||
*)
|
||||
if [ "$1" != "--help" -a "$1" != "-h" ]; then
|
||||
EXITVAL=1
|
||||
fi
|
||||
showhelp
|
||||
;;
|
||||
esac
|
||||
|
||||
exit $EXITVAL
|
107
gimp.spec
107
gimp.spec
@ -30,8 +30,8 @@
|
||||
Summary: GNU Image Manipulation Program
|
||||
Name: gimp
|
||||
Epoch: 2
|
||||
Version: 2.6.8
|
||||
Release: 8%{?dist}
|
||||
Version: 2.6.9
|
||||
Release: 1%{?dist}
|
||||
%define binver 2.6
|
||||
%define gimp_lang_ver 20
|
||||
%define interfacever 2.0
|
||||
@ -117,7 +117,6 @@ Requires: xdg-utils
|
||||
Requires: gimp-libs%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||
|
||||
Source0: ftp://ftp.gimp.org/pub/gimp/v%{binver}/gimp-%{version}.tar.bz2
|
||||
Source1: gimp-plugin-mgr.in
|
||||
# distro specific: use xdg-open instead of firefox as web browser
|
||||
Patch0: gimp-2.6.2-xdg-open.patch
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=559081
|
||||
@ -128,14 +127,8 @@ Patch1: gimp-2.6.7-jpeg-units.patch
|
||||
Patch2: gimp-2.6.6-minimize-dialogs.patch
|
||||
# backport: fix building with "gold" linker
|
||||
Patch3: gimp-2.6.8-gold.patch
|
||||
# backport: statusbar code needed for GTK+ >= 2.19.1 (#559726)
|
||||
Patch4: gimp-2.6.8-gtk219.patch
|
||||
# distro-specific: add --stack-trace-mode=never to desktop file
|
||||
Patch5: gimp-2.6.8-never-stack-trace-desktop.patch
|
||||
# backport: fix saving indexed PNM files (#605615)
|
||||
Patch6: gimp-2.6.8-indexed-pnm.patch
|
||||
# Makefile.in files generated by Makefile.am changed in patches
|
||||
Patch10: gimp-2.6.8-4-automake.patch.bz2
|
||||
Patch10: gimp-2.6.9-1-automake.patch.bz2
|
||||
|
||||
%description
|
||||
GIMP (GNU Image Manipulation Program) is a powerful image composition and
|
||||
@ -150,7 +143,6 @@ with multi-level undo.
|
||||
Summary: GIMP libraries
|
||||
Group: System Environment/Libraries
|
||||
License: LGPLv2+
|
||||
Provides: gimp-libs%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||
|
||||
%description libs
|
||||
The gimp-libs package contains shared libraries needed for the GNU Image
|
||||
@ -219,16 +211,9 @@ EOF
|
||||
%patch1 -p1 -b .jpeg-units
|
||||
%patch2 -p1 -b .minimize-dialogs
|
||||
%patch3 -p1 -b .gold
|
||||
%patch4 -p1 -b .gtk219
|
||||
%patch5 -p1 -b .never-stack-trace-desktop
|
||||
%patch6 -p1 -b .indexed-pnm
|
||||
%patch10 -p1 -b .automake
|
||||
|
||||
%build
|
||||
# if [ ! -f configure ]; then
|
||||
# ./autogen.sh --quiet $MYARCH_FLAGS --prefix=%{_prefix}
|
||||
# fi
|
||||
|
||||
# Use PIC/PIE because gimp is likely to deal with files coming from untrusted
|
||||
# sources
|
||||
CFLAGS='-fPIC %optflags -fno-strict-aliasing'
|
||||
@ -276,9 +261,6 @@ LDFLAGS='-pie'
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
# convenience stuff for external plugins (e.g. xsane)
|
||||
sed -e 's|@GIMPPLUGINDIR@|%{_libdir}/gimp/%{interfacever}|g' < %{SOURCE1} > gimp-plugin-mgr
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
|
||||
@ -342,35 +324,15 @@ ln -snf gimptool-%{interfacever}.1 %{buildroot}%{_mandir}/man1/gimptool.1
|
||||
ln -snf gimprc-%{binver}.5 %{buildroot}/%{_mandir}/man5/gimprc.5
|
||||
%endif
|
||||
|
||||
# convenience stuff for external plugins (e.g. xsane)
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/gimp/plugins.d
|
||||
mkdir -p %{buildroot}%{_sbindir}
|
||||
install -m 0755 gimp-plugin-mgr %{buildroot}%{_sbindir}/gimp-plugin-mgr
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%pre
|
||||
# First, remove old symlinks which are possibly in an old location (before a
|
||||
# major version update)
|
||||
if [ -x "%{_sbindir}/gimp-plugin-mgr" ]; then
|
||||
%{_sbindir}/gimp-plugin-mgr --uninstall '*' || :
|
||||
fi
|
||||
|
||||
%post
|
||||
/usr/bin/update-desktop-database %{_datadir}/applications &> /dev/null || :
|
||||
touch --no-create %{_datadir}/icons/hicolor
|
||||
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
|
||||
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
|
||||
fi
|
||||
# Then re-add the symlinks
|
||||
%{_sbindir}/gimp-plugin-mgr --install '*' || :
|
||||
|
||||
%preun
|
||||
# Only delete symlinks when uninstalling
|
||||
if [ "$1" = "0" ]; then
|
||||
%{_sbindir}/gimp-plugin-mgr --uninstall '*' || :
|
||||
fi
|
||||
|
||||
%postun
|
||||
if [ "$1" = "0" ]; then
|
||||
@ -419,7 +381,6 @@ fi
|
||||
%{_datadir}/gimp/%{interfacever}/themes/
|
||||
|
||||
%dir %{_sysconfdir}/gimp
|
||||
%dir %{_sysconfdir}/gimp/plugins.d
|
||||
%dir %{_sysconfdir}/gimp/%{interfacever}
|
||||
%config(noreplace) %{_sysconfdir}/gimp/%{interfacever}/controllerrc
|
||||
%config(noreplace) %{_sysconfdir}/gimp/%{interfacever}/gimprc
|
||||
@ -433,7 +394,6 @@ fi
|
||||
%{_bindir}/gimp-%{binver}
|
||||
%{_bindir}/gimp-remote-%{binver}
|
||||
%{_bindir}/gimp-console-%{binver}
|
||||
%{_sbindir}/gimp-plugin-mgr
|
||||
|
||||
%if %{with convenience}
|
||||
%{_bindir}/gimp
|
||||
@ -484,7 +444,7 @@ fi
|
||||
%endif
|
||||
%defattr (-, root, root, 0755)
|
||||
%doc HACKING README.i18n
|
||||
%doc %{_datadir}/gtk-doc/*
|
||||
%doc %{_datadir}/gtk-doc/html/*/
|
||||
|
||||
%{_libdir}/*.so
|
||||
%dir %{_libdir}/gimp
|
||||
@ -513,6 +473,65 @@ fi
|
||||
%{_libdir}/gimp/%{interfacever}/plug-ins/help-browser
|
||||
|
||||
%changelog
|
||||
* Wed Jun 23 2010 Nils Philippsen <nils@redhat.com> - 2:2.6.9-1
|
||||
- version 2.6.9
|
||||
|
||||
Overview of Changes from GIMP 2.6.8 to GIMP 2.6.9
|
||||
=================================================
|
||||
|
||||
* Bugs fixed:
|
||||
|
||||
612618 - Font selection remains visible
|
||||
622234 - gimp.desktop: image/x-psd in MimeTypes twice
|
||||
622196 - Unportable test(1) construct in configure script
|
||||
620604 - Description of "histogram" procedure is slightly inaccurate
|
||||
541586 - Tool options not saved/loaded correctly?
|
||||
614153 - Importing PDF files with long titles
|
||||
600112 - blur-gauss-selective.exe crashes
|
||||
599233 - Dialog of "Save as BMP" ignores changes which are not made
|
||||
with a mous
|
||||
565001 - Text-Tool crashes when edit a 2.4.2 version xcf
|
||||
610478 - Layer preview suddenly stops getting updated
|
||||
609026 - leaks shared memory
|
||||
609056 - Exporting to Alias PIX format fails
|
||||
608188 - a few strings in Save as... > Raw image data dialog are always
|
||||
in English
|
||||
604820 - GEGL Operation "path" crashes GIMP
|
||||
603711 - Crashes when using path tool
|
||||
607242 - GIMP 2.7.0 fails to build against libpng 1.4.0
|
||||
606372 - Saving to .ppm fails on indexed colorspace
|
||||
605237 - the "Antialiasing..." message in the progress bar does not show
|
||||
translated
|
||||
604508 - gimp-layer-new-from-visible should work from updated projection
|
||||
|
||||
* Updated and new translations:
|
||||
|
||||
Asturian (ast)
|
||||
Basque (eu)
|
||||
Burmese (my)
|
||||
Catalan (ca)
|
||||
Chinese (Hong Kong) (zh_HK)
|
||||
Chinese (Taiwan) (zh_HK)
|
||||
German (de)
|
||||
Italian (it)
|
||||
Latvian (lv)
|
||||
Low German (nds)
|
||||
Romanian (ro)
|
||||
Simplified Chinese (zh_CN)
|
||||
Slovenian (sl)
|
||||
Ukrainian (uk)
|
||||
Valencian (ca@valencia)
|
||||
|
||||
- remove obsolete gtk219, never-stack-trace-desktop, indexed-pnm patches
|
||||
- don't manually provide "gimp-libs%%{?_isa}" in gimp-libs
|
||||
- don't package %%{_datadir}/gtk-doc/html, but dirs beneath
|
||||
|
||||
* Wed Jun 23 2010 Nils Philippsen <nils@redhat.com> - 2:2.6.8-10
|
||||
- get rid of obsolete gimp-plugin-mgr
|
||||
|
||||
* Tue Jun 22 2010 Matthias Clasen <mclasen@redhat.com> - 2:2.6.8-9
|
||||
- Rebuild against new poppler
|
||||
|
||||
* Fri Jun 18 2010 Nils Philippsen <nils@redhat.com> - 2:2.6.8-8
|
||||
- backport fix for saving indexed PNM files (#605615)
|
||||
|
||||
|
1
import.log
Normal file
1
import.log
Normal file
@ -0,0 +1 @@
|
||||
gimp-2_6_9-1_fc14:F-13:gimp-2.6.9-1.fc14.src.rpm:1277370842
|
Loading…
Reference in New Issue
Block a user