version 2.6.7 remove obsolete gegl-babl-versions-check, help-browser-webkit
patches comment/explain patches
This commit is contained in:
parent
dd8054f502
commit
50bd81b6d6
@ -1 +1 @@
|
||||
gimp-2.6.6.tar.bz2
|
||||
gimp-2.6.7.tar.bz2
|
||||
|
@ -1,59 +0,0 @@
|
||||
diff -up gimp-2.6.6/app/sanity.c.gegl-babl-versions-check gimp-2.6.6/app/sanity.c
|
||||
--- gimp-2.6.6/app/sanity.c.gegl-babl-versions-check 2008-11-20 23:43:08.000000000 +0100
|
||||
+++ gimp-2.6.6/app/sanity.c 2009-06-05 10:26:03.043506642 +0200
|
||||
@@ -75,6 +75,29 @@ sanity_check (void)
|
||||
|
||||
/* private functions */
|
||||
|
||||
+static gboolean
|
||||
+sanity_check_version (guint major_version, guint required_major,
|
||||
+ guint minor_version, guint required_minor,
|
||||
+ guint micro_version, guint required_micro)
|
||||
+{
|
||||
+ if (major_version > required_major)
|
||||
+ return TRUE;
|
||||
+
|
||||
+ if (major_version < required_major)
|
||||
+ return FALSE;
|
||||
+
|
||||
+ if (minor_version > required_minor)
|
||||
+ return TRUE;
|
||||
+
|
||||
+ if (minor_version < required_minor)
|
||||
+ return FALSE;
|
||||
+
|
||||
+ if (micro_version >= required_micro)
|
||||
+ return TRUE;
|
||||
+
|
||||
+ return FALSE;
|
||||
+}
|
||||
+
|
||||
static gchar *
|
||||
sanity_check_gimp (void)
|
||||
{
|
||||
@@ -266,9 +289,9 @@ sanity_check_babl (void)
|
||||
&babl_minor_version,
|
||||
&babl_micro_version);
|
||||
|
||||
- if (babl_major_version < BABL_REQUIRED_MAJOR ||
|
||||
- babl_minor_version < BABL_REQUIRED_MINOR ||
|
||||
- babl_micro_version < BABL_REQUIRED_MICRO)
|
||||
+ if (! sanity_check_version (babl_major_version, BABL_REQUIRED_MAJOR,
|
||||
+ babl_minor_version, BABL_REQUIRED_MINOR,
|
||||
+ babl_micro_version, BABL_REQUIRED_MICRO))
|
||||
{
|
||||
return g_strdup_printf
|
||||
("BABL version too old!\n\n"
|
||||
@@ -304,9 +327,9 @@ sanity_check_gegl (void)
|
||||
&gegl_minor_version,
|
||||
&gegl_micro_version);
|
||||
|
||||
- if (gegl_major_version < GEGL_REQUIRED_MAJOR ||
|
||||
- gegl_minor_version < GEGL_REQUIRED_MINOR ||
|
||||
- gegl_micro_version < GEGL_REQUIRED_MICRO)
|
||||
+ if (! sanity_check_version (gegl_major_version, GEGL_REQUIRED_MAJOR,
|
||||
+ gegl_minor_version, GEGL_REQUIRED_MINOR,
|
||||
+ gegl_micro_version, GEGL_REQUIRED_MICRO))
|
||||
{
|
||||
return g_strdup_printf
|
||||
("GEGL version too old!\n\n"
|
@ -1,145 +0,0 @@
|
||||
commit 76c11122dd72e2c47675da394dadcca53c9069dd
|
||||
Author: Nils Philippsen <nils@redhat.com>
|
||||
Date: Mon Jun 29 13:34:13 2009 +0200
|
||||
|
||||
patch: help-browser-webkit
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit 7f26593f67532850a2c3e1141f5c7f5e667b9064
|
||||
Author: Sven Neumann <sven@gimp.org>
|
||||
Date: Tue May 12 09:39:21 2009 +0200
|
||||
|
||||
help-browser: fix history menus
|
||||
|
||||
The history menus located at the back and forward buttons stopped working
|
||||
after a webkit update some time ago. With these changes the menus work
|
||||
again, at least with recent webkit releases.
|
||||
|
||||
Signed-off-by: Nils Philippsen <nils@redhat.com>
|
||||
|
||||
commit 7647788dbf37369b602361a6abd598388a4cb923
|
||||
Author: Sven Neumann <sven@gimp.org>
|
||||
Date: Sat Mar 28 16:42:50 2009 +0000
|
||||
|
||||
Bug 577024 – help-browser plugin crashes when used with webkit 1.1.3
|
||||
|
||||
2009-03-28 Sven Neumann <sven@gimp.org>
|
||||
|
||||
Bug 577024 – help-browser plugin crashes when used with webkit 1.1.3
|
||||
|
||||
* plug-ins/help-browser/help-browser.c (run): call g_thread_init().
|
||||
Seems to be needed with newer versions of webkit.
|
||||
|
||||
svn path=/trunk/; revision=28227
|
||||
|
||||
Signed-off-by: Nils Philippsen <nils@redhat.com>
|
||||
|
||||
diff --git a/plug-ins/help-browser/dialog.c b/plug-ins/help-browser/dialog.c
|
||||
index 5ad6a06..159c67a 100644
|
||||
--- a/plug-ins/help-browser/dialog.c
|
||||
+++ b/plug-ins/help-browser/dialog.c
|
||||
@@ -886,27 +886,30 @@ close_callback (GtkAction *action,
|
||||
}
|
||||
|
||||
static void
|
||||
-menu_callback (GtkWidget *menu,
|
||||
- WebKitWebHistoryItem *item)
|
||||
+menu_callback (GtkWidget *menu,
|
||||
+ gpointer data)
|
||||
{
|
||||
- browser_dialog_load (webkit_web_history_item_get_uri (item));
|
||||
+ gint steps = GPOINTER_TO_INT (data);
|
||||
+
|
||||
+ webkit_web_view_go_back_or_forward (WEBKIT_WEB_VIEW (view), steps);
|
||||
}
|
||||
|
||||
-/* this function unrefs the items and frees the list */
|
||||
static GtkWidget *
|
||||
-build_menu (GList *items)
|
||||
+build_menu (const GList *items,
|
||||
+ gboolean back)
|
||||
{
|
||||
- GtkWidget *menu;
|
||||
- GList *list;
|
||||
+ GtkWidget *menu;
|
||||
+ const GList *iter;
|
||||
+ gint steps;
|
||||
|
||||
if (! items)
|
||||
return NULL;
|
||||
|
||||
menu = gtk_menu_new ();
|
||||
|
||||
- for (list = items; list; list = g_list_next (list))
|
||||
+ for (iter = items, steps = 1; iter; iter = g_list_next (iter), steps++)
|
||||
{
|
||||
- WebKitWebHistoryItem *item = list->data;
|
||||
+ WebKitWebHistoryItem *item = iter->data;
|
||||
const gchar *title;
|
||||
|
||||
title = webkit_web_history_item_get_title (item);
|
||||
@@ -918,16 +921,12 @@ build_menu (GList *items)
|
||||
gtk_menu_shell_append (GTK_MENU_SHELL (menu), menu_item);
|
||||
gtk_widget_show (menu_item);
|
||||
|
||||
- g_signal_connect_object (menu_item, "activate",
|
||||
- G_CALLBACK (menu_callback),
|
||||
- item, 0);
|
||||
-
|
||||
- g_object_unref (item);
|
||||
+ g_signal_connect (menu_item, "activate",
|
||||
+ G_CALLBACK (menu_callback),
|
||||
+ GINT_TO_POINTER (back ? - steps : steps));
|
||||
}
|
||||
}
|
||||
|
||||
- g_list_free (items);
|
||||
-
|
||||
return menu;
|
||||
}
|
||||
|
||||
@@ -950,12 +949,12 @@ update_actions (void)
|
||||
|
||||
if (back_forward_list)
|
||||
{
|
||||
- GList *list;
|
||||
+ const GList *list;
|
||||
|
||||
list = webkit_web_back_forward_list_get_back_list_with_limit (back_forward_list,
|
||||
12);
|
||||
gtk_menu_tool_button_set_menu (GTK_MENU_TOOL_BUTTON (button_prev),
|
||||
- build_menu (list));
|
||||
+ build_menu (list, TRUE));
|
||||
}
|
||||
else
|
||||
{
|
||||
@@ -971,12 +970,12 @@ update_actions (void)
|
||||
|
||||
if (back_forward_list)
|
||||
{
|
||||
- GList *list;
|
||||
+ const GList *list;
|
||||
|
||||
list = webkit_web_back_forward_list_get_forward_list_with_limit (back_forward_list,
|
||||
12);
|
||||
gtk_menu_tool_button_set_menu (GTK_MENU_TOOL_BUTTON (button_next),
|
||||
- build_menu (list));
|
||||
+ build_menu (list, FALSE));
|
||||
}
|
||||
else
|
||||
{
|
||||
diff --git a/plug-ins/help-browser/help-browser.c b/plug-ins/help-browser/help-browser.c
|
||||
index efbabfe..d632d9c 100644
|
||||
--- a/plug-ins/help-browser/help-browser.c
|
||||
+++ b/plug-ins/help-browser/help-browser.c
|
||||
@@ -129,6 +129,9 @@ run (const gchar *name,
|
||||
|
||||
INIT_I18N ();
|
||||
|
||||
+ if (! g_thread_supported ())
|
||||
+ g_thread_init (NULL);
|
||||
+
|
||||
switch (run_mode)
|
||||
{
|
||||
case GIMP_RUN_INTERACTIVE:
|
87
gimp.spec
87
gimp.spec
@ -30,8 +30,8 @@
|
||||
Summary: GNU Image Manipulation Program
|
||||
Name: gimp
|
||||
Epoch: 2
|
||||
Version: 2.6.6
|
||||
Release: 8%{?dist}
|
||||
Version: 2.6.7
|
||||
Release: 1%{?dist}
|
||||
%define binver 2.6
|
||||
%define gimp_lang_ver 20
|
||||
%define interfacever 2.0
|
||||
@ -120,11 +120,14 @@ Provides: gimp-%{_arch} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||
|
||||
Source0: ftp://ftp.gimp.org/pub/gimp/v%{binver}/gimp-%{version}.tar.bz2
|
||||
Source1: gimp-plugin-mgr.in
|
||||
# distro specific: use xdg-open instead of firefox as web browser
|
||||
Patch0: gimp-2.6.2-xdg-open.patch
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=559081
|
||||
# "JPEG Save dialog preview should adjust size units"
|
||||
Patch1: gimp-2.6.2-jpeg-units.patch
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=556896
|
||||
# "Dialogs don't get minimized with single image window"
|
||||
Patch2: gimp-2.6.6-minimize-dialogs.patch
|
||||
Patch3: gimp-2.6.6-gegl-babl-versions-check.patch
|
||||
Patch4: gimp-2.6.6-help-browser-webkit.patch
|
||||
|
||||
%description
|
||||
GIMP (GNU Image Manipulation Program) is a powerful image composition and
|
||||
@ -206,8 +209,6 @@ EOF
|
||||
%patch0 -p1 -b .xdg-open
|
||||
%patch1 -p1 -b .jpeg-units
|
||||
%patch2 -p1 -b .minimize-dialogs
|
||||
%patch3 -p1 -b .gegl-babl-versions-check
|
||||
%patch4 -p1 -b .help-browser-webkit
|
||||
|
||||
%build
|
||||
# if [ ! -f configure ]; then
|
||||
@ -498,6 +499,80 @@ fi
|
||||
%{_libdir}/gimp/%{interfacever}/plug-ins/help-browser
|
||||
|
||||
%changelog
|
||||
* Fri Aug 14 2009 Nils Philippsen <nils@redhat.com> - 2:2.6.7-1
|
||||
- version 2.6.7
|
||||
|
||||
Overview of Changes from GIMP 2.6.6 to GIMP 2.6.7
|
||||
=================================================
|
||||
|
||||
* Bugs fixed:
|
||||
|
||||
591017 - Tablet pan is not working as fast as it should
|
||||
577581 - Crashes when using any colors tool/function on Windows
|
||||
589667 - GIMP crashes when clicking GEGL Operation on Windows
|
||||
569833 - file-jpeg-save erroneous with small quality values
|
||||
590638 - Changing palettes from list to grid view loses "locked to dock"
|
||||
status
|
||||
589674 - "Send by Email" does not update "Filename"
|
||||
589674 - "Send by Email" does not update "Filename"
|
||||
586851 - Transparent BMP files fail to load
|
||||
589205 - help-browser uses deprecated (and sometimes broken) webkit call
|
||||
582821 - 'Sphere Designer' does not reset correctly...
|
||||
570353 - first time open of .svg file ignores the requested units
|
||||
555777 - Export to MNG animation fails
|
||||
577301 - Dithering with transparency is broken for "positioned" method
|
||||
493778 - metadata plug-in crashes on some images
|
||||
567466 - PNG comment not found if more than 1 tEXt chunks
|
||||
585665 - Exporting to PSD with a blank text layer creates a corrupt file
|
||||
586316 - Levels tool does not adjust output levels correctly if input
|
||||
levels are changed
|
||||
569661 - Import from PDF throws errors when entering resolution in
|
||||
pixels per millimetre
|
||||
567262 - Black pixels appear in "Spread" filter preview
|
||||
554658 - Path Dialog: Path preview pics not to see constantly
|
||||
167604 - gimp_gradient_get_color_at() may return out-of-bounds values
|
||||
567393 - Rectangle select tool size shrinks to 0 if size is larger than
|
||||
the image and the up or down arrow is pressed
|
||||
587543 - crash when invoking certain actions by keyboard shortcut
|
||||
563029 - Closing maximized image doesn't restore document window size
|
||||
585488 - Perspective transformation on a layer with a mask causes crash
|
||||
586008 - GIMP crashes when right-click canceling a drawing action initiated
|
||||
outside layer boundaries
|
||||
584345 - when printing, the number of copies should be reset to 1
|
||||
557061 - Alpha to Logo
|
||||
472644 - Rotate with clipping crops the whole layer
|
||||
577575 - transform tool fills underlying extracted area wrongly
|
||||
555738 - Image display is wrong after undoing canvas size
|
||||
577024 - help-browser plugin crashes when used with webkit 1.1.3
|
||||
555025 - Action GEGL box widgets weirdness
|
||||
|
||||
* Updated and new translations:
|
||||
|
||||
Czech (cs)
|
||||
Danish (da)
|
||||
German (de)
|
||||
Spanish (es)
|
||||
Basque (eu)
|
||||
Finnish (fi)
|
||||
Hungarian (hu)
|
||||
Italian (it)
|
||||
Gujarati (gu)
|
||||
Japanese (ja)
|
||||
Kannada (kn)
|
||||
Marathi (mr)
|
||||
Norwegian bokmål (nb)
|
||||
Oriya (or)
|
||||
Portuguese (pt)
|
||||
Romanian (ro)
|
||||
Sinhala (si)
|
||||
Swedish (sv)
|
||||
Simplified Chinese (zh_CN)
|
||||
Traditional Chinese - Hong Kong (zh_HK)
|
||||
Traditional Chinese - Taiwan (zh_TW)
|
||||
|
||||
- remove obsolete gegl-babl-versions-check, help-browser-webkit patches
|
||||
- comment/explain patches
|
||||
|
||||
* Fri Jul 24 2009 Nils Philippsen <nils@redhat.com> - 2:2.6.6-8
|
||||
- rebuild with chrpath >= 0.13-5 (#513419)
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user