version 2.2.15 remove obsolete patches
This commit is contained in:
parent
152a6b843f
commit
5081ba00a0
@ -1 +1 @@
|
||||
gimp-2.2.14.tar.bz2
|
||||
gimp-2.2.15.tar.bz2
|
||||
|
@ -1,34 +0,0 @@
|
||||
--- gimp-2.2.11/plug-ins/common/png.c.libpng 2004-11-23 09:28:43.000000000 -0500
|
||||
+++ gimp-2.2.11/plug-ins/common/png.c 2006-05-09 10:12:05.000000000 -0400
|
||||
@@ -1,5 +1,5 @@
|
||||
/*
|
||||
- * "$Id: png.c,v 1.118 2004/11/23 14:28:43 mitch Exp $"
|
||||
+ * "$Id: png.c,v 1.118.2.1 2006/04/23 07:01:47 yosh Exp $"
|
||||
*
|
||||
* Portable Network Graphics (PNG) plug-in for The GIMP -- an image
|
||||
* manipulation program
|
||||
@@ -1012,7 +1012,11 @@
|
||||
* Done with the file...
|
||||
*/
|
||||
|
||||
+#if PNG_LIBPNG_VER > 99
|
||||
+ png_destroy_read_struct (&pp, &info, NULL);
|
||||
+#else
|
||||
png_read_destroy (pp, info, NULL);
|
||||
+#endif
|
||||
|
||||
g_free (pixel);
|
||||
g_free (pixels);
|
||||
@@ -1441,7 +1445,12 @@
|
||||
};
|
||||
|
||||
png_write_end (pp, info);
|
||||
+
|
||||
+#if PNG_LIBPNG_VER > 99
|
||||
+ png_destroy_write_struct (&pp, &info);
|
||||
+#else
|
||||
png_write_destroy (pp);
|
||||
+#endif
|
||||
|
||||
g_free (pixel);
|
||||
g_free (pixels);
|
@ -1,11 +0,0 @@
|
||||
--- gimp-2.2.12/app/widgets/gimpfiledialog.c.filename 2006-06-26 11:49:39.000000000 +0200
|
||||
+++ gimp-2.2.12/app/widgets/gimpfiledialog.c 2006-08-02 16:36:03.000000000 +0200
|
||||
@@ -412,7 +412,7 @@
|
||||
gimp_file_dialog_set_file_proc (dialog, NULL);
|
||||
|
||||
dirname = g_path_get_dirname (uri);
|
||||
- basename = g_path_get_basename (uri);
|
||||
+ basename = file_utils_uri_to_utf8_basename (uri);
|
||||
|
||||
if (dirname && strlen (dirname) && strcmp (dirname, "."))
|
||||
gtk_file_chooser_set_current_folder_uri (GTK_FILE_CHOOSER (dialog),
|
@ -1,59 +0,0 @@
|
||||
--- gimp-2.2.14/ChangeLog.sunras-overflow 2007-04-17 23:58:21.000000000 +0200
|
||||
+++ gimp-2.2.14/ChangeLog 2007-04-30 15:38:06.000000000 +0200
|
||||
@@ -0,0 +1,7 @@
|
||||
+2007-04-27 Sven Neumann <sven@gimp.org>
|
||||
+
|
||||
+ Merged from trunk:
|
||||
+
|
||||
+ * plug-ins/common/sunras.c (set_color_table): guard against a
|
||||
+ possible stack overflow.
|
||||
+
|
||||
--- gimp-2.2.14/plug-ins/common/sunras.c.sunras-overflow 2007-04-17 23:11:23.000000000 +0200
|
||||
+++ gimp-2.2.14/plug-ins/common/sunras.c 2007-04-30 15:36:33.000000000 +0200
|
||||
@@ -102,8 +102,7 @@
|
||||
gint32 image_ID,
|
||||
gint32 drawable_ID);
|
||||
|
||||
-static void set_color_table (gint32, L_SUNFILEHEADER *, unsigned char *);
|
||||
-
|
||||
+static void set_color_table (gint32, L_SUNFILEHEADER *, const guchar *);
|
||||
static gint32 create_new_image (const gchar *filename,
|
||||
guint width,
|
||||
guint height,
|
||||
@@ -865,19 +864,20 @@
|
||||
static void
|
||||
set_color_table (gint32 image_ID,
|
||||
L_SUNFILEHEADER *sunhdr,
|
||||
- guchar *suncolmap)
|
||||
+ const guchar *suncolmap)
|
||||
{
|
||||
- int ncols, j;
|
||||
- guchar ColorMap[256*3];
|
||||
+ guchar ColorMap[256 * 3];
|
||||
+ gint ncols, j;
|
||||
|
||||
ncols = sunhdr->l_ras_maplength / 3;
|
||||
- if (ncols <= 0) return;
|
||||
+ if (ncols <= 0)
|
||||
+ return;
|
||||
|
||||
- for (j = 0; j < ncols; j++)
|
||||
+ for (j = 0; j < MIN (ncols, 256); j++)
|
||||
{
|
||||
- ColorMap[j*3] = suncolmap[j];
|
||||
- ColorMap[j*3+1] = suncolmap[j+ncols];
|
||||
- ColorMap[j*3+2] = suncolmap[j+2*ncols];
|
||||
+ ColorMap[j * 3 + 0] = suncolmap[j];
|
||||
+ ColorMap[j * 3 + 1] = suncolmap[j + ncols];
|
||||
+ ColorMap[j * 3 + 2] = suncolmap[j + 2 * ncols];
|
||||
}
|
||||
|
||||
#ifdef DEBUG
|
||||
@@ -886,6 +886,7 @@
|
||||
printf ("%3d: 0x%02x 0x%02x 0x%02x\n", j,
|
||||
ColorMap[j*3], ColorMap[j*3+1], ColorMap[j*3+2]);
|
||||
#endif
|
||||
+
|
||||
gimp_image_set_colormap (image_ID, ColorMap, ncols);
|
||||
}
|
||||
|
File diff suppressed because it is too large
Load Diff
22
gimp.spec
22
gimp.spec
@ -36,14 +36,14 @@
|
||||
|
||||
Summary: GNU Image Manipulation Program
|
||||
Name: gimp
|
||||
Version: 2.2.14
|
||||
Version: 2.2.15
|
||||
%define binver 2.2
|
||||
%define gimp_lang_ver 20
|
||||
%define interfacever 2.0
|
||||
%define age 0
|
||||
%define minorver 200
|
||||
%define microver %(ver=%{version}; echo ${ver##*.*.})
|
||||
Release: 5%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Epoch: 2
|
||||
License: GPL, LGPL
|
||||
Group: Applications/Multimedia
|
||||
@ -102,7 +102,6 @@ Patch2: gimp-2.2.3-icontheme.patch
|
||||
Patch4: gimp-2.2.4-gifload.patch
|
||||
Patch5: gimp-2.2.11-htmlview.patch
|
||||
Patch6: gimp-2.2.11-gimptool.patch
|
||||
Patch7: gimp-2.2.14-sunras-overflow.patch
|
||||
|
||||
%description
|
||||
GIMP (GNU Image Manipulation Program) is a powerful image composition and
|
||||
@ -157,7 +156,6 @@ EOF
|
||||
%patch4 -p1 -b .gifload
|
||||
%patch5 -p1 -b .htmlview
|
||||
%patch6 -p1 -b .gimptool
|
||||
%patch7 -p1 -b .sunras-overflow
|
||||
|
||||
%build
|
||||
libtoolize --copy --force
|
||||
@ -421,6 +419,22 @@ fi
|
||||
%{_libdir}/pkgconfig/*
|
||||
|
||||
%changelog
|
||||
* Thu May 31 2007 Nils Philippsen <nphilipp@redhat.com> - 2:2.2.15-1
|
||||
- version 2.2.15
|
||||
|
||||
Bugs fixed in GIMP 2.2.15
|
||||
=========================
|
||||
|
||||
- fixed parsing of GFig files with CRLF line endings (bug #346988)
|
||||
- guard against a possible stack overflow in the Sunras loader (bug #433902)
|
||||
- fixed definition of datarootdir in gimptool-2.0 (bug #436386)
|
||||
- fixed Perspective tool crash on Mac OS X (bug #349483)
|
||||
- fixed area resizing in the Image Map plug-in (bug #439222)
|
||||
- added missing library in gimptool-2.0 --libs output
|
||||
- added new localizations: Occitan and Persian
|
||||
|
||||
- remove obsolete sunras-overflow patch
|
||||
|
||||
* Tue May 01 2007 Nils Philippsen <nphilipp@redhat.com> - 2:2.2.14-5
|
||||
- don't let gimp-plugin-mgr --uninstall fail %%pre/%%preun scriptlets (#238337)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user