fix clicking scroll bar buttons from combo boxes

This commit is contained in:
Nils Philippsen 2010-06-25 11:57:14 +00:00
parent 3f61a5f647
commit 3c341e76fe
2 changed files with 51 additions and 1 deletions

View File

@ -0,0 +1,44 @@
From ac799274bd9ac1f3cb24624853ad35ee5b860f62 Mon Sep 17 00:00:00 2001
From: Nils Philippsen <nils@redhat.com>
Date: Fri, 25 Jun 2010 13:53:04 +0200
Subject: [PATCH] patch: combo-popup
Squashed commit of the following:
commit 0d1a4fd3c9bdf86ab71951c63bdf6915b8befd05
Author: Michael Natterer <mitch@gimp.org>
Date: Thu Jun 24 21:56:41 2010 +0200
Bug 622608 - GIMP crashes when clicking any scroll bar from combo boxes
Don't cancel the popup in grab_notify() if the popup's grab was
shadowed by one of the widgets in the popup, like the scrollbar.
(cherry picked from commit 991210c0f94ed8e88eab7ebf19438bad85931930)
---
app/widgets/gimpcontainerpopup.c | 10 ++++++++--
1 files changed, 8 insertions(+), 2 deletions(-)
diff --git a/app/widgets/gimpcontainerpopup.c b/app/widgets/gimpcontainerpopup.c
index 50624cc..40cdfce 100644
--- a/app/widgets/gimpcontainerpopup.c
+++ b/app/widgets/gimpcontainerpopup.c
@@ -181,8 +181,14 @@ static void
gimp_container_popup_grab_notify (GtkWidget *widget,
gboolean was_grabbed)
{
- if (! was_grabbed)
- g_signal_emit (widget, popup_signals[CANCEL], 0);
+ if (was_grabbed)
+ return;
+
+ /* ignore grabs on one of our children, like the scrollbar */
+ if (gtk_widget_is_ancestor (gtk_grab_get_current (), widget))
+ return;
+
+ g_signal_emit (widget, popup_signals[CANCEL], 0);
}
static gboolean
--
1.7.0.1

View File

@ -31,7 +31,7 @@ Summary: GNU Image Manipulation Program
Name: gimp
Epoch: 2
Version: 2.6.9
Release: 1%{?dist}
Release: 2%{?dist}
%define binver 2.6
%define gimp_lang_ver 20
%define interfacever 2.0
@ -127,6 +127,8 @@ Patch1: gimp-2.6.7-jpeg-units.patch
Patch2: gimp-2.6.6-minimize-dialogs.patch
# backport: fix building with "gold" linker
Patch3: gimp-2.6.8-gold.patch
# backport: GIMP crashes when clicking any scroll bar from combo boxes
Patch4: gimp-2.6.9-combo-popup.patch
# Makefile.in files generated by Makefile.am changed in patches
Patch10: gimp-2.6.9-1-automake.patch.bz2
@ -211,6 +213,7 @@ EOF
%patch1 -p1 -b .jpeg-units
%patch2 -p1 -b .minimize-dialogs
%patch3 -p1 -b .gold
%patch4 -p1 -b .combo-popup
%patch10 -p1 -b .automake
%build
@ -473,6 +476,9 @@ fi
%{_libdir}/gimp/%{interfacever}/plug-ins/help-browser
%changelog
* Fri Jun 25 2010 Nils Philippsen <nils@redhat.com> - 2:2.6.9-2
- fix clicking scroll bar buttons from combo boxes
* Wed Jun 23 2010 Nils Philippsen <nils@redhat.com> - 2:2.6.9-1
- version 2.6.9